Subject: [Cfrg] Soliciting agenda topics for Buenos Aires

From: Alexey Melnikov <[email-masked]>
Date: Mon, 14 Mar 2016 13:36:35 +0000

Hi,
Kenny and I will discuss agenda this Wednesday. In the meantime, please 
suggest topics you would like to present or discuss.

Thank you,
Alexey

---

From: David McGrew <[email-masked]>
Date: Mon, 14 Mar 2016 12:08:35 -0400

Hi Alexey,

> On Mar 14, 2016, at 9:36 AM, Alexey Melnikov <[email-masked]> wrote:
> 
> Hi,
> Kenny and I will discuss agenda this Wednesday. In the meantime, please suggest topics you would like to present or discuss.

I would like to present on some work that I am doing with Denis, Stefan, Scott, and Panos (copied).  Our work outlines good implementation strategies for stateful hash based signature schemes, and analyzes the different security risks, use cases, and factors affecting performance.   This work addresses some concerns previously expressed on this mail list, so we think it would be a topic of interest.   We are preparing an analysis document and will post a link before the meeting.   This presentation needs 20 minutes to do it right (and could be a better presentation given 30 minutes :-) but it could be done in 10 or 15 if there is time pressure.

I also suggest that there be a discussion on how standards should evolve to provide Quantum Resistant Cryptography (QRC).   Here are some suggested topics for discussion:
- Where will QRC be needed?   
- In what IETF standards will QRC be needed?
- On what timeline will QRC need to be adopted?
- What are the barriers to QRC adoption?
- How can CFRG contribute to the development of QRC algorithm standards?  
- How can CFRG/IETF help the adoption of QRC algorithms in IETF standards?  

No doubt there are other interesting questions as well.

best regards,

David

> 
> Thank you,
> Alexey
> 
> _______________________________________________
> Cfrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/cfrg

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 16 Mar 2016 17:36:38 +0000

> On 14 Mar 2016, at 13:36, Alexey Melnikov <[email-masked]> wrote:
> 
> Hi,

Chairs would like to ask CFRG participants to submit proposals by the end of Sunday, March 20th.

Thank you,
Alexey