Subject: [Cfrg] Comment on draft-irtf-cfrg-eddsa

From: "Jim Schaad" <[email-masked]>
Date: Wed, 6 Jul 2016 11:40:14 -0700

I was going through the document doing a bad implementation and I ran across
the following issue.

In Table 1 there is constant 'a' defined as being -1.
In section 5.1.6, the first step defines a new variable 'a'. As this is not
strongly highlighted, the variable is defined in the middle of a sentence, I
missed that it was being defined as I worked things out and had a problem.

I would suggest that one or the other variables be re-named so that the
confusion does not exist.

Jim

---

From: Ilari Liusvaara <[email-masked]>
Date: Wed, 6 Jul 2016 22:27:10 +0300

> confusion does not exist.

Renamed to 's' in Editor's Copy (that also seems to be the letter the generic
EdDSA description used).

-Ilari