Subject: [Cfrg] Rev RFC 7539?

From: Yoav Nir <[email-masked]>
Date: Mon, 14 Nov 2016 15:32:10 +0900

Hi

RFC 7539 (“ChaCha20 and Poly1305 for IETF Protocols”)[1] is now implemented in many places and referenced by 3 RFCs and 8 Internet Drafts ([2])

However, the quality of the document is not where we’d like it to be. There have been 7 errata filed against it. Most of it is editorial or insignificant, but still no errata is better than some errata.

So what do the participants and chairs think about spinning up a quick[4] rfc7539bis that has the same text, except that the errata will be merged in?

I think such a document should be fairly easy and quick.

Yoav

P.S: and yes, of course I’m volunteering to write it.

[1] https://tools.ietf.org/html/rfc7539 <https://tools.ietf.org/html/rfc7539>
[2] https://datatracker.ietf.org/doc/rfc7539/referencedby/ <https://datatracker.ietf.org/doc/rfc7539/referencedby/>
[3] https://www.rfc-editor.org/errata_search.php?rfc=7539 <https://www.rfc-editor.org/errata_search.php?rfc=7539>
[4] My spell check actually corrected “quick” to “quic”. The contents of my mails are veering far away from regular English.

---

From: Eric Rescorla <[email-masked]>
Date: Mon, 14 Nov 2016 15:55:55 +0900

This seems like a good plan.

-Ekr

On Mon, Nov 14, 2016 at 3:32 PM, Yoav Nir <[email-masked]> wrote:

> Hi
>
> RFC 7539 (“ChaCha20 and Poly1305 for IETF Protocols”)[1] is now
> implemented in many places and referenced by 3 RFCs and 8 Internet Drafts
> ([2])
>
> However, the quality of the document is not where we’d like it to be.
> There have been 7 errata filed against it. Most of it is editorial or
> insignificant, but still no errata is better than some errata.
>
> So what do the participants and chairs think about spinning up a quick[4]
> rfc7539bis that has the same text, except that the errata will be merged in?
>
> [1] https://tools.ietf.org/html/rfc7539
> [2] https://datatracker.ietf.org/doc/rfc7539/referencedby/
> [3] https://www.rfc-editor.org/errata_search.php?rfc=7539
> [4] My spell check actually corrected “quick” to “quic”. The contents of
> my mails are veering far away from regular English.
>
>
> _______________________________________________
> Cfrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/cfrg
>
>

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 14 Nov 2016 16:20:54 +0900

Hi,

> On 14 Nov 2016, at 15:32, Yoav Nir <[email-masked]> wrote:
> 
> Hi
> 

This chair thinks it is a good idea.

---

From: John Mattsson <[email-masked]>
Date: Mon, 14 Nov 2016 07:28:46 +0000

Hi,

I think  such an update should also include guidance on tag truncation (i.e. do not truncate), perhaps in the security consideration section. This was raised by Jim Schaad on the CFRG list.

https://www.ietf.org/mail-archive/web/cfrg/current/msg07176.html

I have also heard discussions on truncating poly1305 in other places.

If there any other clarifications regarding secure or interoperable implementations, I think they should be added as well.

Cheers,
John

From: Cfrg <[email-masked]<mailto:[email-masked]>> on behalf of Alexey Melnikov <[email-masked]<mailto:[email-masked]>>
Date: Monday, 14 November 2016 at 16:20
To: Yoav Nir <[email-masked]<mailto:[email-masked]>>
Cc: IRTF CFRG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Cfrg] Rev RFC 7539?

Hi,

On 14 Nov 2016, at 15:32, Yoav Nir <[email-masked]<mailto:[email-masked]>> wrote:

Hi

Yoav

_______________________________________________
Cfrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/cfrg

---

From: Sean Turner <[email-masked]>
Date: Wed, 16 Nov 2016 10:06:34 +0900

+1 - if you got the cycles.

spt

> On Nov 14, 2016, at 15:55, Eric Rescorla <[email-masked]> wrote:
>

---

From: Yoav Nir <[email-masked]>
Date: Wed, 16 Nov 2016 16:09:11 +0900

Cycles found.

Attached please find two files:
  1. rfc7539_long.txt is RFC 7539 with page breaks and page numbers removed. 
 2. draft-nir-cfrg-rfc7539bis-00.raw.txt is the unpaginated form of the new draft.

Couldn’t do much about the boilerplate, but this makes it easy to compare.

Yoav

> On 16 Nov 2016, at 10:06, Sean Turner <[email-masked]> wrote:
>