Subject: [Cfrg] CFRG adoption call: draft-viguier-kangarootwelve

From: "Paterson, Kenny" <[email-masked]>
Date: Wed, 13 Feb 2019 12:57:44 +0000

Dear CFRG,

This email begins a 2-week adoption call for draft-viguier-kangarootwelve available from:

https://tools.ietf.org/html/draft-viguier-kangarootwelve-04

(see also slides from IETF 99 at: https://datatracker.ietf.org/meeting/99/materials/slides-99-cfrg-kangarootwelve-draft-viguier-kangarootwelve-00-00).

Please express your opinions on whether this draft should be adopted by CFRG or not. If you think it should be adopted, please also indicate whether you'd be willing to help review and/or work on the draft.

Thanks,

Kenny (for the chairs)

---

From: "Dang, Quynh (Fed)" <[email-masked]>
Date: Fri, 15 Feb 2019 09:33:41 +0000

Hi Kenny and Alexey,

Personally, I support adoption of the draft. I am willing to review, comment or work on it.

Regards,

Quynh.

________________________________
From: Cfrg <[email-masked]> on behalf of Paterson, Kenny <[email-masked]>
Sent: Wednesday, February 13, 2019 7:57 AM
To: [email-masked]
Subject: [Cfrg] CFRG adoption call: draft-viguier-kangarootwelve

Dear CFRG,

https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-viguier-kangarootwelve-04&amp;data=02%7C01%7Cquynh.dang%40nist.gov%7C29ee9f1acb924b99e5c108d691b2fb30%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C636856595234425238&amp;sdata=SkTKw79vv%2BWYjtk%2BDksusiI2Pvg5p4QxBjg81Cgx1lM%3D&amp;reserved=0

(see also slides from IETF 99 at: https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fmeeting%2F99%2Fmaterials%2Fslides-99-cfrg-kangarootwelve-draft-viguier-kangarootwelve-00-00&amp;data=02%7C01%7Cquynh.dang%40nist.gov%7C29ee9f1acb924b99e5c108d691b2fb30%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C636856595234425238&amp;sdata=rZbUJzUzCxv7baOs5Mi9dViab1I8fK26vqvUHQnvW7U%3D&amp;reserved=0).

Thanks,

Kenny (for the chairs)

_______________________________________________
Cfrg mailing list
[email-masked]
https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.irtf.org%2Fmailman%2Flistinfo%2Fcfrg&amp;data=02%7C01%7Cquynh.dang%40nist.gov%7C29ee9f1acb924b99e5c108d691b2fb30%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C636856595234425238&amp;sdata=U3SDSaNf2jkLsYScutB0I4YkJss68ojAQmURDb1buWo%3D&amp;reserved=0

---

From: "Stanislav V. Smyshlyaev" <[email-masked]>
Date: Fri, 15 Feb 2019 17:03:29 +0300

Dear Kenny and Alexey!

I support adoption of the draft and will be happy to review.

Best regards,
Stanislav

ср, 13 февр. 2019 г. в 15:58, Paterson, Kenny <[email-masked]>:

> (see also slides from IETF 99 at:
> https://datatracker.ietf.org/meeting/99/materials/slides-99-cfrg-kangarootwelve-draft-viguier-kangarootwelve-00-00
> ).
>
> Please express your opinions on whether this draft should be adopted by
> CFRG or not. If you think it should be adopted, please also indicate
> whether you'd be willing to help review and/or work on the draft.
>
> Thanks,
>
> Kenny (for the chairs)
>
>
> https://www.irtf.org/mailman/listinfo/cfrg
>

---

From: Benoît Viguier <[email-masked]>
Date: Mon, 25 Feb 2019 16:21:08 +0100

Dear CFRG, Hi Kenny and Alexey,    

as the current draft author, I support the adoption of this
draft and I am willing to continue to review & work on it.

Regards,
Benoit

---

From: David Wong <[email-masked]>
Date: Mon, 25 Feb 2019 16:32:38 +0100

I think it should be adopted for the following reasons:

* it is probably the fastest hash function for small and large inputs
* it's a XOF as well
* it is based on long years of analysis on SHA-3
* it is going to benefit greatly from hardware support of keccak

It would be good to see people trying to implement the hash from the
draft only, to see how implementer-friendly it is.