Subject: [Cfrg] FW: New Version Notification for draft-mattsson-cfrg-det-sigs-with-noise-02.txt

From: John Mattsson <[email-masked]>
Date: Wed, 11 Mar 2020 16:14:53 +0000

Dear CFRG,

After the comments on the list I submitted a new version. The changes since -00 are

- As suggested Quynh Dang and Uri Blumenthal, the new version replaces the XOR construction with concatenation and places the random value before the message.
- As suggested [SBBDS17] and Uri Blumenthal, the new version implements the additional countermeasure to pad with zeroes so that so that the first block is composed only of the hashed private key and the random value, but not the message.
- As suggested by Tony Arcieri, the terminology "noise" could be confusing and has been changes to "additional randomness"
- Some more text on the construction and benefits with the construction.
- Reduced and slightly rewritten discussion section (to be removed in the future)

Cheers,
John

-----Original Message-----
From: "[email-masked]" <[email-masked]>
Date: Wednesday, 11 March 2020 at 16:11
To: John Mattsson <[email-masked]>, John Mattsson <[email-masked]>, Sini Ruohomaa <[email-masked]>, Erik Thormarker <[email-masked]>
Subject: New Version Notification for draft-mattsson-cfrg-det-sigs-with-noise-02.txt

    A new version of I-D, draft-mattsson-cfrg-det-sigs-with-noise-02.txt
    has been successfully submitted by =?utf-8?q?John_Preu=C3=9F_Mattsson?= and posted to the
    IETF repository.
    
    Name:		draft-mattsson-cfrg-det-sigs-with-noise
    Revision:	02
    Title:		Deterministic ECDSA and EdDSA Signatures with Additional Randomness
    Document date:	2020-03-11
    Group:		Individual Submission
    Pages:		13
    URL:            https://www.ietf.org/internet-drafts/draft-mattsson-cfrg-det-sigs-with-noise-02.txt
    Status:         https://datatracker.ietf.org/doc/draft-mattsson-cfrg-det-sigs-with-noise/
    Htmlized:       https://tools.ietf.org/html/draft-mattsson-cfrg-det-sigs-with-noise-02
    Htmlized:       https://datatracker.ietf.org/doc/html/draft-mattsson-cfrg-det-sigs-with-noise
    Diff:           https://www.ietf.org/rfcdiff?url2=draft-mattsson-cfrg-det-sigs-with-noise-02
    
    Abstract:
       Deterministic elliptic-curve signatures such as deterministic ECDSA
       and EdDSA have gained popularity over randomized ECDSA as their
       security do not depend on a source of high-quality randomness.
       Recent research has however found that implementations of these
       signature algorithms may be vulnerable to certain side-channel and
       fault injection attacks due to their determinism.  One countermeasure
       to such attacks is to re-add randomness to the otherwise
       deterministic calculation of the per-message secret number.  This
       document updates RFC 6979 and RFC 8032 to recommend constructions
       with additional randomness for deployments where side-channel attacks
       and fault injection attacks are a concern.

    
    Please note that it may take a couple of minutes from the time of submission
    until the htmlized version and diff are available at tools.ietf.org.
    
    The IETF Secretariat

---

From: "Blumenthal, Uri - 0553 - MITLL" <[email-masked]>
Date: Wed, 11 Mar 2020 16:38:22 +0000

Perfect, *thank you!*

On 3/11/20, 12:15 PM, "Cfrg on behalf of John Mattsson" <[email-masked] on behalf of john.mattsson=[email-masked]> wrote:

    Dear CFRG,

    
    Cheers,
    John
    
    -----Original Message-----
    From: "[email-masked]" <[email-masked]>
    Date: Wednesday, 11 March 2020 at 16:11
    To: John Mattsson <[email-masked]>, John Mattsson <[email-masked]>, Sini Ruohomaa <[email-masked]>, Erik Thormarker <[email-masked]>
    Subject: New Version Notification for draft-mattsson-cfrg-det-sigs-with-noise-02.txt

        
        Abstract:

        
        
        The IETF Secretariat

    
    _______________________________________________
    Cfrg mailing list
    [email-masked]
    https://www.irtf.org/mailman/listinfo/cfrg