Subject: Re: [CFRG] Call for adoption: Threshold Signatures

From: Nick Sullivan <[email-masked]>
Date: Wed, 27 Jan 2021 15:24:56 -0500

Dear CFRG participants,

The chairs have reviewed the call for adoption thread and concluded that
the CFRG will adopt the idea of threshold signatures as a working group
item with the FROST document as a starting point as a single document to
adopt. Additionally, given the feedback, we recommend the document be
updated to include concrete "cipher suites" that are compatible with both
the RFC7748 curves and RFC8032 signatures and the standard NIST curves
(similar to how the hash-to-curve draft handles specialization).

As a next step, we encourage the authors of draft-komlo-frost-00 to submit
a new document as draft-irft-cfrg-frost-00. Note that as the item is now a
research group document, the chairs may decide to designate new or
different authors and/or editors of this document going forward.

Thanks to everyone for their patience on this one.

Nick, Stanislav, Alexey

On Thu, Oct 8, 2020 at 12:33 PM Nick Sullivan <[email-masked]> wrote:

> Dear CFRG participants,
>
> After some active conversations on the mailing list, there seems to be
> support for taking on work related to threshold signatures at the CFRG.
> This email commences a 3-week call for adoption for the topic of "Threshold
> Signatures" that will end on October 28th, 2020:
>
> There are two drafts that have been submitted for consideration on this
> topic:
> https://datatracker.ietf.org/doc/draft-komlo-frost/
> https://datatracker.ietf.org/doc/draft-hallambaker-threshold-sigs/
>
> Please give your views on the following questions:
> a) should this topic be adopted by the CFRG as a work item, and if so
> b) should one or both of these documents should be considered as a
> starting point for this work
> c) are you willing to help work on this item and/or review it
>
> Please reply to this email (or in exceptional circumstances, you can email
> CFRG chairs directly at [email-masked]).
>
> Thank you,
> Nick (for the chairs)
>

---

From: Chelsea Komlo <[email-masked]>
Date: Thu, 28 Jan 2021 00:01:55 +0000

Hi Nick,

Thanks for the update. We'll begin the draft-irft-cfrg-frost-00 draft, and will update the list after we've submitted.

Best,

Chelsea

________________________________
From: CFRG <[email-masked]> on behalf of Nick Sullivan <nick=[email-masked]>
Sent: Wednesday, January 27, 2021 8:24:56 AM
To: [email-masked]
Subject: Re: [CFRG] Call for adoption: Threshold Signatures

Dear CFRG participants,

The chairs have reviewed the call for adoption thread and concluded that the CFRG will adopt the idea of threshold signatures as a working group item with the FROST document as a starting point as a single document to adopt. Additionally, given the feedback, we recommend the document be updated to include concrete "cipher suites" that are compatible with both the RFC7748 curves and RFC8032 signatures and the standard NIST curves (similar to how the hash-to-curve draft handles specialization).

As a next step, we encourage the authors of draft-komlo-frost-00 to submit a new document as draft-irft-cfrg-frost-00. Note that as the item is now a research group document, the chairs may decide to designate new or different authors and/or editors of this document going forward.

Nick, Stanislav, Alexey

On Thu, Oct 8, 2020 at 12:33 PM Nick Sullivan <[email-masked]<mailto:[email-masked]>> wrote:
Dear CFRG participants,

After some active conversations on the mailing list, there seems to be support for taking on work related to threshold signatures at the CFRG. This email commences a 3-week call for adoption for the topic of "Threshold Signatures" that will end on October 28th, 2020:

There are two drafts that have been submitted for consideration on this topic:
https://datatracker.ietf.org/doc/draft-komlo-frost/
https://datatracker.ietf.org/doc/draft-hallambaker-threshold-sigs/

Please give your views on the following questions:
a) should this topic be adopted by the CFRG as a work item, and if so
b) should one or both of these documents should be considered as a starting point for this work
c) are you willing to help work on this item and/or review it

Please reply to this email (or in exceptional circumstances, you can email CFRG chairs directly at [email-masked]<mailto:[email-masked]>).

Thank you,
Nick (for the chairs)