Subject: [CFRG] Proposed resolution for erratum 5930 on RFC 8032

From: Alexey Melnikov <[email-masked]>
Date: Fri, 15 Jan 2021 17:39:22 +0000

Dear CFRG (and editors),

Daniel Bleichenbacher submitted the following editorial erratum on RFC 
8032 ("Edwards-Curve Digital Signature Algorithm (EdDSA)")

Section 6 says:

OLD:

def verify(public, msg, signature):
     if len(public) != 32:
         raise Exception("Bad public key length")
     if len(signature) != 64:
         Exception("Bad signature length")

It should say:

def verify(public, msg, signature):
     if len(public) != 32:
         raise Exception("Bad public key length")
     if len(signature) != 64:
         raise Exception("Bad signature length")

Note: Missing raise before Exception

-------------------

This is indeed looks like a Python syntax error. So I propose to resolve 
this erratum as suggested by Daniel.

Please provide your feedback by the end of January 29th.

Best Regards,

Alexey, as a co-chair

---

From: Simon Josefsson <[email-masked]>
Date: Fri, 15 Jan 2021 18:42:55 +0100

+1

/Simon

> 15 jan. 2021 kl. 18:39 skrev Alexey Melnikov <[email-masked]>:
> 
> Dear CFRG (and editors),
> 
> Daniel Bleichenbacher submitted the following editorial erratum on RFC 8032 ("Edwards-Curve Digital Signature Algorithm (EdDSA)")
> 
> Section 6 says:
> 
> OLD:
> 
> This is indeed looks like a Python syntax error. So I propose to resolve this erratum as suggested by Daniel.
>

---

From: Mike Hamburg <[email-masked]>
Date: Fri, 15 Jan 2021 14:43:18 -0400

I also agree.  — Mike

> On Jan 15, 2021, at 1:42 PM, Simon Josefsson <simon=[email-masked]> wrote:
> 
> +1
> 
> /Simon
> 
> _______________________________________________
> CFRG mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/cfrg

---

From: Ilari Liusvaara <[email-masked]>
Date: Mon, 18 Jan 2021 07:52:23 +0200

On Fri, Jan 15, 2021 at 05:39:22PM +0000, Alexey Melnikov wrote:
> Dear CFRG (and editors),
> 
> Daniel Bleichenbacher submitted the following editorial erratum on RFC 8032
> ("Edwards-Curve Digital Signature Algorithm (EdDSA)")
> 
> Section 6 says:
> 
> OLD:
> 

While I think the proposed text above is correct, I am not so sure about
the errata being marked editorial (I very well might be incorrect here).
The error makes code work incorrectly (on one case with invalid input),
it is not an error in code that does not affect function (e.g., typo in
comment or consistent typo in variable name).

-Ilari