Subject: Re: [CFRG] draft-fluhrer-lms-more-parm-sets-01

From: Russ Housley <[email-masked]>
Date: Sun, 11 Apr 2021 12:27:34 -0400

Scott:

I am trying to expand my implementation for the new parameter sets, but I have run into a problem with typecodes the test vectors.

Section 7 defines the experimental typecodes as: 0xE000000X

However, the test vectors use: 0e00000X.

Should the four-octet typecode begin with 0E or E0?

Russ

---

From: "Scott Fluhrer (sfluhrer)" <[email-masked]>
Date: Mon, 12 Apr 2021 12:39:31 +0000

*BLEEP*

Yes, it should be 0xE000000X; I got the test vectors wrong.  The values were intended to be in the private use region of 8554; obviously, 0x0E00000X are not.

I'll need to update the draft with the fixed test vectors.  Sorry about that...

-----Original Message-----
From: CFRG <[email-masked]> On Behalf Of Russ Housley
Sent: Sunday, April 11, 2021 12:28 PM
To: Scott Fluhrer (sfluhrer) <[email-masked]>
Cc: IRTF CFRG <[email-masked]>
Subject: Re: [CFRG] draft-fluhrer-lms-more-parm-sets-01

Scott:

Russ

_______________________________________________
CFRG mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/cfrg

---

From: "Scott Fluhrer (sfluhrer)" <[email-masked]>
Date: Mon, 12 Apr 2021 18:37:14 +0000

Ok, I just redid the test vectors (and checked them thoroughly this time); the new version of the draft was just posted.

-----Original Message-----
From: CFRG <[email-masked]> On Behalf Of Scott Fluhrer (sfluhrer)
Sent: Monday, April 12, 2021 8:40 AM
To: Russ Housley <[email-masked]>
Cc: IRTF CFRG <[email-masked]>
Subject: Re: [CFRG] draft-fluhrer-lms-more-parm-sets-01

*BLEEP*

-----Original Message-----
From: CFRG <[email-masked]> On Behalf Of Russ Housley
Sent: Sunday, April 11, 2021 12:28 PM
To: Scott Fluhrer (sfluhrer) <[email-masked]>
Cc: IRTF CFRG <[email-masked]>
Subject: Re: [CFRG] draft-fluhrer-lms-more-parm-sets-01

Scott:

Russ

---

From: Russ Housley <[email-masked]>
Date: Mon, 12 Apr 2021 14:56:09 -0400

Scott:

Thanks.  I will let you know if my code encounters any problems.

I did notice that the comments in the test vectors use _SHAKE256_, but the body of the document uses _SHAKE_ for the typecode.  I prefer the shorter name.

Russ

> On Apr 12, 2021, at 2:37 PM, Scott Fluhrer (sfluhrer) <[email-masked]> wrote:
>

---

From: Russ Housley <[email-masked]>
Date: Mon, 12 Apr 2021 18:24:11 -0400

Scott:

I check the SHAKE-related test vectors, and they work with my implementation.

Russ

> On Apr 12, 2021, at 2:37 PM, Scott Fluhrer (sfluhrer) <sfluhrer=[email-masked]> wrote:
>