Subject: Re: [CFRG] I-D Action: draft-irtf-cfrg-hpke-08.txt

From: Frank Denis <[email-masked]>
Date: Mon, 19 Apr 2021 21:51:47 +0200

General comments on draft-irtf-cfrg-hpke-08:

* The document is well-written and every function is clearly specified.
I wrote implementations solely based on it, that were verified to be interoperable with other implementations, and didn’t hit anything that required additional information.

* The test vectors also appear to be correct.

Given this, the maturity of the scheme, and the fact that it is a dependency for other protocols, I’d like to see this document move forward.

---

Additional comments:

* Section 4:

“This function can raise an DecapError” -> “a DecapError”

* Section 4: "The Seal() and Open() functions can return a NonceOverflowError."

The fact that HPKE uses increasing nonces is an internal detail; exposing this to applications looks like the wrong abstraction level.

From an application perspective, a more meaningful error would be `TooManyMessages` or a more generic `Overflow` error that could also encompass the case of the AEAD’s internal counter reaching a limit.

Using `NonceOverflowError` may catalyze inconsistencies between the specification and its implementations.

* Section 4: LabeledExtract() and LabeledExpand() functions

The document doesn’t mention any size limits regarding the `suite_id` and `label` parameters of these functions.

This can be an issue for implementations favoring static/pre-allocated storage space over heap allocations.

Specifying reasonable limits (64 bytes?) may be useful to avoid interoperability issues.
These limits can also be documented in section 7.2.1.

* Section 8.1.3

Splitting this into 2 or 3 paragraphs would make the section more readable.

* Section 8.4: “Further, because HPKE uses AEAD schemes that are not key-committing”

This seems to suggest that non key-committing schemes are a requirement for HPKE, which is not the case.
Further revisions of the document can include key-committing schemes, and exported keys can safely be used with such AEADs.

Cheers,
-Frank.

---

From: "Christopher Wood" <[email-masked]>
Date: Tue, 20 Apr 2021 15:03:06 -0700

Thanks, Frank! We applied your suggestions in this PR:

   https://github.com/cfrg/draft-irtf-cfrg-hpke/pull/217

Since this was mostly editorial, we'll hold off publishing a new version for now. (Chairs, please let us know if you'd like to see a new version in order to move this document forward.)

Best,
Chris

On Mon, Apr 19, 2021, at 12:51 PM, Frank Denis wrote:
> I wrote implementations solely based on it, that were verified to be 
> interoperable with other implementations, and didn’t hit anything that 
> required additional information.
> 
> Given this, the maturity of the scheme, and the fact that it is a 
> dependency for other protocols, I’d like to see this document move 
> forward.
> 
> 
> ---
> 
> 
> Additional comments:
> 
> 
> * Section 4:
> 
> The fact that HPKE uses increasing nonces is an internal detail; 
> exposing this to applications looks like the wrong abstraction level.
> 
> From an application perspective, a more meaningful error would be 
> `TooManyMessages` or a more generic `Overflow` error that could also 
> encompass the case of the AEAD’s internal counter reaching a limit.
> 
> The document doesn’t mention any size limits regarding the `suite_id` 
> and `label` parameters of these functions.
> 
> Further revisions of the document can include key-committing schemes, 
> and exported keys can safely be used with such AEADs.
> 
> 
> 
> 
> 
> Cheers,
> -Frank.
> 
> 
> 
> _______________________________________________
> CFRG mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/cfrg
>

---

From: "Stanislav V. Smyshlyaev" <[email-masked]>
Date: Wed, 21 Apr 2021 10:59:32 +0300

Dear Chris,

HPKE is now in "Awaiting IRSG Reviews" status.

I would suggest updating the draft if there are updates, so that all future
reviewers could find the most up-to-date version in the datatracker.

Regards,
Stanislav

On Wed, 21 Apr 2021 at 01:04, Christopher Wood <[email-masked]> wrote:

> Since this was mostly editorial, we'll hold off publishing a new version
> for now. (Chairs, please let us know if you'd like to see a new version in
> order to move this document forward.)
>
> Best,
> Chris
>