Subject: [CFRG] I-D Action: draft-irtf-cfrg-ristretto255-decaf448-01.txt

From: [email-masked]
Date: Wed, 04 Aug 2021 12:26:17 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Crypto Forum RG of the IRTF.

        Title           : The ristretto255 and decaf448 Groups
        Authors         : Henry de Valence
                          Jack Grigg
                          George Tankersley
                          Filippo Valsorda
                          Isis Lovecruft
                          Mike Hamburg
	Filename        : draft-irtf-cfrg-ristretto255-decaf448-01.txt
	Pages           : 26
	Date            : 2021-08-04

Abstract:
   This memo specifies two prime-order groups, ristretto255 and
   decaf448, suitable for safely implementing higher-level and complex
   cryptographic protocols.  The ristretto255 group can be implemented
   using Curve25519, allowing existing Curve25519 implementations to be
   reused and extended to provide a prime-order group.  Likewise, the
   decaf448 group can be implemented using edwards448.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-irtf-cfrg-ristretto255-decaf448/

There is also an HTML version available at:
https://www.ietf.org/archive/id/draft-irtf-cfrg-ristretto255-decaf448-01.html

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-irtf-cfrg-ristretto255-decaf448-01

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Christopher Wood" <[email-masked]>
Date: Wed, 04 Aug 2021 12:33:33 -0700

It looks like draft-irtf-cfrg-ristretto255-decaf448 was just updated to bump the date. It seems to me the draft is feature complete, and it has a number of different implementations available. It is also a dependency for a number of ongoing CFRG drafts, including darft-irtf-cfrg-voprf, draft-irtf-cfrg-hash-to-curve, and (most likely) draft-irtf-cfrg-frost. 

What remains for this draft to move forward? If nothing, perhaps we can start RGLC and move this document along in the process?

Best,
Chris

On Wed, Aug 4, 2021, at 12:26 PM, [email-masked] wrote:
> _______________________________________________
> CFRG mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/cfrg
>