Subject: [CFRG] HPKE: final call for objections on the changes

From: "Stanislav V. Smyshlyaev" <[email-masked]>
Date: Thu, 5 Aug 2021 11:03:57 +0300

Dear CFRG,

The HPKE draft (https://datatracker.ietf.org/doc/draft-irtf-cfrg-hpke/) has
been updated (versions -08, -09, -10, -11, see
https://www.ietf.org/rfcdiff?url1=draft-irtf-cfrg-hpke-07&url2=draft-irtf-cfrg-hpke-11)
based on the comments obtained during the IRSG review (many thanks to
Kirsty and Spencer!).

Colin Perkins and the CFRG chairs would like to do a final call for
objections on the changes with the RG.

This final call will end on August 15th.

Please send your comments in reply to this message or directly to Colin
Perkins and the CFRG chairs.

Best regards,
Stanislav (on behalf of CFRG Chairs)

---

From: "Martin Thomson" <[email-masked]>
Date: Thu, 05 Aug 2021 18:46:24 +1000

I have read, implemented, and deployed the changes in HPKE since -07.

I do want to confirm however that the change in test vectors between -08 (where the final version string was added) and -09 was just the result of missing the test vectors in the -08 update.  I've code that uses the source JSON file, which were updated one day after -08 was published.

Nit: in \S9.7.5, the first sentence could use an em-dash (' - ' or ' -- ' to taste):
   If the randomness used for KEM encapsulation is bad - i.e., of low	
   entropy or compromised because of a broken or subverted random number	
   generator - the confidentiality guarantees of HPKE degrade	
   significantly.

On Thu, Aug 5, 2021, at 18:03, Stanislav V. Smyshlyaev wrote:
> Dear CFRG,
> 
> The HPKE draft (https://datatracker.ietf.org/doc/draft-irtf-cfrg-hpke/) 
> has been updated (versions -08, -09, -10, -11, see 
> https://www.ietf.org/rfcdiff?url1=draft-irtf-cfrg-hpke-07&url2=draft-irtf-cfrg-hpke-11) based on the comments obtained during the IRSG review (many thanks to Kirsty and Spencer!). 
> 
> _______________________________________________
> CFRG mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/cfrg
>

---

From: "Christopher Wood" <[email-masked]>
Date: Thu, 05 Aug 2021 07:29:21 -0700

On Thu, Aug 5, 2021, at 1:46 AM, Martin Thomson wrote:
> I do want to confirm however that the change in test vectors between 
> -08 (where the final version string was added) and -09 was just the 
> result of missing the test vectors in the -08 update.  I've code that 
> uses the source JSON file, which were updated one day after -08 was 
> published.

-08 was not missing test vector updates. The test vector changes in -09 came from renaming some fields in the test vector generation code, and then rerunning that code:

   https://github.com/cfrg/draft-irtf-cfrg-hpke/pull/224

The JSON file in the repository matches those in the latest version of the document. (These have been checked and confirmed by multiple people, though we welcome additional confirmation.)

>    generator - the confidentiality guarantees of HPKE degrade	

Done: https://github.com/cfrg/draft-irtf-cfrg-hpke/pull/236

Best,
Chris