Subject: Re: [CFRG] SRTP: Any work on more cryptoalgorithms?

From: Hal Murray <[email-masked]>
Date: Thu, 03 Feb 2022 04:11:49 -0800

[email-masked] said:
>>   If you want to take advantage of a lower L, you have to ensure that
>>   legitimate users _refuse to accept_ larger messages -- it's not enough
>>    for the legitimate users to normally send smaller ones.
> No need to - physical layer puts hard limit on L. There's nothing a user can
> do to increase it. 

I'd be very careful depending on that.  For example, IP/UDP has fragmentation 
to carry larger payloads than the transport layer can carry in a single packet.

Even if you design a protocol in a context where that can't happen, people are 
likely to use it in a slightly different environment.

-- 
These are my opinions.  I hate spam.

---

From: "Blumenthal, Uri - 0553 - MITLL" <[email-masked]>
Date: Thu, 3 Feb 2022 12:20:01 +0000

>    to carry larger payloads than the transport layer can carry in a single packet.

Yes. As I said, my use case is rather specific. And the analysis we did does not automatically extend to other use cases, such as, e.g., UDP.

>    likely to use it in a slightly different environment.

Hmm... True - but in general, I see no way to prevent misuse, except for telling people "this is designed to work in X, and all the guarantees are limited to X. Outside, you're on your own, and probably not secure".