Subject: [CFRG] I-D Action: draft-irtf-cfrg-ristretto255-decaf448-02.txt

From: [email-masked]
Date: Thu, 17 Feb 2022 12:55:51 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Crypto Forum RG of the IRTF.

        Title           : The ristretto255 and decaf448 Groups
        Authors         : Henry de Valence
                          Jack Grigg
                          Mike Hamburg
                          Isis Lovecruft
                          George Tankersley
                          Filippo Valsorda
	Filename        : draft-irtf-cfrg-ristretto255-decaf448-02.txt
	Pages           : 22
	Date            : 2022-02-17

Abstract:
   This memo specifies two prime-order groups, ristretto255 and
   decaf448, suitable for safely implementing higher-level and complex
   cryptographic protocols.  The ristretto255 group can be implemented
   using Curve25519, allowing existing Curve25519 implementations to be
   reused and extended to provide a prime-order group.  Likewise, the
   decaf448 group can be implemented using edwards448.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-irtf-cfrg-ristretto255-decaf448/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-irtf-cfrg-ristretto255-decaf448-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-irtf-cfrg-ristretto255-decaf448-02

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

---

From: Christopher Wood <[email-masked]>
Date: Thu, 17 Feb 2022 13:01:50 -0800

Hi folks,

I think this latest update adequately addresses the Crypto Panel review from Thomas Pornin [1]. At this point, the document appears to be ready to move forward in the process. Given that it’s a dependency for draft-irtf-cfrg-voprf, draft-irtf-cfrg-hash-to-curve, and draft-irtf-cfrg-frost, can we please start RGLC?

Thanks,
Chris

[1] https://mailarchive.ietf.org/arch/msg/crypto-panel/isgCxg9ddxoPkNnOdGbwK2Z2_Cw/

> On Feb 17, 2022, at 12:55 PM, [email-masked] wrote:
> 
> 
> _______________________________________________
> CFRG mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/cfrg

---

From: Watson Ladd <[email-masked]>
Date: Fri, 18 Feb 2022 09:37:04 -0800

On Thu, Feb 17, 2022, 1:03 PM Christopher Wood <[email-masked]> wrote:

> Hi folks,
>
> I think this latest update adequately addresses the Crypto Panel review
> from Thomas Pornin [1]. At this point, the document appears to be ready to
> move forward in the process. Given that it’s a dependency for
> draft-irtf-cfrg-voprf, draft-irtf-cfrg-hash-to-curve, and
> draft-irtf-cfrg-frost, can we please start RGLC?
>

Yes please. We have an emerging cluster C450, and it would be nice to nip
it in the bud.

> Thanks,
> Chris
>
> [1]
> https://mailarchive.ietf.org/arch/msg/crypto-panel/isgCxg9ddxoPkNnOdGbwK2Z2_Cw/
>
> https://www.irtf.org/mailman/listinfo/c
> <https://www.irtf.org/mailman/listinfo/cfrg>frg
>

---

From: John Mattsson <[email-masked]>
Date: Mon, 21 Feb 2022 10:31:29 +0000

Two (minor) comments on draft-irtf-cfrg-ristretto255-decaf448-02

- "However, every Edwards curve has a point of order 4.  Thus, the group of points on the curve is not of prime order but has a small cofactor.

- "point of order 4" is true but maybe not relevant in the introduction. I don't think the cofactor has to be "small" in general Edwards curves. Suggestion:

"However, the group of points is not of prime order and has a cofactor."

- "this document specifies the ristretto255 group, which MAY be implemented using Curve25519."

The document should have similar text about decaf448, i.e., "this document specifies the decaf448 group, which MAY be implemented using edwards448."

Cheers,
John

From: CFRG <[email-masked]> on behalf of [email-masked] <[email-masked]>
Date: Thursday, 17 February 2022 at 21:57
To: [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: [CFRG] I-D Action: draft-irtf-cfrg-ristretto255-decaf448-02.txt

Abstract:

_______________________________________________
CFRG mailing list
[email-masked]
https://protect2.fireeye.com/v1/url?k=31323334-501d5122-313273af-454445555731-40f7d10cf9eb7c69&q=1&e=0048f726-f572-4ace-a957-75d0268108dc&u=https%3A%2F%2Fwww.irtf.org%2Fmailman%2Flistinfo%2Fcfrg

---

From: "Filippo Valsorda" <[email-masked]>
Date: Tue, 22 Feb 2022 10:38:02 +0100

> Two (minor) comments on draft-irtf-cfrg-ristretto255-decaf448-02

Thank you, added to the current editing pass.

https://github.com/cfrg/draft-irtf-cfrg-ristretto255/pull/11

> *From: *CFRG <[email-masked]> on behalf of [email-masked] <[email-masked]>
> *Date: *Thursday, 17 February 2022 at 21:57
> *To: [email-masked] <[email-masked]>
> *Cc: [email-masked] <[email-masked]>
> *Subject: *[CFRG] I-D Action: draft-irtf-cfrg-ristretto255-decaf448-02.txt
>