Subject: [CGA-EXT] Key Hash field in the RSA Sig Option

From: "Jean-Michel Combes" <[email-masked]>
Date: Wed, 2 Jul 2008 14:38:05 +0200

Hi,

In reviewing draft-kukec-csi-hash-threat-02, I was wondering what was
the reason to add a Key Hash field in the RSA Signature Option. How is
it useful to have it from a security point of view?

Thanks in advance for your help.

Best regards.

JMC.
_______________________________________________
CGA-EXT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/cga-ext

---

From: "Jean-Michel Combes" <[email-masked]>
Date: Wed, 2 Jul 2008 15:14:52 +0200

Hi Sheng,

2008/7/2 Sheng Jiang <[email-masked]>:
> Hi, Jean,
>
> Firstly, the Key Hash field is not added by this draft. It is defined in SEND
> specification - RFC 3971.

Sure :)
But, in fact, my question was regarding RFC 3971 and not your draft.
Sorry for the confusion.

> Secondly, the answer for you: it is "Its purpose is to
> associate the signature to a particular key known by the receiver."

Agree but:
o For NS/NA/RS
When there is a CGA option, the key hash field MUST contain the hash
of the CGA public key but the CGA public key is already in the CGA
Parameters field in the CGA option.
o For RA
In the case where there is no CGA option, the key hash should be the
hash of public key from the Router Authorization Certificate but this
key is already in this cert.

So, in the two cases, you have already the key, so why do you need to
have a hash of the key too?

Best regards.

JMC.

>
> Best regards,
>
> Sheng JIANG, Ph.D.
>
> IP Research Department, Networking Research Department, Network Product Line, Huawei
> Technologies Co. Ltd.
>
>
> *-----Original Message-----
> *From: [email-masked]
> *[mailto:[email-masked]] On Behalf Of Jean-Michel Combes
> *Sent: Wednesday, July 02, 2008 8:38 PM
> *To: [email-masked]
> *Subject: [CGA-EXT] Key Hash field in the RSA Sig Option
> *
> *Hi,
> *
> *In reviewing draft-kukec-csi-hash-threat-02, I was wondering
> *what was the reason to add a Key Hash field in the RSA
> *Signature Option. How is it useful to have it from a security
> *point of view?
> *
> *Thanks in advance for your help.
> *
> *Best regards.
> *
> *JMC.
> *_______________________________________________
> *CGA-EXT mailing list
> [email-masked]
> *https://www.ietf.org/mailman/listinfo/cga-ext
> *
>
>
>

---

From: Suresh Krishnan <[email-masked]>
Date: Wed, 02 Jul 2008 18:52:29 -0400

Hi JM,

> have a hash of the key too?

The Key Hash field is necessary in the RSA signature option because the 
signer can be different from the address owner. In this case

* The Key hash in the RSA signature option is the hash of the public key 
of the signer
* The Public key in the CGA params field is that of the address owner.

RFC3971 does not make such distinction and hence this field does not 
make sense in the context of RFC3971 only. I think it has been left in 
there as an extension mechanism.

Cheers
Suresh