Subject: [CGA-EXT] (small) Review of draft-ietf-csi-sndp-prob-00.txt

From: Tony Cheneau <[email-masked]>
Date: Fri, 19 Dec 2008 16:46:14 +0100 (CET)

Hello,

Here is some small comments on your draft.

In Figure 1, in the legend, you explain the meaning of the RS and RA, but 
you use them only in Figure 3, maybe it should be better to Introduce it 
there.

Also, in Figure 3, when the proxy is proxying the RTSOL:
      RS:SL3=S,DL3=AllR,
         SL2=p,DL2=sol(A),SLL=p
Is there a reason why DL2 isn't allr ? Does the proxy cache the address of 
a router ?

In figure 5:

  Mobile Node         Proxy          Mobile Node - M
  (Departed)            P            (New Location)

   + - - +                            +-----+ NC:
   '     '     NC:          NC:       |     | N -> n
   + - - +     N -> n+-----+M -> m    +-----+
      |              |     |             |
   ------------------|     |--------------------
        |            |     |
     +-----+NC:      +-----+
     |     |M -> m
     +-----+

     Existing
    Neighbor - N

I'm probably wrong since I didn't go through all 3775 RFC, but when a MN
is leaving a network (home or foreign), shouldn't it flush its Neighbor
Cache from entries related to that previous network ? If it is the case,
the NC of the Mobile Node should be empty in its "New Location".

I also agree with Julien that there should be a part on PMIP.

Hope it helps.

Regards,
 	Tony Cheneau
_______________________________________________
CGA-EXT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/cga-ext

---

From: "Jean-Michel Combes" <[email-masked]>
Date: Sat, 27 Dec 2008 18:52:19 +0100

Hi,

At first sorry for the late reply and thanks for the review.

> you use them only in Figure 3, maybe it should be better to Introduce it

We can add the all the legend again in Fig. 3 :)

> Is there a reason why DL2 isn't allr ?

None :) I will correct this.

> Does the proxy cache the address of a
> router ?
>
> In figure 5:
>

Normally, there is nothing specifying that a MN must flush its
Neighbor Cache when it moves to a new subnet.

> I also agree with Julien that there should be a part on PMIP.

Cf. my reply to his comment :)

Best regards and happy new year.

JMC.