Subject: Re: [Chirp] Fwd: IETF 107 Vancouver In-Person Meeting Cancelled

From: Stephen Farrell <[email-masked]>
Date: Thu, 2 Apr 2020 12:32:27 +0100

Hiya,

I only got one request to hold such a meeting so I guess
we don't want one.

That, and the lack of activity on this list is a bit of
a pity I think so ideas welcome as to how to energise a
discussion... If you have such an idea, then please just
start a new thread on the list.

Cheers,
S.

On 10/03/2020 20:50, Stephen Farrell wrote:
> 
> Hi all,
> 
> Many of you will have seen this but we'll not be meeting
> f2f in Vancouver this time. Hopefully things will have
> improved by the timeframe of IETF108 and we'll be able
> to enjoy a meeting then.
> 
> In the meantime, would people like to organise a call
> in a few weeks to replace our planned get together in
> Vancouver? If so, please mail me, the IAB or the list:-)
> 
> If we do want a call, the IESG have asked for a
> bit of time to do some scheduling that they need to do
> before WGs (and groups like us:-) start to schedule
> such calls. So let's first see if we want a call and
> then we can do scheduling.
> 
> Cheers,
> S.
> 
> 
> -------- Forwarded Message --------
> Subject: IETF 107 Vancouver In-Person Meeting Cancelled
> Date: Tue, 10 Mar 2020 12:10:27 -0700
> From: The IESG <[email-masked]>
> Reply-To: [email-masked]
> To: IETF Announcement List <[email-masked]>
> CC: [email-masked], [email-masked], [email-masked]
> 
> The IESG and the IRTF Chair have decided to cancel the in-person IETF
> 107 Vancouver meeting. This decision is based on input we gathered from
> Working Group (WG) and Research Group (RG) chairs about our ability to
> hold productive WG and RG sessions at IETF 107. Our assessment of this
> feedback is that a majority of sessions would not be viable if we were
> to hold the in-person IETF meeting. On this basis, we believe we cannot
> hold an effective in-person meeting.
> As a result of this cancellation, the in-person Hackathon, Code Sprint,
> all other in-person events planned for the weekend of March 21-22, the
> chairs training scheduled for March 20, and all other in-person sessions
> during the week are cancelled.
> 
> The IESG is working on an alternative all-virtual agenda for the week of
> March 21-27 with a limited schedule adapted to accommodate the time
> zones of as many participants as possible. We are also planning to
> support an increased volume of virtual interim meetings during the weeks
> that follow. We will send another update to the community soon with more
> information about these plans. The Hackathon organizers are also
> considering plans for virtual Hackathon support.
> 
> We have re-opened Internet-Draft submissions, which had been closed on
> March 9 in anticipation of the in-person meeting. Internet-Drafts may be
> submitted at <https://datatracker.ietf.org/submit/>.
> 
> A separate announcement from the IETF Executive Director will follow
> with details about registration cancellations and refunds.
> These are unusual times given the circumstances created by the spread of
> COVID-19.  We hope that everyone remains safe and healthy.
> 
> Regards,
> The IESG and the IRTF Chair
> 
> _______________________________________________
> IETF-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-announce
> 
> 
>

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 2 Apr 2020 17:27:17 +0200

[Cc'ing to architecture-discuss, because this reply goes
beyond the scope of chirp.]

Stephen, *:

I don't think that a mailing list alone is a sufficient way to
encourage interested parties to invest significant amount of
cycles to contribute original work towards a subject even if
as a one off: document and/or presentation. If you want
people to invest cycles towards something you're interested in,
you need to give contributors a well defined opportunity to
engage in-person through a meeting (or virtual meeting
in the time of corona) and allowing the work invested to be
referenceable by future work of others (such as meeting
proceedings for presentations).

We have this mode of operations in hundreds of conferences
including IRTF, we have it in IETF WGs for standards, we do
not have this for architectural discussions for the Internet. 

Why not ?

Stephen, I know we may have a fundamental difference in opinion about
this if i correctly interpret your harsh criticism about my teams
organized inofficial side-meeting in march, but i for once don't
think that a discussion about internet architecture will magically
improve through the absence of such meetings.

Why is there no internet architecture discuss meeting slot in
every IETF meeting (virtual in times of corona) ? I can not
even start to comprehend why i am seemingly the only one asking
this question.

To me, providing such fairly open scoped meeting looks like
the most fundamental meeting the IAB should organize to engage
the community in an open fashion. Consider it the "dispatch"
equivalent of other areas.

Topics of special interest to IAB (such as chirp) could be
indicated as prioritized topics to encourage contribution to 
them, and if they show critical mass the could be dispatched
into separate forums.

I can see no outcome worse than what we seemingly have now on
this architecture-discuss mailing list: agony and inactivity
interrupted by often snide lecturing meta discussions about those who
attempt to contribute something, however well or badly that is done.

Cheers
    Toerless

> > The IESG and the IRTF Chair

pub   RSA 4096/7B172BEA 2017-12-22 Stephen Farrell (2017) <[email-masked]>
> sub   RSA 4096/36CB8BB6 2017-12-22
> 

> -- 
> Chirp mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/chirp

-- 
---
[email-masked]

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 2 Apr 2020 16:32:05 +0100

Hiya,

> Why not ?

I'd be really happy to organise a meeting for chirp. [1]
If people want one, just mail me or that list.

But, I asked on the list already, as I just said, and
only 1 person was interested, so I'm very puzzled as
to what it is you are complaining about.

S.

[1] https://www.iab.org/mailman/listinfo/chirp

---

From: Jari Arkko <[email-masked]>
Date: Thu, 2 Apr 2020 18:37:02 +0300

Toerless, you ask good questions. But I’d say it is difficult to discuss a large topic in the abstract. Not saying we shouldn’t have arch-dispatch, but it isn’t immediately obvious to me that such a meeting would work well. It is however easier to discuss more specific issues, and for those there does exist many IAB-sponsored meetings (such as ones Stephen has helped set up), IRTF RG meetings looking at interesting Internet evolution topics, and meetings outside IETF meeting week (such as workshops). And ultimately there are of course many more private gatherings where some smaller set of people are starting to discuss a new topic.

Jari

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 2 Apr 2020 18:14:57 +0200

On Thu, Apr 02, 2020 at 06:37:02PM +0300, Jari Arkko wrote:
> Toerless, you ask good questions. But I???d say it is difficult to discuss a large topic in the abstract. Not saying we shouldn???t have arch-dispatch, but it isn???t immediately obvious to me that such a meeting would work well.

I am sure it will not work well initially because it would be
new for us, but i am even more persuaded we should attempt to
do it and give it time through iteration and learning of how
to improve the process. For example, like in research
conferences, we might need to invest more into upfront
vetting/review of proposals - but not to limit the topics, but
to improve the quality. 

And we can look at the continuum of useful outputs:

On one end, there is a one-off draft/presentation, but it could
still turn out to be viable long-term reference for further
followup work. And compared to all those research conferences
we would have the chance for the community to review and
help improve the document through few iterations, even if it
stops there. Such as many abandoned IETF drafts. IMHO still
a lot better outcome than that of many journal published research
conference papers.

On the other end is the criticial mass of interested parties that
drive a topic over to a community vetted/approved RFC. But we
do not even have such a process for possible architecture RFCs
and IMHO existing IETF WGs mostly start when the architecture
is defined well enough already.

> It is however easier to discuss more specific issues, and for those there does exist many IAB-sponsored meetings (such as ones Stephen has helped set up)

The main problem to limit discussions to more specific topics
is always the problem of timelyness and priorities between
what the organizers think is of interest and what possible
contributors think.  Especially when there are commercial
divergences if not conflicts. 

> IRTF RG meetings looking at interesting Internet evolution topics, and meetings outside IETF meeting week (such as workshops).

Unfortunately, i have seen very strong rejection by the IRTF chair
to consider topics he deems to be more architectural in nature than
"research" in nature. Starting even with the problem of what
composition model we want or the like to have for system level
architecture or principles of how to evolve the forwarding plane.
And i would have no argument about that distinction if we just
had an architecture track as we have a reearch track to do the work.

> And ultimately there are of course many more private gatherings where some smaller set of people are starting to discuss a new topic.

Who are not even given equal access to collaboration tools in the IETF
community (concern raised at plenary by me). because of the IMHO bogus
argument of fear of "endorsement". 

Cheers
    Toerless

> Architecture-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/architecture-discuss

-- 
---
[email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 2 Apr 2020 18:37:05 +0200

I am complaining about the absence of a recurring, IAB organized
architecture-discuss/dispatch meeting slot at IETF meetings.

If we had this, then you could indicate that 'chirp' contributions are
a preferred topic to be presented/discussed in such a track.

You do encourage contributions by giving them these incentices:
recurring meeting with longer time horizon: ability to plan putting cycles
into a contribution. Present in a larger context of an arch-discuss
track == reach out to more opportunistic participants.

Cheers
    Toerless

-- 
---
[email-masked]