Subject: [cicm] Comments on -00

From: Sean Turner <[email-masked]>
Date: Mon, 22 Mar 2010 18:45:35 -0700

Lev,

I haven't gotten all the way through the ID, but I did have a couple of 
questions:

Is there any intention to insert the removed figures?  ASCII art might 
not be your thing but maybe if you posted a pdf of the figures somebody 
might be able to draw them for you?  The figures would definitely help 
me come up to speed quicker.

Is there a freeware IDL compiler available?

Is there any intention to include a sample ICS?

Please add an appendix that collects of the IDL code in one location.
It makes it easier for lazy people like me to compile it.

spt

---

From: Vincent Roca <[email-masked]>
Date: Tue, 23 Mar 2010 03:22:04 +0100

Hello Sean,

In the meantime, you'll find what you're looking for (i.e. the PDF
version with
all figures) here:
    http://www.ietf.org/id/draft-lanz-cicm-00.pdf
Cheers,

    Vincent

Le 23/03/10 02:45, Sean Turner a écrit :
> Lev,
>
> I haven't gotten all the way through the ID, but I did have a couple
> of questions:
>
> not be your thing but maybe if you posted a pdf of the figures
> somebody might be able to draw them for you?  The figures would
> definitely help me come up to speed quicker.
>
> _______________________________________________
> cicm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cicm

---

From: Sean Turner <[email-masked]>
Date: Tue, 23 Mar 2010 09:41:22 -0700

Thanks.  I never even thought to look for the pdf version.

spt

---

From: "Novikov, Lev" <[email-masked]>
Date: Tue, 23 Mar 2010 13:56:21 -0400

Sean,

All good points.

Regarding freeware IDL compilers see: http://patriot.net/~tvalesky//freecorba.html 
Also: I know that Java comes with a utility called idlj (in the JDK) to make Java code out of IDL. Many the tools mentioned generate CORBA-based code which is NOT a requirement for CICM.

IDL is being used as a language-neutral way to specify inheritance, names, methods, parameters, etc. If someone wanted to do CORBA, the IDL would be normative.

There's a unified IDL file that I can easily add as an appendix for -01 (for now see: http://www.mitre.org/tech/cicm/cicm.idl)

Lev
 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Sean Turner
Sent: Monday, March 22, 2010 9:46 PM
To: [email-masked]
Subject: [cicm] Comments on -00

Lev,

spt