Subject: [cicm] Document Structure

From: "Novikov, Lev" <[email-masked]>
Date: Thu, 15 Jul 2010 16:08:00 -0400

As I hinted to last week, I'd like to raise some issues about the document structure.

The current draft (-01) is long (315 pages) and combines 20+ pages of informative
text with hundreds of pages of normative text. Also, some people have also mentioned 
that we do not provide an explicit logical model.

More importantly, however, is that the current shape of the document makes it hard for people
to read and comment on it. This is likely to keep us from getting on the Standards Track
when members of the IETF at-large and other review groups, such as the Security Area Advisory Group 
aren't willing to read the document and give it the go-ahead.

Therefore, I'd like to propose that we split the text of CICM into several different documents:

1. An informative background document that provides an introduction to the space, 
   the terminology, and logical model. (See: http://tools.ietf.org/html/rfc3264 for an 
   example of this sort of document.)
   ~ 30 pages.

2. A normative base document that defines the basic types and the Conformance & Extension model.
   ~ 20 pages.

3. A normative document that defines Module Management capabilities.
   ~ 50 pages.

4. A normative document that defines Key Management capabilities.
   ~ 50 pages.

5. A normative document that defines Channel Management capabilities.
   ~ 130 pages. (Still long, but there's a lot to cover.)

Document #2 would actually reference documents #1, 3, 4, and 5 and would, therefore,
"be CICM". The other normative documents would be using the extension mechanism
to provide the definitions for the actual capabilities.

* What do people think about this proposal? Other ideas?

Lev

---

From: "Dr. Joe Mitola" <[email-masked]>
Date: Thu, 15 Jul 2010 19:28:16 -0400

Superb recommendation, Lev
joe

Dr. Joseph Mitola III, Fellow of the IEEE
Distinguished Professor
Charles V. Schaefer, Jr.  School of Engineering and Science
School of Systems and Enterprises
Vice President for the Research Enterprise
Stevens Institute of Technology
Castle Point on Hudson, Hoboken, NJ, USA
Cell: 703-314-5709

Novikov, Lev wrote:
> _______________________________________________
> cicm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cicm
>