Subject: [cicm] Why do we need a high assurance API?

From: "Novikov, Lev" <[email-masked]>
Date: Thu, 21 Jul 2011 12:01:55 -0400

For the benefit of IETF folks who are unfamiliar with this area who will
be reading this list during and after the BOF:

  Why do we need a high assurance crypto API?

Please write a brief response that relates to your (or your 
organization's) experience.

Thank you,
Lev

---

From: "Otaway Thomas" <[email-masked]>
Date: Thu, 21 Jul 2011 18:04:47 -0400

CICM Distro List,
One application in which this API is needed in the development of high
assurance software definable radios.
In JTRS this is handled by the "closed" JTRS Red Security Services (RSS) API
which is under need-to-know distribution control of the U.S. DoD.
An equivalent open standard would provide reduced development costs through
commercial competition and a wider global market.
The API would also be helpful in the wider range of communications systems,
such as terminals and crypto devices (ECUs), that are becoming increasingly
"software definable."
Thanks,
Otaway

Otaway Thomas, CISSP, ISSEP, IAM
Chief Engineer
Arkham Technology Ltd.
20 Pacifica, Suite 670
Irvine, CA 92618
949-228-6677

-----Original Message-----
From: Novikov, Lev [mailto:[email-masked]] 
Sent: Thursday, July 21, 2011 12:02 PM
To: CICM Discussion List ([email-masked])
Subject: [cicm] Why do we need a high assurance API?

Thank you,
Lev