Subject: [cicm] Key Fill (was: Proposed WG Charter)

From: "Novikov, Lev" <[email-masked]>
Date: Fri, 15 Jul 2011 09:51:30 -0400

On 2011-07-15 08:14, Kevin Wall wrote:
>...[snip]...
>>
>>  * add module events for symmetric and asymmetric key filled
>
>               ^^^^^
>
>Is that supposed to be 'key field' ??? Because I don't get
>"key filled".

From: http://tools.ietf.org/html/draft-lanz-cicm-lm-00

   $ key fill device

      Devices that read-in, transfer, and store key material.

   $ key fill interface

      Set of protocols, electrical connections, and physical
      characteristics that comprise the connecting link between a key
      fill device and a cryptographic module.  CICM enables a key fill
      interface to be configured and actions to be initiated on a key
      fill device via the key fill interface.

See Also:
http://tools.ietf.org/html/draft-lanz-cicm-km-00 (search for "key fill")

Lev

---

From: "Kevin W. Wall" <[email-masked]>
Date: Fri, 15 Jul 2011 13:41:41 -0400

Lev,

You mean like an HSM, as an example of a key filled device?

Seems like it should say something like "Key filled device" or
"key filled interface" or "key filled action" or "key filled protocol" or
_something_ then. The way it's worded is a bit odd as far as the
English grammar goes.

To me, that bullet reads as though some word is missing at the
end. Even with your explanation (which now makes it makes it sense)
it still reads very awkward to me.

-kevin

On Fri, Jul 15, 2011 at 9:51 AM, Novikov, Lev <[email-masked]> wrote:
> _______________________________________________
> cicm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cicm
>

-- 
Blog: http://off-the-wall-security.blogspot.com/
"The most likely way for the world to be destroyed, most experts agree,
is by accident. That's where we come in; we're computer professionals.
We *cause* accidents."        -- Nathaniel Borenstein

---

From: "Krishnamurthy, Hema - ES" <[email-masked]>
Date: Fri, 15 Jul 2011 13:44:20 -0400

Maybe just say " add module events for symmetric and asymmetric key fill"

'Key Fill' is a common terminology.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Kevin W. Wall
Sent: Friday, July 15, 2011 10:42 AM
To: CICM Discussion List
Subject: Re: [cicm] Key Fill (was: Proposed WG Charter)

Lev,

-kevin

This e-mail and any files transmitted with it may be proprietary and are intended solely for the use of the individual or entity to whom they are addressed. If you have received this e-mail in error please notify the sender.
Please note that any views or opinions presented in this e-mail are solely those of the author and do not necessarily represent those of ITT Corporation. The recipient should check this e-mail and any attachments for the presence of viruses. ITT accepts no liability for any damage caused by any virus transmitted by this e-mail.

---

From: "Novikov, Lev" <[email-masked]>
Date: Fri, 15 Jul 2011 15:18:49 -0400

On 2011-07-14 19:17, Lev Novikov wrote:
> [...]
> [...]

> You mean like an HSM, as an example of a key filled device?

Not quite; I'm referring to a device which fills (loads) a module 
with keys. E.g. http://en.wikipedia.org/wiki/Fill_device

> "key filled interface" or "key filled action" or "key filled protocol"
> or _something_ then. The way it's worded is a bit odd as far as the
> English grammar goes.
>

Funny, I had a similar reaction when I was introduced to the term 
"key fill"-- I kept wanting to say "key filling" (as a gerund), but I 
kept getting corrected "yes, it does key fill" (verb acting as a noun 
without being a gerund). It would almost be better, grammatically, if it
was hyphenated "key-fill" so that it looked more like a noun than a 
verb. Alas, it is not the common usage. So it's not clear how you 
conjugate the past tense of a verb that doesn't normally get 
conjugated.

On 2011-07-15 13:44, Hema Krishnamurthy wrote:
> Maybe just say "add module events for symmetric and asymmetric 
> key fill" 

Good suggestion. It keeps the bizarre conjugation consistent.

Lev

---

From: "Kevin W. Wall" <[email-masked]>
Date: Fri, 15 Jul 2011 15:32:20 -0400

That sounds better to me. Let's go with that.

---

From: Sean Turner <[email-masked]>
Date: Fri, 15 Jul 2011 17:57:33 -0400

> http://tools.ietf.org/html/draft-lanz-cicm-km-00 (search for "key fill")

You could point to https://datatracker.ietf.org/doc/rfc4949:

   $ fill device
       (N) /COMSEC/ A device used to transfer or store keying material in
       electronic form or to insert keying material into cryptographic
       equipment.

spt

---

From: "Novikov, Lev" <[email-masked]>
Date: Thu, 21 Jul 2011 11:54:37 -0400

Sean,

>       electronic form or to insert keying material into cryptographic

Good idea. There are probably several places where we can reference RFC 4949 better.

Lev