Subject: [cicm] Proposed WG Charter

From: "Novikov, Lev" <[email-masked]>
Date: Thu, 14 Jul 2011 19:16:42 -0400

Since the WG BOF at IETF 81 is just around the corner (currently scheduled for: Wed, 2011-07-27 15:10-16:10), let's review the text of the proposed charter (included below) to make sure we're all on the same page.

Now is the time to voice your suggestions, revisions, comments about the charter.

Regards,
Lev

From: http://code.google.com/p/ietf-cicm/wiki/WGCharter

The Common Interface to Cryptographic Modules (CICM) defines an abstract
API for the security services provided by cryptographic modules 
developed by multiple vendors. The API is intended to support high 
assurance cryptography, security domain separation, and enhanced module,
key, and channel management capabilities that are vendor neutral.

The purpose of the CICM Working Group is to shepherd the CICM 
specification documents to publication and provide guidance for any new 
submissions related to high assurance cryptos.

Specifically, the Working Group will:

Complete existing requests:
  * replace algorithm strings with OIDs
  * use ABNF notation for unique identifiers syntax
  * add module events for symmetric and asymmetric key filled
  * add unprotected-side APIs for:
    * moving data into / out of the module
    * performing administrative functions (e.g., supply IV, 
      header-bypass data)

Shepard the following documents to publication:
  * draft-lanz-cicm
  * draft-lanz-cicm-lm
  * draft-lanz-cicm-mm
  * draft-lanz-cicm-km
  * draft-lanz-cicm-cm

Goals and Milestones
TBD  introduce draft-lanz-cicm-lm to WG
TBD  introduce draft-lanz-cicm to WG
TBD  introduce draft-lanz-cicm-mm to WG
TBD  introduce draft-lanz-cicm-km to WG
TBD  Submit draft-lanz-cicm to the IESG as Proposed Standard

---

From: "Kevin W. Wall" <[email-masked]>
Date: Fri, 15 Jul 2011 08:14:24 -0400

On Thu, Jul 14, 2011 at 7:16 PM, Novikov, Lev <[email-masked]> wrote:
...[snip]...
>  * add module events for symmetric and asymmetric key filled

               ^^^^^

Is that supposed to be 'key field' ??? Because I don't get
"key filled".

-kevin
-- 
Blog: http://off-the-wall-security.blogspot.com/
"The most likely way for the world to be destroyed, most experts agree,
is by accident. That's where we come in; we're computer professionals.
We *cause* accidents."        -- Nathaniel Borenstein

---

From: "Novikov, Lev" <[email-masked]>
Date: Wed, 27 Jul 2011 09:52:10 -0400

A few weeks ago, there were some tweaks to the charter language from "shepherd" to "propose" that were not finished.

Below is an updated text (changes are in the second paragraph).

Thanks,
Lev

The purpose of the CICM Working Group is to publish an API for high 
assurance cryptographic devices and to provide guidance for any new 
submissions related to high assurance cryptos.

Goals and Milestones

---

From: "Novikov, Lev" <[email-masked]>
Date: Wed, 27 Jul 2011 11:05:06 -0400

Well, that was silly. Here's the REAL updated draft. (hat tip: Sean)

Apologies,
Lev

= Description of Working Group =

  * Complete existing requests:
    * replace algorithm strings with OIDs
    * use ABNF notation for unique identifiers syntax
    * add module events for symmetric and asymmetric key fill
    * add unprotected-side APIs for:
      * moving data into / out of the module
      * performing administrative functions (e.g., supply IV, 
        header-bypass data)

  * Propose the following documents to the Working Group:
    * draft-lanz-cicm
    * draft-lanz-cicm-lm
    * draft-lanz-cicm-mm
    * draft-lanz-cicm-km
    * draft-lanz-cicm-cm

= Goals and Milestones =