Subject: [clue] RTP Mux - Endpoint Configuration Implications

From: Peter Musgrave <[email-masked]>
Date: Wed, 2 Feb 2011 06:32:50 +0000

Hi all, 

If an RTP mux solution is chosen then this imposes a need for an endpoint to receive all media of a certain type (audio or video) at the same IP address:port. 

Consequently this dictates endpoint architecture (an endpoint which wants to decode a second stream on another IP in a media service type of architecture will need to relay the data). 

Personally I can live with one IP - since that's what my endpoints do. 

Does this give anyone heartburn?

Thanks, 

Peter Musgrave

---

From: Stephen Botzko <[email-masked]>
Date: Wed, 2 Feb 2011 06:32:00 -0500

Although our endpoints use multliple IP addresses, I am ok with a relay.
One caveat - I would not want a encryption approach that requires the relay
to encrypt/decrypt the full multiplex.  Rather, the individual streams
should be encrypted/decrypted independently.

Stephen Botzko

On Wed, Feb 2, 2011 at 1:32 AM, Peter Musgrave <[email-masked]
> wrote:

> Hi all,
>
> If an RTP mux solution is chosen then this imposes a need for an endpoint
> to receive all media of a certain type (audio or video) at the same IP
> address:port.
>
> Consequently this dictates endpoint architecture (an endpoint which wants
> to decode a second stream on another IP in a media service type of
> architecture will need to relay the data).
>
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue
>