Subject: [clue] Definitions-00 posted

From: Stephan Wenger <[email-masked]>
Date: Thu, 19 May 2011 10:07:52 +0200

Hi all,
I just posted the 00 draft, reflecting (hopefully) the outcome of the
discussions of the last six days as well as (hopefully) addressing most
typos.  Comments welcome.
Stephan

http://www.ietf.org/id/draft-wenger-clue-definitions-00.txt

---

From: Roni Even <[email-masked]>
Date: Wed, 25 May 2011 08:58:34 +0300

Hi Stephan,

About the left right directions you suggested 
Left: to be interpreted as a stage direction, see
also[StageDirection(Wikipadia)].
<http://en.wikipedia.org/wiki/Blocking_(stage)>
http://en.wikipedia.org/wiki/Blocking_(stage) 
When looking at the reference it looks to me that we were proposing what is
called "house left" and not "stage left"
 
Roni

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Stephan Wenger
Sent: Thursday, May 19, 2011 11:08 AM
To: [email-masked]
Subject: [clue] Definitions-00 posted

Hi all,

I just posted the -00 draft, reflecting (hopefully) the outcome of the
discussions of the last six days as well as (hopefully) addressing most
typos.  Comments welcome.

Stephan

---

From: Songhaibin <[email-masked]>
Date: Wed, 25 May 2011 07:19:18 +0000

Hi Stephan,

Thanks for the good draft.

When reading about the definition for the "endpoint". It says:

The logical point of final termination through receiving, decoding and rendering, and/or initiation through  capturing, encoding, and sending of media streams.An endpoint consists of one or more physical devices which source and sink media streams, and exactly one [RFC4353] Participant (which, in turn, includes exactly one SIP User Agent)...

So here what is the definition for "Participant"? Is it a person, a device, or an endpoint? I think it should mean endpoint. But the text is confusing.

BR,
-Haibin

From: [email-masked] [mailto:[email-masked]] On Behalf Of Stephan Wenger
Sent: Thursday, May 19, 2011 4:08 PM
To: [email-masked]
Subject: [clue] Definitions-00 posted

Hi all,
I just posted the -00 draft, reflecting (hopefully) the outcome of the discussions of the last six days as well as (hopefully) addressing most typos.  Comments welcome.
Stephan

---

From: Stephan Wenger <[email-masked]>
Date: Wed, 25 May 2011 07:21:00 -0700

I tought that, by having the reference [RFC4353] right next to
"Participant", it would be clear from context that one has to use the
definition of Participant of RFC4353.  Isn't it?
Stephan

On 5.25.2011 00:19 , "Songhaibin" <[email-masked]> wrote:

>The logical point of final termination through receiving, decoding and
>rendering, and/or initiation through  capturing, encoding, and sending of
>media streams.An endpoint consists of one or more physical devices which
>source and sink media streams, and exactly one [RFC4353] Participant
>(which, in turn, includes exactly one SIP User Agent)...
>
>So here what is the definition for "Participant"? Is it a person, a
>device, or an endpoint? I think it should mean endpoint. But the text is
>confusing.
>
>BR,
>-Haibin
>
>
>
>

---

From: Stephan Wenger <[email-masked]>
Date: Wed, 25 May 2011 07:23:15 -0700

Would like to hear Steve Botzko's opinion here, as I believe to recall he
suggested the use of "stage left" first.
I personally don't care whether we take "stage" or "house" viewpoint, as
long as we pick one of the two.
(Has anyone a more stable reference for stage directions?  I'm not sure that
the RFC editor will let us get away with unstable wikipedia referencesŠ)
Stephan

From:  Roni Even <[email-masked]>
Date:  Wed, 25 May 2011 08:58:34 +0300
To:  Stephan Wenger <[email-masked]>, <[email-masked]>
Subject:  RE: [clue] Definitions-00 posted

Hi Stephan,
 
Roni

Hi all,

Stephan

---

From: Stephen Botzko <[email-masked]>
Date: Wed, 25 May 2011 10:41:46 -0400

If you want to describe the spatial relationships from a perspective of a
sender (more precisely a human in the sending room), then "stage left" is
more natural.

"House Left"  is more natural if you want to describe spatial relationships
from the perspective of humans in the receiving room.

Though since we are unlikely to have a lot of normative text for rendering
in receivers, "Stage Left" seems more useful to me.  However, I have no
objection to defining both terms.

Steve B,

On Wed, May 25, 2011 at 10:23 AM, Stephan Wenger <[email-masked]> wrote:

> (Has anyone a more stable reference for stage directions?  I'm not sure
> that the RFC editor will let us get away with unstable wikipedia
> references…)
> Stephan
>
>
> Left: to be interpreted as a stage direction, see also[StageDirection(Wikipadia)]. http://en.wikipedia.org/wiki/Blocking_(stage)
>
> When looking at the reference it looks to me that we were proposing what is called "house left" and not "stage left"
>
>
>
> Roni
>
>
>
>
>
>
>
> *From:* [email-masked] [mailto:[email-masked]<[email-masked]>]
> *On Behalf Of *Stephan Wenger
> *Sent:* Thursday, May 19, 2011 11:08 AM
> *To:* [email-masked]
> *Subject:* [clue] Definitions-00 posted
>
>
>
> Hi all,
>
> I just posted the –00 draft, reflecting (hopefully) the outcome of the
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue
>
>

---

From: Stephen Botzko <[email-masked]>
Date: Wed, 25 May 2011 10:53:26 -0400

The current draft of the use case document uses word "participants" to mean
persons.  There are likely to be related requirements that also need to
refer to human participants.

In any event, we will need a consistent way to distinguish people  who are
participating in the conference from devices and endpoints. "Remote
participant" sounds more natural to native English speakers than using
"remote person" or "remote human".

Stephen Botzko

---

From: Roni Even <[email-masked]>
Date: Wed, 25 May 2011 18:44:27 +0300

Steve,

According to Wikipedia

	

Monitor    1                                         Monitor 2
Monitor 3                              

	

                                                                Participant

Here monitor 1 is house left and stage right. Monitor 3 is house right and
stage left.  Assuming that the local participant is the house. 

I do not care which one we pick, I just thought that during the conference
call we mentioned using house left and right

Roni

From: Stephen Botzko [mailto:[email-masked]] 
Sent: Wednesday, May 25, 2011 5:42 PM
To: Stephan Wenger
Cc: Roni Even; [email-masked]
Subject: Re: [clue] Definitions-00 posted

Steve B,

(Has anyone a more stable reference for stage directions?  I'm not sure that
the RFC editor will let us get away with unstable wikipedia references.)

Stephan

Hi Stephan,

<http://en.wikipedia.org/wiki/Blocking_%28stage%29>
 
Roni

Hi all,

Stephan

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Wed, 25 May 2011 17:55:07 +0200

Note that in theatre parlance "house left" and "house right" are not generally used in the UK. Generally we refer to "auditorium left" and "auditorium right". Note that "stage house" refers to everything behind the proscenium so use of "house" can be confusing in this context.

Of course we could always use "prompt side (PS) " and "off prompt (OP)"!!!

Keith

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Roni Even
Sent: 25 May 2011 16:44
To: 'Stephen Botzko'; 'Stephan Wenger'
Cc: [email-masked]
Subject: Re: [clue] Definitions-00 posted

Steve,

According to Wikipedia

Monitor    1                                         Monitor 2                                            Monitor 3

                                                                Participant

Here monitor 1 is house left and stage right. Monitor 3 is house right and stage left.  Assuming that the local participant is the house.
I do not care which one we pick, I just thought that during the conference call we mentioned using house left and right

Roni

If you want to describe the spatial relationships from a perspective of a sender (more precisely a human in the sending room), then "stage left" is more natural.

"House Left"  is more natural if you want to describe spatial relationships from the perspective of humans in the receiving room.

Though since we are unlikely to have a lot of normative text for rendering in receivers, "Stage Left" seems more useful to me.  However, I have no objection to defining both terms.

Steve B,

On Wed, May 25, 2011 at 10:23 AM, Stephan Wenger <[email-masked]<mailto:[email-masked]>> wrote:
Would like to hear Steve Botzko's opinion here, as I believe to recall he suggested the use of "stage left" first.
I personally don't care whether we take "stage" or "house" viewpoint, as long as we pick one of the two.
(Has anyone a more stable reference for stage directions?  I'm not sure that the RFC editor will let us get away with unstable wikipedia references...)
Stephan

From: Roni Even <[email-masked]<mailto:[email-masked]>>
Date: Wed, 25 May 2011 08:58:34 +0300
To: Stephan Wenger <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>
Subject: RE: [clue] Definitions-00 posted

Hi Stephan,

Left: to be interpreted as a stage direction, see also[StageDirection(Wikipadia)]. http://en.wikipedia.org/wiki/Blocking_(stage)<http://en.wikipedia.org/wiki/Blocking_%28stage%29>

Roni

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Stephan Wenger
Sent: Thursday, May 19, 2011 11:08 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [clue] Definitions-00 posted

Hi all,

_______________________________________________
clue mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/clue

---

From: Stephen Botzko <[email-masked]>
Date: Wed, 25 May 2011 12:02:10 -0400

This depends on where you think the stage is!   Though I agree that monitor
3 is house right, and that the stream it is displaying is stage left.

BTW, I don't recall a "house left"  discussion in the conference call, but
perhaps I missed it.

Steve B.

On Wed, May 25, 2011 at 11:44 AM, Roni Even <[email-masked]> wrote:

> Monitor    1                                         Monitor
> 2                                            Monitor
> 3
> *From:* Stephen Botzko [mailto:[email-masked]]
> *Sent:* Wednesday, May 25, 2011 5:42 PM
> *To:* Stephan Wenger
> *Cc:* Roni Even; [email-masked]
> *Subject:* Re: [clue] Definitions-00 posted
>
>
>
> *From: *Roni Even <[email-masked]>
> *Date: *Wed, 25 May 2011 08:58:34 +0300
> *To: *Stephan Wenger <[email-masked]>, <[email-masked]>
> *Subject: *RE: [clue] Definitions-00 posted
>
>
>
> Hi Stephan,
>

---

From: Stephan Wenger <[email-masked]>
Date: Wed, 25 May 2011 09:17:36 -0700

I don't recall discussion about "house left" either.
Steve, take a look at the wikipedia page mentioned.  It may be that
wikipedia and you disagree about what "stage left" actually is.  From what I
understood there (which is consistent with what I thought during the call):
stage directions are from the viewpoint of an actor facing the crowd, not
from the crowd's viewpoint.
Stephan

From:  Stephen Botzko <[email-masked]>
Date:  Wed, 25 May 2011 12:02:10 -0400
To:  Roni Even <[email-masked]>
Cc:  Stephan Wenger <[email-masked]>, <[email-masked]>
Subject:  Re: [clue] Definitions-00 posted

Steve B.

On Wed, May 25, 2011 at 11:44 AM, Roni Even <[email-masked]> wrote:
> sender (more precisely a human in the sending room), then "stage left" is more
> natural.
> 
> Though since we are unlikely to have a lot of normative text for rendering in
> receivers, "Stage Left" seems more useful to me.  However, I have no objection
> to defining both terms.
> 
> Steve B,
> 
> 
> also[StageDirection(Wikipadia)]. http://en.wikipedia.org/wiki/Blocking_(stage)
> discussions of the last six days as well as (hopefully) addressing most typos.
> Comments welcome.
> 
> Stephan
> 
>  
>

---

From: "Mike Hammer (hmmr)" <[email-masked]>
Date: Wed, 25 May 2011 11:32:55 -0500

Keith,

And we could always table this. ;)

How about viewer left and viewer right?  That should be
self-explanatory.

Sorry, I was not a theater major in college.

Mike

From: [email-masked] [mailto:[email-masked]] On Behalf Of
DRAGE, Keith (Keith)
Sent: Wednesday, May 25, 2011 11:55 AM
To: Roni Even; 'Stephen Botzko'; 'Stephan Wenger'
Cc: [email-masked]
Subject: Re: [clue] Definitions-00 posted

Note that in theatre parlance "house left" and "house right" are not
generally used in the UK. Generally we refer to "auditorium left" and
"auditorium right". Note that "stage house" refers to everything behind
the proscenium so use of "house" can be confusing in this context. 

Of course we could always use "prompt side (PS) " and "off prompt
(OP)"!!!

Keith

Roni Even

Steve,

According to Wikipedia

 

Monitor    1                                         Monitor 2
Monitor 3                              

	 	

Participant

Here monitor 1 is house left and stage right. Monitor 3 is house right
and stage left.  Assuming that the local participant is the house. 

I do not care which one we pick, I just thought that during the
conference call we mentioned using house left and right

Roni

If you want to describe the spatial relationships from a perspective of
a sender (more precisely a human in the sending room), then "stage left"
is more natural.

"House Left"  is more natural if you want to describe spatial
relationships from the perspective of humans in the receiving room.  

Though since we are unlikely to have a lot of normative text for
rendering in receivers, "Stage Left" seems more useful to me.  However,
I have no objection to defining both terms.

Steve B,

On Wed, May 25, 2011 at 10:23 AM, Stephan Wenger <[email-masked]>
wrote:

Would like to hear Steve Botzko's opinion here, as I believe to recall
he suggested the use of "stage left" first.

references...)

Stephan

Hi Stephan,

About the left right directions you suggested 
Left: to be interpreted as a stage direction, see
also[StageDirection(Wikipadia)]. 
http://en.wikipedia.org/wiki/Blocking_(stage)
<http://en.wikipedia.org/wiki/Blocking_%28stage%29>  
When looking at the reference it looks to me that we were proposing what
is called "house left" and not "stage left"
 
Roni

Hi all,

Stephan

---

From: Stephen Botzko <[email-masked]>
Date: Wed, 25 May 2011 13:48:23 -0400

Yes, I agree that "stage left" is from the viewpoint of the actor (which I
am interpreting as the sending human participant).  So if you are seated in
the center, and I am on your left, then I am "stage left" (and in a 3-stream
telepresence system, I would be carried in the "left" stream, and displayed
on Monitor 3 in Roni's diagram).

Whether it is actually necessary to describe Monitor 3 as left or right is
unclear to me; I am thinking we are mostly describing spatial relationships
of streams, not display devices.  However, from a receiving perspective, the
monitors represent the far-end stage.  So it would be sensible to label the
monitor as "audience right".

What's tricky here is that there are two "stages", one at each end of the
call.  So we don't want to call Monitor 3 the "stage left" monitor, since it
is on the right of the local "stage".

Maybe consistently using "stage left" for streams and sending, and "audience
right" or "house right" for receiving and rendering of the"stage left"
stream is the best answer.  It does make the required reversal explicit.

Stephen Botzko

---

From: "Gorzynski, Mark E (The Right One)" <[email-masked]>
Date: Wed, 25 May 2011 18:19:39 +0000

My concern is establishing a convention for spatial order.  As I am writing this text, I am writing from left to right, top to bottom.  That simple convention for ASCII characters allows us all to read this.  It is not the only convention and perhaps not even the best but it is one we share.

It is insufficient to specify order without the receiver knowing the sense of the order for reproduction.

I suggest that left is the participant's left as that person views the reproduction.  I further suggest that spatial order be defined as left to right.  (you can add top to bottom if you wish).

Thus receiving streams labeled [0, 1, 2, ..] would be interpreted as starting on the left and tiled in raster fashion to the right.

Mark

From: [email-masked] [mailto:[email-masked]] On Behalf Of Stephen Botzko
Sent: Wednesday, May 25, 2011 10:48 AM
To: Stephan Wenger
Cc: [email-masked]
Subject: Re: [clue] Definitions-00 posted

Yes, I agree that "stage left" is from the viewpoint of the actor (which I am interpreting as the sending human participant).  So if you are seated in the center, and I am on your left, then I am "stage left" (and in a 3-stream telepresence system, I would be carried in the "left" stream, and displayed on Monitor 3 in Roni's diagram).

Whether it is actually necessary to describe Monitor 3 as left or right is unclear to me; I am thinking we are mostly describing spatial relationships of streams, not display devices.  However, from a receiving perspective, the monitors represent the far-end stage.  So it would be sensible to label the monitor as "audience right".

What's tricky here is that there are two "stages", one at each end of the call.  So we don't want to call Monitor 3 the "stage left" monitor, since it is on the right of the local "stage".

Maybe consistently using "stage left" for streams and sending, and "audience right" or "house right" for receiving and rendering of the"stage left" stream is the best answer.  It does make the required reversal explicit.

Stephen Botzko

On Wed, May 25, 2011 at 12:17 PM, Stephan Wenger <[email-masked]<mailto:[email-masked]>> wrote:
I don't recall discussion about "house left" either.
Steve, take a look at the wikipedia page mentioned.  It may be that wikipedia and you disagree about what "stage left" actually is.  From what I understood there (which is consistent with what I thought during the call): stage directions are from the viewpoint of an actor facing the crowd, not from the crowd's viewpoint.
Stephan

From: Stephen Botzko <[email-masked]<mailto:[email-masked]>>
Date: Wed, 25 May 2011 12:02:10 -0400
To: Roni Even <[email-masked]<mailto:[email-masked]>>
Cc: Stephan Wenger <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>

This depends on where you think the stage is!   Though I agree that monitor 3 is house right, and that the stream it is displaying is stage left.

BTW, I don't recall a "house left"  discussion in the conference call, but perhaps I missed it.

Steve B.

On Wed, May 25, 2011 at 11:44 AM, Roni Even <[email-masked]<mailto:[email-masked]>> wrote:
Steve,

According to Wikipedia

                                                                Participant

Roni

From: Stephen Botzko [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Wednesday, May 25, 2011 5:42 PM
To: Stephan Wenger
Cc: Roni Even; [email-masked]<mailto:[email-masked]>
Subject: Re: [clue] Definitions-00 posted

Steve B,

Hi Stephan,

Roni

Hi all,

---

From: Stephen Botzko <[email-masked]>
Date: Wed, 25 May 2011 14:23:05 -0400

"sender left" and "sender right", "viewer left" and "viewer right" would
also be equivalent, and avoid theatrics...

Regards
Stephen Botzko

On Wed, May 25, 2011 at 1:48 PM, Stephen Botzko <[email-masked]>wrote:

> Maybe consistently using "stage left" for streams and sending, and
> "audience right" or "house right" for receiving and rendering of the"stage
> left" stream is the best answer.  It does make the required reversal
> explicit.
>
> Stephen Botzko
>
>
>
>> This depends on where you think the stage is!   Though I agree that
>> monitor 3 is house right, and that the stream it is displaying is stage
>> left.
>>
>>> rendering in receivers, "Stage Left" seems more useful to me.  However, I
>>> have no objection to defining both terms.
>>>
>>> Steve B,
>>>
>>>

---

From: Songhaibin <[email-masked]>
Date: Thu, 26 May 2011 02:11:27 +0000

>Thus receiving streams labeled [0, 1, 2, ..] would be interpreted as starting on the left and tiled in raster fashion to the right.

I agree with you.

But now we can not use the term "participant" in your sentence(as it means software element as RFC 4353 defines)  :)

-Haibin

From: [email-masked] [mailto:[email-masked]] On Behalf Of Gorzynski, Mark E (The Right One)
Sent: Thursday, May 26, 2011 2:20 AM
To: [email-masked]
Subject: Re: [clue] Definitions-00 posted

Mark

Stephen Botzko

Steve B.

According to Wikipedia

                                                                Participant

Roni

Steve B,

Hi Stephan,

Roni

Hi all,