Subject: [clue] framework - capture set

From: Roni Even <[email-masked]>
Date: Thu, 28 Jul 2011 00:59:13 +0300

Hi,

The capture set example has (VC4 - zoomed out view of all people in the
room.). Now is there a way to differentiate between zoom out view and
composite view of all cameras to the 3 to 1 screen use case?

How do you see the extension to support multi view is there is no way to
describe the camera view port explicitly?

Roni

---

From: "Duckworth, Mark" <[email-masked]>
Date: Wed, 27 Jul 2011 20:49:03 -0700

Yes, the attributes "composed" and "scale" can be used to differentiate between a zoomed out view and a composite view.

I expect the multi view case can be addressed by adding a video capture attribute to give more information about the relative viewpoints of the cameras for each video capture.

Mark

From: [email-masked] [mailto:[email-masked]] On Behalf Of Roni Even
Sent: Wednesday, July 27, 2011 5:59 PM
To: [email-masked]
Subject: [clue] framework - capture set

Hi,

The capture set example has (VC4 - zoomed out view of all people in the room.). Now is there a way to differentiate between zoom out view and composite view of all cameras to the 3 to 1 screen use case?

How do you see the extension to support multi view is there is no way to describe the camera view port explicitly?

Roni

---

From: Roni Even <[email-masked]>
Date: Thu, 28 Jul 2011 07:16:42 +0300

Mark,

Composed (true/false) does not provide any meaningful information, composed
from what? See my question on the examples in the draft.

How do you know from the attributes that the meaning is what in the comment
you have at the beginning in the following examples.

   4.  VC3- (the loudest panel stream), encoding group:EG1, attributes:

       purpose=main;auto-switched:yes

   5.  VC4- (the loudest panel stream with PiPs), encoding group:EG1,

       attributes: purpose=main; composed=true; auto-switched:yes

   6.  VC5- (the zoomed out view of all people in the room), encoding

       group:EG1, attributes: purpose=main;auto-switched:no

VC3 is switched but maybe it is also used some zoom.  So what is being
switched?

VC4 - composed from what where do I see that it is the loudest panel with
two PiPs and not just the loudest speaker with one PiP?

VC5- how do I know from the attributes that is a zoomed view of all the
people in the room

As for scale

   An optional integer valued variable indicating the spatial scale of

   the video capture, for example centimeters for horizontal image

   width.

I am not sure what it means, and saying for example is not a definition.
Spatial scale between what?

Roni

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Duckworth, Mark
Sent: Thursday, July 28, 2011 6:49 AM
To: [email-masked]
Subject: Re: [clue] framework - capture set

Yes, the attributes "composed" and "scale" can be used to differentiate
between a zoomed out view and a composite view.

I expect the multi view case can be addressed by adding a video capture
attribute to give more information about the relative viewpoints of the
cameras for each video capture.

Mark

From: [email-masked] [mailto:[email-masked]] On Behalf Of Roni
Even
Sent: Wednesday, July 27, 2011 5:59 PM
To: [email-masked]
Subject: [clue] framework - capture set

Hi,

Roni

  _____

---

From: Michael Hammer <[email-masked]>
Date: Thu, 28 Jul 2011 10:11:38 -0400

Does composed mean that selected multiple RTP streams (typically audio) are
mixed/combined into a single RTP stream?  (Two or more voices appear on one
track?)

Mike

On Thu, Jul 28, 2011 at 12:16 AM, Roni Even <[email-masked]> wrote:

> ** **
> Mark,****
> from what? See my question on the examples in the draft.****
>
> ** **
>
> you have at the beginning in the following examples.****
>
> ** **
>
>    4.  VC3- (the loudest panel stream), encoding group:EG1, attributes:***
> *
>
>        purpose=main;auto-switched:yes****
>
> ** **
>
>    5.  VC4- (the loudest panel stream with PiPs), encoding group:EG1,****
>
>        attributes: purpose=main; composed=true; auto-switched:yes****
>
> ** **
>
>    6.  VC5- (the zoomed out view of all people in the room), encoding****
>
>        group:EG1, attributes: purpose=main;auto-switched:no****
>
> ** **
>
> ** **
>
> switched?****
> VC4 – composed from what where do I see that it is the loudest panel with
> two PiPs and not just the loudest speaker with one PiP?****
>
> people in the room****
> ** **
> As for scale****
>    An optional integer valued variable indicating the spatial scale of****
>
>    the video capture, for example centimeters for horizontal image****
>
>    width.****
>
> ** **
>
> Spatial scale between what?****
>
> ** **
>
> Roni****
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of
> *Duckworth, Mark
> *Sent:* Thursday, July 28, 2011 6:49 AM
> *To:* [email-masked]
> *Subject:* Re: [clue] framework - capture set****
>
> ** **
>
> Yes, the attributes “composed” and “scale” can be used to differentiate
> between a zoomed out view and a composite view.****
>
> ** **
>
> cameras for each video capture.****
>
> ** **
>
> Mark****
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of
> *Roni Even
> *Sent:* Wednesday, July 27, 2011 5:59 PM
> *To:* [email-masked]
> *Subject:* [clue] framework - capture set****
>
> ** **
>
> Hi,****
>
> composite view of all cameras to the 3 to 1 screen use case?****
>
> ** **
>
> describe the camera view port explicitly?****
>
> ** **
>
> Roni****
>
> ** **
> **
> ------------------------------
> **
>
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue
>
>

---

From: "Duckworth, Mark" <[email-masked]>
Date: Thu, 28 Jul 2011 14:05:52 -0700

Roni, you are correct those attributes and the framework do not specify the video captures as precisely as that.  We thought that level of detail in specifying what specifically is shown in video captures was not needed.  But if it is needed, I think that type of detail can be added to the framework by adding some new attributes.

The scale attribute is not well specified in the document, we need a more precise definition of what that attribute means.  The intent is to indicate the size of the field of view shown in the video capture.  Not the angle of the field of view of a camera, but the width of the image at the plane where the primary subject is located, such as the first row of people in a telepresence room.

Mark

From: Roni Even [mailto:[email-masked]]
Sent: Thursday, July 28, 2011 12:17 AM
To: Duckworth, Mark; [email-masked]
Subject: RE: [clue] framework - capture set

Mark,
Composed (true/false) does not provide any meaningful information, composed from what? See my question on the examples in the draft.

How do you know from the attributes that the meaning is what in the comment you have at the beginning in the following examples.

VC3 is switched but maybe it is also used some zoom.  So what is being switched?
VC4 - composed from what where do I see that it is the loudest panel with two PiPs and not just the loudest speaker with one PiP?
VC5- how do I know from the attributes that is a zoomed view of all the people in the room

As for scale

   width.

I am not sure what it means, and saying for example is not a definition. Spatial scale between what?

Roni

From: [email-masked] [mailto:[email-masked]] On Behalf Of Duckworth, Mark
Sent: Thursday, July 28, 2011 6:49 AM
To: [email-masked]
Subject: Re: [clue] framework - capture set

Mark

Hi,

Roni

---

From: "Duckworth, Mark" <[email-masked]>
Date: Thu, 28 Jul 2011 14:07:45 -0700

That was the intent of the "mixed" attribute  for audio.
"composed" was meant to be applied to video, but they are conceptually the same sort of thing.
Mark

From: Michael Hammer [mailto:[email-masked]]
Sent: Thursday, July 28, 2011 10:12 AM
To: Roni Even
Cc: Duckworth, Mark; [email-masked]
Subject: Re: [clue] framework - capture set

Does composed mean that selected multiple RTP streams (typically audio) are mixed/combined into a single RTP stream?  (Two or more voices appear on one track?)

Mike
On Thu, Jul 28, 2011 at 12:16 AM, Roni Even <[email-masked]<mailto:[email-masked]>> wrote:
Mark,
Composed (true/false) does not provide any meaningful information, composed from what? See my question on the examples in the draft.

As for scale

   width.

Roni

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Duckworth, Mark
Sent: Thursday, July 28, 2011 6:49 AM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [clue] framework - capture set

Mark

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Roni Even
Sent: Wednesday, July 27, 2011 5:59 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [clue] framework - capture set

Hi,

Roni

________________________________

_______________________________________________
clue mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/clue