Subject: [clue] Comment on framework - who gives the hint

From: "Elwell, John" <[email-masked]>
Date: Thu, 28 Jul 2011 00:13:19 +0200

The framework is based on the following general principle:
- receiver optionally sends hints as to what it would like to receive;
- sender indicates what it can send;
- receives selects what it will receive.

Another possibility would be:
- transmitter optionally sends hints as to what it can send;
- receiver indicates what it can receive;
- transmitter selects what it will send.

I don't have any opinion as to which is the better - in fact I tend to lean towards the first, but I can't give a reason. But it would be good to know if there are specific reasons for going with the first rather than the second.

John

John Elwell
Tel: +44 1908 817801 (office and mobile)
Email: [email-masked]
http://www.siemens-enterprise.com/uk/

Siemens Enterprise Communications Limited.
Registered office: Brickhill Street, Willen Lake, Milton Keynes, MK15 0DJ.
Registered No: 5903714, England.

Siemens Enterprise Communications Limited is a Trademark Licensee of Siemens AG.

---

From: Roni Even <[email-masked]>
Date: Thu, 28 Jul 2011 01:18:05 +0300

John,
I think that this will enable the sender to send a smaller subset if its
options. For example if the receiver can hint that it has one monitor the
sender can indicate just the options for sending a proposal for one screen.
It is not perfect since maybe the receiver can receive three streams and
compose them so it depends on how the  receivers hints will be flexible.
Roni

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Elwell, John
> Sent: Thursday, July 28, 2011 1:13 AM
> To: [email-masked]
> Subject: [clue] Comment on framework - who gives the hint
> 
> I don't have any opinion as to which is the better - in fact I tend to
> lean towards the first, but I can't give a reason. But it would be good
> to know if there are specific reasons for going with the first rather
> than the second.
> 
> John
> 
> 
> John Elwell
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 27 Jul 2011 18:55:41 -0400

> I don't have any opinion as to which is the better - in fact I tend to lean towards the first, but I can't give a reason. But it would be good to know if there are specific reasons for going with t…

I also don't know which is better.
Its not apparent to me that there is a difference.

Either way, it will take a 3-way handshake to negotiate.
And since each side is both a sender and a receiver, it will take a 
3-way handshake for each. At best that will take four messages.

(This could be done with o/a and preconditions. But that's mechanism and 
we aren't ready to start discussing that yet.)

	Thanks,
	Paul

---

From: "Duckworth, Mark" <[email-masked]>
Date: Wed, 27 Jul 2011 20:43:48 -0700

I also prefer the first way.  It seems to me the receiver's final preference in making the choice is more important than the sender's preference.  It is the receiver that has to do something useful with the streams it receives, so it should be the one to make the final choice.

Mark

> Sent: Wednesday, July 27, 2011 6:13 PM
> To: [email-masked]

---

From: Michael Hammer <[email-masked]>
Date: Thu, 28 Jul 2011 10:06:42 -0400

Mark,

Do these preference ratchet down?  Meaning that each step must be a subset
of the previous indication?

Or are they orthogonal and comprehensive?

Also, are these indications capabilities of the device, or current
preferences that could change during the session?  Both up and down?

Mike Hammer

On Wed, Jul 27, 2011 at 11:43 PM, Duckworth, Mark <
[email-masked]> wrote:

> I also prefer the first way.  It seems to me the receiver's final
> preference in making the choice is more important than the sender's
> preference.  It is the receiver that has to do something useful with the
> streams it receives, so it should be the one to make the final choice.
>
> Mark
>

---

From: "Allyn Romanow (allyn)" <[email-masked]>
Date: Thu, 28 Jul 2011 07:43:35 -0700

See inline

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Michael Hammer
Sent: Thursday, July 28, 2011 7:07 AM
To: Duckworth, Mark
Cc: [email-masked]
Subject: Re: [clue] Comment on framework - who gives the hint

Mark,

Do these preference ratchet down?  Meaning that each step must be a
subset of the previous indication?

The consumer says whatever it wants about itself.

The provider states it's capabilities. It may choose which it in light
of what it knows about the consumer. 

So these 2 messages are not derived from each other.

The consumer chooses from the advertised capabilities.

So the third message is chosen from what is listed in the second

These indications can be changed throughout the call, as conditions
change.

Some of the exchanged info relates to device, other to network
conditions, other to events that occur.

The slides for the preso in CLUE enumerate more the inputs to the
messages.

Mike Hammer

On Wed, Jul 27, 2011 at 11:43 PM, Duckworth, Mark
<[email-masked]> wrote:

Mark

> Tel: +44 1908 817801 <tel:%2B44%201908%20817801>  (office and mobile)