Subject: [clue] Comment on the presentation use case

From: <[email-masked]>
Date: Thu, 21 Jul 2011 11:32:40 +0000

Hi,

The presentation use case as described in the use-cases document is based on the assumption that the presentation stream relies on a video stream, and is limited to usage of presentation video streams. But we could also consider collaborative use cases, meaningful for telepresence, which are not covered by the existing text.
I propose to complete the existing text as follows:

"
Furthermore, although most today's systems use video streams for presentations, there are use cases where this is not suitable. For example:
- The professor which shares an electronic whiteboard (could be a whiteboard application on a PC, with screen capture of the PC) where all students can participate. Students will take control of the shared whiteboard in turns.
- In a multipoint meeting, a shared document can be kept always visible in a screen, while other documents are presented on other screens (with possible in turns presentation). For instance, for the purpose of shared design document, notes taking, polls, etc. A shared document implies that all participants can modify it in turns.
"

Stephane.

---

From: Roni Even <[email-masked]>
Date: Thu, 28 Jul 2011 01:07:41 +0300

Hi Stephane,

Is there a standard protocol that is used for conveying this information, is
it RTP based. 

To me this is a separate application that can be integrated in the
application level and not as part of the multistream.

Roni

From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Thursday, July 21, 2011 2:33 PM
To: [email-masked]
Subject: [clue] Comment on the presentation use case

Hi,

The presentation use case as described in the use-cases document is based on
the assumption that the presentation stream relies on a video stream, and is
limited to usage of presentation video streams. But we could also consider
collaborative use cases, meaningful for telepresence, which are not covered
by the existing text.

"

Furthermore, although most today's systems use video streams for
presentations, there are use cases where this is not suitable. For example:

- The professor which shares an electronic whiteboard (could be a whiteboard
application on a PC, with screen capture of the PC) where all students can
participate. Students will take control of the shared whiteboard in turns.

- In a multipoint meeting, a shared document can be kept always visible in a
screen, while other documents are presented on other screens (with possible
in turns presentation). For instance, for the purpose of shared design
document, notes taking, polls, etc. A shared document implies that all
participants can modify it in turns.

"

Stephane.

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 27 Jul 2011 18:29:09 -0400

On 7/27/11 6:07 PM, Roni Even wrote:
> Hi Stephane,
>
> Is there a standard protocol that is used for conveying this
> information, is it RTP based.

AFAIK this is often http. (E.g. webex)

> application level and not as part of the multistream.

I guess this depends on whether the support for it is integrated into 
the "room", or is just incidental equipment brought by the users, not 
formally related to the telepresence session.

	Thanks,
	Paul
	(speaking as an individual)

> Roni
>
> [email-masked] [mailto:[email-masked]] *On Behalf Of
> [email-masked]
> *Sent:* Thursday, July 21, 2011 2:33 PM
> *To:* [email-masked]
> *Subject:* [clue] Comment on the presentation use case*
>
> **
>
> *Hi,*
>
> **
>
> *The presentation use case as described in the use-cases document is
> based on the assumption that the presentation stream relies on a video
> stream, and is limited to usage of presentation video streams. But we
> could also consider collaborative use cases, meaningful for
> telepresence, which are not covered by the existing text.*
>
> *I propose to complete the existing text as follows:*
>
> **
>
> *Furthermore, although most today's systems use video streams for
> presentations, there are use cases where this is not suitable. For example:*
>
> *- The professor which shares an electronic whiteboard (could be a
> whiteboard application on a PC, with screen capture of the PC) where all
> students can participate. Students will take control of the shared
> whiteboard in turns.*
>
> *- In a multipoint meeting, a shared document can be kept always visible
> in a screen, while other documents are presented on other screens (with
> possible in turns presentation). For instance, for the purpose of shared
> design document, notes taking, polls, etc. A shared document implies
> that all participants can modify it in turns.*
>
> *“*
>
> **
>
> **
>
> *St ephane. v>
> *
>
> *
> *
>
> *_______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue
> *

---

From: Roni Even <[email-masked]>
Date: Thu, 28 Jul 2011 06:28:47 +0300

Hi,
HTTP is not defining a common data sharing protocol. WebEx may be carried
over HTTP but the data sharing application is not standard. What I meant is
that it can either be something that is a common data sharing protocol or
something that is carried as an RTP payload which require some common
defined protocol on top.

> -----Original Message-----
> Paul Kyzivat
> Sent: Thursday, July 28, 2011 1:29 AM
> To: [email-masked]
> Subject: Re: [clue] Comment on the presentation use case
> 
> > *"*
> _______________________________________________
> clue mailing list
> [email-masked]

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 28 Jul 2011 00:04:46 -0400

> something that is carried as an RTP payload which require some common

I was being a bit tongue in cheek, though not entirely.
Of course you are right - that if you want to push data to everybody you 
need more.

But data sharing by pointing a video camera at a piece of paper is a tad 
out of date. Connecting the video port on a user's computer as a video 
source and distributing it with the other video is better than that. But 
its not nearly as convenient as webex or any of its competitors.

It isn't entirely clear that its *necessary* to bundle the data sharing 
application with the telepresence protocols. Its kind of limiting since 
the web apps evolve very rapidly. Perhaps we should be doing the 
opposite of that: providing a way to embed the control of the 
telepresence system into a web app.

	Thanks,
	Paul

---

From: <[email-masked]>
Date: Thu, 28 Jul 2011 08:37:34 +0200

I think we should take a look to 
http://tools.ietf.org/html/draft-garcia-mmusic-sdp-collaboration-00

Bruno

> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] De la part de
> Paul Kyzivat
> Envoyé : jeudi 28 juillet 2011 06:05
> À : Roni Even
> Cc : [email-masked]
> Objet : Re: [clue] Comment on the presentation use case
> 
> >>> whiteboard application on a PC, with screen capture of the PC)
> where
> >> all

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 28 Jul 2011 07:41:07 -0400

> http://tools.ietf.org/html/draft-garcia-mmusic-sdp-collaboration-00

Maybe. But that is almost orthogonal to what I was suggesting.

	THanks,
	Paul
	(as individual)