Subject: [clue] Ticket #16: Need a term for a particular encoding of a capture

From: Paul Kyzivat <[email-masked]>
Date: Wed, 05 Sep 2012 12:02:27 -0400

I am trying to kick off discussion to get this one resolved.

Here is the description of the issue:

> We keep encountering places where the term "capture" is used
> but where what is meant is a specific encoding of a capture.
> (It is possible to request/send multiple encodings of the
> same capture.)
>
> We need a specific term, and definition, for this concept.
> This should be in the framework, and it and other documents
> should be fixed to use this new term where appropriate.

A few things come to mind:

- "capture encoding" - the obvious choice
- "encoded capture"
- "capture rendition"

Or any of the above with a "-" instead of the space.

	Thanks,
	Paul

---

From: "Espen Berger (espeberg)" <[email-masked]>
Date: Wed, 5 Sep 2012 21:54:45 +0000

I am wondering if a part of the discussion is the definition of the 'Encoding' within the encoding-group.  

What if we say that 

Capture + Quality = Encoding  (or the longer Capture + Encoding quality = Capture encoding) 

Capture = > The capture definition as in the CLUE framework  
Quality => The available quality definition, e.g. high quality 720p60 and low quality 360p30 (or maybe encoding-quality)
Encoding => A concrete encoding that a receiver can map back to a capture and a quality.  

The proposed change here is to start talking about a quality definition within the encoder-group and start using the name 'encoding' to be a specific capture with a defined quality. An encoding could also include multiple qualities, since at least SVC allows multiple qualities be embedded into a single encoded stream. 

At least one simulcast and multi stream draft [1] also refer to the term 'encoding', so I also suggest we align on terminology used in other working groups.

Cheers 

-Espen 
[1] - http://tools.ietf.org/html/draft-westerlund-avtcore-multistream-and-simulcast-00

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Paul Kyzivat
Sent: 5. september 2012 18:02
To: CLUE
Subject: [clue] Ticket #16: Need a term for a particular encoding of a capture

Here is the description of the issue:

> We keep encountering places where the term "capture" is used but where 
> what is meant is a specific encoding of a capture.
> (It is possible to request/send multiple encodings of the same 
> capture.)
>
> This should be in the framework, and it and other documents should be 
> fixed to use this new term where appropriate.

	Thanks,
	Paul
_______________________________________________
clue mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/clue

---

From: Christian Groves <[email-masked]>
Date: Thu, 06 Sep 2012 09:46:07 +1000

"Capture rendition"??? Isn't that  the term for being kidnapped and put 
on a plane to some unknown (unpleasant) destination? That might be a 
little beyond the scope of CLUE ;-).

How about "capture encoding instance"?

Regards,
Christian

---

From: John Leslie <[email-masked]>
Date: Thu, 6 Sep 2012 10:31:13 -0400

Christian Groves <[email-masked]> wrote:
>> ["clue issue tracker" <[email-masked]>] wrote:
>> 

   This sounds correct, but a bit wordy...

   The question arises, is it possible there would be multiple instances
of the same "encoding" of the same capture?

--
John Leslie <[email-masked]>

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 06 Sep 2012 12:18:31 -0400

> Encoding => A concrete encoding that a receiver can map back to a capture and a quality.

I find this an interesting approach.
But I'm not sure that "quality" is quite the right word.

> The proposed change here is to start talking about a quality definition within the encoder-group and start using the name 'encoding' to be a specific capture with a defined quality. An encoding cou…

Then wouldn't we have "quality groups" rather than "encoding groups"???

Instead of "quality", how about "encoding-type"?
Then Capture + Encoding-type = Encoding.

> At least one simulcast and multi stream draft [1] also refer to the term 'encoding', so I also suggest we align on terminology used in other working groups.

If we can. Eventually all good terms become overloaded. :-(

	Thanks,
	Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 06 Sep 2012 12:21:35 -0400

> little beyond the scope of CLUE ;-).

I was "reaching" for words. I realize there might be unpleasant 
connotations for that word. Even in its more conventional meaning it 
isn't a great fit.

> How about "capture encoding instance"?

That could work, though it's a bit cumbersome. See discussion with Espen.

	Thanks,
	Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 06 Sep 2012 12:24:49 -0400

> of the same "encoding" of the same capture?

I hope not! Why?

Perhaps if they are being requested on different 5-tuples, but even that 
seems weird. Two on the same 5-tuple would seem a useless waste of 
bandwidth - just redundant coding.

	Thanks,
	Paul

---

From: "Espen Berger (espeberg)" <[email-masked]>
Date: Mon, 10 Sep 2012 16:06:54 +0000

Hi paul 

-----Original Message-----
From: Paul Kyzivat [mailto:[email-masked]] 
Sent: 6. september 2012 18:19
To: Espen Berger (espeberg)
Cc: CLUE
Subject: Re: [clue] Ticket #16: Need a term for a particular encoding of a capture

On 9/5/12 5:54 PM, Espen Berger (espeberg) wrote:
> Capture = > The capture definition as in the CLUE framework Quality => 
> The available quality definition, e.g. high quality 720p60 and low 
> quality 360p30 (or maybe encoding-quality) Encoding => A concrete encoding that a receiver can map back to a capture and a quality.

>But I'm not sure that "quality" is quite the right word.

EBE>> I agree that the word quality alone is not so good, but the longer 'encoding quality' could do. I do think that the main thing we want to describe with an encoder-group is the various qualities we can encode of a single capture. 

>Then wouldn't we have "quality groups" rather than "encoding groups"???
EBE>> What about encoder restrictions or encoding capabilities? 

>Then Capture + Encoding-type = Encoding.

EBE>> For me an encoding-type sounds like an enumerated list of fixed values. 

	Thanks,
	Paul

> Cheers
>
> -Espen
> [1] - 
> http://tools.ietf.org/html/draft-westerlund-avtcore-multistream-and-si
> mulcast-00
>
>
>> We keep encountering places where the term "capture" is used but 
>> where what is meant is a specific encoding of a capture.

---

From: "Roni Even" <[email-masked]>
Date: Mon, 10 Sep 2012 19:45:36 +0200

Hi,
Maybe we can use srcname as proposed in
http://tools.ietf.org/id/draft-westerlund-avtext-rtcp-sdes-srcname-01.txt
Roni

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Paul
Kyzivat
Sent: 05 September, 2012 6:02 PM
To: CLUE
Subject: [clue] Ticket #16: Need a term for a particular encoding of a
capture

	Thanks,
	Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 10 Sep 2012 15:12:35 -0400

> http://tools.ietf.org/id/draft-westerlund-avtext-rtcp-sdes-srcname-01.txt

IIUC, SRCNAME would correspond to what Jonathan has been calling a 
"source". But it wouldn't correspond to a Capture, or and Encoding, or 
an RTP stream that is the result of applying a particular encoding to a 
capture.

So, while I think SRCNAME is useful, I don't see its applicability to 
ticket #16.

	Thanks,
	Paul

---

From: Roni Even <[email-masked]>
Date: Mon, 10 Sep 2012 20:46:32 +0000

Paul,
srcname describes a specific encoding by using a hierarchy tree. I am not sure what byou mean by a source but it can be used to describe a specific enconding using the hierarchy. For example v1.hires and v1.lowres.
Roni

________________________________________
From: [email-masked] [[email-masked]] on behalf of Paul Kyzivat [[email-masked]]
Sent: Monday, September 10, 2012 10:12 PM
To: Roni Even
Cc: 'CLUE'
Subject: Re: [clue] Ticket #16: Need a term for a particular encoding of a capture

        Thanks,
        Paul

---

From: Xiaojing <[email-masked]>
Date: Wed, 12 Sep 2012 03:24:13 +0000

Hi Paul,

How about "(Capture) Implementation" or "(Capture) Embodiment"?

Best regards,
Lennard

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Paul Kyzivat
Sent: Thursday, September 06, 2012 12:02 AM
To: CLUE
Subject: [clue] Ticket #16: Need a term for a particular encoding of a capture

	Thanks,
	Paul

---

From: "Espen Berger (espeberg)" <[email-masked]>
Date: Fri, 14 Sep 2012 14:45:51 +0000

I like the srcname draft since its allow a producer to forward meta-information and attached it to an SSRC. The intent seems to be to be able to forward names like a capture name and a quality modifier. The example from the draft matched my suggestion to do a 'capture' .'encoding-quality' 

However I do not think its represent a name for the actual encoded stream, so I still like the capture encoding to represent a single media stream. 

Cheers 
 
-Espen 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Roni Even
Sent: 10. september 2012 22:47
To: Paul Kyzivat; Roni Even
Cc: 'CLUE'
Subject: Re: [clue] Ticket #16: Need a term for a particular encoding of a capture

Paul,

> http://tools.ietf.org/id/draft-westerlund-avtext-rtcp-sdes-srcname-01.

IIUC, SRCNAME would correspond to what Jonathan has been calling a "source". But it wouldn't correspond to a Capture, or and Encoding, or an RTP stream that is the result of applying a particular encoding to a capture.

So, while I think SRCNAME is useful, I don't see its applicability to ticket #16.

        Thanks,
        Paul