Subject: [clue] Next Steps on CLUE Signaling **PLEASE READ**

From: Paul Kyzivat <[email-masked]>
Date: Thu, 29 Aug 2013 16:51:26 -0400

Hey all CLUE signaling fans!

(This is a little long, but please read.)

I hope you are all now recovered from Berlin, and now ready to get back 
to work. As you should have seen by now, we are about to start up design 
team calls again, with a primary focus on signaling.

To get CLUE done, we really really need to have a signaling document in 
reasonable shape by the Vancouver meeting. And that isn't a lot of time.
By "reasonable shape", I mean that all the major decisions have been 
made, and reflected as substance in the document. I'll be satisfied with 
that. It doesn't have to be pretty. (Getting the document entirely 
consistent, readable, pretty, with all the necessary boiler plate can wait.)

We had a number of "volunteers" who expressed an interest in working on 
signaling, in addition to me: Simon, Christer, Rob, Roni. Jonathan 
expressed interest, but very limited time. I'm hoping that Simon was 
also volunteering Roberta.

Are all of those mentioned above able to participate in the design team 
calls? (Please confirm.)

When I talked about signaling in Berlin I broke it down into a number of 
open issues. (See the slides for details.) Some are bigger than others. 
I'd like to get somebody to volunteer to take the lead on each of these. 
I have some ideas who would be good based on comments on past contributions:

o Relationship between CLUE messages & SDP (Rob)
o Representation of encodings: SDP or ADV (Rob)
o Approach to message responses (Simon/Roberta)
o Elaboration of message sequencing (Simon/Roberta)
o Legacy mode (Christer)
o CLUE channel (Paul/Christer)
o Message Syntax Details (Simon/Roberta)
o Approach to versioning/options/extensions (Paul)
o Approach to message encoding: stand-alone or deltas
o Examples/call flows

Please comment on the "assignments" I made above:
Are you ok with having your name where I put it?
Do you really want your name on something else?

My thought is to focus each design team meeting on one issue, or some 
closely coupled issues. And to have the lead person for that issue make 
a proposal and discuss it.

As we go, we can update the document. I'm willing to do the actual 
editing, or others can do it themselves if that is easier.

I propose that we start with some "easy" topics, in order to get the 
ball rolling and make some progress. That will also give others time to 
work up proposals for the harder issues. (Discussions on the mailing 
list on any of the issues is strongly recommended.)

The easy ones I have in mind are Versioning(...) and the CLUE channel.
I'm willing to take the lead regarding Versioning on the first call of 
the new series, September 10.

The September 17 meeting is preempted by our virtual interim. Perhaps we 
should defer detailed scheduling of following meetings until then.

I'll be available for the Sept 24 meeting, but I'll be traveling much of 
the prior week, so not able to do much prep. So it would be good if 
somebody else can take the lead that day.

	Thanks,
	Paul (as co-chair)

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 30 Aug 2013 06:48:54 +0000

Hi,

I have been working on some legacy text, and should have something to share shortly.

Regards,

Christer

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Paul Kyzivat
Sent: 29. elokuuta 2013 23:51
To: CLUE
Subject: [clue] Next Steps on CLUE Signaling **PLEASE READ**

I hope you are all now recovered from Berlin, and now ready to get back to work. As you should have seen by now, we are about to start up design team calls again, with a primary focus on signaling.

To get CLUE done, we really really need to have a signaling document in reasonable shape by the Vancouver meeting. And that isn't a lot of time.
By "reasonable shape", I mean that all the major decisions have been made, and reflected as substance in the document. I'll be satisfied with that. It doesn't have to be pretty. (Getting the document entirely consistent, readable, pretty, with all the necessary boiler plate can wait.)

We had a number of "volunteers" who expressed an interest in working on signaling, in addition to me: Simon, Christer, Rob, Roni. Jonathan expressed interest, but very limited time. I'm hoping that Simon was also volunteering Roberta.

Are all of those mentioned above able to participate in the design team calls? (Please confirm.)

When I talked about signaling in Berlin I broke it down into a number of open issues. (See the slides for details.) Some are bigger than others. 
I'd like to get somebody to volunteer to take the lead on each of these. 
I have some ideas who would be good based on comments on past contributions:

o Relationship between CLUE messages & SDP (Rob) o Representation of encodings: SDP or ADV (Rob) o Approach to message responses (Simon/Roberta) o Elaboration of message sequencing (Simon/Roberta) o Legacy mode (Christer) o CLUE channel (Paul/Christer) o Message Syntax Details (Simon/Roberta) o Approach to versioning/options/extensions (Paul) o Approach to message encoding: stand-alone or deltas o Examples/call flows

My thought is to focus each design team meeting on one issue, or some closely coupled issues. And to have the lead person for that issue make a proposal and discuss it.

As we go, we can update the document. I'm willing to do the actual editing, or others can do it themselves if that is easier.

I propose that we start with some "easy" topics, in order to get the ball rolling and make some progress. That will also give others time to work up proposals for the harder issues. (Discussions on the mailing list on any of the issues is strongly recommended.)

The easy ones I have in mind are Versioning(...) and the CLUE channel.
I'm willing to take the lead regarding Versioning on the first call of the new series, September 10.

The September 17 meeting is preempted by our virtual interim. Perhaps we should defer detailed scheduling of following meetings until then.

I'll be available for the Sept 24 meeting, but I'll be traveling much of the prior week, so not able to do much prep. So it would be good if somebody else can take the lead that day.

	Thanks,
	Paul (as co-chair)
_______________________________________________
clue mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/clue

---

From: Simon Pietro Romano <[email-masked]>
Date: Fri, 30 Aug 2013 12:03:38 +0200

Hello Paul,

the proposed approach and breakdown of work look good to me (and to Roberta as well).

We're already working on CLUE related stuff and we'll keep you all updated on this list.

Simon