Subject: [clue] Advertising what is in an MCC - allow wildcard?

From: "Duckworth, Mark" <[email-masked]>
Date: Thu, 9 Jan 2014 14:11:42 -0800

In an advertisement, the provider can indicate which other captures are referenced by an MCC, for example:

Individual captures advertised: VC1, VC2, VC3, VC4, VC5
MCC1(VC1, VC2)
This means MCC1 can include VC1 and/or VC2, but not the others.

MCC2()
Without any specific references, this means the provider is not saying which other captures can be included in MCC2, and the consumer cannot choose.

I propose adding a wildcard:
MCC3(*)
This means MCC3 can include any of the other captures VC1 through VC5, and the consumer can choose.

For some types of MCUs, that want to give consumers the choice of which specific captures to receive in an MCC, this is useful for large advertisements with many media captures.  When endpoints join or leave a conference, causing the advertisement to change to add or remove scenes and captures, the part of the advertisement with MCCs wouldn't have to change at all.

Related text from framework-13:
>From 7.2: "The MCC may contain a reference to the Single Media Captures... (or) A MCC MAY contain no references to other Captures to indicate that the MCC contains content from multiple sources but no information regarding those sources is given."  And in section 10 "If the MCC in the advertisement does not reference any individual captures, then the Consumer cannot choose what is included in the MCC"

I propose adding text:
The MCC may contain a wildcard reference, meaning it can refer to any of the other captures in the advertisement.  The consumer, in a configure message, may choose which of the other media captures it wishes to receive in the MCC.

What do you think?

Mark

---

From: Christian Groves <[email-masked]>
Date: Fri, 10 Jan 2014 12:42:28 +1100

Hello Mark,

Please see my comments below.

Regards, Christian

On 10/01/2014 9:11 AM, Duckworth, Mark wrote:
> Without any specific references, this means the provider is not saying 
> which other captures can be included in MCC2, and the consumer cannot 
> choose.
>

> For some types of MCUs, that want to give consumers the choice of 
> which specific captures to receive in an MCC, this is useful for large 
> advertisements with many media captures. When endpoints join or leave 
> a conference, causing the advertisement to change to add or remove 
> scenes and captures, the part of the advertisement with MCCs wouldn’t 
> have to change at all.
>
> From 7.2: “The MCC may contain a reference to the Single Media 
> Captures… (or) A MCC MAY contain no references to other Captures to 
> indicate that the MCC contains content from multiple sources but no 
> information regarding those sources is given.” And in section 10 “If 
> the MCC in the advertisement does not reference any individual 
> captures, then the Consumer cannot choose what is included in the MCC”
>
> I propose adding text:
>
> The MCC may contain a wildcard reference, meaning it can refer to any 
> of the other captures in the advertisement. The consumer, in a 
> configure message, may choose which of the other media captures it 
> wishes to receive in the MCC.
>
> What do you think?
>
[CNG] I'm supportive of adding a wildcard mechanism. It could help 
shorten messages. I think we should be clear about what the scope of the 
wildcard is. i.e. is it the captures in the same scene as the MCC or 
across all scenes in the Advertisement.
I think what may perhaps be additionally useful is to be able to provide 
a range, i.e. MCC4(VC2-VC4). However this would imply that captureIDs 
would have to have a numeric aspect.
>
> Mark
>
>
>
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 10 Jan 2014 13:24:25 -0500

> I propose adding a wildcard:

IIUC you mean this to be strictly a syntactic shortcut, not adding any 
functionality that isn't present without it.

> and the consumer can choose.

Do you intent this to mean all the captures in the advertisement, or all 
the captures in the same scene?

> For some types of MCUs, that want to give consumers the choice of which
> specific captures to receive in an MCC, this is useful for large
> advertisements with many media captures.

Perhaps. But I have my doubts that this would be of common use in practice.

So it becomes a question of whether the added implementation burden of 
supporting this optimization is justified for the number of cases when 
it would be of use.

	Thanks,
	Paul

> When endpoints join or leave a
> conference, causing the advertisement to change to add or remove scenes
> and captures, the part of the advertisement with MCCs wouldn’t have to
> change at all.
>
> the MCC in the advertisement does not reference any individual captures,
> then the Consumer cannot choose what is included in the MCC”
>
> I propose adding text:
>
> The MCC may contain a wildcard reference, meaning it can refer to any of
> the other captures in the advertisement.  The consumer, in a configure
> message, may choose which of the other media captures it wishes to
> receive in the MCC.
>
> What do you think?
>
> Mark
>
>
>

---

From: "Duckworth, Mark" <[email-masked]>
Date: Fri, 10 Jan 2014 12:38:30 -0800

Christian,

I intended the scope of the wildcard to refer to all other captures, not just within the same scene.

I'm against the range idea (MCC4(VC2-VC4)) because I think capture IDs should be just an identifier, without implying some ordered list.

Mark

> -----Original Message-----
> From: clue [mailto:[email-masked]] On Behalf Of Christian Groves
> Sent: Thursday, January 09, 2014 8:42 PM
> To: [email-masked]
> Subject: Re: [clue] Advertising what is in an MCC - allow wildcard?
> 
> Hello Mark,
> 
> > scenes and captures, the part of the advertisement with MCCs wouldn't
> > have to change at all.
> >
> > From 7.2: "The MCC may contain a reference to the Single Media
> > Captures... (or) A MCC MAY contain no references to other Captures to
> > information regarding those sources is given." And in section 10 "If
> > captures, then the Consumer cannot choose what is included in the MCC"
> >
> > I propose adding text:
> >
> [CNG] I'm supportive of adding a wildcard mechanism. It could help shorten
> messages. I think we should be clear about what the scope of the wildcard is.
> i.e. is it the captures in the same scene as the MCC or across all scenes in the
> Advertisement.
> I think what may perhaps be additionally useful is to be able to provide a
> range, i.e. MCC4(VC2-VC4). However this would imply that captureIDs would
> have to have a numeric aspect.
> >
> > Mark
> >
> >
> >

---

From: "Duckworth, Mark" <[email-masked]>
Date: Fri, 10 Jan 2014 12:46:46 -0800

Paul,

Yes, I think the wildcard is just a syntax shortcut.
One other impact that I was thinking of is if we decide to have partial updates of advertisements then it removes the need to re-advertise any MCC(*) captures when other captures change.  Without wildcard, any other addition or removal of a contributing capture means also re-advertising every MCC with a new list of contributors.
I think the wildcard fits very nicely with the switching scenario option (2) from the other discussion thread.

Mark

> From: clue [mailto:[email-masked]] On Behalf Of Paul Kyzivat
> Sent: Friday, January 10, 2014 1:24 PM
> To: [email-masked]
> Do you intent this to mean all the captures in the advertisement, or all the
> captures in the same scene?
> 
> supporting this optimization is justified for the number of cases when it
> would be of use.
> 
> 	Thanks,
> 	Paul
> 
> > conference, causing the advertisement to change to add or remove

---

From: "Roni Even" <[email-masked]>
Date: Tue, 14 Jan 2014 17:06:57 +0200

Hi,

What does the consumer do if he does not want to choose the composition but
the MCC is with a wild card?

Roni

From: clue [mailto:[email-masked]] On Behalf Of Duckworth, Mark
Sent: 10 January, 2014 12:12 AM
To: [email-masked]
Subject: [clue] Advertising what is in an MCC - allow wildcard?

In an advertisement, the provider can indicate which other captures are
referenced by an MCC, for example:

MCC1(VC1, VC2)

MCC2()

Without any specific references, this means the provider is not saying which
other captures can be included in MCC2, and the consumer cannot choose.

MCC3(*)

This means MCC3 can include any of the other captures VC1 through VC5, and
the consumer can choose.

For some types of MCUs, that want to give consumers the choice of which
specific captures to receive in an MCC, this is useful for large
advertisements with many media captures.  When endpoints join or leave a
conference, causing the advertisement to change to add or remove scenes and
captures, the part of the advertisement with MCCs wouldn't have to change at
all.

Related text from framework-13:

>From 7.2: "The MCC may contain a reference to the Single Media Captures.
(or) A MCC MAY contain no references to other Captures to indicate that the
MCC contains content from multiple sources but no information regarding
those sources is given."  And in section 10 "If the MCC in the advertisement
does not reference any individual captures, then the Consumer cannot choose
what is included in the MCC"

I propose adding text:

The MCC may contain a wildcard reference, meaning it can refer to any of the
other captures in the advertisement.  The consumer, in a configure message,
may choose which of the other media captures it wishes to receive in the
MCC.

What do you think?

Mark

---

From: "Duckworth, Mark" <[email-masked]>
Date: Tue, 14 Jan 2014 07:49:57 -0800

Hi Roni,
The consumer, in a configure message, would just specify it wants an encoding of the MCC without giving any further restrictions on what could be in the MCC.  From framework section 10: "If it wants all the individual Captures then it returns only the MCC identity (i.e. MCC1)." This means the consumer is asking for the MCC encoding, and the provider decides how to switch or compose the contributing MCs into the MCC.

Mark

From: Roni Even [mailto:[email-masked]]
Sent: Tuesday, January 14, 2014 10:07 AM
To: Duckworth, Mark; [email-masked]
Subject: RE: [clue] Advertising what is in an MCC - allow wildcard?

Hi,
What does the consumer do if he does not want to choose the composition but the MCC is with a wild card?
Roni

MCC2()

I propose adding text:

What do you think?

Mark

---

From: Christian Groves <[email-masked]>
Date: Mon, 20 Jan 2014 12:58:54 +1100

Hello Mark,

I'm not sure how useful an "all" would be if the scope is across all 
captures in the CLUE message rather than a particular scene. I would 
actually think that a range would be the more useful case.
Is there a reason why you don't like an ordered list?

Regards, Christian

---

From: "Duckworth, Mark" <[email-masked]>
Date: Mon, 20 Jan 2014 13:31:46 -0800

I'd like to stop this thread of discussion, it is superseded by the "MCC grouping label" thread.

Mark

> From: Christian Groves [mailto:[email-masked]]
> Sent: Sunday, January 19, 2014 8:59 PM
> I'm not sure how useful an "all" would be if the scope is across all captures in
> the CLUE message rather than a particular scene. I would actually think that a
> range would be the more useful case.
> > I'm against the range idea (MCC4(VC2-VC4)) because I think capture IDs
> should be just an identifier, without implying some ordered list.
> >
> > Mark
> >
> >>> Without any specific references, this means the provider is not
> >>> saying which other captures can be included in MCC2, and the
> >>> consumer cannot choose.
> >>>
> >>> which specific captures to receive in an MCC, this is useful for
> >>> large advertisements with many media captures. When endpoints join
> >>> or leave a conference, causing the advertisement to change to add or
> >>> remove scenes and captures, the part of the advertisement with MCCs
> >>> wouldn't have to change at all.
> >>>
> >>> Captures... (or) A MCC MAY contain no references to other Captures
> >>> to indicate that the MCC contains content from multiple sources but
> >>> no information regarding those sources is given." And in section 10
> >>> "If the MCC in the advertisement does not reference any individual
> >>> The MCC may contain a wildcard reference, meaning it can refer to
> >>> any of the other captures in the advertisement. The consumer, in a
> wildcard is.
> >> i.e. is it the captures in the same scene as the MCC or across all
> >> scenes in the Advertisement.
> >> I think what may perhaps be additionally useful is to be able to
> >> provide a range, i.e. MCC4(VC2-VC4). However this would imply that
> >> captureIDs would have to have a numeric aspect.
> >>> Mark
> >>>
> >>>
> >>>