Subject: [clue] FW: RTCWEB data channel protocol: Do both endpoints need to send DATA_CHANNEL_OPEN?

From: Christer Holmberg <[email-masked]>
Date: Tue, 28 Jan 2014 08:18:46 +0000

FYI,

One of the questions that came up yesterday, regarding the RTCWEB data channel protocol, was whether both endpoints are mandated to send DATA_CHANNEL_OPEN. I sent the e-mail below to the RTCWEB list, asking for clarification.

NOTE that the DATA_CHANNEL_ACK is actually sent on the same SCTP stream where DATA_CHANNEL_OPEN is received - EVEN if the SCTP stream is unidirectional.

This email is just fyi. If you have any comments/input, please use the rtcweb list :)

Regards,

Christer

From: rtcweb [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 28. tammikuuta 2014 10:16
To: [email-masked]
Subject: [rtcweb] RTCWEB data channel protocol: Do both endpoints need to send DATA_CHANNEL_OPEN?

Hi,

As defined in draft-ietf-rtcweb-data-channel-06, a data channel consists of two unidirectional SCTP streams.

draft-ietf-rtcweb-data-protocol-01 says that, if one endpoint wants to open a data channel, it sends a DATA_CHANNEL_OPEN (using a SCTP stream ID value of its choice). Then, the other endpoints sends DATA_CHANNEL_ACK on the same SCTP stream (eventhough it is a unidirectional stream).

Q1: Assuming that both endpoints want to use the data channel, do both endpoints need to send DATA_CHANNEL_OPEN (on separate SCTP streams)? Or, can one of the endpoints, if it has received DCO, start using the data channel (using a SCTP stream of its choice)?

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 28 Jan 2014 08:55:59 +0000

Hi,

Correction: the DATA_CHANNEL_ACK is NOT sent on the same SCTP stream, but the same stream ID is used.

As you may have seen on the RTCWEB list, it has been clarified that both endpoints do NOT have to send DATA_CHANNEL_OPEN. So, that was a misunderstanding from my part yesterday. Sorry for the confusion.

Regards,

Christer

From: clue [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 28. tammikuuta 2014 10:19
To: [email-masked]
Subject: [clue] FW: RTCWEB data channel protocol: Do both endpoints need to send DATA_CHANNEL_OPEN?

FYI,

Regards,

Christer

From: rtcweb [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 28. tammikuuta 2014 10:16
To: [email-masked]<mailto:[email-masked]>
Subject: [rtcweb] RTCWEB data channel protocol: Do both endpoints need to send DATA_CHANNEL_OPEN?

Hi,

Regards,

Christer

---

From: Simon Pietro Romano <[email-masked]>
Date: Tue, 28 Jan 2014 10:49:12 +0100

This was indeed what I said  yesterday during the interim...

Simon

Christer Holmberg <[email-masked]> ha scritto:
>As you may have seen on the RTCWEB list, it has been clarified that
>both endpoints do NOT have to send DATA_CHANNEL_OPEN. So, that was a
>misunderstanding from my part yesterday. Sorry for the confusion.
>
>Regards,
>
>Christer
>
>One of the questions that came up yesterday, regarding the RTCWEB data
>channel protocol, was whether both endpoints are mandated to send
>DATA_CHANNEL_OPEN. I sent the e-mail below to the RTCWEB list, asking
>for clarification.
>
>NOTE that the DATA_CHANNEL_ACK is actually sent on the same SCTP stream
>where DATA_CHANNEL_OPEN is received - EVEN if the SCTP stream is
>unidirectional.
>
>As defined in draft-ietf-rtcweb-data-channel-06, a data channel
>consists of two unidirectional SCTP streams.
>
>draft-ietf-rtcweb-data-protocol-01 says that, if one endpoint wants to
>open a data channel, it sends a DATA_CHANNEL_OPEN (using a SCTP stream
>ID value of its choice). Then, the other endpoints sends
>DATA_CHANNEL_ACK on the same SCTP stream (eventhough it is a
>unidirectional stream).
>
>Q1: Assuming that both endpoints want to use the data channel, do both
>endpoints need to send DATA_CHANNEL_OPEN (on separate SCTP streams)?
>Or, can one of the endpoints, if it has received DCO, start using the
>data channel (using a SCTP stream of its choice)?
>
>Regards,
>
>Christer
>
>
>
>
>------------------------------------------------------------------------
>
>_______________________________________________
>clue mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/clue