Subject: [clue] <capturePoint> should be optional

From: "Duckworth, Mark" <[email-masked]>
Date: Fri, 17 Jan 2014 14:57:35 -0800

In the data model section 10.4, in "spatialInformationType", the "capturePoint" element is mandatory.  It really should be optional.  In earlier versions of the framework it was optional.  This is described in section 10.4.1: "If the point of capture is not specified, it means the consumer should not assume anything about the spatial location of the capturing device."

So I think the schema should have minOccurs="0" for "capturePoint" element.  And the text right below the schema part should say optional instead of mandatory.

Mark

---

From: Christian Groves <[email-masked]>
Date: Mon, 20 Jan 2014 13:37:48 +1100

Hello Mark,

I agree.

Regards,
Christian

On 18/01/2014 9:57 AM, Duckworth, Mark wrote:
>
> In the data model section 10.4, in “spatialInformationType”, the 
> “capturePoint” element is mandatory. It really should be optional. In 
> earlier versions of the framework it was optional. This is described 
> in section 10.4.1: “If the point of capture is not specified, it means 
> the consumer should not assume anything about the spatial location of 
> the capturing device.”
>
> So I think the schema should have minOccurs=”0” for “capturePoint” 
> element. And the text right below the schema part should say optional 
> instead of mandatory.
>
> Mark
>
>
>
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue