Subject: [clue] Question on relationship between Clue protocol SDP negotiation and RFC 5688

From: Andrew Allen <[email-masked]>
Date: Thu, 24 Jul 2014 18:38:12 +0000

One issue I have been struggling with is understanding what should be populated in the sip.app-tsubype media feature tag defined in RFC 5688.

Ideally IMHO  this should indicate the support for the clue channel media type but it is not clear to me from RFC 5688 and the clue drafts that this will be what most implementers would populate. Maybe this should be clarified in CLUE.

Andrew

---

From: Christian Groves <[email-masked]>
Date: Fri, 25 Jul 2014 13:29:13 +1000

In clause 3 of draft-ietf-clue-signaling-02 it defines a media feature 
tag "sip.clue". Would we need to populate a sip.app-subtype beyond that?

Regards, Christian

On 25/07/2014 4:38 AM, Andrew Allen wrote:
>
> One issue I have been struggling with is understanding what should be 
> populated in the sip.app-tsubype media feature tag defined in RFC 5688.
>
> Ideally IMHO  this should indicate the support for the clue channel 
> media type but it is not clear to me from RFC 5688 and the clue drafts 
> that this will be what most implementers would populate. Maybe this 
> should be clarified in CLUE.
>
> Andrew
>
>
>
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 25 Jul 2014 17:53:10 -0400

> should be clarified in CLUE.

We have not considered this.
If we were to do so, it would be +sip.app-subtype="webrtc-datachannel".

But I don't think this would be very helpful. It doesn't say we want to 
use the datachannel for clue. The +sip.clue, already mentioned by 
Christian, is more helpful.

	Thanks,
	Paul