Subject: [clue] Ticket #61 Proposal for describing the coordinate system

From: "Duckworth, Mark" <[email-masked]>
Date: Thu, 11 Sep 2014 14:48:38 -0700

The ticket says describe it without using left/right/front/back terminology, but I don't think that was the point.  I think the point is to make it clear the provider can pick the one coordinate system origin and orientation for a scene even if there are multiple cameras pointing in different (even opposite) directions within that scene.

So here is a proposal, I would like your feedback.

Remove the definition of Front in section 3.  Remove the definitions of Camera-Left and Right, and Stage-Left and Right.

In section 6. Spatial Relationships, starting with the last bullet item, replace the rest of that section with this:
============== begin new text =========
o The coordinate system is right-handed Cartesian X, Y, Z with the origin at a spatial location of the Provider's choosing.  The Provider MUST use the same coordinate system with the same scale and origin for all coordinates within the same Capture Scene.

The direction of increasing coordinate values is:
X increases from left to right, from the point of view of an observer at the front of the room looking toward the back
Y increases from the front of the room to the back of the room
Z increases from low to high (i.e. floor to ceiling)

Cameras in a scene typically point in the direction of increasing Y, from front to back.  But there could be multiple cameras pointing in different directions.  If the physical space does not have a well-defined front and back, the provider chooses any direction for X and Y consistent with right-handed coordinates.
============== end new text =========

In section 12 examples, replace "camera-left" and "camera-right" with "left" and "right".

Regards,
Mark

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 11 Sep 2014 22:00:31 -0400

Mark,

WFM.

I will note that there *could* be scenes where low/high, floor/ceiling 
aren't well defined. (E.g. in a space station.) But these are rare 
enough that I don't think we need to worry about them.

	Thanks,
	Paul

On 9/11/14 5:48 PM, Duckworth, Mark wrote:
> The ticket says describe it without using left/right/front/back
> terminology, but I don’t think that was the point.  I think the point is
> to make it clear the provider can pick the one coordinate system origin
> and orientation for a scene even if there are multiple cameras pointing
> in different (even opposite) directions within that scene.
>
> Remove the definition of Front in section 3.  Remove the definitions of
> Camera-Left and Right, and Stage-Left and Right.
>
> In section 6. Spatial Relationships, starting with the last bullet item,
> replace the rest of that section with this:
>
> o The coordinate system is right-handed Cartesian X, Y, Z with the
> origin at a spatial location of the Provider's choosing.  The Provider
> MUST use the same coordinate system with the same scale and origin for
> all coordinates within the same Capture Scene.
>
> X increases from left to right, from the point of view of an observer at
> the front of the room looking toward the back
>
> Cameras in a scene typically point in the direction of increasing Y,
> from front to back.  But there could be multiple cameras pointing in
> different directions.  If the physical space does not have a
> well-defined front and back, the provider chooses any direction for X
> and Y consistent with right-handed coordinates.
>
> In section 12 examples, replace “camera-left” and “camera-right” with
> “left” and “right”.
>
> Regards,
>
> Mark
>
>
>
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue
>

---

From: Mary Barnes <[email-masked]>
Date: Fri, 12 Sep 2014 11:53:55 -0500

Mark,

Thanks for the posting the proposed solution.  I think the proposal ought
to work - we do need additional WG to review and comment.

One comment below [MB].

Mary.

On Thu, Sep 11, 2014 at 4:48 PM, Duckworth, Mark <[email-masked]
> wrote:

> terminology, but I don’t think that was the point.
>
[MB] Please feel free to update the text in the ticket. The ticket text is
based upon what is captured in notes and meeting minutes:
http://www.ietf.org/proceedings/90/minutes/minutes-90-clue
 It's too late to change those (deadline was Monday), but it would be good
to have the ticket accurate so that it's much more clear that the solution
proposed resolves the ticket. [/MB]

> I think the point is to make it clear the provider can pick the one
> coordinate system origin and orientation for a scene even if there are
> multiple cameras pointing in different (even opposite) directions within
> that scene.
>
>
>
> o The coordinate system is right-handed Cartesian X, Y, Z with the origin
> at a spatial location of the Provider's choosing.  The Provider MUST use
> the same coordinate system with the same scale and origin for all
> coordinates within the same Capture Scene.
>
>
>
> Cameras in a scene typically point in the direction of increasing Y, from
> front to back.  But there could be multiple cameras pointing in different
> directions.  If the physical space does not have a well-defined front and
> back, the provider chooses any direction for X and Y consistent with
> right-handed coordinates.
>

---

From: Christian Groves <[email-masked]>
Date: Mon, 15 Sep 2014 10:50:21 +1000

Hello Mark,

I'm OK with the proposal. Do you have an example that you were thinking 
about for the "not well-defined" case?

Regards, Christian

On 12/09/2014 7:48 AM, Duckworth, Mark wrote:
> terminology, but I don’t think that was the point. I think the point 
> is to make it clear the provider can pick the one coordinate system 
> origin and orientation for a scene even if there are multiple cameras 
> pointing in different (even opposite) directions within that scene.
>
> In section 6. Spatial Relationships, starting with the last bullet 
> item, replace the rest of that section with this:
>
> X increases from left to right, from the point of view of an observer 
> at the front of the room looking toward the back
>

---

From: "Duckworth, Mark" <[email-masked]>
Date: Mon, 15 Sep 2014 06:00:06 -0700

Thanks Mary.
I couldn’t figure out how to edit the description in the ticket.  Am I supposed to be able to do that?  So I added a comment to the ticket.
Mark

From: Mary Barnes [mailto:[email-masked]]
Sent: Friday, September 12, 2014 12:54 PM
To: Duckworth, Mark
Cc: [email-masked]
Subject: Re: [clue] Ticket #61 Proposal for describing the coordinate system

Mark,

Thanks for the posting the proposed solution.  I think the proposal ought to work - we do need additional WG to review and comment.

One comment below [MB].

Mary.

On Thu, Sep 11, 2014 at 4:48 PM, Duckworth, Mark <[email-masked]<mailto:[email-masked]>> wrote:
The ticket says describe it without using left/right/front/back terminology, but I don’t think that was the point.
[MB] Please feel free to update the text in the ticket. The ticket text is based upon what is captured in notes and meeting minutes:
http://www.ietf.org/proceedings/90/minutes/minutes-90-clue
 It's too late to change those (deadline was Monday), but it would be good to have the ticket accurate so that it's much more clear that the solution proposed resolves the ticket. [/MB]

I think the point is to make it clear the provider can pick the one coordinate system origin and orientation for a scene even if there are multiple cameras pointing in different (even opposite) directions within that scene.

In section 12 examples, replace “camera-left” and “camera-right” with “left” and “right”.
Regards,
Mark

_______________________________________________
clue mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/clue

---

From: "Duckworth, Mark" <[email-masked]>
Date: Mon, 15 Sep 2014 06:02:10 -0700

Hi Christian,
One possibility is a room with a table in the center, people seated all around the table, with a camera on one wall pointed toward the table, and a camera on another wall pointed toward the table.
Mark

> -----Original Message-----
> From: clue [mailto:[email-masked]] On Behalf Of Christian Groves
> Sent: Sunday, September 14, 2014 8:50 PM
> To: [email-masked]
> > terminology, but I don't think that was the point. I think the point

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 15 Sep 2014 11:01:42 -0400

> about for the "not well-defined" case?

The operating room in the telemedical use case.

	Thanks,
	Paul