Subject: [clue] Examples in draft-ietf-clue-signaling-03 and draft-ietf-clue-signaling-03

From: Christian Groves <[email-masked]>
Date: Mon, 29 Sep 2014 17:14:11 +1000

There's an error that seems to have crept into the CLUE SDP example 
syntax in our documents.

The RTCWeb-datachannel uses an SCTP over DTLS transport i.e. DTLS/SCTP. 
Whereas in the examples where CLUE is involved SCTP/DTLS is specified. 
We should probably update that.

Also the latest draft draft-ietf-mmusic-sctp-sdp-07 has changed the 
syntax for specifying a SCTP m-line.

So:
[draft-ietf-clue-datachannel-01]/5.8. Example
m=application 54111 SCTP/DTLS 54111
a=sctpmap:54111 webrtc-datachannel

could be changed to:
m=application 54111 DTLS/SCTP webrtc-datachannel
a=fmtp:webrtc-datachannel max-message-size=100000
a=sctp-port 5000

more correctly to describe a "CLUE datachannel" the webrtc-datachannel 
would need to be added to a CLUE group. Therefore I think the following 
is probably a better example:
a=group:CLUE 3
...
m=application 54111 DTLS/SCTP webrtc-datachannel
a=fmtp:webrtc-datachannel max-message-size=100000
a=sctp-port 5000
a=mid:3

draft-ietf-clue-signaling-03 needs to be updated accordingly.

Regards, Christian

---

From: Robert Hansen <[email-masked]>
Date: Mon, 29 Sep 2014 15:38:32 +0100

Hi Christian,

Good catch - thanks. Will make sure that gets fixed in -04 of the 
signalling doc.

Rob

On 29/09/14 08:14, Christian Groves wrote:
> The RTCWeb-datachannel uses an SCTP over DTLS transport i.e. 
> DTLS/SCTP. Whereas in the examples where CLUE is involved SCTP/DTLS is 
> specified. We should probably update that.
>
> would need to be added to a CLUE group. Therefore I think the 
> following is probably a better example:
> a=group:CLUE 3
> ...
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue