Subject: [clue] data model comments

From: "Duckworth, Mark" <[email-masked]>
Date: Mon, 29 Sep 2014 07:52:29 -0700

Hi,

I'm sorry I won't be able to attend the design team discussion tomorrow about the data model.  I have a few more comments here related to the new framework updates that impact the data model.  This is in addition to my comments on the list from July 21<http://www.ietf.org/mail-archive/web/clue/current/msg03995.html>.

Update names of <sceneEntry> and <globalSceneEntries> to better match new terms in framework, according to Ticket #59 and Ticket #60.

In the data model, it looks like the only way to associate a capture with a scene is through a Capture Scene Entry (see <sceneEntriesType>) (now called CSV).  The framework says media captures are associated with a particular scene.  Framework-17 now says a media capture does not have to be referenced by a CSV.  So linking a capture to a scene through a CSV can't be the only way to make the association between capture and scene.  Should <captureSceneType> include a <mediaCapturesType> to fix this?

10.4.2 <captureArea> should say it is for video only.

16 <encodingGroup> - can include different media types in the same encoding group

Regards,
Mark

---

From: Roberta Presta <[email-masked]>
Date: Mon, 29 Sep 2014 19:23:32 +0200

Hi Mark,
please see below.

Il 29/09/2014 16:52, Duckworth, Mark ha scritto:
>
> Hi,
>
> I'm sorry I won't be able to attend the design team discussion 
> tomorrow about the data model.  I have a few more comments here 
> related to the new framework updates that impact the data model.  This 
> is in addition to my comments on the list from July 21 
> <http://www.ietf.org/mail-archive/web/clue/current/msg03995.html>.
>
I'm sending you the reply after this email.
>
> Update names of <sceneEntry> and <globalSceneEntries> to better match 
> new terms in framework, according to Ticket #59 and Ticket #60.
>
Ok.
>
> In the data model, it looks like the only way to associate a capture 
> with a scene is through a Capture Scene Entry (see <sceneEntriesType>) 
> (now called CSV). The framework says media captures are associated 
> with a particular scene.  Framework-17 now says a media capture does 
> not have to be referenced by a CSV.  So linking a capture to a scene 
> through a CSV can't be the only way to make the association between 
> capture and scene.  Should <captureSceneType> include a 
> <mediaCapturesType> to fix this?
>
Media captures have a mandatory <captureSceneIDREF> to refer to a 
capture scene. Currently in the datamodel draft there is no text saying 
that they must appear within capture scene view(s).
In a capture scene, besides the <sceneViews> element,  we could add a 
<mediaCaptures> section for listing media captures that do not appear in 
capture scene views, but it is not strictly necessary, thanks to the 
<captureSceneIDREF>.  If we do not add this further section, we could 
just clarify in the text.
Which solution is better?

> 10.4.2 <captureArea> should say it is for video only.
OK.
> 16 <encodingGroup> - can include different media types in the same 
Ok.
> Mark
Thank you,

Roberta

---

From: "Duckworth, Mark" <[email-masked]>
Date: Mon, 29 Sep 2014 10:34:44 -0700

Hi Roberta,

Sorry I forgot about the <captureSceneIDREF>, thanks for reminding me.  That should be fine, with no need for any additional list of captures in a scene.

Mark

From: Roberta Presta [mailto:[email-masked]]
Sent: Monday, September 29, 2014 1:24 PM
To: Duckworth, Mark; [email-masked]
Subject: Re: [clue] data model comments

Hi Mark,
please see below.

Media captures have a mandatory <captureSceneIDREF> to refer to a capture scene. Currently in the datamodel draft there is no text saying that they must appear within capture scene view(s).
In a capture scene, besides the <sceneViews> element,  we could add a <mediaCaptures> section for listing media captures that do not appear in capture scene views, but it is not strictly necessary, thanks to the <captureSceneIDREF>.  If we do not add this further section, we could just clarify in the text.
Which solution is better?

Ok.

Regards,
Mark

Thank you,

Roberta