Subject: Re: [clue] READV

From: Simon Pietro Romano <[email-masked]>
Date: Mon, 15 Sep 2014 15:36:44 +0200

Hello Christian,

first of all let me apologize for the long delay before this answer to your message. We're currently working on the long mail backlog we accumulated during Summer holidays.
As to your question, we actually discussed the points that you had raised before the face-to-face meeting in Toronto. The part related to READV messages (and responses) is available here:

http://recordings.conf.meetecho.com/Recordings/watch.jsp?recording=IETF90_CLUE&chapter=part_2

You can seek directly to minute 0:15:58 for the start of the discussion, which lasts approximately until minute 0:21:48.

Cheers,

Simon

On 04/ago/2014, at 03:29, Christian Groves <[email-masked]> wrote:

> Any reasoning? I can't see the reason why READV-ACK must contain an CLUEinfo structure.
> 
> Christian
> 
> On 24/07/2014 11:06 AM, Christian Groves wrote:
>> Hello
>> 
>> I heard that there were some discussions at the meeting regarding the READV and in particular questions:
>> 1. Do we need a separate READV response message to carry the CLUE data?
>> 2. Couldn't the READV simply trigger the MP to send an ADV?
>> 
>> It seems that the answer at the meeting to 1 was "Yes" and the answer to 2 was "No". Can anyone give some background / reasons for those answers? Is there some fundamental issue with using the READV as a trigger rather having to send CLUE Advertisement data in the READV response? The state machines in the protocol draft appear to use ADV in response to a READV.
>> 
>> 
>> Regards, Christian
>> 
>> _______________________________________________
>> clue mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/clue
>> 
> 
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue
> 

                     					       _\\|//_
                           				      ( O-O )
   ~~~~~~~~~~~~~~~~~~~~~~o00~~(_)~~00o~~~~~~~~~~~~~~~~~~~~~~~~
                    				Simon Pietro Romano
             				 Universita' di Napoli Federico II
                		     Computer Engineering Department 
	             Phone: +39 081 7683823 -- Fax: +39 081 7683816
                                           e-mail: [email-masked]

		    <<Molti mi dicono che lo scoraggiamento è l'alibi degli 
		    idioti. Ci rifletto un istante; e mi scoraggio>>. Magritte.
               			                     oooO
  ~~~~~~~~~~~~~~~~~~~~~~~(   )~~~ Oooo~~~~~~~~~~~~~~~~~~~~~~~~~
					                 \ (            (   )
			                                  \_)          ) /
                                                                       (_/

---

From: Christian Groves <[email-masked]>
Date: Tue, 16 Sep 2014 10:57:30 +1000

Hello Simon,

Thanks for the reply. I listened to the discussion and it seemed that 
the motivation was to identify the different between CLUE data from an 
MP initiated message (i.e. Advertisement) versus a MC initiated message 
(Readv/Readv.response). Is that correct?

I wonder what the MC makes of this distinction? My understanding is that 
given a point in time the MP would send exactly the same CLUE data in an 
Advertisement or Readv.response because it's media capabilities remain 
the same. Is that a fair assumption?

Regards, Christian

On 15/09/2014 11:36 PM, Simon Pietro Romano wrote:
> Hello Christian,
>
> first of all let me apologize for the long delay before this answer to 
> your message. We're currently working on the long mail backlog we 
> accumulated during Summer holidays.
> As to your question, we actually discussed the points that you had 
> raised before the face-to-face meeting in Toronto. The part related to 
> READV messages (and responses) is available here:
>
> You can seek directly to minute 0:15:58 for the start of the 
> discussion, which lasts approximately until minute 0:21:48.
>
> Cheers,
>
> Simon
>
>
> On 04/ago/2014, at 03:29, Christian Groves 
> <[email-masked] <mailto:[email-masked]>> 
> wrote:
>
>>> It seems that the answer at the meeting to 1 was "Yes" and the 
>>> answer to 2 was "No". Can anyone give some background / reasons for 
>>> those answers? Is there some fundamental issue with using the READV 
>>> as a trigger rather having to send CLUE Advertisement data in the 
>>> READV response? The state machines in the protocol draft appear to 
>>> use ADV in response to a READV.
>>>
>>>
>>> Regards, Christian
>>>
>>> [email-masked] <mailto:[email-masked]>
>> [email-masked] <mailto:[email-masked]>
>    e-mail: [email-masked] <mailto:[email-masked]>
>

---

From: Simon Pietro Romano <[email-masked]>
Date: Tue, 16 Sep 2014 14:15:05 +0200

Hello Christian,

> I wonder what the MC makes of this distinction? My understanding is that given a point in time the MP would send exactly the same CLUE data in an Advertisement or Readv.response because it's media capabilities remain the same. Is that a fair assumption?

It is. As I said, there is just a (subtle) semantic difference.

Cheers,

Simon

>> On 04/ago/2014, at 03:29, Christian Groves <[email-masked]<mailto:[email-masked]>> wrote:
>> 

                     					       _\\|//_
                           				      ( O-O )

---

From: Christian Groves <[email-masked]>
Date: Tue, 16 Sep 2014 23:13:41 +1000

Hello Simon,

Given its the same media capabilities then I'm not sure there is a 
semantic difference.

The other concern I have is what happens in terms of error handling? If 
a Media Consumer has trouble parsing the CLUE info in a received 
Advertisement it can send a NACK. What happens when a Media Consumer has 
trouble parsing CLUEinfo in a READV.response?

As I mentioned below the state machine seems to support the READV 
triggering a new Advertisement.

Regards, Christian

On 16/09/2014 10:15 PM, Simon Pietro Romano wrote:
> Hello Christian,
>
>> I wonder what the MC makes of this distinction? My understanding is 
>> that given a point in time the MP would send exactly the same CLUE 
>> data in an Advertisement or Readv.response because it's media 
>> capabilities remain the same. Is that a fair assumption?
>
>>> first of all let me apologize for the long delay before this answer 
>>> to your message. We're currently working on the long mail backlog we 
>>> raised before the face-to-face meeting in Toronto. The part related 
>>> to READV messages (and responses) is available here:
>>>
>>> <[email-masked] 
>>> <mailto:[email-masked]><mailto:[email-masked]>> 
>>> wrote:
>>>
>>>>> answer to 2 was "No". Can anyone give some background / reasons 
>>>>> for those answers? Is there some fundamental issue with using the 
>>>>> READV as a trigger rather having to send CLUE Advertisement data 
>>>>> in the READV response? The state machines in the protocol draft 
>>>>> appear to use ADV in response to a READV.
>>>>>
>>>>>
>>>>> Regards, Christian
>>>>>
>>>>> [email-masked] <mailto:[email-masked]><mailto:[email-masked]>
>>>> [email-masked] <mailto:[email-masked]><mailto:[email-masked]>
>>>   e-mail:[email-masked] 
>>> <mailto:[email-masked]><mailto:[email-masked]>
>>>