Subject: Re: [clue] call on Mandating using DTLS/SRTP for all media in CLUE signaling draft

From: Christer Holmberg <[email-masked]>
Date: Wed, 1 Apr 2015 07:58:17 +0000

Hi,

I support 2) or 3), and the when-not-to-use text would indicate that there are environments where media is protected using other means.

Regards,

Christer

From: clue [mailto:[email-masked]] On Behalf Of Roni Even
Sent: 31. maaliskuuta 2015 21:11
To: [email-masked]
Subject: [clue] call on Mandating using DTLS/SRTP for all media in CLUE signaling draft

Hi,

In IETF 91 there was according to the meeting notes Rough consensus in favor of mandating DTLS/SRTP for all media in CLUE signaling draft. There was no follow up discussion on the list.

The topic was presented again in IETF92 and the comments were made for having DTLS/SRTP but Mandate only the support and not the use.

The WG chairs are looking for which direction to take. I see three options

1.       DTLS/SRTP MUST be used as in the current 05 draft section 13

2.       DTLS/SRTP MUST be supported (and have some text about when not to use)

3.       DTLS/SRTP MUST be supported and SHOULD be used (and some text about when not to use)

Please provide feedback about which text to use by April 15th

Note that the current text is option1 and if no comments it will need to stay

Thanks

Roni Even

CLUE WG co-chair

---

From: Christian Groves <[email-masked]>
Date: Wed, 01 Apr 2015 20:49:33 +1100

+1

Christian

On 1/04/2015 6:58 PM, Christer Holmberg wrote:
>
> Hi,
>
> I support 2) or 3), and the when-not-to-use text would indicate that 
> there are environments where media is protected using other means.
>
> Regards,
>
> Christer
>
> *From:*clue [mailto:[email-masked]] *On Behalf Of *Roni Even
> *Sent:* 31. maaliskuuta 2015 21:11
> *To:* [email-masked]
> *Subject:* [clue] call on Mandating using DTLS/SRTP for all media in 
> CLUE signaling draft
>
> Hi,
>
> In IETF 91 there was according to the meeting notesRough consensus in favor of mandating DTLS/SRTP for all media in CLUE signaling draft. There was no follow up discussion on the list.
> Please provide feedback about which text to use by April 15^th    
>   
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue

---

From: "Duckworth, Mark" <[email-masked]>
Date: Wed, 1 Apr 2015 05:38:13 -0700

+1
Mark

> -----Original Message-----
> From: clue [mailto:[email-masked]] On Behalf Of Christian Groves
> Sent: Wednesday, April 01, 2015 5:50 AM
> To: [email-masked]
> Subject: Re: [clue] call on Mandating using DTLS/SRTP for all media in CLUE
> signaling draft
> 
> +1
> 
> Christian
> 
> > In IETF 91 there was according to the meeting notesRough consensus in favor
> of mandating DTLS/SRTP for all media in CLUE signaling draft. There was no
> follow up discussion on the list.
> > The topic was presented again in IETF92 and the comments were made for
> having DTLS/SRTP but Mandate only the support and not the use.
> >

---

From: Robert Hansen <[email-masked]>
Date: Wed, 01 Apr 2015 14:42:23 +0100

I support #3, "media is protected using other means" being one of those 
cases where the implementer has a good reason to ignore the SHOULD.

Rob

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 01 Apr 2015 10:16:55 -0400

+1

---

From: Stephen Botzko <[email-masked]>
Date: Thu, 9 Apr 2015 14:51:14 -0400

+1

BR
Stephen

On Wed, Apr 1, 2015 at 10:16 AM, Paul Kyzivat <[email-masked]> wrote:

>> In IETF 91 there was according to the meeting notesRough consensus in
>> favor of mandating DTLS/SRTP for all media in CLUE signaling draft. There
>> was no follow up discussion on the list.
>>