Subject: Re: [clue] Unauthenticated participants

From: Alissa Cooper <[email-masked]>
Date: Mon, 20 Jul 2015 16:25:52 +0200

Hi Paul,

> On Jul 20, 2015, at 2:16 PM, Paul Kyzivat <[email-masked]> wrote:
> 
> Followup to discussion in session today:
> 
> A question came up about whether participants must be authenticated. IIUC the answer is no. At the least, there could be participants into a conference who don't support clue and aren't authenticated, while other participants do support clue.

This is different from my understanding of what Roni said in the meeting. So, which is it? 

> 
> When the focus sends out an advertisement, all the participant info in that advertisement is an assertion by it. So when I receive an advertisement I base my trust in it on my level of trust in the advertiser. If the focus is forwarding participant info that it received in advertisements from other participants, then it ought to vet that info before passing it on.

Per your point above and the discussion earlier today, unauthenticated participants wouldn't be sending advertisements because they wouldn't support CLUE, right? I thought the trust problem is the other way around: you want the focus to not forward CLUE info *to* unauthenticated participants.

Alissa

> 
> It could be useful to add a property to the participant info indicating whether the participant has been authenticated. With appropriate words, this could allow the focus to forward along participant properties even when it cannot vouch for them.
> 
>    Thanks,
>    Paul
> 
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 20 Jul 2015 11:39:41 -0400

> This is different from my understanding of what Roni said in the meeting. So, which is it?

I'm not sure what Roni said.

At the least there can be unauthenticated non-clue participants 
connected to a focus, with their media being shared with the clue 
participants.

And given that, I see no reason to make a *total* ban on unauthenticated 
clue participants. (SHOULD strength is ok with me.)_At the very least 
there ought to be provision to allow a participant whose certification 
has expired, and for conferences that allow anybody to join.

> Per your point above and the discussion earlier today, unauthenticated participants wouldn't be sending advertisements because they wouldn't support CLUE, right? I thought the trust problem is the…

See my earlier reply in this thread.

	Thanks,
	Paul