Subject: Re: [clue] Mirja Kühlewind's Discuss on draft-ietf-clue-protocol-17: (with DISCUSS and COMMENT)

From: "Roni Even (A)" <[email-masked]>
Date: Fri, 2 Nov 2018 12:52:45 +0000

Hi Mirja,
Thanks for the review.
The protocol document describes the clue protocol. The establishment of the data channel is discussed in the signaling protocol  https://tools.ietf.org/html/draft-ietf-clue-signaling-14 

The introduction says

CLUE-capable endpoints are connected by means of the CLUE data
   channel, an SCTP over DTLS channel which is opened and established as
   described in [I-D.ietf-clue-signaling] and
   [I-D.ietf-clue-datachannel].  CLUE protocol messages flowing over
   such a channel are detailed in this document, both syntactically and
   semantically.

Roni Even

-----Original Message-----
From: clue [mailto:[email-masked]] On Behalf Of Mirja Kühlewind
Sent: Thursday, November 01, 2018 2:32 AM
To: The IESG
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [clue] Mirja Kühlewind's Discuss on draft-ietf-clue-protocol-17: (with DISCUSS and COMMENT)

Mirja Kühlewind has entered the following ballot position for
draft-ietf-clue-protocol-17: Discuss

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-clue-protocol/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

This document does not discuss any interactions with the transport protocol (e.g. who establishes the connection? what happens if the connections breaks; who should re-establish?). Also, I assume that SCTP is used (instead of TCP) because the idea is to use different SCTP streams for the different directions of the communication...? However, this is a complete guess, as the document does unfortunately not say nothing about the mapping of CLUE messages to SCTP sessions. In case all message are assumed to be send over the same stream instead, why is SCTP used and not TCP? Please provide more information and guidance on the use of SCTP!

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Two minor editorial commets:

1) In the terminology section: What does MCU actually stand for?

2) sec 4:
"CLUE protocol version numbers are
   characterized by a major version number (single digit) and a minor
   version number (single digit)..."
However, later on the text says that the numbers can also consist of multiple digits...

_______________________________________________
clue mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/clue

---

From: "Mirja Kuehlewind (IETF)" <[email-masked]>
Date: Sun, 4 Nov 2018 15:11:12 +0700

Yes, I saw this right after I pushed the send button and already revised my position. Thanks for the pointer and sorry for the noise.

> Am 02.11.2018 um 19:52 schrieb Roni Even (A) <[email-masked]>:
> 
> Hi Mirja,
> Thanks for the review.