Subject: [clue] Scope of SDP m= line 'webrtc-datachannel'

From: Christer Holmberg <[email-masked]>
Date: Sun, 21 Apr 2019 23:12:35 +0000

Hi,

I am cross-posting this on multiple list, to make people aware of the issue. However, I ask that any comments and discussions take place on the MMUSIC list only.

I found the following statement in section 4.5 of draft-ietf-mmusic-sctp-sdp:

   “NOTE: 'webrtc-datachannel' indicates the WebRTC Data Channel
   Establishment Protocol defined in [I-D.ietf-rtcweb-data-protocol].”

In addition, in the IANA registration of ‘webrtc-datachannel’ (section 15.3), draft-ietf-rtcweb-data-protocol is referenced.

To refresh everyone, draft-ietf-rtcweb-data-protocol defines DCEP (the inband protocol for handling WebRTC Data Channels), and ‘webrtc-datachannel’ is used in the SDP m= line when establishing an SCTP association for such channel.

However, both draft-ietf-mmusic-datachannel-sdp-neg and draft-ietf-clue-data-channel use ‘webrtc-datachannel’ in the “m=” line, and those drafts do not use DCEP.

My suggestion to fix this is to modify the text in draft-ietf-mmusic-sctp-sdp, to always use ‘webrtc-datachannel’ for WebRTC Data Channels – no matter whether DCEP is used or not.

I have created a pull request:

https://github.com/cdh4u/draft-sctp-sdp/pull/15

Regards,

Christer

---

From: Flemming Andreasen <[email-masked]>
Date: Mon, 22 Apr 2019 15:08:34 -0400

Folks

Please take a look at the proposed update below and let the authors and 
MMUSIC chairs know if you have any concerns with this change (by April 29).

Thanks

-- Flemming (as MMUSIC co-chair)

On 4/21/19 7:12 PM, Christer Holmberg wrote:
>
> Hi,
>
> I am cross-posting this on multiple list, to make people aware of the 
> issue. However, I ask that any comments and discussions take place on 
> the MMUSIC list only.
>
> In addition, in the IANA registration of ‘webrtc-datachannel’ (section 
> 15.3), draft-ietf-rtcweb-data-protocol is referenced.
>
> To refresh everyone, draft-ietf-rtcweb-data-protocol defines DCEP (the 
> inband protocol for handling WebRTC Data Channels), and 
> ‘webrtc-datachannel’ is used in the SDP m= line when establishing an 
> SCTP association for such channel.
>
> However, both draft-ietf-mmusic-datachannel-sdp-neg and 
> draft-ietf-clue-data-channel use ‘webrtc-datachannel’ in the “m=” 
> line, and those drafts do not use DCEP.
>
> My suggestion to fix this is to modify the text in 
> draft-ietf-mmusic-sctp-sdp, to always use ‘webrtc-datachannel’ for 
> WebRTC Data Channels – no matter whether DCEP is used or not.
>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb