Subject: status messages....

From: Michael Mealling <[email-masked]>
Date: Wed, 19 Apr 2000 13:57:39 -0400

Hi folx,
  Here is a list of potential status messages. If you can think of more
_please_ let me know. You don't need to spend a lot of time on it. Just
drop me a note about the general case and I'll flesh it out. More to come
on the actual format and encoding on Friday...

error invalid commonname
  -- there was a common name but acording to the rules
     of this service it just made no sense.
error cn empty
  -- There was no commonname in the query.
error invalid id
  -- You asked for an invalid ID
error id empty
  -- You asked for an ID but didn't give one.
error invalid property name
  -- Invalid property name
error invalid property type
 -- Invalid property type
error invalid property value
 -- Invalid property value
error invalid xml
 -- You sent something that violated the DTD.
error query to complex
 -- Your query was to complex for me to handle.
error server to busy
 -- This server is to busy
error service to busy
 -- All of the servers cooperating in providing this service are to busy
error service no longer available
 -- All servers cooperating in providing this service are no longer available

--
--------------------------------------------------------------------------------
Michael Mealling        |      Vote Libertarian!       | www.rwhois.net/michael
Sr. Research Engineer   |   www.ga.lp.org/gwinnett     | ICQ#:         14198821
Network Solutions       |          www.lp.org          |  [email-masked]

---

From: Ben Schepens <[email-masked]>
Date: Wed, 19 Apr 2000 15:02:00 -0400

>  -- All servers cooperating in providing this service are no longer
available

The following message is also needed:
error server no longer available
  -- This server is no longer available as a cooperating provider for this
service

---

From: Leslie Daigle <[email-masked]>
Date: Wed, 19 Apr 2000 15:16:28 -0400

Howdy,

I assume you'll be distinguishing (either in the 3-digit code fashion,
or some other way) between fatal errors & warnings?  permanent and
transient conditions?

Also, how about warnings re. hints (in the user query) that were
ignored in the processing; info re. which properties were used
for ranking, etc?

Need something for "too many hits" -- i.e., result set is
truncated; this _might_ be tied in with the "range" aspect of
the query, but it also should be used when the query is just too
general (intentional or accidental data mining).

Finally, all your "to's" should be "too's".  Yeah, I know -- it's
"o" compression, but... ;-)

Leslie.

--

-------------------------------------------------------------------
"My body obeys Aristotelian laws of physics."
   -- ThinkingCat

Leslie Daigle
[email-masked]
-------------------------------------------------------------------

---

From: Michael Mealling <[email-masked]>
Date: Wed, 19 Apr 2000 15:19:16 -0400

> or some other way) between fatal errors & warnings?  permanent and

Yes. I'm really just trying to identify the conditions right now.
After a brief discussion with Keith after the meeting I'm suggesting
that the codes look like this: x.y.z where x, y and z are the
code levels. Its unlimited so we don't have the problems that the three
digit codes have, plus they can't be confused with HTTP status codes.

> ignored in the processing; info re. which properties were used

Ahhh.... hmmm... I can create a few of those but they won't be remotely
complete. I'll create some levels for where that kind of info goes and
then provide a place to extend from...

> general (intentional or accidental data mining).

Yep.

> "o" compression, but... ;-)

;-)

-MM