Subject: [Coin] RG Status and Prague meeting

From: Marie-Jose Montpetit <[email-masked]>
Date: Thu, 20 Dec 2018 10:16:09 -0500

Hello list:

we may get a RG status which would put us on the schedule for Prague (Yeah). Also means we need your inputs on where this COIN thing should go. Please look at the current charter in:

https://trac.ietf.org/trac/irtf/wiki/coin#no1 <https://trac.ietf.org/trac/irtf/wiki/coin#no1>

Comments are welcome and even better help with drafts. We have a datacenter one, something on AR/VR but more importantly a yet to be defined architecture draft. Drafts on edge computing/networking are welcome. And of course charter discussion to focus on the real research on in-network computing.

I am more into being inclusive and apps oriented. But I understand that we could focus on specific problems too. At this point we are open :) But of course your feed back is essential.

Happy Holidays and let’s talk in 2019!

mjm

Marie-Jose Montpetit, Ph.D.
[email-masked]
[email-masked]
+1-781-526-2661
@SocialTVMIT

---

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Fri, 21 Dec 2018 08:03:19 +0000

Hello,

Thanks Marie-José for the update.

While I'm not for a too restrained focus for COIN, I think one of the challenges at this stage is to define a precise scope.

COIN seems to be at the crossroads of several important trends, enabling technologies, and problems.
Making COIN a melting pot (or salad bowl if you prefer this expression) might not be a good approach on the mid/long-terms.

I don't have specific inputs on how to scope better the activities right now (thinking about it).
We may look at recent initiatives and try to analyse why they failed (and what they did well), identify boundaries/synergies with other activities/groups inside IETF/IRTF and outside (e.g. IEEE)... just sharing some thoughts.

I also think that COIN shouldn't be only defined comparatively but should develop its own vision.

HTH.

Will be glad to join further discussion before and after IETF104, and from NMRG perspective a joint discussion on the management/operation implications of COIN type networks/systems would be interesting.

Best regards, Laurent.
________________________________
From: Coin <[email-masked]> on behalf of Marie-Jose Montpetit <[email-masked]>
Sent: Thursday, December 20, 2018 4:16:09 PM
To: [email-masked]
Subject: [Coin] RG Status and Prague meeting

Hello list:

https://trac.ietf.org/trac/irtf/wiki/coin#no1

[Image result for new year 2019]

mjm

Marie-Jose Montpetit, Ph.D.
[email-masked]<mailto:[email-masked]>
[email-masked]<mailto:[email-masked]>
+1-781-526-2661
@SocialTVMIT

---

From: "Hejianfei (Jeffrey)" <[email-masked]>
Date: Fri, 21 Dec 2018 09:48:06 +0000

Hi Laurent,
To provide something as inputs, rather than restraining the discussion, to me personally, there are 3 interesting topics for COIN.

The first one is quite specific:  there are quite a few use cases in Data Centers using programmable switches and P4 which looks promising in end-to-end performance, but need to be better testified with further investigation in network architecture, protocols and security.

The second topic is  a little bit “tricky”: for the distributed compute(e.g edge compute) , if we re-think the compute and the network in a holistic way, will we get a new understanding about the issues, new function demarcations?  There are a lot of works (workshops and events) in edge and fog computing etc, some(majority?) are from the compute or application community. Maybe we can make difference by leverage the unique expertise in IETF/IRTF.

The third topic is on “top” of these two: what characteristics are common for these two cases, can they borrow experience from each other , or even more ambitious: can we have a common “abstraction”? As Dave Oran raised at the side meeting in Bangkok, this would be challenging. The data planes are so different: quite limited capability at programmable switch in DCN vs turin-complete CPU at edge compute( I know there are also GPU/FPGA may be involved)

Best,
jeff

发件人: Coin [mailto:[email-masked]] 代表 Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)
发送时间: 2018年12月21日 16:03
收件人: [email-masked]; Marie-Jose Montpetit <[email-masked]>
主题: Re: [Coin] RG Status and Prague meeting

Hello,
From: Coin <[email-masked]<mailto:[email-masked]>> on behalf of Marie-Jose Montpetit <[email-masked]<mailto:[email-masked]>>
To: [email-masked]<mailto:[email-masked]>

Hello list:

mjm

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Fri, 21 Dec 2018 05:32:49 -0500

I completely agree on moving away from the “salad bowl” and find the right focus! I think we are getting passed the “what is computing in the network enabling” which was in a way the basis for the Bangkok meeting  to what are the common abstractions that link it all together and the research necessary to make it happen. 

And yes this is the work to be done hopefully before Prague.

mjm

> On Dec 21, 2018, at 3:03 AM, Ciavaglia, Laurent (Nokia - FR/Paris-Saclay) <[email-masked]> wrote:
> 
> Hello,
> 
> [email-masked] <mailto:[email-masked]>
> [email-masked] <mailto:[email-masked]>
> +1-781-526-2661
> @SocialTVMIT
> 
> 
>

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Fri, 21 Dec 2018 05:43:55 -0500

Personally and it terms of research I think 3 is the most interesting :) The common abstractions are where I am focusing my own efforts right now. 

> On Dec 21, 2018, at 4:48 AM, Hejianfei (Jeffrey) <[email-masked]> wrote:
> 
> Hi Laurent,
> 发件人: Coin [mailto:[email-masked] <mailto:[email-masked]>] 代表 Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)
> 发送时间: 2018年12月21日 16:03
> 收件人: [email-masked] <mailto:[email-masked]>; Marie-Jose Montpetit <[email-masked] <mailto:[email-masked]>>
> From: Coin <[email-masked] <mailto:[email-masked]>> on behalf of Marie-Jose Montpetit <[email-masked] <mailto:[email-masked]>>
> To: [email-masked] <mailto:[email-masked]>

---

From: "David R. Oran" <[email-masked]>
Date: Fri, 21 Dec 2018 09:00:13 -0800

On 21 Dec 2018, at 2:43, Marie-Jose Montpetit wrote:

> Personally and it terms of research I think 3 is the most interesting 
> :) The common abstractions are where I am focusing my own efforts 
> right now.
>
There are actually two aspects to the challenge for unifying the 
environments as I see it; both are worth addressing. The limited 
programmability of switch ASICs noted below, but there is another. 
Here’s my (quick) take on this; I have some more detailed material 
which I may be able to share later.

1. Data center switches, both ToR and spine (but not the routers 
attached to the outside world) have limited-function ASICs and wimpy 
CPUs. This makes it tricky to know what things are feasible to move into 
the switches and which not, and if moved whether you have to write very 
different code (e.g. P4 not Java/RUST/Go). One way to think about this 
is to cast both this and many edge cases as inherently heterogeneous 
compute designs, and address this in COIN right up front.

2. The edge is unlikely to adopt the service chaining or NFV style of 
control system nor the packet interception approach for the data plane. 
The edge applications almost certainly will mirror the virtualized 
general compute and remote-invocation methods of distributing 
computation that have dominated cloud computing applications and tools. 
If we want a common programming environment for both data center 
switches and edge, we may have to figure out how to change this in data 
center networking devices.

DaveO.

>> To provide something as inputs, rather than restraining the 
>> discussion, to me personally, there are 3 interesting topics for 
>> COIN.
>>
>> The first one is quite specific:  there are quite a few use cases in 
>> Data Centers using programmable switches and P4 which looks promising 
>> in end-to-end performance, but need to be better testified with 
>> further investigation in network architecture, protocols and 
>> security.
>>
>> The second topic is  a little bit “tricky”: for the distributed 
>> compute(e.g edge compute) , if we re-think the compute and the 
>> network in a holistic way, will we get a new understanding about the 
>> issues, new function demarcations?  There are a lot of works 
>> (workshops and events) in edge and fog computing etc, some(majority?) 
>> are from the compute or application community. Maybe we can make 
>> difference by leverage the unique expertise in IETF/IRTF.
>>
>> The third topic is on “top” of these two: what characteristics 
>> are common for these two cases, can they borrow experience from each 
>> other , or even more ambitious: can we have a common 
>> “abstraction”? As Dave Oran raised at the side meeting in 
>> Bangkok, this would be challenging. The data planes are so different: 
>> quite limited capability at programmable switch in DCN vs 
>> turin-complete CPU at edge compute( I know there are also GPU/FPGA 
>> may be involved)
>>
>> Best,
>> jeff
>>
>> 发件人: Coin [mailto:[email-masked] 
>> <mailto:[email-masked]>] 代表 Ciavaglia, Laurent (Nokia - 
>> FR/Paris-Saclay)
>> 发送时间: 2018年12月21日 16:03
>> 收件人: [email-masked] <mailto:[email-masked]>; Marie-Jose Montpetit 
>> <[email-masked] <mailto:[email-masked]>>
>> While I'm not for a too restrained focus for COIN, I think one of the 
>> challenges at this stage is to define a precise scope.
>>
>> Making COIN a melting pot (or salad bowl if you prefer this 
>> expression) might not be a good approach on the mid/long-terms.
>>
>> We may look at recent initiatives and try to analyse why they failed 
>> (and what they did well), identify boundaries/synergies with other 
>> activities/groups inside IETF/IRTF and outside (e.g. IEEE)... just 
>> sharing some thoughts.
>>
>> Will be glad to join further discussion before and after IETF104, and 
>> from NMRG perspective a joint discussion on the management/operation 
>> implications of COIN type networks/systems would be interesting.
>>
>> Best regards, Laurent.
>> From: Coin <[email-masked] <mailto:[email-masked]>> on 
>> behalf of Marie-Jose Montpetit <[email-masked] 
>> <mailto:[email-masked]>>
>> we may get a RG status which would put us on the schedule for Prague 
>> (Yeah). Also means we need your inputs on where this COIN thing 
>> should go. Please look at the current charter in:
>>
>> <https://trac.ietf.org/trac/irtf/wiki/coin#no1>
>>
>> Comments are welcome and even better help with drafts. We have a 
>> datacenter one, something on AR/VR but more importantly a yet to be 
>> defined architecture draft. Drafts on edge computing/networking are 
>> welcome. And of course charter discussion to focus on the real 
>> research on in-network computing.
>>
>> I am more into being inclusive and apps oriented. But I understand 
>> that we could focus on specific problems too. At this point we are 
>> open :) But of course your feed back is essential.
>>

> -- 
> Coin mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/coin

DaveO

---

From: "Aaron Falk" <[email-masked]>
Date: Fri, 21 Dec 2018 11:57:03 -0500

I confess that I’m not following this area closely but reading this 
thread a topic that I see coming up more and more in the IETF is the 
tension between the current focus on end-to-end privacy and security and 
the new model of in-network computation in this group.  I’d love to 
see some work on how the two can co-exist.

--aaron

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Fri, 21 Dec 2018 12:08:11 -0500

I think 2 is key. We can keep DC and edge separate at his moment as it is in the current charter but with the view that the edge may end up driving the DC and not the other way around. 

mjm

> On Dec 21, 2018, at 12:00 PM, David R. Oran <[email-masked]> wrote:
> 
> There are actually two aspects to the challenge for unifying the environments as I see it; both are worth addressing. The limited programmability of switch ASICs noted below, but there is another. Here’s my (quick) take on this; I have some more detailed material which I may be able to share later.
> 
> Data center switches, both ToR and spine (but not the routers attached to the outside world) have limited-function ASICs and wimpy CPUs. This makes it tricky to know what things are feasible to move into the switches and which not, and if moved whether you have to write very different code (e.g. P4 not Java/RUST/Go). One way to think about this is to cast both this and many edge cases as inherently heterogeneous compute designs, and address this in COIN right up front.
> 
> The edge is unlikely to adopt the service chaining or NFV style of control system nor the packet interception approach for the data plane. The edge applications almost certainly will mirror the virtualized general compute and remote-invocation methods of distributing computation that have dominated cloud computing applications and tools. If we want a common programming environment for both data center switches and edge, we may have to figure out how to change this in data center networking devices.
> 
> DaveO.
> 
> 发件人: Coin [mailto:[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>] 代表 Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)
> 发送时间: 2018年12月21日 16:03
> 收件人: [email-masked] <mailto:[email-masked] <mailto:[email-masked]>>; Marie-Jose Montpetit <[email-masked] <mailto:[email-masked] <mailto:[email-masked]>>>
> From: Coin <[email-masked] <mailto:[email-masked] <mailto:[email-masked]>>> on behalf of Marie-Jose Montpetit <[email-masked] <mailto:[email-masked] <mailto:[email-masked]>>>
> To: [email-masked] <mailto:[email-masked] <mailto:[email-masked]>>
> https://trac.ietf.org/trac/irtf/wiki/coin#no1 <https://trac.ietf.org/trac/irtf/wiki/coin#no1> <https://trac.ietf.org/trac/irtf/wiki/coin#no1 <https://trac.ietf.org/trac/irtf/wiki/coin#no1>>
> 
> [email-masked] <mailto:[email-masked] <mailto:[email-masked]>>
> [email-masked] <mailto:[email-masked] <mailto:[email-masked]>>
> +1-781-526-2661
> @SocialTVMIT
> 
> 
> -- 
> Coin mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/coin <https://www.irtf.org/mailman/listinfo/coin>
> DaveO
>

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Fri, 21 Dec 2018 12:14:13 -0500

The issue of what transport security protocols are ready to expose is on our “hot topics” list especially with QUIC coming up. And beyond single domain operators. I think the work in DINRG is also very related to this and could help define how to “authenticate” (for lack of a better word) the computing nodes. 

But yes you are not the only one wanting to see how the flexibility of having coin for specific and potentially hyper-localized applications and services can also support the security and privacy that those same apps and services require.

mjm

> On Dec 21, 2018, at 11:57 AM, Aaron Falk <[email-masked]> wrote:
> 
> I confess that I’m not following this area closely but reading this thread a topic that I see coming up more and more in the IETF is the tension between the current focus on end-to-end privacy and security and the new model of in-network computation in this group. I’d love to see some work on how the two can co-exist.
> 
> --aaron
> 
>> On Dec 21, 2018, at 4:48 AM, Hejianfei (Jeffrey) <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi Laurent,

---

From: "Diego R. Lopez" <[email-masked]>
Date: Tue, 25 Dec 2018 20:30:17 +0000

Hi,

I see this authencication Marie-Jose mentions directly related to the attestation matters being recently considered in the ETS/RATS BoF. All in all, we need mutual attestation (of both the computing nodes and the applications to be run on them), and the network as well. Furthermore, these attestation procedures could be the base for addressing the concerns on privacy in-network computing can bring, as Aaron pointed.

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno

Dr Diego R. Lopez
Telefonica I+D
https://www.linkedin.com/in/dr2lopez/

e-mail: [email-masked]<mailto:[email-masked]>
Tel:         +34 913 129 041
Mobile:  +34 682 051 091
----------------------------------

On 21/12/2018, 18:14, "Coin on behalf of Marie-Jose Montpetit" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

mjm

On Dec 21, 2018, at 11:57 AM, Aaron Falk <[email-masked]<mailto:[email-masked]>> wrote:

On Dec 21, 2018, at 4:48 AM, Hejianfei (Jeffrey) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Laurent,

Best,
jeff

发件人: Coin [mailto:[email-masked]] 代表 Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)
发送时间: 2018年12月21日 16:03
收件人: [email-masked]<mailto:[email-masked]>; Marie-Jose Montpetit <[email-masked]<mailto:[email-masked]>>
主题: Re: [Coin] RG Status and Prague meeting

Hello,

Hello list:

[Image removed by sender. Image result for new year 2019]

mjm

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição