Subject: [Coin] I-D on application-centric micro services

From: Dirk Trossen <[email-masked]>
Date: Thu, 2 May 2019 14:39:31 +0000

All,

We have submitted a draft as a contribution to the (proposed) RG discussion, which can be found at https://www.ietf.org/internet-drafts/draft-sarathchandra-coin-appcentres-00.txt

This draft discusses the idea of application-centric micro services (and their flexible execution in edge/cloud data centres and terminals). We outline areas of enabling technologies and hope that this will contribute to the discussions and support the creation of the RG.

Comments are very welcome!

Best,

Dirk

---

From: "Hejianfei (Jeffrey)" <[email-masked]>
Date: Tue, 7 May 2019 13:11:30 +0000

Hi Dirk,
Thank you for sharing your draft.
<chair hat off>
Below are some comments.

(1)    Your vision: Interpreting an application as a chain of micro-services, that could be executed in a distributed(networked) way at edge/cloud etc,). I am exploring towards the similar direction: it looks something interesting will happen when two trends meet together:  serverless/function-as-a-service starts to break monolithic app into micro-services, and computation resources become pervasive(with smart devices and edge etc)

(2)    Besides the challenges that you mentioned in the section “enabling technologies”, it is also tricky how to balance the control at app/user side and (in-network) micro-service execution, particularly in “a true multi-X (multi-user, multi-infrastructure, multi-domain) environment” that your draft mentioned.  The paper below addresses the “mobile function offloading” and results shows:” An automated algorithm cannot always predict when to offload and can be costly. Therefore, it is important for the programmer to be able to easily change deployment to adapt to new technologies.”

“Customizable and extensible deployment for mobile/cloud applications” (https://dl.acm.org/citation.cfm?id=2685057)

(3)    Your draft outlines a framework which covers various areas such as application, compute, networking etc. It is definitely challenging, needs expertise and experience from different background, but also interesting, probably inevitable if we want to view the network and compute in a new way. Well, this is why we have COIN here.
Cheers,
Jeffrey

发件人: Coin [mailto:[email-masked]] 代表 Dirk Trossen
发送时间: 2019年5月2日 22:40
收件人: [email-masked]
主题: [Coin] I-D on application-centric micro services

All,

We have submitted a draft as a contribution to the (proposed) RG discussion, which can be found at https://www.ietf.org/internet-drafts/draft-sarathchandra-coin-appcentres-00..txt<https://www.ietf.org/internet-drafts/draft-sarathchandra-coin-appcentres-00.txt>

Best,

Dirk

---

From: Dirk Trossen <[email-masked]>
Date: Tue, 7 May 2019 13:53:34 +0000

Hi Jeffrey,

Many thanks for your comments. Indeed, we position our vision in the intersection of true distribution desired by execution of more ‘suitable’ resources and the very availability of said resources in future pervasive edge deployments. So why being tied to my mobile handset if I’ve got more suitable resources around me?

As for the control issue: I fully agree and we left the entire area of ‘runtime control’ out of the draft (due to keeping the focus) with aspects such as execution correctness, resource scheduling etc needing consideration.

Best,

Dirk

From: Hejianfei (Jeffrey) <[email-masked]>
Sent: 07 May 2019 14:12
To: Dirk Trossen <[email-masked]>; [email-masked]
Subject: 答复: I-D on application-centric micro services

Hi Dirk,

  1.  Your vision: Interpreting an application as a chain of micro-services, that could be executed in a distributed(networked) way at edge/cloud etc,). I am exploring towards the similar direction: it looks something interesting will happen when two trends meet together:  serverless/function-as-a-service starts to break monolithic app into micro-services, and computation resources become pervasive(with smart devices and edge etc)
  2.  Besides the challenges that you mentioned in the section “enabling technologies”, it is also tricky how to balance the control at app/user side and (in-network) micro-service execution, particularly in “a true multi-X (multi-user, multi-infrastructure, multi-domain) environment” that your draft mentioned.  The paper below addresses the “mobile function offloading” and results shows:” An automated algorithm cannot always predict when to offload and can be costly. Therefore, it is important for the programmer to be able to easily change deployment to adapt to new technologies.”

  1.  Your draft outlines a framework which covers various areas such as application, compute, networking etc. It is definitely challenging, needs expertise and experience from different background, but also interesting, probably inevitable if we want to view the network and compute in a new way. Well, this is why we have COIN here.
Cheers,
Jeffrey

发件人: Coin [mailto:[email-masked]] 代表 Dirk Trossen
发送时间: 2019年5月2日 22:40
收件人: [email-masked]<mailto:[email-masked]>
主题: [Coin] I-D on application-centric micro services

All,

Best,

Dirk