Subject: [Coin] "Checking-in on Network Functions" - ANRW'19 presentation

From: "Schooler, Eve M" <[email-masked]>
Date: Wed, 24 Jul 2019 15:04:39 +0000

In case you missed the IETF-hosted ANRW’19 (Applied Network Research Workshop) on Monday, check out (pun intended) the interesting and relevant presentation below.
With programmability comes the need for correctness and safety….
E.

“Checking-in on Network Functions”, by Zeeshan Lakhani (CMU) and Heather Miller (CMU)

Slides: https://irtf.org/anrw/2019/slides-anrw19-final36.pdf
Paper: https://dl.acm.org/authorize?N687431
Abstract: When programming network functions, changes within a packet tend to have consequences—side effects which must be accounted for by network programmers or administrators via arbitrary logic and an innate understanding of dependencies. Examples of this include updating checksums when a packet’s contents has been modified or adjusting a payload length field of a IPv6 header if another header is added or updated within a packet. While static-typing captures interface specifications and how packet contents should behave, it does not enforce precise invariants around runtime dependencies like the examples above. Instead, during the design phase of network functions, programmers should be given an easier way to specify checks up front, all without having to account for and keep track of these *consequences* at each and every step during the development cycle. In keeping with this view, we present a unique approach for adding and generating both static checks and dynamic contracts for specifying and checking packet processing operations. We develop our technique within an existing framework called NetBricks and demonstrate how our approach simplifies and checks common dependent packet and header processing logic that other systems take for granted, all without adding much overhead during development.

---

From: <[email-masked]>
Date: Thu, 25 Jul 2019 07:21:14 -0400

Thanks for sending the note.

Long before COIN started, I think, the first computing in the network was done by NetSift (George Verghese and Cisco) to detect viruses. I see the presentation below use contracts.  Six-seven years back, Cisco ACI started using contracts in switching.  Another way to look at computing in the network is to first, find hard problems, and then see how networking can solve any.  Also, switch hardware runs at 12.8 Tbps.  Router hardware runs at 100 Gbps.   Some problems are best solved in a router while others in a switch.

Regards,

Hemant

From: Coin <[email-masked]> On Behalf Of Schooler, Eve M
Sent: Wednesday, July 24, 2019 11:05 AM
To: [email-masked]
Cc: [email-masked]; Schooler, Eve M <[email-masked]>
Subject: [Coin] "Checking-in on Network Functions" - ANRW'19 presentation

E.

Slides:  <https://irtf.org/anrw/2019/slides-anrw19-final36.pdf> https://irtf.org/anrw/2019/slides-anrw19-final36.pdf

Paper:  <https://dl.acm.org/authorize?N687431> https://dl.acm.org/authorize?N687431