Subject: [Coin] Fwd: New Version Notification for draft-kutscher-coinrg-dir-00.txt

From: "Dirk Kutscher" <[email-masked]>
Date: Mon, 08 Jul 2019 21:46:33 +0200

Hello,

We have written up some ideas on COIN Research Directions -- hope you 
find that useful.

Naturally, we’d be interested in feedback — either on the list or at 
the meeting in Montreal.

Best regards,

Dirk, Teemu, Jörg

Forwarded message:

> From: [email-masked]
> To: Joerg Ott <[email-masked]>, Teemu Karkkainen <[email-masked]>, 
> Teemu Kaerkkaeinen <[email-masked]>, Dirk Kutscher 
> <[email-masked]>
> Subject: New Version Notification for draft-kutscher-coinrg-dir-00.txt
> Date: Mon, 08 Jul 2019 12:41:52 -0700
>
> A new version of I-D, draft-kutscher-coinrg-dir-00.txt
> has been successfully submitted by Dirk Kutscher and posted to the
> IETF repository.
>
> Name:		draft-kutscher-coinrg-dir
> Revision:	00
> Title:		Directions for Computing in the Network
> Document date:	2019-07-08
> Group:		Individual Submission
> Pages:		17
> URL:            
> https://www.ietf.org/internet-drafts/draft-kutscher-coinrg-dir-00.txt
> Status:         
> https://datatracker.ietf.org/doc/draft-kutscher-coinrg-dir/
> Htmlized:       
> https://tools.ietf.org/html/draft-kutscher-coinrg-dir-00
> Htmlized:       
> https://datatracker.ietf.org/doc/html/draft-kutscher-coinrg-dir
>
>
> Abstract:
>    In-network computing can be conceived in many different ways - from
>    active networking, data plane programmability, running virtualized
>    functions, service chaining, to distributed computing.
>
>    This memo proposes a particular direction for Computing in the
>    Networking (COIN) research and lists suggested research challenges.
>
>
>
>
> Please note that it may take a couple of minutes from the time of 
> submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> The IETF Secretariat

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Mon, 8 Jul 2019 15:50:24 -0400

Thanks a lot!

Marie-José Montpetit, Ph.D.
Research Affiliate, MIT Media Laboratory
[email-masked]
[email-masked]

On July 8, 2019 at 3:46:50 PM, Dirk Kutscher ([email-masked]) wrote:

Hello,

Best regards,

Dirk, Teemu, Jörg

-- 
Coin mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/coin

---

From: Dirk Trossen <[email-masked]>
Date: Fri, 12 Jul 2019 15:39:37 +0000

Hi Dirk, all,

Thanks for sending the draft - very interesting and good to have!

Two minor comments from my side:
1. in the introduction, you refer to edge computing  but, from the description, seem to limit the view of it to ETSI MEC, given the strong references to VMs and VIMs (linkage to NFV for LCM). It would be good to make this clearer, i.e., edge computing is meant to be (ETSI) MEC since, as a general 'paradigm', edge computing is not married into VMs or VIM realizations.

2. I generally agree with the SFC text in the introduction but wanted to point to the 'named SFC' work we introduced to the SFC WG a while ago with drafts in the WG before pursuing, in agreement with the SFC chairs, the named SFF draft as an ISE contribution. The use cases and motivation for this is very much aligned with the idea of in-networking computing. It also aligns, to some extent, with the approach of realizing IP-based services over a path forwarding based ICN substrate; something we are introducing into the ICNRG (as you might know). 

Best,

Dirk

-----Original Message-----
From: Coin <[email-masked]> On Behalf Of Dirk Kutscher
Sent: 08 July 2019 20:47
To: [email-masked]
Subject: [Coin] Fwd: New Version Notification for draft-kutscher-coinrg-dir-00.txt

Hello,

We have written up some ideas on COIN Research Directions -- hope you find that useful.

Naturally, we’d be interested in feedback — either on the list or at the meeting in Montreal.

Best regards,

Dirk, Teemu, Jörg

Forwarded message:

> A new version of I-D, draft-kutscher-coinrg-dir-00.txt has been 
> successfully submitted by Dirk Kutscher and posted to the IETF 
> repository.
>
> submission until the htmlized version and diff are available at 
> tools.ietf.org.
>
> The IETF Secretariat

---

From: "Dirk Kutscher" <[email-masked]>
Date: Sun, 21 Jul 2019 14:01:27 -0400

Hi Dirk,

Thanks for these comments.

> 1. in the introduction, you refer to edge computing  but, from the 
> description, seem to limit the view of it to ETSI MEC, given the 
> strong references to VMs and VIMs (linkage to NFV for LCM). It would 
> be good to make this clearer, i.e., edge computing is meant to be 
> (ETSI) MEC since, as a general 'paradigm', edge computing is not 
> married into VMs or VIM realizations.

Yes, good point — that should be made clearer.

> 2. I generally agree with the SFC text in the introduction but wanted 
> to point to the 'named SFC' work we introduced to the SFC WG a while 
> ago with drafts in the WG before pursuing, in agreement with the SFC 
> chairs, the named SFF draft as an ISE contribution. The use cases and 
> motivation for this is very much aligned with the idea of 
> in-networking computing. It also aligns, to some extent, with the 
> approach of realizing IP-based services over a path forwarding based 
> ICN substrate; something we are introducing into the ICNRG (as you 
> might know).

Right, I am aware of the named SFC work (and your ICNRG contributions of 
course). I can imagine that named SFC could be useful for certain COIN 
scenarios — would be interested to discuss this more as well.

Cheers,
Dirk