Subject: [Coin] RG formation - IAB Feedback

From: "Schooler, Eve M" <[email-masked]>
Date: Wed, 20 Nov 2019 03:49:08 +0000

Hi All,
We presented a COIN PRG overview to the IAB Monday morning 11/18 at Colin's request as a necessary step en route to possibly graduate from PRG to RG. Below are the comments we received. We plan to discuss briefly at the meeting on Friday.
Eve
(on behalf of J/E/M)

Feedback from IAB

-        Christian Huitema: There should be greater consideration given to privacy and security issues and solutions - early on

-        Ted Hardie:

*        One thought: look at Commercial 5G systems and their definition and architecture of the Edge, because the 5G community likely can provide guidance on an approach to Privacy/Security. For example around their Slices solution. They offer a relationship between the customer and the slice provider.

*        Can the work in DCs shed light on the APIs for COIN - will cloud-based computations have the same API as Edge-only computations?

-        Stephen Farrell:

*        Without considering security/privacy, the architecture is misplaced, and relying on homomorphic ciphers for security will be difficult. [Elsewhere, in hallway conversations, growing consensus that data will remain encrypted throughout its life cycle - what's the implication of that?]

*        What's been the most interesting finding so far?

*        Marie-Jose:

?  Noa Zilberman's paper - that it came out of the Data policy community - how to sell services to customers

?  Programmable networking devices

*        Jeffrey:

?  How significantly in-network compute can improve the distributed systems inside the DCN, probably also applicable to edge computing

?  Co-Flow notion: using in-network compute to process the packets from correlated flows

*        Eve:

?  Not only a convergence of compute and network -  BUT ALSO storage

?  The need to ponder WHAT can the IETF bring to the discussion/solution space, in the way of protocols and architecture?

?  For example what will we leverage, extend, throw-away and offer as new in the way of existing standards? For example, for Edge Data Discovery, should we use, extend, propose an alternate solution to DNS.

-        Brian Trammell:

o   Yes! Stress the Internet focus, as compared with other communities looking at Edge computing and COIN!

o   Noted that there's a fundamental tension: nodes that do the computation need access to the data; other nodes need to be prevented from this; e.g., been thinking about opportunistically storing data in other peoples' nodes but at the same time be able to ensure they cannot actually see it

o   Security model is critical if the work is to be relevant.

o   Goal should be to bring some of the work into the world.

-        Wes Hardaker:

o   Threat models vary for different applications. Different model for security when there is a single owner of the resources and data vs the security solution when there are different owners, as with COIN - e.g., threat models for IoT

o   Would be just as useful to Identify the things that are not suited - dream big and fail

o   Suggested some use case focus - seems like we haven't identified a primary or main use case

-        Re security/privacy know-how - continue to bring some/more of our questions to the DIN RG, and leverage solutions under scrutiny there

-        Recommendation: find people in the research community who are approaching the COIN problem from the computing standpoint vs network perspective

*        The way things are scheduled from DC standpoint vs once resources are liberated from the DC and are more distributed

*        What is sent in the clear on the lines or not

-        Have we considered CDNs in COIN? Yes, not only CDNs but reverse CDNs (rCDNs)

---

From: <[email-masked]>
Date: Wed, 20 Nov 2019 10:51:54 +0530

One has to assume, the DCN encrypts data, both intra and inter DCN traffic.
Thus, it will be interesting if network compute is performed over encrypted
data or decrypted data?  Few years back, MIT published a paper with database
operations over encrypted data.  If it is decrypted data, then key
distribution is another issue.   Some security vendors decrypt network data
to invoke security and if security passes, the data is encrypted to forward
data.

IOT is also expected to encrypt wireless data.  Not sure if 5G encrypts
wireless data, but certainly 3G and 4G support privacy.

I agree, it's better to find use cases in 5G Edge or IOT, CDN (pick one) and
see what compute can be run in the network. 

Hemant

From: Coin <[email-masked]> On Behalf Of Schooler, Eve M
Sent: Wednesday, November 20, 2019 9:19 AM
To: [email-masked]
Cc: Schooler, Eve M <[email-masked]>; Marie-Jose Montpetit
<[email-masked]>; Colin Perkins <[email-masked]>; Hejianfei
(Jeffrey) <[email-masked]>
Subject: [Coin] RG formation - IAB Feedback

Hi All,

We presented a COIN PRG overview to the IAB Monday morning 11/18 at Colin's
request as a necessary step en route to possibly graduate from PRG to RG.
Below are the comments we received. We plan to discuss briefly at the
meeting on Friday.

Eve 

(on behalf of J/E/M)

Feedback from IAB

-        Christian Huitema: There should be greater consideration given to
privacy and security issues and solutions - early on

-        Ted Hardie: 

*        One thought: look at Commercial 5G systems and their definition and
architecture of the Edge, because the 5G community likely can provide
guidance on an approach to Privacy/Security. For example around their Slices
solution. They offer a relationship between the customer and the slice
provider.

*        Can the work in DCs shed light on the APIs for COIN - will
cloud-based computations have the same API as Edge-only computations?

-        Stephen Farrell: 

*        Without considering security/privacy, the architecture is
misplaced, and relying on homomorphic ciphers for security will be
difficult. [Elsewhere, in hallway conversations, growing consensus that data
will remain encrypted throughout its life cycle - what's the implication of
that?]

*	Marie-Jose:

*	Noa Zilberman's paper - that it came out of the Data policy
community - how to sell services to customers
*	Programmable networking devices

*	Jeffrey:

*	How significantly in-network compute can improve the distributed
systems inside the DCN, probably also applicable to edge computing
*	Co-Flow notion: using in-network compute to process the packets from
correlated flows

*	Eve: 

*	Not only a convergence of compute and network -  BUT ALSO storage
*	The need to ponder WHAT can the IETF bring to the
discussion/solution space, in the way of protocols and architecture?
*	For example what will we leverage, extend, throw-away and offer as
new in the way of existing standards? For example, for Edge Data Discovery,
should we use, extend, propose an alternate solution to DNS.

-        Brian Trammell: 

o   Yes! Stress the Internet focus, as compared with other communities
looking at Edge computing and COIN! 

o   Noted that there's a fundamental tension: nodes that do the computation
need access to the data; other nodes need to be prevented from this; e.g.,
been thinking about opportunistically storing data in other peoples' nodes
but at the same time be able to ensure they cannot actually see it

-        Wes Hardaker: 

o   Threat models vary for different applications. Different model for
security when there is a single owner of the resources and data vs the
security solution when there are different owners, as with COIN - e.g.,
threat models for IoT

o   Would be just as useful to Identify the things that are not suited -
dream big and fail

o   Suggested some use case focus - seems like we haven't identified a
primary or main use case

-        Re security/privacy know-how - continue to bring some/more of our
questions to the DIN RG, and leverage solutions under scrutiny there

-        Recommendation: find people in the research community who are
approaching the COIN problem from the computing standpoint vs network
perspective

*        The way things are scheduled from DC standpoint vs once resources
are liberated from the DC and are more distributed

-        Have we considered CDNs in COIN? Yes, not only CDNs but reverse
CDNs (rCDNs)

---

From: Sharon Barkai <[email-masked]>
Date: Wed, 20 Nov 2019 14:27:55 +0800

We presented in the LISP wg a GeoState use case leveraging an addressable objects abstraction which can potentially be generalized by COIN.

Its a step further then CDN and NFV in that addressable objects can hold changing state and apply functions to it. As an example access methods invoked by DPDK type mechanisms like in NFV are scoped to the specific state, and,  AI methods can change in-network state utilizing edge GPUs (assuming interoperable termination of  heavy video, propagation of lighter enumerations at the edge is of need).

The point is that being scoped, subscribed, sharded by standard overlay routers means - existing practices for protecting security, privacy, SLA, slicing, and CoS/QoS - apply.

This is to the point of bring-your-own overlay-router, since its the only entity that knows your underlay IP and the overlay EID of the object you are addressing.

Happy to explore further study.
Attached ppt used:

--szb
Cell: +972.53.2470068
WhatsApp: +1.650.492.0794

> On Nov 20, 2019, at 11:49 AM, Schooler, Eve M <[email-masked]> wrote:
> 
> 
> Hi All,
> We presented a COIN PRG overview to the IAB Monday morning 11/18 at Colin’s request as a necessary step en route to possibly graduate from PRG to RG. Below are the comments we received. We plan to discuss briefly at the meeting on Friday.
> Eve
> (on behalf of J/E/M)
>  
> Feedback from IAB
> ·        One thought: look at Commercial 5G systems and their definition and architecture of the Edge, because the 5G community likely can provide guidance on an approach to Privacy/Security. For example around their Slices solution. They offer a relationship between the customer and the slice provider.
> ·        Can the work in DCs shed light on the APIs for COIN – will cloud-based computations have the same API as Edge-only computations?
> -        Stephen Farrell:
> ·        Without considering security/privacy, the architecture is misplaced, and relying on homomorphic ciphers for security will be difficult. [Elsewhere, in hallway conversations, growing consensus that data will remain encrypted throughout its life cycle – what’s the implication of that?]
> ·        What’s been the most interesting finding so far?
> ·        Marie-Jose:
> §  Noa Zilberman’s paper – that it came out of the Data policy community – how to sell services to customers
> §  Programmable networking devices
> ·        Jeffrey:
> §  How significantly in-network compute can improve the distributed systems inside the DCN, probably also applicable to edge computing
> §  Co-Flow notion: using in-network compute to process the packets from correlated flows
> ·        Eve:
> §  Not only a convergence of compute and network -  BUT ALSO storage
> §  The need to ponder WHAT can the IETF bring to the discussion/solution space, in the way of protocols and architecture?
> §  For example what will we leverage, extend, throw-away and offer as new in the way of existing standards? For example, for Edge Data Discovery, should we use, extend, propose an alternate solution to DNS.
> -        Brian Trammell:
> o   Noted that there’s a fundamental tension: nodes that do the computation need access to the data; other nodes need to be prevented from this; e.g., been thinking about opportunistically storing data in other peoples’ nodes but at the same time be able to ensure they cannot actually see it
> o   Threat models vary for different applications. Different model for security when there is a single owner of the resources and data vs the security solution when there are different owners, as with COIN – e.g., threat models for IoT
> o   Would be just as useful to Identify the things that are not suited – dream big and fail
> o   Suggested some use case focus - seems like we haven’t identified a primary or main use case
> -        Re security/privacy know-how – continue to bring some/more of our questions to the DIN RG, and leverage solutions under scrutiny there
> ·        The way things are scheduled from DC standpoint vs once resources are liberated from the DC and are more distributed
> ·        What is sent in the clear on the lines or not
> -- 
> Coin mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/coin

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Wed, 20 Nov 2019 00:01:48 -0800

Thanks. Are you joining us Friday?

Marie-José Montpetit, Ph.D.
Research Affiliate, MIT Media Laboratory
[email-masked]
[email-masked]

On November 20, 2019 at 2:27:55 PM, Sharon Barkai (
[email-masked]) wrote:

> We presented in the LISP wg a GeoState use case leveraging an addressable
> objects abstraction which can potentially be generalized by COIN.
>
> Its a step further then CDN and NFV in that addressable objects can hold
> changing state and apply functions to it. As an example access methods
> invoked by DPDK type mechanisms like in NFV are scoped to the specific
> state, and,  AI methods can change in-network state utilizing edge GPUs
> (assuming interoperable termination of  heavy video, propagation of lighter
> enumerations at the edge is of need).
>
> The point is that being scoped, subscribed, sharded by standard overlay
> routers means - existing practices for protecting security, privacy, SLA,
> slicing, and CoS/QoS - apply.
>
> This is to the point of bring-your-own overlay-router, since its the only
> entity that knows your underlay IP and the overlay EID of the object you
> are addressing.
>
> ------------------------------
>
>
>
>
> --szb
> Cell: +972.53.2470068
> We presented a COIN PRG overview to the IAB Monday morning 11/18 at
> Colin’s request as a necessary step en route to possibly graduate from PRG
> to RG. Below are the comments we received. We plan to discuss briefly at
> the meeting on Friday.
>
> Eve
>
> (on behalf of J/E/M)
>
>
>
> *Feedback from IAB*
>
> -        Christian Huitema: There should be greater consideration given
> to privacy and security issues and solutions - early on
>
> -        Ted Hardie:
>
> ·        One thought: look at Commercial 5G systems and their definition
> and architecture of the Edge, because the 5G community likely can provide
> guidance on an approach to Privacy/Security. For example around their
> Slices solution. They offer a relationship between the customer and the
> slice provider.
>
> ·        Can the work in DCs shed light on the APIs for COIN – will
> ·        Without considering security/privacy, the architecture is
> difficult. [Elsewhere, in hallway conversations, growing consensus that
> data will remain encrypted throughout its life cycle – what’s the
> implication of that?]
>
> §  How significantly in-network compute can improve the distributed
> §  The need to ponder WHAT can the IETF bring to the discussion/solution
> space, in the way of protocols and architecture?
>
> §  For example what will we leverage, extend, throw-away and offer as new
> in the way of existing standards? For example, for Edge Data Discovery,
> o   Noted that there’s a fundamental tension: nodes that do the
> computation need access to the data; other nodes need to be prevented from
> this; e.g., been thinking about opportunistically storing data in other
> peoples’ nodes but at the same time be able to ensure they cannot actually
> see it
>
> security solution when there are different owners, as with COIN – e.g.,
> threat models for IoT
>
> -        Re security/privacy know-how – continue to bring some/more of
> our questions to the DIN RG, and leverage solutions under scrutiny there
>
> ·        The way things are scheduled from DC standpoint vs once
> resources are liberated from the DC and are more distributed
>