Subject: [Coin] COINRG and QIR : interaction for generic architecture of quantum computation node ?

From: Kuhn Nicolas <[email-masked]>
Date: Mon, 25 Nov 2019 09:43:44 +0000

Hi all,

Despite my interest in QIRG activity, I could not attend the meeting at last IETF106 for conflict with other meetings reasons.
However, I could attend COINRG.
I think there is an opportunity for interaction between QIRG and COINRG.

The draft "Directions for Computing in the Network" [https://datatracker.ietf.org/doc/draft-kutscher-coinrg-dir/] mentions a terminology towards a novel "computing in the network (COIN)" approach that revisits the function split between computing and networking.
The document takes one example: "Compute-First Networking with ICN". To assess whether the proposed terminology is generic, it may be interesting to consider other use-cases where the computing is spread within the network.
Another example could then be "Interconnected Quantum Computers".
Indeed, the charter of QIRG mentions an architectural framework to support a first step toward a quantum network architecture [https://datatracker.ietf.org/rg/qirg/about/].

I am not sure about the way towards an interaction between those activities, but starting email discussions may pull a trigger.

I hope this helps,
Kind regards,

Nicolas

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Mon, 25 Nov 2019 02:39:30 -0800

Thanks.

At the QIRG meeting last week COIN was mentioned so maybe there is an
opportunity to indeed start a dialogue.

mjm

Marie-José Montpetit, Ph.D.
Research Affiliate, MIT Media Laboratory
[email-masked]
[email-masked]

On November 25, 2019 at 10:44:55 AM, Kuhn Nicolas ([email-masked])
wrote:

Hi all,

Despite my interest in QIRG activity, I could not attend the meeting at
last IETF106 for conflict with other meetings reasons.

The draft “Directions for Computing in the Network” [
https://datatracker.ietf.org/doc/draft-kutscher-coinrg-dir/] mentions a
terminology towards a novel "computing in the network (COIN)" approach that
revisits the function split between computing and networking.

The document takes one example: “Compute-First Networking with ICN”. To
assess whether the proposed terminology is generic, it may be interesting
to consider other use-cases where the computing is spread within the
network.

Another example could then be “Interconnected Quantum Computers”.

Indeed, the charter of QIRG mentions an architectural framework to support
a first step toward a quantum network architecture [
https://datatracker.ietf.org/rg/qirg/about/].

I am not sure about the way towards an interaction between those
activities, but starting email discussions may pull a trigger.

I hope this helps,

Kind regards,

Nicolas

-- 
Coin mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/coin

---

From: Wojciech Kozlowski <[email-masked]>
Date: Mon, 25 Nov 2019 13:04:55 +0000

Following a mention of COIN at the QIRG meeting I attended the meeting on Friday and I do think there is definitely at least some scope for initial exploration. However, I am new to COIN so please forgive me any obvious blunders in the technical matters.

I picked up an interest in COIN, because one of the problems of developing an architectural model for a quantum network is that the stateless packet processing model just does not apply when you have to deal with certain quantum phenomena such as entanglement where you have a pair of qubits on two different physical devices yet they share state information which must be tracked by the network. Rodney Van Meter who is a co-chair of QIRG and published a lot of early work on this topic often suggests that quantum networking is a form of distributed computation. Furthermore, quantum networks (at least the near-term realisations) will be incredibly time-sensitive - latency will matter _a lot_ - so I was interested to see that one of the driving factors for COIN is reducing the latency.

Quantum networking will have a significant non-quantum processing component which will involve local processing and networked communication with other nodes. This has caused me some trouble in my own research when trying to apply the conventional notion of data and control planes to the problem. Perhaps computation in the network might end up being one way of looking at this problem. I have even been exploring using P4 for quantum "data planes" (but more from the SDN and central controller approach) which would open up a practical way of adding computation in the network to quantum nodes.

This is a line of thinking I would like to explore and I'm sure it would be of interest to some in the QIRG. If the people at COINRG are interested and think it's relevant there might be some scope to move forward on this topic.

Thanks,
Wojtek

PS For curious readers: we are currently working on a "Architectural Principles of a Quantum Internet" draft which will serve as an introduction for networking people with no quantum background to the subject of quantum networking (for a quick look into the challenges involved that might be addressed with COIN see sections 4.1 and 5.1).

On Mon, 2019-11-25 at 02:39 -0800, Marie-Jose Montpetit wrote:
Thanks.

At the QIRG meeting last week COIN was mentioned so maybe there is an opportunity to indeed start a dialogue.

mjm

Marie-José Montpetit, Ph.D.
Research Affiliate, MIT Media Laboratory
[email-masked]<mailto:[email-masked]>
[email-masked]<mailto:[email-masked]>

On November 25, 2019 at 10:44:55 AM, Kuhn Nicolas ([email-masked]<mailto:[email-masked]>) wrote:
Hi all,

The draft “Directions for Computing in the Network” [https://datatracker.ietf.org/doc/draft-kutscher-coinrg-dir/] mentions a terminology towards a novel "computing in the network (COIN)" approach that revisits the function split between computing and networking.
The document takes one example: “Compute-First Networking with ICN”. To assess whether the proposed terminology is generic, it may be interesting to consider other use-cases where the computing is spread within the network.
Another example could then be “Interconnected Quantum Computers”.
Indeed, the charter of QIRG mentions an architectural framework to support a first step toward a quantum network architecture [https://datatracker.ietf.org/rg/qirg/about/].

I hope this helps,
Kind regards,

Nicolas

--
Coin mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf..org/mailman/listinfo/coin<https://www.irtf.org/mailman/listinfo/coin>

---

From: "Hejianfei (Jeffrey)" <[email-masked]>
Date: Tue, 26 Nov 2019 04:12:22 +0000

Hi Wojtek and Nicolas ,
Thanks for raising this topic. And the QIRG architecture draft is a very good introduction for me, one without any quantum background. I have a question after reading it.
It seems to me what you need for the control plane (which is built above the classical channels) is a signaling mechanism to  reserve the resource on quantum repeater/routers along a path, as the arch draft mentioned in section5.2.
The challenge in the first item in section 5.1 ( “no headers”) reminds me the similarity to all-optical networks, particularly the Optical Burst Switch(OBS), which is also separating the control plane from the data plane, doesn’t rely on processing headers in data (bursts), and try to reduce the requirement of buffer(optical buffer is non-trivial). This paper below may provide some information how OBS handle their reservations :Just-in-time, Just-enough-time et. My understanding is that the basic idea is to send a message at the control plane ahead of the data burst to reserve the resource before the real data arrives. I have to also mention that OBS hasn’t been deployed in real networks(as far as I know), although there were many research and some prototypes in the optical community back to nearly 20 years ago.
(https://rouskas.csc.ncsu.edu/Publications/Conferences/WOBS-Teng-2003.pdf)
Maybe I am wrong, you are exploring something more than resource reservation?
Cheers,
Jeffrey
发件人: Coin [mailto:[email-masked]] 代表 Wojciech Kozlowski
发送时间: 2019年11月25日 21:05
收件人: [email-masked]
主题: Re: [Coin] COINRG and QIR : interaction for generic architecture of quantum computation node ?

Thanks,
Wojtek

mjm

I hope this helps,
Kind regards,

Nicolas

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Mon, 25 Nov 2019 23:24:09 -0800

I actually had a slightly different take more in the sense of what Quantum
could do to help computing in the network in terms of fast route/re-route
decision in complex interconnected topologies base don localized criteria
and the use of strong encryption/fast decrytption on a path.

SoI can see reasons to communicate...

On November 26, 2019 at 5:12:37 AM, Hejianfei (Jeffrey) (
[email-masked]) wrote:

Hi Wojtek and Nicolas ,

Thanks for raising this topic. And the QIRG architecture draft is a very
good introduction for me, one without any quantum background. I have a
question after reading it.

It seems to me what you need for the control plane (which is built above
the classical channels) is a signaling mechanism to  reserve the resource
on quantum repeater/routers along a path, as the arch draft mentioned in
section5.2.

The challenge in the first item in section 5.1 ( “no headers”) reminds me
the similarity to all-optical networks, particularly the Optical Burst
Switch(OBS), which is also separating the control plane from the data
plane, doesn’t rely on processing headers in data (bursts), and try to
reduce the requirement of buffer(optical buffer is non-trivial). This paper
below may provide some information how OBS handle their reservations
:Just-in-time, Just-enough-time et. My understanding is that the basic idea
is to send a message at the control plane ahead of the data burst to
reserve the resource before the real data arrives. I have to also mention
that OBS hasn’t been deployed in real networks(as far as I know), although
there were many research and some prototypes in the optical community back
to nearly 20 years ago.

Maybe I am wrong, you are exploring something more than resource
reservation?

Cheers,

Jeffrey

*发件人**:* Coin [mailto:[email-masked]] *代表 *Wojciech Kozlowski
*发送时间:* 2019年11月25日 21:05
*收件人:* [email-masked]
*主题:* Re: [Coin] COINRG and QIR : interaction for generic architecture of
quantum computation node ?

Following a mention of COIN at the QIRG meeting I attended the meeting on
Friday and I do think there is definitely at least some scope for initial
exploration. However, I am new to COIN so please forgive me any obvious
blunders in the technical matters.

I picked up an interest in COIN, because one of the problems of developing
an architectural model for a quantum network is that the stateless packet
processing model just does not apply when you have to deal with certain
quantum phenomena such as entanglement where you have a pair of qubits on
two different physical devices yet they share state information which must
be tracked by the network. Rodney Van Meter who is a co-chair of QIRG and
published a lot of early work on this topic often suggests that quantum
networking is a form of distributed computation. Furthermore, quantum
networks (at least the near-term realisations) will be incredibly
time-sensitive - latency will matter _a lot_ - so I was interested to see
that one of the driving factors for COIN is reducing the latency.

Quantum networking will have a significant non-quantum processing component
which will involve local processing and networked communication with other
nodes. This has caused me some trouble in my own research when trying to
apply the conventional notion of data and control planes to the problem.
Perhaps computation in the network might end up being one way of looking at
this problem. I have even been exploring using P4 for quantum "data planes"
(but more from the SDN and central controller approach) which would open up
a practical way of adding computation in the network to quantum nodes.

This is a line of thinking I would like to explore and I'm sure it would be
of interest to some in the QIRG. If the people at COINRG are interested and
think it's relevant there might be some scope to move forward on this topic.

Thanks,

Wojtek

PS For curious readers: we are currently working on a "Architectural
Principles of a Quantum Internet" draft which will serve as an introduction
for networking people with no quantum background to the subject of quantum
networking (for a quick look into the challenges involved that might be
addressed with COIN see sections 4.1 and 5.1).

Thanks.

mjm

[email-masked]

Hi all,

I hope this helps,

Kind regards,

Nicolas

-- 
Coin mailing list
[email-masked]
https://www.irtf..org/mailman/listinfo/coin
<https://www.irtf.org/mailman/listinfo/coin>