Subject: [Coin] Hackaton

From: Marie-Jose Montpetit <[email-masked]>
Date: Mon, 11 Nov 2019 11:10:55 +0000

Some notes about the P4 (Programming Protocol-independent Packet Processors)

Here are the links to the P4 material we used in Montreal:
https://github.com/p4lang/tutorials

In particular look at the  *Obtaining required software* section to setup
your environment.
Printing the cheat sheet could also be a good idea:
https://drive.google.com/file/d/1Z8woKyElFAOP6bMd8tRa_Q4SA1cd_Uva/view

This reference to the language is also interesting:
https://github.com/p4lang/education/blob/master/GettingStarted.md

Look into P4 14 (as mentioned at the interim) for some available tools at
the hackaton or 16.
This page also has a list of *Code Examples.*

There will be *no tech support* this time but I hope some people from
Montreal will be there to help newcomers. For those more advanced the
“initial group project” is a packet filtering application to identify
packets based on a specific criterion.

There is a slack channel if people want to connect remotely:
coinrg.slack.com

Montreal participants: chime in for ideas and suggestions to the newcomers.

CU Saturday and have safe trips to Singapore.

mjm

Marie-José Montpetit, Ph.D.
Research Affiliate, MIT Media Laboratory
[email-masked]
[email-masked]

---

From: "Schooler, Eve M" <[email-masked]>
Date: Fri, 15 Nov 2019 00:07:38 +0000

Hi All,

At the last Hackathon there was some terrific work on implementing match-action functions in P4.
These largely performed functions on single streams of data.

One thought I had for a longer-term Hackathon goal is if we can create and demonstrate good examples of group-oriented match-action functions?
This question is motivated by the upstream nature of data flows at the IoT Edge, particularly visual data flows, as they meet up or converge at various points in the network.
Flows of this nature have been captured in at least one draft that discusses Extended Reality<https://datatracker.ietf.org/doc/draft-montpetit-coin-xr/>, and there have been COIN presentations on the Ubiquitous Witness use case<https://trac.ietf.org/trac/irtf/raw-attachment/wiki/coin/COIN%20-%20Use%20Case%20discussion%20-%202018-11-08.pdf> and Cascading Video<https://datatracker.ietf.org/meeting/105/materials/slides-105-coinrg-5-jiang-video-analytics-and--coin-01>.

In some cases, multiple contextually-related streams pass through/converge/implode on network elements (switches, routers, access points, etc) as they flow upstream. As they pass through these boxes, can we perform some kind of collective computation on them before forwarding the (potentially new) stream onwards?

For example, in the Ubiquitous Witness use case, multiple cameras in a Smart City capture and send video streams of an anomaly that has occurred (e.g., a car crash in an intersection). Each stream contains video frames from a different perspective and that relate to a specific point in time (at the moment the accident occurred, give or take a few milliseconds) and space (within some short distance around the intersection). I’d like the network box receiving those streams to perform some functions on those related data flows. The function could be simply to identify what “contextually-related” means for the use case at hand. Another function could be to identify which is the “best” stream to store as evidence, or it could be to identify “the top 10 streams” to “stitch” together into an immersive MPEG-I 360-degree view of the intersection or etc. Although this example highlights video data flows, the contextually-related streams can live in the video or non-video realm.

Thoughts?
Eve

From: Marie-Jose Montpetit [mailto:[email-masked]]
Sent: Monday, November 11, 2019 3:11 AM
To: [email-masked]
Cc: [email-masked]
Subject: Hackaton

In particular look at the  Obtaining required software section to setup your environment.
Printing the cheat sheet could also be a good idea:
https://drive.google.com/file/d/1Z8woKyElFAOP6bMd8tRa_Q4SA1cd_Uva/view

Look into P4 14 (as mentioned at the interim) for some available tools at the hackaton or 16.
This page also has a list of Code Examples.

There will be no tech support this time but I hope some people from Montreal will be there to help newcomers. For those more advanced the “initial group project” is a packet filtering application to identify packets based on a specific criterion.

There is a slack channel if people want to connect remotely:
coinrg.slack.com<http://coinrg.slack.com>

mjm

Marie-José Montpetit, Ph.D.
Research Affiliate, MIT Media Laboratory
[email-masked]<mailto:[email-masked]>
[email-masked]<mailto:[email-masked]>

---

From: <[email-masked]>
Date: Sat, 16 Nov 2019 11:30:01 +0530

Please see in line below.

From: Coin <[email-masked]> On Behalf Of Schooler, Eve M
Sent: Friday, November 15, 2019 5:38 AM
To: [email-masked]
Cc: [email-masked]; Schooler, Eve M <[email-masked]>; [email-masked]; Marie-Jose Montpetit <[email-masked]>
Subject: Re: [Coin] Hackaton

Hi All, 

Not sure what is group oriented.  You could use multiple actions in P4 bound to the same action.  

Flows of this nature have been captured in at least one draft that discusses Extended Reality <https://datatracker.ietf.org/doc/draft-montpetit-coin-xr/> , and there have been COIN presentations on the Ubiquitous Witness use case <https://trac.ietf.org/trac/irtf/raw-attachment/wiki/coin/COIN%20-%20Use%20Case%20discussion%20-%202018-11-08.pdf>  and Cascading Video <https://datatracker.ietf.org/meeting/105/materials/slides-105-coinrg-5-jiang-video-analytics-and--coin-01> .

Video processing involves floating point computation and division (percentage).  A switching data plane does not support floating point computation.  One would have to quantize the data first.  P4 does not support division used by percentage.  In regards to top 10 streams, one could use elephant vs. mice flow detection which uses hashes.  Just change the rate metric of elephant flow to another metric.  <https://web.stanford.edu/~balaji/papers/07elephanttrap.pdf> https://web.stanford.edu/~balaji/papers/07elephanttrap.pdf

Reasonable plan.  Details such as what is context, metric for “best”, etc. need working out.

Hemant

Thoughts?

Eve

From: Marie-Jose Montpetit [mailto:[email-masked]] 
Sent: Monday, November 11, 2019 3:11 AM
To: [email-masked] <mailto:[email-masked]> 
Cc: [email-masked] <mailto:[email-masked]> 
Subject: Hackaton 

coinrg.slack.com <http://coinrg.slack.com> 

 

mjm

[email-masked] <mailto:[email-masked]> 

[email-masked] <mailto:[email-masked]>