Subject: [Coin] COIN activities update

From: Marie-Jose Montpetit <[email-masked]>
Date: Wed, 2 Sep 2020 06:09:37 -0700

Hello everyone and welcome to September!

Some group maintenance and announcements to start the last months of the
year (annus horribilis 2020).

*Documents*

At the IRTF meeting we had discussed accepting some documents as RG
documents. At that moment we had suggested:
The directions draft:
https://datatracker.ietf.org/doc/draft-kutscher-coinrg-dir/
and the industrial use cases
https://tools.ietf.org/html/draft-kunze-coin-industrial-use-cases-02
If anyone has an objection please tell usb the end of this week (Sept. 4
EOB Pacific) if not we will go ahead.

We also believe the app centre draft is also very mature
https://tools.ietf.org/html/draft-sarathchandra-coin-appcentres-01 and we
could accept it at our next meeting.

And of course there is the discovery draft has also been going though a
number of revisions
https://datatracker.ietf.org/doc/draft-mcbride-edge-data-discovery-overview/
:
which raised the discussion topic of “in-network” vs. “on-network” and we
suppose the reach of computing in the network, a great discussion topic to
prepare for our next meetings and milestone updates. There are now 3
discovery draft and we welcome a discussion on maybe consolidating them.

*Relevant conferences and bibliography:*

We plan to update the wiki with related conferences (like the up coming
European P4 Workshop and ICIN2021) and an “living” bibiography. I wrote a
book chapter and I have more than 100 related references so I will update
the wiki and the GitHub this week but you are welcome to edit and/or email
with other titles after.

*Next meetings:*

We plan to have 2 interims instead of a single November meeting in the
October and then Dec. or January timeframe so we are less time-constrained.
We would like:
- the first to be dedicated to academic talks and plan to invite some of
the Sigcomm authors and speakers as well as prominent researchers
- the second for document maintenance, new work and milestones.
We also need to decide about the hackaton so feel free to chime in. And
stay tuned for next emails and proposed dates.

We hope you and yours are safe and healthy.

J/E/M

p.s. please join Eve and I in congratulating Jeff for going to back to
academia and to soon become Dr. J (sounds like a rap star!).

Marie-José Montpetit, Ph.D.
[email-masked]

---

From: Dirk Trossen <[email-masked]>
Date: Mon, 7 Sep 2020 13:36:37 +0000

Hi Marie-Jose, all,

Thanks for the update on the activities. As for the RG adoption, I’m certainly supporting the adoption of the directions and industrial use case drafts.

As for the app centre draft, I wanted to note that  V2 of that draft (https://tools.ietf.org/html/draft-sarathchandra-coin-appcentres-02) just expired but we are planning an update, focused on Section 4 (in the update from v1 to v2, we updated the use cases and added requirements). Of course, an adoption of this draft is something I would support as a co-author but I wanted to also give an update on plans since there were reasons for the delay in update which let the V2 draft lapse, but it was not abandoned.

Best,

Dirk

From: Coin [mailto:[email-masked]] On Behalf Of Marie-Jose Montpetit
Sent: 02 September 2020 15:10
To: [email-masked]
Cc: [email-masked]
Subject: [Coin] COIN activities update

Some group maintenance and announcements to start the last months of the year (annus horribilis 2020).

Documents

At the IRTF meeting we had discussed accepting some documents as RG documents. At that moment we had suggested:
The directions draft: https://datatracker.ietf.org/doc/draft-kutscher-coinrg-dir/
and the industrial use cases https://tools.ietf.org/html/draft-kunze-coin-industrial-use-cases-02
If anyone has an objection please tell usb the end of this week (Sept. 4 EOB Pacific) if not we will go ahead.

We also believe the app centre draft is also very mature https://tools.ietf.org/html/draft-sarathchandra-coin-appcentres-01 and we could accept it at our next meeting.

And of course there is the discovery draft has also been going though a number of revisions https://datatracker.ietf.org/doc/draft-mcbride-edge-data-discovery-overview/:
which raised the discussion topic of “in-network” vs. “on-network” and we suppose the reach of computing in the network, a great discussion topic to prepare for our next meetings and milestone updates. There are now 3 discovery draft and we welcome a discussion on maybe consolidating them.

Relevant conferences and bibliography:

We plan to update the wiki with related conferences (like the up coming European P4 Workshop and ICIN2021) and an “living” bibiography. I wrote a book chapter and I have more than 100 related references so I will update the wiki and the GitHub this week but you are welcome to edit and/or email with other titles after.

Next meetings:

We plan to have 2 interims instead of a single November meeting in the October and then Dec. or January timeframe so we are less time-constrained. We would like:
- the first to be dedicated to academic talks and plan to invite some of the Sigcomm authors and speakers as well as prominent researchers
- the second for document maintenance, new work and milestones.
We also need to decide about the hackaton so feel free to chime in. And stay tuned for next emails and proposed dates.

J/E/M

p.s. please join Eve and I in congratulating Jeff for going to back to academia and to soon become Dr. J (sounds like a rap star!).

Marie-José Montpetit, Ph.D.
[email-masked]<mailto:[email-masked]>

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Mon, 7 Sep 2020 06:40:44 -0700

Thanks. We will wait for the updates and discuss at the interim(s).

mjm

On September 7, 2020 at 9:36:38 AM, Dirk Trossen ([email-masked])
wrote:

Hi Marie-Jose, all,

Thanks for the update on the activities. As for the RG adoption, I’m
certainly supporting the adoption of the directions and industrial use case
drafts.

As for the app centre draft, I wanted to note that  V2 of that draft (
https://tools.ietf.org/html/draft-sarathchandra-coin-appcentres-02) just
expired but we are planning an update, focused on Section 4 (in the update
from v1 to v2, we updated the use cases and added requirements). Of course,
an adoption of this draft is something I would support as a co-author but I
wanted to also give an update on plans since there were reasons for the
delay in update which let the V2 draft lapse, but it was not abandoned.

Best,

Dirk

*From:* Coin [mailto:[email-masked]] *On Behalf Of *Marie-Jose
Montpetit
*Sent:* 02 September 2020 15:10
*To:* [email-masked]
*Cc:* [email-masked]
*Subject:* [Coin] COIN activities update

*Documents*

The directions draft:

*Next meetings:*

J/E/M

[email-masked]