Subject: Re: [Coin] COIN activities update

From: Dirk Trossen <[email-masked]>
Date: Thu, 1 Oct 2020 09:45:23 +0000

Hi Marie-Jose, all,

In addition to the support for adopting the suggested drafts as RG ones, I was wondering for the industrial use cases one if we could widen the scope towards a document that represents a number of use case areas, not just industrial specifically? For instance, I’m thinking of use cases we are describing in the micro-service draft, currently captured in a separate section. Moving those to an RG-wide use case draft would allow for reference a single (RG) document.

I had thought of linking to some of the industrial ones already but instead thought suggesting the scope widening for the draft might be a good first step.

I would be interested to hear what the RG as well as authors, of course, of the draft think of that.

Best,

Dirk

From: Marie-Jose Montpetit [mailto:[email-masked]]
Sent: 07 September 2020 15:41
To: [email-masked]; Dirk Trossen <[email-masked]>
Cc: [email-masked]
Subject: RE: [Coin] COIN activities update

Thanks. We will wait for the updates and discuss at the interim(s).

mjm

Marie-José Montpetit, Ph.D.
[email-masked]<mailto:[email-masked]>

On September 7, 2020 at 9:36:38 AM, Dirk Trossen ([email-masked]<mailto:[email-masked]>) wrote:
Hi Marie-Jose, all,

Thanks for the update on the activities. As for the RG adoption, I’m certainly supporting the adoption of the directions and industrial use case drafts.

As for the app centre draft, I wanted to note that  V2 of that draft (https://tools.ietf.org/html/draft-sarathchandra-coin-appcentres-02) just expired but we are planning an update, focused on Section 4 (in the update from v1 to v2, we updated the use cases and added requirements). Of course, an adoption of this draft is something I would support as a co-author but I wanted to also give an update on plans since there were reasons for the delay in update which let the V2 draft lapse, but it was not abandoned.

Best,

Dirk

From: Coin [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Marie-Jose Montpetit
Sent: 02 September 2020 15:10
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [Coin] COIN activities update

Hello everyone and welcome to September!

Some group maintenance and announcements to start the last months of the year (annus horribilis 2020).

Documents

At the IRTF meeting we had discussed accepting some documents as RG documents. At that moment we had suggested:
The directions draft: https://datatracker.ietf.org/doc/draft-kutscher-coinrg-dir/
and the industrial use cases https://tools.ietf.org/html/draft-kunze-coin-industrial-use-cases-02
If anyone has an objection please tell usb the end of this week (Sept. 4 EOB Pacific) if not we will go ahead.

We also believe the app centre draft is also very mature https://tools.ietf.org/html/draft-sarathchandra-coin-appcentres-01 and we could accept it at our next meeting.

And of course there is the discovery draft has also been going though a number of revisions https://datatracker.ietf.org/doc/draft-mcbride-edge-data-discovery-overview/:
which raised the discussion topic of “in-network” vs. “on-network” and we suppose the reach of computing in the network, a great discussion topic to prepare for our next meetings and milestone updates. There are now 3 discovery draft and we welcome a discussion on maybe consolidating them.

Relevant conferences and bibliography:

We plan to update the wiki with related conferences (like the up coming European P4 Workshop and ICIN2021) and an “living” bibiography. I wrote a book chapter and I have more than 100 related references so I will update the wiki and the GitHub this week but you are welcome to edit and/or email with other titles after.

Next meetings:

We plan to have 2 interims instead of a single November meeting in the October and then Dec. or January timeframe so we are less time-constrained. We would like:
- the first to be dedicated to academic talks and plan to invite some of the Sigcomm authors and speakers as well as prominent researchers
- the second for document maintenance, new work and milestones.
We also need to decide about the hackaton so feel free to chime in. And stay tuned for next emails and proposed dates.

We hope you and yours are safe and healthy.

J/E/M

p.s. please join Eve and I in congratulating Jeff for going to back to academia and to soon become Dr. J (sounds like a rap star!).

Marie-José Montpetit, Ph.D.
[email-masked]<mailto:[email-masked]>

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Thu, 1 Oct 2020 04:21:48 -0700

Seems like a good idea. Use cases are are on our list of milestones :)

[email-masked]

On October 1, 2020 at 5:45:25 AM, Dirk Trossen ([email-masked])
wrote:

Hi Marie-Jose, all,

In addition to the support for adopting the suggested drafts as RG ones, I
was wondering for the industrial use cases one if we could widen the scope
towards a document that represents a number of use case areas, not just
industrial specifically? For instance, I’m thinking of use cases we are
describing in the micro-service draft, currently captured in a separate
section. Moving those to an RG-wide use case draft would allow for
reference a single (RG) document.

I had thought of linking to some of the industrial ones already but instead
thought suggesting the scope widening for the draft might be a good first
step.

I would be interested to hear what the RG as well as authors, of course, of
the draft think of that.

Best,

Dirk

*From:* Marie-Jose Montpetit [mailto:[email-masked]]
*Sent:* 07 September 2020 15:41
*To:* [email-masked]; Dirk Trossen <[email-masked]>
*Cc:* [email-masked]
*Subject:* RE: [Coin] COIN activities update

mjm

[email-masked]

On September 7, 2020 at 9:36:38 AM, Dirk Trossen ([email-masked])
wrote:

Hi Marie-Jose, all,

Thanks for the update on the activities. As for the RG adoption, I’m
certainly supporting the adoption of the directions and industrial use case
drafts.

As for the app centre draft, I wanted to note that  V2 of that draft (
https://tools.ietf.org/html/draft-sarathchandra-coin-appcentres-02) just
expired but we are planning an update, focused on Section 4 (in the update
from v1 to v2, we updated the use cases and added requirements). Of course,
an adoption of this draft is something I would support as a co-author but I
wanted to also give an update on plans since there were reasons for the
delay in update which let the V2 draft lapse, but it was not abandoned.

Best,

Dirk

*From:* Coin [mailto:[email-masked]] *On Behalf Of *Marie-Jose
Montpetit
*Sent:* 02 September 2020 15:10
*To:* [email-masked]
*Cc:* [email-masked]
*Subject:* [Coin] COIN activities update

Some group maintenance and announcements to start the last months of the
year (annus horribilis 2020).

*Documents*

At the IRTF meeting we had discussed accepting some documents as RG
documents. At that moment we had suggested:

The directions draft:
https://datatracker.ietf.org/doc/draft-kutscher-coinrg-dir/

and the industrial use cases
https://tools.ietf.org/html/draft-kunze-coin-industrial-use-cases-02

If anyone has an objection please tell usb the end of this week (Sept. 4
EOB Pacific) if not we will go ahead.

We also believe the app centre draft is also very mature
https://tools.ietf.org/html/draft-sarathchandra-coin-appcentres-01 and we
could accept it at our next meeting.

And of course there is the discovery draft has also been going though a
number of revisions
https://datatracker.ietf.org/doc/draft-mcbride-edge-data-discovery-overview/
:

which raised the discussion topic of “in-network” vs. “on-network” and we
suppose the reach of computing in the network, a great discussion topic to
prepare for our next meetings and milestone updates. There are now 3
discovery draft and we welcome a discussion on maybe consolidating them.

*Relevant conferences and bibliography:*

We plan to update the wiki with related conferences (like the up coming
European P4 Workshop and ICIN2021) and an “living” bibiography. I wrote a
book chapter and I have more than 100 related references so I will update
the wiki and the GitHub this week but you are welcome to edit and/or email
with other titles after.

*Next meetings:*

We plan to have 2 interims instead of a single November meeting in the
October and then Dec. or January timeframe so we are less time-constrained.
We would like:

- the first to be dedicated to academic talks and plan to invite some of
the Sigcomm authors and speakers as well as prominent researchers

We also need to decide about the hackaton so feel free to chime in. And
stay tuned for next emails and proposed dates.

J/E/M

p.s. please join Eve and I in congratulating Jeff for going to back to
academia and to soon become Dr. J (sounds like a rap star!).

[email-masked]

---

From: Ike Kunze <[email-masked]>
Date: Thu, 1 Oct 2020 11:56:17 +0000

Hi all,

as I said during our last meeting, I definitely support efforts that intend to create a common basis for the RG.
In this context, I think that widening the scope from industrial use cases to use cases in general could make sense.
However, in my opinion, we have to make sure that we keep a common level of abstraction for all use cases, but that should be possible.

If there are no objections to Dirk’s proposal, I would try to prepare our draft accordingly for IETF-109.
I will also open up the sources so that everyone can contribute as soon as I find the time for that.

@all:
Which other use cases should we include in the draft?
Any proposals and/or volunteers to work on including them? :)

Best,
Ike

On 1. Oct 2020, at 13:21, Marie-Jose Montpetit <[email-masked]<mailto:[email-masked]>> wrote:

On October 1, 2020 at 5:45:25 AM, Dirk Trossen ([email-masked]<mailto:[email-masked]>) wrote:
Hi Marie-Jose, all,

Best,

Dirk

From: Marie-Jose Montpetit [mailto:[email-masked]<mailto:[email-masked]>]
Sent: 07 September 2020 15:41
To: [email-masked]<mailto:[email-masked]>; Dirk Trossen <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [Coin] COIN activities update

mjm

Best,

Dirk

Documents

Next meetings:

J/E/M

--
Coin mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/coin

---

From: Dirk Trossen <[email-masked]>
Date: Thu, 1 Oct 2020 13:58:18 +0000

Hi Ike, all,

Great to see your support. Please see more comments inline.

Best,

Dirk

From: Coin [mailto:[email-masked]] On Behalf Of Ike Kunze
Sent: 01 October 2020 13:56
To: Marie-Jose Montpetit <[email-masked]>
Cc: Dirk Trossen <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [Coin] COIN activities update

Hi all,

as I said during our last meeting, I definitely support efforts that intend to create a common basis for the RG.
In this context, I think that widening the scope from industrial use cases to use cases in general could make sense.
However, in my opinion, we have to make sure that we keep a common level of abstraction for all use cases, but that should be possible.
[DOT] I’m not entirely sure what ‘common level of abstraction’ you mean. If you are thinking of some form of ‘taxonomy’ for those use cases then that’s absolutely something I would support. In fact, to me, that’s the work to be done in the draft beyond just ‘putting some use cases in a text’.

If there are no objections to Dirk’s proposal, I would try to prepare our draft accordingly for IETF-109.
[DOT] Please let me know if I can be of any help, particularly in the taxonomy structuring.  If you indeed plan on making those changes for IETF109, I would happily align the app-centric micro-services draft with this by moving those use cases out into the revised use case draft and refer to the revised draft instead. But we can coordinate that then.

@all:
Which other use cases should we include in the draft?
Any proposals and/or volunteers to work on including them? :)
[DOT] See above for my volunteering on this ;-) but happy to see others for sure.

Best,
Ike

Best,

Dirk

mjm

Best,

Dirk

Documents

Next meetings:

J/E/M

---

From: Ike Kunze <[email-masked]>
Date: Fri, 2 Oct 2020 14:29:34 +0000

Hi Dirk, all,

I actually meant something else, but setting up a taxonomy sounds like the right thing to do.
Would be really interesting to see which other use cases we have to include, though :)

Anyways: I have set up a public repository (https://github.com/ike-kunze/coin-use-cases), so feel free to contribute.
I will probably start restructuring the draft next week if time permits.

Best,
Ike
On 1. Oct 2020, at 15:58, Dirk Trossen <[email-masked]<mailto:[email-masked]>> wrote:

Hi Ike, all,

Best,

Dirk

From: Coin [mailto:[email-masked]] On Behalf Of Ike Kunze
Sent: 01 October 2020 13:56
To: Marie-Jose Montpetit <[email-masked]<mailto:[email-masked]>>
Cc: Dirk Trossen <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Coin] COIN activities update

Hi all,

@all:

Best,
Ike

Hi Marie-Jose, all,

Best,

Dirk

mjm

Hi Marie-Jose, all,

Best,

Dirk

Documents

Next meetings:

J/E/M

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Fri, 2 Oct 2020 14:47:36 +0000

Ike: we have a COIN GitHub account.
https://github.com/irtf-coinrg/rg-materials

This is where the use cases should go.

mjm

On October 2, 2020 at 10:29:37 AM, Ike Kunze (
[email-masked]) wrote:

Hi Dirk, all,

I actually meant something else, but setting up a taxonomy sounds like the
right thing to do.
Would be really interesting to see which other use cases we have to
include, though :)

Anyways: I have set up a public repository (
https://github.com/ike-kunze/coin-use-cases), so feel free to contribute.
I will probably start restructuring the draft next week if time permits.

Best,
Ike

On 1. Oct 2020, at 15:58, Dirk Trossen <[email-masked]> wrote:

Hi Ike, all,

Best,

Dirk

*From:* Coin [mailto:[email-masked] <[email-masked]>] *On
Behalf Of *Ike Kunze
*Sent:* 01 October 2020 13:56
*To:* Marie-Jose Montpetit <[email-masked]>
*Cc:* Dirk Trossen <[email-masked]>; [email-masked];
[email-masked]
*Subject:* Re: [Coin] COIN activities update

Hi all,

as I said during our last meeting, I definitely support efforts that intend
to create a common basis for the RG.
In this context, I think that widening the scope from industrial use cases
to use cases in general could make sense.
However, in my opinion, we have to make sure that we keep a common level of
abstraction for all use cases, but that should be possible.
*[DOT] I’m not entirely sure what ‘common level of abstraction’ you mean.
If you are thinking of some form of ‘taxonomy’ for those use cases then
that’s absolutely something I would support. In fact, to me, that’s the
work to be done in the draft beyond just ‘putting some use cases in a
text’.*

If there are no objections to Dirk’s proposal, I would try to prepare our
draft accordingly for IETF-109.
*[DOT] Please let me know if I can be of any help, particularly in the
taxonomy structuring.  If you indeed plan on making those changes for
IETF109, I would happily align the app-centric micro-services draft with
this by moving those use cases out into the revised use case draft and
refer to the revised draft instead. But we can coordinate that then.*

I will also open up the sources so that everyone can contribute as soon as
I find the time for that.

@all:
Which other use cases should we include in the draft?
Any proposals and/or volunteers to work on including them? :)
*[DOT] See above for my volunteering on this ;-) but happy to see others
for sure.*

Best,
Ike

On 1. Oct 2020, at 13:21, Marie-Jose Montpetit <[email-masked]>
wrote:

Hi Marie-Jose, all,

Best,

Dirk

mjm

Hi Marie-Jose, all,

Best,

Dirk

*Documents*

*Next meetings:*

J/E/M

-- 
Coin mailing list
[email-masked]

---

From: Xavier de Foy <[email-masked]>
Date: Mon, 26 Oct 2020 15:04:36 -0400

Hi Marie-José, all,

number of revisions

  Thanks for initiating the discussion. In the hope of contributing to it,
here is a set of simplified discovery scenarios (at least as a starting
point, please feel free to update it). I think drafts [1][2] cover
scenarios (a) and (b), and [3] covers (d). A goal is to frame the discovery
scenarios in the context of COIN.

  The scenarios involve a "COIN network" (which, based my understanding of
the charter, would be made of distributed/decentralized "COIN nodes"
providing a computing service integrated with network/transport layers),
and endpoints (non-COIN nodes, e.g. COIN network users or external data
sources).

  a. A COIN node discovers a data source (COIN node or endpoint), for the
purpose of influencing COIN network operation (e.g. code placement, request
routing, input for computation). Data discovery information may be further
disseminated between COIN nodes. In a related scenario a COIN node
discovers an external network function (e.g. SFC node), for the purpose of
using the service, influencing request routing, and placing the code that
uses the service.

  b. A COIN node discovers computing/storage resources, for the purpose of
creating/instantiating new COIN nodes.

  c. A COIN node discovers another COIN node (that belongs to a different
domain), for the purpose of interfacing 2 different COIN networks.

  d. An endpoint or COIN node (which can be multihomed) discovers a COIN
network entry point, for the purpose of connecting to it (e.g., as a user,
or to join a COIN network). As a variant for wireless devices, mobile
endpoints may need to determine which AP to attach to, in order to access a
COIN network entry point.

  To come back to the consolidation discussion, would the RG community be
willing to work on a document covering all or some scenarios listed here?

  Best Regards,

Xavier.

[1] draft-mcbride-edge-data-discovery-overview
[2] draft-mcbride-data-discovery-problem-statement
[3] draft-defoy-coinrg-mobile-discovery

---

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Wed, 28 Oct 2020 08:02:37 +0000

Hi Xavier, all,

Apologies if my comments are out of scope as I'm not so up-to-date with the status of COIN technical work / terminology.

I think the examples you gave makes sense and could be useful to clarify of how various operations/flows could work.

Two comments:

  1.  What strikes me when reading the text is the reference to "COIN node" and "COIN network". Are these really necessary/useful terms?
I mean, I could map the examples you describe (partially or fully) to different existing technologies/operations. I find that adding the "COIN stuff" may shift the focus away from the genuine technical problem to solve by giving a false impression that the "COIN xyz" are sketching a different case. Reading your examples without the COIN-related terms, the sentences are still very valid. So, I guess the technical problem/solution to address is situated at another level, i.e. what is not working as you expect it or what would like to enable (in a COIN-like framework) that would be (solved) differently. I think this should be the core/focus of the examples.

  1.  COIN being a RG, I would advise to carefully position the below examples wrt. state of the art, and outline what/where the proposal is proposing new (research) things. Again, on the examples, most, if not all of the pieces/functions could be mapped to existing technologies/protocols. Can we pinpoint more specifically the technical propositions of COIN in these contexts?

Please don't take my comments negatively, I'm just trying to get to the core of the issues here; and I think COIN has good potential to deliver compelling research.

Best regards,
Laurent

From: Coin <[email-masked]> On Behalf Of Xavier de Foy
Sent: Monday, October 26, 2020 20:05
To: Marie-Jose Montpetit <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [Coin] COIN activities update

Hi Marie-José, all,

> which raised the discussion topic of “in-network” vs. “on-network” and we suppose the reach of computing in the network, a great discussion topic to prepare for our next meetings and milestone upda…

  Thanks for initiating the discussion. In the hope of contributing to it, here is a set of simplified discovery scenarios (at least as a starting point, please feel free to update it). I think drafts [1][2] cover scenarios (a) and (b), and [3] covers (d). A goal is to frame the discovery scenarios in the context of COIN.

  The scenarios involve a "COIN network" (which, based my understanding of the charter, would be made of distributed/decentralized "COIN nodes" providing a computing service integrated with network/transport layers), and endpoints (non-COIN nodes, e.g. COIN network users or external data sources).

  a. A COIN node discovers a data source (COIN node or endpoint), for the purpose of influencing COIN network operation (e.g. code placement, request routing, input for computation). Data discovery information may be further disseminated between COIN nodes. In a related scenario a COIN node discovers an external network function (e.g. SFC node), for the purpose of using the service, influencing request routing, and placing the code that uses the service.

  b. A COIN node discovers computing/storage resources, for the purpose of creating/instantiating new COIN nodes.

  c. A COIN node discovers another COIN node (that belongs to a different domain), for the purpose of interfacing 2 different COIN networks.

  d. An endpoint or COIN node (which can be multihomed) discovers a COIN network entry point, for the purpose of connecting to it (e.g., as a user, or to join a COIN network). As a variant for wireless devices, mobile endpoints may need to determine which AP to attach to, in order to access a COIN network entry point.

  To come back to the consolidation discussion, would the RG community be willing to work on a document covering all or some scenarios listed here?

  Best Regards,

Xavier.

---

From: Xavier de Foy <[email-masked]>
Date: Wed, 28 Oct 2020 22:58:25 -0400

Hi Laurent,

  Thank you for bringing up those questions.

On Wed, Oct 28, 2020 at 4:02 AM Ciavaglia, Laurent (Nokia -
FR/Paris-Saclay) <[email-masked]> wrote:

> Hi Xavier, all,
>
>
>
> Apologies if my comments are out of scope as I'm not so up-to-date with
> the status of COIN technical work / terminology.
>
>
>
> I think the examples you gave makes sense and could be useful to clarify
> of how various operations/flows could work.
>
>
>
> Two comments:
>
>    1. What strikes me when reading the text is the reference to "COIN
>    node" and "COIN network". Are these really necessary/useful terms
>
>
To give some context, a discussion on whether discovery is within the scope
of COIN was started in IETF 108 and never resolved. This email was an
attempt to move this forward. The scenarios were my interpretation of how
(data/resource/service) discovery would be used in the context of COIN.

> I mean, I could map the examples you describe (partially or fully) to
> different existing technologies/operations. I find that adding the "COIN
> stuff" may shift the focus away from the genuine technical problem to solve
> by giving a false impression that the "COIN xyz" are sketching a different
> case. Reading your examples without the COIN-related terms, the sentences
> are still very valid. So, I guess the technical problem/solution to address
> is situated at another level, i.e. what is not working as you expect it or
> what would like to enable (in a COIN-like framework) that would be (solved)
> differently. I think this should be the core/focus of the examples.
>
>
>

The distributed and local/edge nature of COIN nodes may be a specificity of
those scenarios (in conjunction with other factors like compute/storage
nature of resources, mobile/battery powered nodes in some cases, etc.) So
it's possible that centralized mechanisms are less efficient in this
context, for example. However this view is based on my current
understanding of COIN in charter and "direction" draft, so it may be off or
incomplete.

>
>    1. COIN being a RG, I would advise to carefully position the below
>    examples wrt. state of the art, and outline what/where the proposal is
>    proposing new (research) things. Again, on the examples, most, if not all
>    of the pieces/functions could be mapped to existing technologies/protocols.
>    Can we pinpoint more specifically the technical propositions of COIN in
>    these contexts?
>
>
  Agreed, these examples were adapted (for most of them) from what is
present in the existing drafts, they did not go into the technical
propositions (especially since I was not involved in the data discovery
drafts). Distributed discovery of a COIN network by mobile nodes could be
of interest (as opposed to centralized mechanisms for edge computing
service discovery for example). Also, I think the data discovery overview
draft points towards multiple specific technical propositions.

> Please don't take my comments negatively, I'm just trying to get to the
> core of the issues here; and I think COIN has good potential to deliver
> compelling research.
>
>
>

  Not at all, thanks again for the comments.

> Best regards,
>
> Laurent
>
>
>
> *From:* Coin <[email-masked]> *On Behalf Of *Xavier de Foy
> *Sent:* Monday, October 26, 2020 20:05
> *Cc:* [email-masked]; [email-masked]
>   On Wed, Sep 2, 2020 at 9:09 AM Marie-Jose Montpetit <
> [email-masked]> wrote:
> > which raised the discussion topic of “in-network” vs. “on-network” and
> we suppose the reach of computing in the network, a great discussion topic
> to prepare for our next meetings and milestone updates. There are now 3