Subject: [Coin] Research Assistant / PhD Position at Instituto Superior Técnico - University of Lisbon / INESC-ID

From: Fernando Ramos <[email-masked]>
Date: Mon, 14 Dec 2020 16:31:36 +0000

Are you excited about research at the intersection of programming languages and networked systems? Come join us at the SyNAPSE project, a joint collaboration between Carnegie Mellon University and the Instituto Superior Técnico - University of Lisbon / INESC-ID. The successful candidate will work from INESC-ID in beautiful Lisbon, Portugal and collaborate closely with PIs Justine Sherry, Ruben Martins, Fernando Ramos, and Luis Pedrosa. The project involves building out a synthesis framework that analyzes software network functions and generates accelerated implementations that automatically use smart network devices, including programmable switches and SmartNICs, to increase performance.

We invite applications for a full time research assistant / PhD student position. Full details, including applicable legislation and application procedures are all available in the public notice:
http://www.eracareers.pt/opportunities/index.aspx?task=global&jobId=128985 <http://www.eracareers.pt/opportunities/index.aspx?task=global&jobId=128985>

STARTING DATE: January 2021
DURATION: 6 months, extendable
LOCATION: Lisbon, Portugal
QUALIFICATIONS: Applicant must hold a Master's degree in Computer Science and Engineering or related fields
APPLICATION DEADLINE: 21/December/2020

About Instituto Superior Técnico - University of Lisbon / INESC-ID:
Instituto Superior Técnico (IST), a part of the University of Lisbon, is the leading school of engineering in Portugal and among the ARWU top-20 engineering schools in all of Europe. The school aims to contribute to the development of society, promoting excellence in higher education, in the fields of Architecture, Engineering, Science, and Technology by promoting Research, Development, and Innovation activities.

INESC-ID is an R&D institute dedicated to advanced research and development in the fields of Information Technologies, Electronics, Communications, and Energy, privately owned by IST and INESC. Computer networks research done by faculty and researchers at INESC-ID is ranked among the top-10 in Europe on CSRankings.org <http://csrankings.org/>.

Contact us in case you are interested or want more information.

Luis Pedrosa ([email-masked] <mailto:[email-masked]>)
Fernando Ramos ([email-masked] <mailto:[email-masked]>)

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Mon, 14 Dec 2020 11:02:50 -0600

Thanks Fernando. I would expect your research team will present this
program at one of our upcoming meetings?

mjm

Marie-José Montpetit, Ph.D.
[email-masked]

On December 14, 2020 at 11:31:55 AM, Fernando Ramos (
fvramos=[email-masked]) wrote:

Are you excited about research at the intersection of programming languages
and networked systems? Come join us at the SyNAPSE project, a joint
collaboration between Carnegie Mellon University and the Instituto Superior
Técnico - University of Lisbon / INESC-ID. The successful candidate will
work from INESC-ID in beautiful Lisbon, Portugal and collaborate closely
with PIs Justine Sherry, Ruben Martins, Fernando Ramos, and Luis Pedrosa.
The project involves building out a synthesis framework that analyzes
software network functions and generates accelerated implementations that
automatically use smart network devices, including programmable switches
and SmartNICs, to increase performance.

We invite applications for a full time research assistant / PhD student
position. Full details, including applicable legislation and application
procedures are all available in the public notice:
http://www.eracareers.pt/opportunities/index.aspx?task=global&jobId=128985

STARTING DATE: January 2021
DURATION: 6 months, extendable
LOCATION: Lisbon, Portugal
QUALIFICATIONS: Applicant must hold a Master's degree in Computer Science
and Engineering or related fields
APPLICATION DEADLINE: 21/December/2020

About Instituto Superior Técnico - University of Lisbon / INESC-ID:
Instituto Superior Técnico (IST), a part of the University of Lisbon, is
the leading school of engineering in Portugal and among the ARWU top-20
engineering schools in all of Europe. The school aims to contribute to the
development of society, promoting excellence in higher education, in the
fields of Architecture, Engineering, Science, and Technology by promoting
Research, Development, and Innovation activities.

INESC-ID is an R&D institute dedicated to advanced research and development
in the fields of Information Technologies, Electronics, Communications, and
Energy, privately owned by IST and INESC. Computer networks research done
by faculty and researchers at INESC-ID is ranked among the top-10 in Europe
on CSRankings.org.

Luis Pedrosa ([email-masked])
Fernando Ramos ([email-masked])
-- 
Coin mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/coin

---

From: Fernando Ramos <[email-masked]>
Date: Mon, 14 Dec 2020 17:19:34 +0000

Hi Marie-Jose,

Absolutely! Let us advance a bit, and we’ll surely be very happy to present this work in one of the upcoming meetings.

Best,

Fernando

> On 14 Dec 2020, at 17:02, Marie-Jose Montpetit <[email-masked]> wrote:
> 
> Thanks Fernando. I would expect your research team will present this program at one of our upcoming meetings?
> 
> mjm
> 
> [email-masked] <mailto:[email-masked]>
> 
> 
> 
> On December 14, 2020 at 11:31:55 AM, Fernando Ramos (fvramos=[email-masked] <mailto:fvramos=[email-masked]>) wrote:
> 
>> [email-masked] <mailto:[email-masked]> 
>> https://www.irtf.org/mailman/listinfo/coin <https://www.irtf.org/mailman/listinfo/coin>

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Mon, 14 Dec 2020 11:38:50 -0600

I will pencil you in.

Feliz Natal!

mjm

On December 14, 2020 at 12:19:40 PM, Fernando Ramos (
[email-masked]) wrote:

Hi Marie-Jose,

Absolutely! Let us advance a bit, and we’ll surely be very happy to present
this work in one of the upcoming meetings.

Best,

Fernando

On 14 Dec 2020, at 17:02, Marie-Jose Montpetit <[email-masked]>
wrote:

mjm

on CSRankings.org <http://csrankings.org/>.

---

From: <[email-masked]>
Date: Mon, 14 Dec 2020 13:08:12 -0500

Fernando,

Thanks for sharing.  

The last work in this area was Flightplan from UPenn (https://flightplan.cis.upenn.edu/flightplan.pdf) which I am sorry to say, used a very poor example, for the research.  Duh, a network switch cannot run FEC and compression/decompression in the data plane, so the research said, these features run on FPGA.  Also, the research was headed to a train wreck because the research did not consider that some features of data plane just cannot be split to run elsewhere.  This is why I wrote a new IETF draft and submitted to coinrg.

It would be good to present at least use case which is not obvious and hence research is needed to split the program to run elsewhere.  UPenn uses the preprocessor to split the program.  It would be good to articulate in new research, what would you do differently – use preprocessor or do anything else? Also UPenn splits a P4 program.  It would be good to also mention, if you work with only P4 or are you also considering, say, C, because some data planes are still programmed in C, e.g., Cisco CPP router asic.

Best wishes,

Hemant

From: Coin <[email-masked]> On Behalf Of Fernando Ramos
Sent: Monday, December 14, 2020 12:20 PM
To: Marie-Jose Montpetit <[email-masked]>
Cc: Luis D. Pedrosa <[email-masked]>; [email-masked]
Subject: Re: [Coin] Research Assistant / PhD Position at Instituto Superior Técnico - University of Lisbon / INESC-ID

Hi Marie-Jose,

Best,

Fernando

On 14 Dec 2020, at 17:02, Marie-Jose Montpetit <[email-masked] <mailto:[email-masked]> > wrote:

mjm

 

On December 14, 2020 at 11:31:55 AM, Fernando Ramos (fvramos=[email-masked] <mailto:fvramos=[email-masked]> ) wrote:

We invite applications for a full time research assistant / PhD student position. Full details, including applicable legislation and application procedures are all available in the public notice:
http://www.eracareers.pt/opportunities/index.aspx?task=global <http://www.eracareers.pt/opportunities/index.aspx?task=global&jobId=128985> &jobId=128985

INESC-ID is an R&D institute dedicated to advanced research and development in the fields of Information Technologies, Electronics, Communications, and Energy, privately owned by IST and INESC. Computer networks research done by faculty and researchers at INESC-ID is ranked among the top-10 in Europe on CSRankings.org <http://csrankings.org/> .

Luis Pedrosa ([email-masked] <mailto:[email-masked]> )

Fernando Ramos ([email-masked] <mailto:[email-masked]> )