Subject: [Coin] Survey on P4

From: Michael Menth <[email-masked]>
Date: Tue, 9 Feb 2021 08:18:20 +0100

Hi all,

I'd like to inform you about our survey on network programming using P4.
The work is under submission and my be extended.
https://arxiv.org/pdf/2101.10632.pdf

You can notify me if you have appropriate work which is not yet cited.

Kind regards,

Michael

-- 
Prof. Dr. habil. Michael Menth
University of Tuebingen
Faculty of Science
Department of Computer Science
Chair of Communication Networks
Sand 13, 72076 Tuebingen, Germany
phone: (+49)-7071/29-70505
fax: (+49)-7071/29-5220
mailto:[email-masked]
http://kn.inf.uni-tuebingen.de

---

From: <[email-masked]>
Date: Tue, 9 Feb 2021 08:17:19 -0500

Thanks for putting this together and also sharing with us.

I maintain a list of P4 targets for the P4 community here:
https://github.com/hesingh/p4-info

I will unicast a few missing P4 software to Michael.   

For now, it does make sense to include pcube since this was the first P4
implementation in the preprocessor to unroll loops etc. for P4-14.
https://github.com/networkedsystemsIITB/pcube
Another application for distributed computing is UPenn's Flightplan.
https://flightplan.cis.upenn.edu/ Flightplan also uses the preprocessor.

We are the first app-store for p4 applications: https://mnkcg.com/app-store/

Best wishes,

Hemant

-----Original Message-----
From: Coin <[email-masked]> On Behalf Of Michael Menth
Sent: Tuesday, February 09, 2021 2:18 AM
To: [email-masked]
Subject: [Coin] Survey on P4

Hi all,

Kind regards,

Michael

-- 
Coin mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/coin

---

From: <[email-masked]>
Date: Tue, 9 Feb 2021 08:42:28 -0500

PVPP is a research paper but does not have software available as open-source
nor from a company.  Why should PVPP even exist in Table II?

Hemant

-----Original Message-----
From: Coin <[email-masked]> On Behalf Of Michael Menth
Sent: Tuesday, February 09, 2021 2:18 AM
To: [email-masked]
Subject: [Coin] Survey on P4

Hi all,

Kind regards,

Michael

---

From: <[email-masked]>
Date: Tue, 9 Feb 2021 09:16:17 -0500

A P4 to VPP plugin effort is underway at the next IETF Hackathon.  See
https://trac.ietf.org/trac/ietf/meeting/wiki/110hackathon

A P4toVPP compiler, proprietary to MNK Labs & Consulting, will be used.

Hemant

-----Original Message-----
From: Coin <[email-masked]> On Behalf Of
hemant=[email-masked]
Sent: Tuesday, February 09, 2021 8:42 AM
To: [email-masked]; [email-masked]
Subject: Re: [Coin] Survey on P4

Hemant

-----Original Message-----
From: Coin <[email-masked]> On Behalf Of Michael Menth
Sent: Tuesday, February 09, 2021 2:18 AM
To: [email-masked]
Subject: [Coin] Survey on P4

Hi all,

Kind regards,

Michael

---

From: Fernando Ramos <[email-masked]>
Date: Tue, 9 Feb 2021 15:03:11 +0000

Great effort, Michael, many thanks.

Another useful and complementary resource is here:

https://programmabledataplane.review <https://programmabledataplane.review/>

It also has a survey paper associated and enables contributions to the reading list via github.

Cheers,

Fernando

> On 9 Feb 2021, at 13:17, hemant=[email-masked] wrote:
>