Subject: [Coin] I-D Action: draft-irtf-coinrg-use-cases-00.txt

From: [email-masked]
Date: Wed, 17 Feb 2021 03:26:25 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Computing in the Network Research Group RG of the IRTF.

        Title           : Use Cases for In-Network Computing
        Authors         : Ike Kunze
                          Klaus Wehrle
                          Dirk Trossen
                          Marie-Jose Montpetit
	Filename        : draft-irtf-coinrg-use-cases-00.txt
	Pages           : 32
	Date            : 2021-02-17

Abstract:
   Computing in the Network (COIN) comes with the prospect of deploying
   processing functionality on networking devices, such as switches and
   network interface cards.  While such functionality can be beneficial
   in several contexts, it has to be carefully placed into the context
   of the general Internet communication.  This document discusses some
   use cases to demonstrate how real applications can benefit from COIN
   and to showcase essential requirements that have to be fulfilled by
   COIN applications.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-irtf-coinrg-use-cases/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-irtf-coinrg-use-cases-00
https://datatracker.ietf.org/doc/html/draft-irtf-coinrg-use-cases-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Ike Kunze <[email-masked]>
Date: Wed, 17 Feb 2021 11:38:38 +0000

Hi all,

we have just submitted the 00-version of the RG draft on COIN use cases.

Status:

This update of the former draft-kunze-coin-industrial-use-cases-04 includes a first shot at a taxonomy that goes beyond what was presented at IETF-109.
In short, there are now five subsections for each use case:

1. Description: explanation of the use case behavior
2. Characterization: explanation of the services that are being realized and the semantics of interactions in the use case
3. Existing solutions: if existing, outline current methods of realizing the use case
4. Opportunities and research questions for COIN: outline how PNDs may support or improve on the use case case in terms of performance and other metrics and state essential questions that are suitable for guiding research.
5. Requirements: describe the requirements for any solutions that may need development along the opportunities outlined in item 4

After contributions by Marie-José (who has also joined the group of authors) and by David Griffin and Miguel Rio, the draft now features the following use cases grouped into three larger categories:

4.  Industrial Use Cases  . . . . . . . . . . . . . . . . . . . .   5
     4.2.  In-Network Control / Time-sensitive applications  . . . .   6
     4.3.  Large Volume Applications . . . . . . . . . . . . . . . .   9
     4.4.  Industrial Safety . . . . . . . . . . . . . . . . . . . .  12
5.  Immersive experiences . . . . . . . . . . . . . . . . . . . .  14
     5.1.  Mobile Application Offloading . . . . . . . . . . . . . .  14
     5.2.  Extended Reality (XR) . . . . . . . . . . . . . . . . . .  17
     5.3.  Personalised and interactive performing arts  . . . . . .  21
6.  Infrastructure Services . . . . . . . . . . . . . . . . . . .  24
     6.1.  Distributed AI  . . . . . . . . . . . . . . . . . . . . .  24
     6.2.  Content Delivery Networks . . . . . . . . . . . . . . . .  25
     6.3.  CFaaS . . . . . . . . . . . . . . . . . . . . . . . . . .  27

The file sources should soon be available on the RG GitHub repository (https://github.com/irtf-coinrg/rg-materials).

Next Steps:

We are aware that there is (significant) overlap between some of the use cases and we plan to consolidate the use cases and tighten the text in the next iteration.
In this context, we especially plan to find a common ground in how the five taxonomy parts are filled out for each use case as this is currently quite imbalanced.
We also plan to have first discussions on how we can derive overall/overarching results from the different use cases.

Call for Feedback and Contribution:

We kindly ask for your feedback on the current status of the draft, especially regarding the following three aspects:

1. Are there any relevant use cases that we missed? We are still looking for new use cases and new contributors, so please reach out if you can identify a missing use case and/or would like to contribute.

2. Does the current form of the taxonomy make sense? Do you have concrete ideas for how it could be improved, i.e., both the text and the taxonomy itself?

3. Do you have concrete suggestions for consolidating the use cases, e.g., by merging two use cases that have similar properties?

We also welcome any other feedback or discussions on the draft!

Best,
Ike
--
Ike Kunze, M.Sc.
Researcher, Ph.D. Student

COMSYS - Communication and Distributed Systems
RWTH Aachen University
Ahornstr. 55
52074 Aachen, Germany
Tel: +49 241 80-21422
[email-masked]<mailto:[email-masked]>
http://www.comsys.rwth-aachen.de/team/ike-kunze/

On 17. Feb 2021, at 12:26, [email-masked]<mailto:[email-masked]> wrote:

Abstract:

--
Coin mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/coin