Subject: [Coin] revisit arguments for edge

From: Aaron Ding <[email-masked]>
Date: Sun, 27 Jun 2021 08:55:14 +0000

COINRG colleagues,

Is the motive for Edge diminishing since its first concepts were formulated more than a decade ago?

A recent work to share on "Revisiting the Arguments for Edge Computing Research"
https://arxiv.org/pdf/2106.12224.pdf

Cheers,
Aaron
--
CPI Lab, TU Delft
https://cpi-lab.github.io/

---

From: Hesham ElBakoury <[email-masked]>
Date: Sun, 27 Jun 2021 03:45:01 -0700

The article answers this question in its conclusion which says: "This
article argues that the motivation for edge computing research has not
diminished since it was first formulated."

Hesham

On Sun, Jun 27, 2021, 1:55 AM Aaron Ding <[email-masked]> wrote:

> A recent work to share on "*Revisiting the Arguments for Edge Computing
> Research*"
> Coin mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/coin
>

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Sun, 27 Jun 2021 11:06:13 +0000

I saw you posted this to many mailing lists.

I had a quick glance. I would say that you are talking of “edge” and
“cloud” in very broad terms. And while the “cloud” is now very much
associated with data and computing centers what is the edge? You seem to
mention many “edges”. And yes there are still very good arguments for edge.

You are right that the cloud has evolved.  There has effectively been a lot
of research to reduce the power consumption of data centers and the
creation of “satellite” systems to reduce delay (not to mention the real
satellites that will take advantage of them).  And of course you cannot run
a service like Rakuten from a bunch of smallish edge devices.

But if you have followed a little bit what has been discussed on COIN and
other lists and within the 6G early discussions,  there is not an “edge vs.
the cloud” war, there is a need to do good engineering and locate services
and their functionality where they make sense in terms of performance,
usability and business cases.

So of course there is not one solution, there are multiple solutions based
on the use cases you are considering. Actually it would have been nice if
your are article had better addressed the need for cloud edge/orchestration
and the functional decomposition and data fusion that are necessary for
federated AI/ML for example. That is becoming important in a number of
industrial use cases and impaired by the hyper verticalisation engendered
by cloud-only solutions.

But at the end there is not a one solution fits all. We are engineers. We
define the solutions based on requirements.

Thanks for posting the article and most likely start a discussion.

mjm

Marie-José Montpetit, Ph.D.
[email-masked]

From: Aaron Ding <[email-masked]> <[email-masked]>
Reply: Aaron Ding <[email-masked]> <[email-masked]>
Date: June 27, 2021 at 4:55:32 AM
To: [email-masked] <[email-masked]> <[email-masked]>
Subject:  [Coin] revisit arguments for edge

COINRG colleagues,

Is the motive for Edge diminishing since its first concepts were formulated
more than a decade ago?

Cheers,
Aaron

---

From: Sharon Barkai <[email-masked]>
Date: Sun, 27 Jun 2021 14:22:28 +0300

"The Automotive Edge Computing Consortium (AECC) estimates that more than 30% of video data produced on the vehicle will need to be offloaded. This is to increase safety thresholds by processing offloaded data with external data for augmenting awareness of the moving vehicle. The volume of data that will need to be offloaded is expected to be between 400 GB to 5 TB per hour. If all the data is sent to the cloud, the QoS objectives cannot not be met due to the limited bandwidth. Therefore, exploiting the edge that efficiently processes the data near the source is required for such applications.”

This “physics” argument is one of the most compelling for a programmable edge:
- not satisfied by CDN/rCDN edge caches with generic traffic management
- crowd-source collection of transient street conditions must be edge curated
- transient conditions such as blockages, free-parking, double-parking, hazards
- curation includes multiple source verification, localization of what is “seen”
- plus tracking for how long transient conditions persist and who needs to know
- all of which have policy based, changing and constantly evolving, enterprise logic 
- attainable today on existing cellular with existing metro DCs peering to carriers

This programmable edge use-case is also very high-function-network COIN oriented:
- requires continues p2p p2mp service while modems switch carriers for reception
- requires addressable in-network instance steering to avoid resolution over mobile
- addressable vehicle IDs and addressable geolocation services while driving
- in-network instance selection, avoids massive client updates upon cluster shifts

> On Jun 27, 2021, at 13:45, Hesham ElBakoury <[email-masked]> wrote:
> 
> The article answers this question in its conclusion which says: "This article argues that the motivation for edge computing research has not diminished since it was first formulated."
> 
> Hesham
> 
> On Sun, Jun 27, 2021, 1:55 AM Aaron Ding <[email-masked] <mailto:[email-masked]>> wrote:
> 
> COINRG colleagues,
> 
> https://arxiv.org/pdf/2106.12224.pdf <https://arxiv.org/pdf/2106.12224.pdf>    
> 
> Cheers,
> Aaron
> --
> CPI Lab, TU Delft
> https://cpi-lab.github.io/ <https://cpi-lab.github.io/>  
> 
> 
> 
> -- 
> Coin mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.irtf.org/mailman/listinfo/coin <https://www.irtf.org/mailman/listinfo/coin>
> -- 
> Coin mailing list
> [email-masked]

---

From: Hesham ElBakoury <[email-masked]>
Date: Sun, 27 Jun 2021 04:30:58 -0700

Gartner report on 2021 Strategic Roadmap for Edge Computing says that "Edge
computing doesn’t compete with cloud computing but will complement and
complete it. Edge computing is part of a distributed computing topology in
which information processing is located close to the physical location
where things and people connect with the networked digital world."

Hesham

On Sun, Jun 27, 2021, 4:22 AM Sharon Barkai <[email-masked]>
wrote:

> "The Automotive Edge Computing Consortium (AECC) estimates that more than
> 30% of video data produced on the vehicle will need to be offloaded. This
> is to increase safety thresholds by processing offloaded data with external
> data for augmenting awareness of the moving vehicle. The volume of data
> that will need to be offloaded is expected to be between 400 GB to 5 TB per
> hour. If all the data is sent to the cloud, the QoS objectives cannot not
> be met due to the limited bandwidth. Therefore, exploiting the edge that
> efficiently processes the data near the source is required for such
> applications.”
>

---

From: Aaron Ding <[email-masked]>
Date: Sun, 27 Jun 2021 12:03:33 +0000

Thanks Marie-Jose. It's meant for research discussions, rather than settling for one or another. Aaron

________________________________
From: Marie-Jose Montpetit <[email-masked]>
Sent: Sunday, June 27, 2021 13:06
To: Aaron Ding; [email-masked]
Subject: Re: [Coin] revisit arguments for edge

I had a quick glance. I would say that you are talking of “edge” and “cloud” in very broad terms. And while the “cloud” is now very much associated with data and computing centers what is the edge? You seem to mention many “edges”. And yes there are still very good arguments for edge.

You are right that the cloud has evolved.  There has effectively been a lot of research to reduce the power consumption of data centers and the creation of “satellite” systems to reduce delay (not to mention the real satellites that will take advantage of them).  And of course you cannot run a service like Rakuten from a bunch of smallish edge devices.

But if you have followed a little bit what has been discussed on COIN and other lists and within the 6G early discussions,  there is not an “edge vs. the cloud” war, there is a need to do good engineering and locate services and their functionality where they make sense in terms of performance, usability and business cases.

So of course there is not one solution, there are multiple solutions based on the use cases you are considering. Actually it would have been nice if your are article had better addressed the need for cloud edge/orchestration and the functional decomposition and data fusion that are necessary for federated AI/ML for example. That is becoming important in a number of industrial use cases and impaired by the hyper verticalisation engendered by cloud-only solutions.

But at the end there is not a one solution fits all. We are engineers. We define the solutions based on requirements.

mjm

Marie-José Montpetit, Ph.D.
[email-masked]<mailto:[email-masked]>

From: Aaron Ding <[email-masked]><mailto:[email-masked]>
Reply: Aaron Ding <[email-masked]><mailto:[email-masked]>
Date: June 27, 2021 at 4:55:32 AM
To: [email-masked]<mailto:[email-masked]> <[email-masked]><mailto:[email-masked]>
Subject:  [Coin] revisit arguments for edge

COINRG colleagues,

A recent work to share on "Revisiting the Arguments for Edge Computing Research"
https://arxiv.org/pdf/2106.12224.pdf<https://urldefense.proofpoint.com/v2/url?u=https-3A__arxiv.org_pdf_2106.12224.pdf&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=Iui-R0PdSAiRXYstq499vMjc_0AA9xFpAzYBY5yBmJc&m=GCoN99rVJcZsALjdHaKSpyo7OM-Sb_zqjCzSnYGEo5A&s=zjgSpj-m3HXNOpYunJp3CEvaT-Wnaner9z3dmH5Xi5I&e=>

Cheers,
Aaron
--
CPI Lab, TU Delft
https://cpi-lab.github.io/<https://urldefense.proofpoint.com/v2/url?u=https-3A__cpi-2Dlab.github.io_&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=Iui-R0PdSAiRXYstq499vMjc_0AA9xFpAzYBY5yBmJc&m=GCoN99rVJcZsALjdHaKSpyo7OM-Sb_zqjCzSnYGEo5A&s=iQUMBdSDk9KeOL3J_cPuyoO-uRFirrgysWqpF4q2IpU&e=>

--
Coin mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/coin<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.irtf.org_mailman_listinfo_coin&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=Iui-R0PdSAiRXYstq499vMjc_0AA9xFpAzYBY5yBmJc&m=GCoN99rVJcZsALjdHaKSpyo7OM-Sb_zqjCzSnYGEo5A&s=gSBokFONgl0HTMsUyBrkk5RoaAEq2V9ltKKjKVBT4RU&e=>

---

From: Aaron Ding <[email-masked]>
Date: Mon, 28 Jun 2021 08:10:40 +0000

Thanks Sharon, Hesham. Forget to mention (as others have asked) this work is in pre-print to appear in IEEE Internet Computing<https://ieeexplore.ieee.org/xpl/RecentIssue.jsp?punumber=4236>. Cheers, Aaron

________________________________
From: Sharon Barkai <[email-masked]>
Sent: Sunday, June 27, 2021 13:22
To: Hesham ElBakoury
Cc: Aaron Ding; [email-masked]
Subject: Re: [Coin] revisit arguments for edge

On Jun 27, 2021, at 13:45, Hesham ElBakoury <[email-masked]<mailto:[email-masked]>> wrote:

Hesham

On Sun, Jun 27, 2021, 1:55 AM Aaron Ding <[email-masked]<mailto:[email-masked]>> wrote:

COINRG colleagues,

A recent work to share on "Revisiting the Arguments for Edge Computing Research"
https://arxiv.org/pdf/2106.12224.pdf<https://urldefense.proofpoint.com/v2/url?u=https-3A__arxiv.org_pdf_2106.12224.pdf&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=Iui-R0PdSAiRXYstq499vMjc_0AA9xFpAzYBY5yBmJc&m=hogSKtumATkFKILl92xzEruzN6Hei5e2FbdsI88owPk&s=TTTRoxwftZyC_6USOtaMuzmM_f57Ul4JVHepY4Qq6Ic&e=>

Cheers,
Aaron
--
CPI Lab, TU Delft
https://cpi-lab.github.io/<https://urldefense.proofpoint.com/v2/url?u=https-3A__cpi-2Dlab.github.io_&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=Iui-R0PdSAiRXYstq499vMjc_0AA9xFpAzYBY5yBmJc&m=hogSKtumATkFKILl92xzEruzN6Hei5e2FbdsI88owPk&s=myyMyUBckLoqrPcp53dxhoQmZpn6z83EXzkoGI8eUwU&e=>

--
Coin mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/coin<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.irtf.org_mailman_listinfo_coin&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=Iui-R0PdSAiRXYstq499vMjc_0AA9xFpAzYBY5yBmJc&m=hogSKtumATkFKILl92xzEruzN6Hei5e2FbdsI88owPk&s=W2OCchl_MfVfdJAB1tfPSW7f4GW1IdqbwqPijQblya4&e=>
--
Coin mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/coin<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.irtf.org_mailman_listinfo_coin&d=DwQFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=Iui-R0PdSAiRXYstq499vMjc_0AA9xFpAzYBY5yBmJc&m=hogSKtumATkFKILl92xzEruzN6Hei5e2FbdsI88owPk&s=W2OCchl_MfVfdJAB1tfPSW7f4GW1IdqbwqPijQblya4&e=>

---

From: Hesham ElBakoury <[email-masked]>
Date: Mon, 28 Jun 2021 11:49:04 -0700

It is worth noting that edge computing is one of the main themes in the
presentations of many companies in MWC 2021.

Hesham

On Mon, Jun 28, 2021, 1:10 AM Aaron Ding <[email-masked]> wrote:

> Thanks Sharon, Hesham. Forget to mention (as others have asked) this work
> is in pre-print to appear in IEEE Internet Computing
> <https://ieeexplore.ieee.org/xpl/RecentIssue.jsp?punumber=4236>. Cheers,
> Aaron
>
>
> ------------------------------
> *From:* Sharon Barkai <[email-masked]>
> *Sent:* Sunday, June 27, 2021 13:22
> *To:* Hesham ElBakoury
> *Cc:* Aaron Ding; [email-masked]
> *Subject:* Re: [Coin] revisit arguments for edge
>
>> <https://urldefense.proofpoint.com/v2/url?u=https-3A__arxiv.org_pdf_2106.12224.pdf&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=Iui-R0PdSAiRXYstq499vMjc_0AA9xFpAzYBY5yBmJc&m=hogSKtumATkFKILl92xzEruzN6Hei5e2FbdsI88owPk&s=TTTRoxwftZyC_6USOtaMuzmM_f57Ul4JVHepY4Qq6Ic&e=>
>>
>>
>> Cheers,
>> Aaron
>> --
>> CPI Lab, TU Delft
>> <https://urldefense.proofpoint.com/v2/url?u=https-3A__cpi-2Dlab.github.io_&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=Iui-R0PdSAiRXYstq499vMjc_0AA9xFpAzYBY5yBmJc&m=hogSKtumATkFKILl92xzEruzN6Hei5e2FbdsI88owPk&s=myyMyUBckLoqrPcp53dxhoQmZpn6z83EXzkoGI8eUwU&e=>
>>
>>
>>
>>
>> --
>> Coin mailing list
>> [email-masked]
>> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.irtf.org_mailman_listinfo_coin&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=Iui-R0PdSAiRXYstq499vMjc_0AA9xFpAzYBY5yBmJc&m=hogSKtumATkFKILl92xzEruzN6Hei5e2FbdsI88owPk&s=W2OCchl_MfVfdJAB1tfPSW7f4GW1IdqbwqPijQblya4&e=>
>>
> --
> Coin mailing list
> [email-masked]
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.irtf.org_mailman_listinfo_coin&d=DwQFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=Iui-R0PdSAiRXYstq499vMjc_0AA9xFpAzYBY5yBmJc&m=hogSKtumATkFKILl92xzEruzN6Hei5e2FbdsI88owPk&s=W2OCchl_MfVfdJAB1tfPSW7f4GW1IdqbwqPijQblya4&e=>
>
>
>