Subject: [Coin] Request for agenda items

From: Marie-Jose Montpetit <[email-masked]>
Date: Wed, 7 Jul 2021 08:35:40 -0400

Hi everyone:

we will soon be putting the agenda together. This meeting has a theme like
we mentioned before: use cases.

There has been a lot of development that was reported in COIN-related use
cases at the Dagstuhl seminar, as part of the Piccolo project, and in
conferences and workshops that I think show that computing+networking is
creating a lot of interesting research in applications and services and on
how to evolve the architectures to support those.

We again will dedicate most of the time to research presentations however
for the draft authors we will have some “lightning” talks at the end to
report on the progress and plan for the future.

J/E/M

Marie-José Montpetit, Ing. Ph.D.
[email-masked]

---

From: "Bernier, Daniel" <[email-masked]>
Date: Wed, 7 Jul 2021 12:38:55 +0000

Hi

Any online content available from the Dagstuhl seminar ?

Regards

Sent from my Bell Samsung device over Canada's largest network.

-------- Original message --------
From: Marie-Jose Montpetit <[email-masked]>
Date: 2021-07-07 9:35 a.m. (GMT-04:00)
To: [email-masked]
Cc: coinrg-chairs <[email-masked]>
Subject: [EXT][Coin] Request for agenda items

Hi everyone:

we will soon be putting the agenda together. This meeting has a theme like we mentioned before: use cases.

There has been a lot of development that was reported in COIN-related use cases at the Dagstuhl seminar, as part of the Piccolo project, and in conferences and workshops that I think show that computing+networking is creating a lot of interesting research in applications and services and on how to evolve the architectures to support those.

We again will dedicate most of the time to research presentations however for the draft authors we will have some "lightning" talks at the end to report on the progress and plan for the future.

J/E/M

Marie-Jos? Montpetit, Ing. Ph.D.
[email-masked]<mailto:[email-masked]>

---

From: Hesham ElBakoury <[email-masked]>
Date: Sun, 11 Jul 2021 13:37:06 -0700

I think the in-network computing use cases show that the end to end
argument can not be or should not be supported in all scenarios. Is it the
end of the end-2-end argument ?

Hesham

On Wed, Jul 7, 2021, 5:36 AM Marie-Jose Montpetit <[email-masked]>
wrote:

> --
> Coin mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/coin
>

---

From: "David R. Oran" <[email-masked]>
Date: Sun, 11 Jul 2021 16:50:06 -0400

> end of the end-2-end argument ?
Uh, no, and no.

DaveO

---

From: Dirk Trossen <[email-masked]>
Date: Mon, 12 Jul 2021 07:10:15 +0000

Hesham,

As a  slightly longer reply than Dave’s ;-)

I find that many/most people like to hang their view of the E2E argument on the text in the paper that goes “The function in question can completely and correctly be implemented only with the knowledge and help of the application standing at the end points of the communication system. Therefore, providing that questioned function as a feature of the communication system itself is not possible.”

But the text continues right away with “(Sometimes an incomplete version of the function provided by the communication system may be useful as a performance enhancement.)”, which seems often ignored. I don’t see COIN in contradiction to the former nor the latter text from the paper.

But in essence, I agree with Dave’s view.

Best,

Dirk

From: Coin [mailto:[email-masked]] On Behalf Of Hesham ElBakoury
Sent: 11 July 2021 22:37
To: Marie-Jose Montpetit <[email-masked]>
Cc: coinrg-chairs <[email-masked]>; [email-masked]
Subject: [Coin] End to End Argument

I think the in-network computing use cases show that the end to end argument can not be or should not be supported in all scenarios. Is it the end of the end-2-end argument ?

Hesham

On Wed, Jul 7, 2021, 5:36 AM Marie-Jose Montpetit <[email-masked]<mailto:[email-masked]>> wrote:
Hi everyone:

We again will dedicate most of the time to research presentations however for the draft authors we will have some “lightning” talks at the end to report on the progress and plan for the future.

J/E/M

--
Coin mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/coin

---

From: Jon Crowcroft <[email-masked]>
Date: Mon, 12 Jul 2021 08:20:56 +0100

the argument never said "don't put functions in the network" - it is
very clearly a tool for deciding what not to put in the network. -
indeed, the paper says it is an "occam's razor" to decide this, and
gives a bunch of examples. -given when it was written, unsurprisingly,
various other examples (for and against placement only in end nodes,
or within the network) have occurred to people - one perennial debate
is, for example, when and where routing&forwarding choices should be
made - this moves to and fro deepdning when people are talking about
multicast, mobilipty, multipath, segment routing etc etc etc

just about the only case where the answer (for me) is unequivocally
"leave it end to end" is encryption. if the function you want is to
provide confidentially (and integrity) then putting that anywhere else
is not providing that function properly:)

On Sun, Jul 11, 2021 at 9:37 PM Hesham ElBakoury <[email-masked]> wrote:
> On Wed, Jul 7, 2021, 5:36 AM Marie-Jose Montpetit <[email-masked]> wrote:
>>
>> Hi everyone:
>>

---

From: Dirk Trossen <[email-masked]>
Date: Mon, 12 Jul 2021 07:25:24 +0000

-----Original Message-----
From: Coin [mailto:[email-masked]] On Behalf Of Jon Crowcroft
Sent: 12 July 2021 09:21
To: Hesham ElBakoury <[email-masked]>
Cc: coinrg-chairs <[email-masked]>; Marie-Jose Montpetit <[email-masked]>; [email-masked]
Subject: Re: [Coin] End to End Argument

the argument never said "don't put functions in the network" - it is very clearly a tool for deciding what not to put in the network. - indeed, the paper says it is an "occam's razor" to decide this, and gives a bunch of examples. -given when it was written, unsurprisingly, various other examples (for and against placement only in end nodes, or within the network) have occurred to people - one perennial debate is, for example, when and where routing&forwarding choices should be made - this moves to and fro deepdning when people are talking about multicast, mobilipty, multipath, segment routing etc etc etc

just about the only case where the answer (for me) is unequivocally "leave it end to end" is encryption. if the function you want is to provide confidentially (and integrity) then putting that anywhere else is not providing that function properly:)
[DOT] T2T - trust-to-trust; sure the extension of the E2E towards trust is not only about encryption though.

---

From: 姜胜明 <[email-masked]>
Date: Tue, 13 Jul 2021 09:45:24 +0800 (GMT+08:00)

I'm not sure whether this "end-to-end argument" is the same as or similar to that for Internet. I ever tried to quantify the "end-to-end argument" for Internet with a short conference paper published in 2009:  Quantitative end-to-end arguments: Fundamental, DOI:10.1109/ICICS.2009.5397600, which is available at Quantitative end-to-end arguments: Fundamental | Request PDF (researchgate.net).

Just for sharing and sorry for any disturbence.

ming

-----原始邮件-----
发件人:"Hesham ElBakoury" <[email-masked]>
发送时间:2021-07-12 04:37:06 (星期一)
收件人: "Marie-Jose Montpetit" <[email-masked]>
抄送: coinrg-chairs <[email-masked]>, [email-masked]
主题: [Coin] End to End Argument

Hesham

Hi everyone:

J/E/M