Subject: [Coin] Final Agenda

From: Marie-Jose Montpetit <[email-masked]>
Date: Thu, 22 Jul 2021 19:40:08 -0500

Here is the final agenda - also loaded in the datatracker.

If someone wants to volunteer as a notetaker it’s greatly appreciated.

See you all Monday!

J/E/M

COIN RG Agenda IETF-111
=======================

*Date*: Monday, July 26, 2021 - Session III
*Time:* 1600-1800 PDT - 23:00-1:00 UTC -- 120 mins
*Chairs*: J/E/M
  Jianfei (Jeffrey) He <[email-masked]>
  Eve Schooler <[email-masked]>
  Marie-Jose Montpetit <[email-masked]>

*Join via Meetecho:*
https://meetings.conf.meetecho.com/ietf111/?group=coinrg&short=&item=1
*Live minutes:* https://codimd.ietf.org/notes-ietf-111-coinrg
*Materials:* https://datatracker.ietf.org/meeting/111/session/coinrg

*Chair updates (J/E/M) - 5 mins*

*COIN related activities*

1. Piccolo use cases: risk monitoring and smart factory (Philip Eardley) -
presenting first to accommodate time zones  - 20 mins
https://piccolo-project.org/
2. Summary of Dagstuhl seminar - a teaser of the report (Dirk Kutscher) -
20 mins
https://www.dagstuhl.de/en/program/calendar/semhp/?semnr=20112

*Theme: COIN Use Cases*
3. BT, Huawei and Cambridge University project on Compute First Networking
(Dirk Trossen) - 20 mins
slides-111-coinrg-compute-first-networking-use-cases
<https://datatracker.ietf.org/doc/slides-111-coinrg-compute-first-networking-use-cases/>
4. Programmability in Mobile Virtual Networks (Xavier de Foy) - 20 mins
"Use Case for P4 Programmability by Tenants of Future Mobile Virtual
Networks” - draft-defoy-coinrg-p4-by-tenants-in-mobile-nw
5.  “Store Edge Networked Data” (SEND), a novel framework for in-network
storage management realized through data repositories deployed at the
network edge (Chris Nicolaescu) - 20 mins
https://www.researchgate.net/publication/346643946_Store_Edge_Networked_Data_SEND_A_Data_and_Performance_Driven_Edge_Storage_Framework/stats

*Lightning presentations of current drafts*
6. Use case draft update (Ike Kunze) - 5 mins

*RG topics*
7. Announcements (related workshops, conferences etc.) - 5 mins
8. Next meetings - 5 mins

Total: 120 minutes

Marie-Jose Montpetit, Ing. Ph.D.
[email-masked]

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Thu, 22 Jul 2021 20:45:37 -0400

The link to the use case document is:
Use Cases for In-Network Computing (draft-irtf-coinrg-use-cases) <https://datatracker.ietf.org/doc/draft-irtf-coinrg-use-cases/>

J/E/M

> On Jul 22, 2021, at 8:40 PM, Marie-Jose Montpetit <[email-masked]> wrote:
> 
> 
> Date: Monday, July 26, 2021 - Session III
> Time: 1600-1800 PDT - 23:00-1:00 UTC -- 120 mins 
> Chairs: J/E/M
>   Jianfei (Jeffrey) He <[email-masked] <mailto:[email-masked]>>
>   Eve Schooler <[email-masked] <mailto:[email-masked]>>
>   Marie-Jose Montpetit <[email-masked] <mailto:[email-masked]>>
> 
> Join via Meetecho: https://meetings.conf.meetecho.com/ietf111/?group=coinrg&short=&item=1 <https://meetings.conf.meetecho.com/ietf111/?group=coinrg&short=&item=1>
> Live minutes: https://codimd.ietf.org/notes-ietf-111-coinrg <https://codimd.ietf.org/notes-ietf-111-coinrg>
> Materials: https://datatracker.ietf.org/meeting/111/session/coinrg <https://datatracker.ietf.org/meeting/111/session/coinrg>
> 
> Chair updates (J/E/M) - 5 mins
> 
> COIN related activities
>  
> 1. Piccolo use cases: risk monitoring and smart factory (Philip Eardley) - presenting first to accommodate time zones  - 20 mins
> https://piccolo-project.org/ <https://piccolo-project.org/>
> 2. Summary of Dagstuhl seminar - a teaser of the report (Dirk Kutscher) - 20 mins
> https://www.dagstuhl.de/en/program/calendar/semhp/?semnr=20112 <https://www.dagstuhl.de/en/program/calendar/semhp/?semnr=20112>
> 
> Theme: COIN Use Cases
> 3. BT, Huawei and Cambridge University project on Compute First Networking (Dirk Trossen) - 20 mins
> slides-111-coinrg-compute-first-networking-use-cases <https://datatracker.ietf.org/doc/slides-111-coinrg-compute-first-networking-use-cases/>
> "Use Case for P4 Programmability by Tenants of Future Mobile Virtual Networks” - draft-defoy-coinrg-p4-by-tenants-in-mobile-nw
> 5.  “Store Edge Networked Data” (SEND), a novel framework for in-network storage management realized through data repositories deployed at the network edge (Chris Nicolaescu) - 20 mins
> https://www.researchgate.net/publication/346643946_Store_Edge_Networked_Data_SEND_A_Data_and_Performance_Driven_Edge_Storage_Framework/stats <https://www.researchgate.net/publication/346643946_Store_Edge_Networked_Data_SEND_A_Data_and_Performance_Driven_Edge_Storage_Framework/stats>
> 
> Lightning presentations of current drafts
> RG topics
> [email-masked] <mailto:[email-masked]>

---

From: Sharon Barkai <[email-masked]>
Date: Sun, 25 Jul 2021 15:17:31 +0300

Been reviewing the CFN slides which are extremely interesting.

Relate to https://datatracker.ietf.org/doc/html/draft-ietf-lisp-nexagon <https://datatracker.ietf.org/doc/html/draft-ietf-lisp-nexagon> which was presented in coinrg, and  combines the transportation and (geospatial) digital twin (of the roads) use-cases. These can be used to facilitate “Geolocation Services”, e.g. mobility services which must be computed at the edge in a geospatial context. For example aggregating uploads from vehicles driving at 20 meters per second in queues that therefore need to be less than 50msec away, correlating uploads from different vehicles and localizing with reference geo-states and images.

Not sure will be able to attend actual session, so for benefit of presenters would like to point out couple additional benefits for using a CFN approach for aggregating mobility services (v2x / geospatial twins) :

1. context-switching: low-latency aggregation of moving elements can not stall for slow chatty resolutions.
Addressable in-network mapping of CFN context prevents this, and prevents massive updates to cached resolutions upon fail-overs.

2. service-continuity: this emphasis is on compute first overly networking. The reason is that roaming modems may switch carriers for reception and hence underlay addresses as do the CFNs. Still preserving point-to-point and point to multi-point identity sessions is important.

Very interesting research, any additional links most welcome.

> On Jul 23, 2021, at 03:40, Marie-Jose Montpetit <[email-masked]> wrote:
> 
> 
> -- 
> Coin mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.irtf.org/mailman/listinfo/coin <https://www.irtf.org/mailman/listinfo/coin>

---

From: Dirk Trossen <[email-masked]>
Date: Mon, 26 Jul 2021 07:52:23 +0000

Dear Sharon, all,

Thanks for the pointers, which are certainly relevant for what we have been looking at for the use cases in terms of requirements and possibly enabling technologies.

In relation to the use cases and their possible realization in limited domains, this list may find the latest ACM CCR editorial on “limited domains considered useful” of interest.

Best,

Dirk

From: Coin [mailto:[email-masked]] On Behalf Of Sharon Barkai
Sent: 25 July 2021 14:18
To: Marie-Jose Montpetit <[email-masked]>
Cc: coinrg-chairs <[email-masked]>; [email-masked]
Subject: Re: [Coin] Final Agenda

Relate to https://datatracker.ietf.org/doc/html/draft-ietf-lisp-nexagon which was presented in coinrg, and  combines the transportation and (geospatial) digital twin (of the roads) use-cases. These can be used to facilitate “Geolocation Services”, e.g. mobility services which must be computed at the edge in a geospatial context. For example aggregating uploads from vehicles driving at 20 meters per second in queues that therefore need to be less than 50msec away, correlating uploads from different vehicles and localizing with reference geo-states and images.

On Jul 23, 2021, at 03:40, Marie-Jose Montpetit <[email-masked]<mailto:[email-masked]>> wrote:

See you all Monday!

J/E/M

COIN RG Agenda IETF-111
=======================

Date: Monday, July 26, 2021 - Session III
Time: 1600-1800 PDT - 23:00-1:00 UTC -- 120 mins
Chairs: J/E/M
  Jianfei (Jeffrey) He <[email-masked]<mailto:[email-masked]>>
  Eve Schooler <[email-masked]<mailto:[email-masked]>>
  Marie-Jose Montpetit <[email-masked]<mailto:[email-masked]>>

Join via Meetecho: https://meetings.conf.meetecho.com/ietf111/?group=coinrg&short=&item=1
Live minutes: https://codimd.ietf.org/notes-ietf-111-coinrg
Materials: https://datatracker.ietf.org/meeting/111/session/coinrg

COIN related activities

Theme: COIN Use Cases
slides-111-coinrg-compute-first-networking-use-cases<https://datatracker.ietf.org/doc/slides-111-coinrg-compute-first-networking-use-cases/>

RG topics

Total: 120 minutes

Marie-Jose Montpetit, Ing. Ph.D.
[email-masked]<mailto:[email-masked]>

--
Coin mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/coin