Subject: [Coin] I-D Action: draft-irtf-coinrg-use-cases-01.txt

From: [email-masked]
Date: Mon, 25 Oct 2021 07:42:43 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Computing in the Network Research Group RG of the IRTF.

        Title           : Use Cases for In-Network Computing
        Authors         : Ike Kunze
                          Klaus Wehrle
                          Dirk Trossen
                          Marie-Jose Montpetit
                          Xavier de Foy
                          David Griffin
                          Miguel Rio
	Filename        : draft-irtf-coinrg-use-cases-01.txt
	Pages           : 46
	Date            : 2021-10-25

Abstract:
   Computing in the Network (COIN) comes with the prospect of deploying
   processing functionality on networking devices, such as switches and
   network interface cards.  While such functionality can be beneficial
   in several contexts, it has to be carefully placed into the context
   of the general Internet communication.  This document discusses some
   use cases to demonstrate how real applications can benefit from COIN
   and to showcase essential requirements that have to be fulfilled by
   COIN applications.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-irtf-coinrg-use-cases/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-irtf-coinrg-use-cases-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-irtf-coinrg-use-cases-01

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Ike Kunze <[email-masked]>
Date: Mon, 25 Oct 2021 14:49:39 +0000

Hi COINRG,

we have just uploaded the -01 version of the RG draft on Use Cases for In-Network Computing.
The most important changes are the following:

1. Xavier has kindly contributed his use case on virtual networks programming that he had presented at IETF-111.

2. We have regrouped the use cases to focus more explicitly on COIN and have restructured the draft accordingly.
In particular, the draft now discusses use cases that (i) provide new COIN experiences, (ii) support new COIN systems, (iii) improve existing COIN capabilities, and (iv) enable new COIN capabilities.

3. We laid the groundwork for a planned analysis that is intended to condense the research questions and requirements of the different use cases.
The overall goal is to identify aspects that are relevant across all use cases to help in shaping the research agenda of COINRG.
In this context, we have first streamlined the use case taxonomy and are currently in the process of making corresponding changes to the individual use cases before starting with the actual analysis.

As always, we are happy to hear your feedback and look forward to discussing the update at the next meeting.

Best,
Ike

On 25. Oct 2021, at 16:42, [email-masked]<mailto:[email-masked]> wrote:

Abstract:

--
Coin mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/coin