Subject: [Coin] Where to discuss Semantic Routing

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 9 Nov 2021 10:03:35 -0000

Hi COIN,

Some of us have been thinking a bit about a concept we are calling "Semantic
Routing". This is the process of enhancing normal packet routing by
considering additional information carried in packets (usually in the packet
headers) to enhance routing by forwarding the packets through links and
nodes best able to meet specific service requirements. It should be noted
that when we say "routing" we are focused on packet routing and not "service
routing" or the choice of transport paths.

There are three Internet-Drafts that provide some background:

https://datatracker.ietf.org/doc/html/draft-farrel-irtf-introduction-to-sema
ntic-routing/ gives an introduction to semantic routing. It is intended to
give readers an easy overview of what we're talking about when

we say "semantic routing" and to set up the information for a wider
discussion of the research challenges.

https://datatracker.ietf.org/doc/html/draft-king-irtf-challenges-in-routing/
sets out (some of) the challenges for the Internet routing infrastructure
introduced by semantic routing.

https://datatracker.ietf.org/doc/html/draft-king-irtf-semantic-routing-surve
y is an initial survey of semantic routing techniques.

In order to try to focus our discussions, we put together some text on
"motivations" and also a draft of what might be a charter if this work was
brought into the IRTF as a research group. See
https://github.com/danielkinguk/sarah/tree/main/RISE for those files. 

In early discussions, it has been suggested that this work might fall in
scope of COIN. So this email is to ask this list whether you are interested
in this work and consider that it is in scope or could be brought into
scope. Is it work you would like to see done in COIN?

Thanks for any thoughts or feedback.

Best,

Adrian

---

From: "David R. Oran" <[email-masked]>
Date: Tue, 09 Nov 2021 10:06:48 -0500

COINRG is currently focused on the kinds of computations done by 
applications (or at least higher-layer communication functions closely 
bound to application state) as opposed the the kinds of computations 
necessary to employ more complex routing and forwarding algorithms than 
are currently supported by conventional routers and/or switch ASICs.

To the extent that some of the enhanced routing/forwarding algorithms 
people envision might require computing infrastructure similar to that 
needed for application functions, there is potential overlap with some 
of the research COINRG is examining and promoting.

On the other hand, my sense is that COINRG already has an expansive 
charter, which would grow in a substantial way if we considered 
forwarding (and possibly also data plane aspects of routing) in scope. 
If we were to revisit charter issues for COINRG there are pretty 
reasonable arguments for actually narrowing it rather than expanding it.

My 2¢, for what it’s worth.

DaveO.

> -- 
> Coin mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/coin
DaveO

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 10 Nov 2021 15:33:52 +0100

+1.

More specifically, I see COIN focusing on how to make (what is from the PoV of routing mostly data plane) processing work, while it is not really the venue that discusses the wider implications of routing advances (the updates in the control plane, but also including *what* would be done on the data plane to support this, but not *how* that is implemented in routers — that would be COIN again).

Grüße, Carsten

> On 2021-11-09, at 16:06, David R. Oran <[email-masked]> wrote:
> 
> COINRG is currently focused on the kinds of computations done by applications (or at least higher-layer communication functions closely bound to application state) as opposed the the kinds of computations necessary to employ more complex routing and forwarding algorithms than are currently supported by conventional routers and/or switch ASICs.
> 
> To the extent that some of the enhanced routing/forwarding algorithms people envision might require computing infrastructure similar to that needed for application functions, there is potential overlap with some of the research COINRG is examining and promoting.
> 
> On the other hand, my sense is that COINRG already has an expansive charter, which would grow in a substantial way if we considered forwarding (and possibly also data plane aspects of routing) in scope. If we were to revisit charter issues for COINRG there are pretty reasonable arguments for actually narrowing it rather than expanding it.
> 
> Some of us have been thinking a bit about a concept we are calling "Semantic Routing". This is the process of enhancing normal packet routing by considering additional information carried in packets (usually in the packet headers) to enhance routing by forwarding the packets through links and nodes best able to meet specific service requirements. It should be noted that when we say “routing” we are focused on packet routing and not “service routing” or the choice of transport paths.
>  
> https://datatracker.ietf.org/doc/html/draft-farrel-irtf-introduction-to-semantic-routing/ gives an introduction to semantic routing. It is intended to give readers an easy overview of what we're talking about when
> we say "semantic routing" and to set up the information for a wider discussion of the research challenges.
>  
> https://datatracker.ietf.org/doc/html/draft-king-irtf-challenges-in-routing/ sets out (some of) the challenges for the Internet routing infrastructure introduced by semantic routing.
>  
> https://datatracker.ietf.org/doc/html/draft-king-irtf-semantic-routing-survey is an initial survey of semantic routing techniques.
>  
> In order to try to focus our discussions, we put together some text on “motivations” and also a draft of what might be a charter if this work was brought into the IRTF as a research group. See https://github.com/danielkinguk/sarah/tree/main/RISE for those files.
>  
> In early discussions, it has been suggested that this work might fall in scope of COIN. So this email is to ask this list whether you are interested in this work and consider that it is in scope or could be brought into scope. Is it work you would like to see done in COIN?
>