Subject: [Coin] Semantic routing at CON interim

From: "Adrian Farrel" <[email-masked]>
Date: Sun, 23 Jan 2022 20:21:52 -0000

Hi chairs,

Thanks for organising the interim. It certainly seems like it would be
helpful to assess what the RG is working on and what is out of scope.

Also, re-reading the charter recently, it looks like it could do with a bit
of a clean-up.

As you know, we recently discussed with the IRTF chair where the Semantic
Routing topic belongs, and he suggested we find a home in COIN. So we'd
appreciate taking some time in the interim to explain what Semantic Routing
is (and, equally important, what it is not). That should give the group a
good chance to decide what they want to work on and what they want to pass
on.

I think we might cover:

- Quick overview of what Semantic Routing is and isn't
- Pointers to some of the work that is being done related to Semantic
Routing (but nothing in depth)
- Describe how the use of programmable network elements is a component of
Semantic Routing, but is not the only possible solution
- Discuss how much "compute" is involved in the relatively dumb mapping of
packet fields to forwarding table in network devices
- Theorise about where the compute function in support of Semantic Routing
might take place and why

Then we could seed the discussion of what elements of Semantic Routing
Belong in COIN

I know that you have scheduled a two hour meeting, and that you will want to
carry some of that time for an open discussion of the scope and charter. I
also don't want to take away all of your agenda, but 30 minutes or so would
seem a reasonable time for a first introduction to the topic. (BTW, it
doesn't have to me talking the whole time, we can find plenty of people to
speak.)

For background, there are currently three drafts to look at:

http://datatracker.ietf.org/doc/draft-farrel-irtf-introduction-to-semantic-r
outing
This gives a background and overview of the concept of Semantic Routing.
Importantly, it spends a few pages saying what Semantic Routing is not.

https://datatracker.ietf.org/doc/draft-king-irtf-challenges-in-routing/ 
This provides a checklist of considerations to take into account when doing
any research into new approaches to routing and forwarding, but particularly
when considering different mechanisms for Semantic Routing.

https://datatracker.ietf.org/doc/draft-king-irtf-semantic-routing-survey/ 
This is a partial survey of prior work on routing and forwarding mechanisms
that might be classed as Semantic Routing.

We are currently working on a couple of additional documents. In particular,
we are looking at the applicability of SDN to Semantic Routing.

Best,
Adrian

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Sun, 23 Jan 2022 20:00:37 -0500

Thank you for your long email. See some comments below with <mjm?

Marie-José Montpetit, Ph.D.
[email-masked]

From: Adrian Farrel <[email-masked]> <[email-masked]>
Reply: [email-masked] <[email-masked]> <[email-masked]>
Date: January 23, 2022 at 3:22:06 PM
To: coinrg-chairs <[email-masked]> <[email-masked]>
Cc: [email-masked] <[email-masked]> <[email-masked]>
Subject:  Semantic routing at CON interim

Hi chairs,

<mjm> As a research group with the goal of creating a community around I
would say an organic view of the progress in the field of “in-network
computing” the group is constantly evolving. We know that anything that is
“standardization” or traditional routing is obviously out. But I agree that
as the field is expanding we will have to be careful to not support too
wide a scope.

<mjm> I love the world “clean-up” which means it’s currently and to a
certain point purposely messy. We are open to ideas. I would call it a
refinement more than a “clean-up” but I think I get what you mean.

<mjm> There has been a lot of discussion on this list and outside of it of
what about Semantic Routing is related to COIN. We welcome a presentation
but this is COIN so:

1. summarize what is related to COIN and what is not (see below)

2. present the research community that is studying the topic with you

I think we might cover:

<mjm> fine but if this is a COIN presentation the use of programmable is
important

<mjm> I think there were discussions about the "dumb mapping” on the list -
but mapping is one aspect of match-action and modifying header fields based
on that mapping is not just dumb -  I would not associate all “in network”
processing of packet to dumb functionality - look at some of the use cases.

<mjm> I think you should do most of the above on the list - and we could
agree on a presentation that focuses on the main aspects of your project.

<mjm> For the moment we are giving everyone 20 minutes hence the idea of
using the list to start the discussion.

outing

Best,
Adrian

<mjm> You should also know that as a research community we also favor
conference or journal papers if you have any.

<mjm> I will put you in the agenda for the interim.

mjm

---

From: Dirk Trossen <[email-masked]>
Date: Mon, 24 Jan 2022 08:23:42 +0000

Hi Marie-Jose,

Picking up on your suggest below on list discussions, I would solicit any feedback on my questions asked to the community in relation to the charter, its main thrust and how we may/should move forward.

Best,

Dirk

From: Coin [mailto:[email-masked]] On Behalf Of Marie-Jose Montpetit
Sent: 24 January 2022 02:01
To: [email-masked]; coinrg-chairs <[email-masked]>
Cc: [email-masked]
Subject: Re: [Coin] Semantic routing at CON interim

Marie-José Montpetit, Ph.D.
[email-masked]<mailto:[email-masked]>

From: Adrian Farrel <[email-masked]><mailto:[email-masked]>
Reply: [email-masked]<mailto:[email-masked]> <[email-masked]><mailto:[email-masked]>
Date: January 23, 2022 at 3:22:06 PM
To: coinrg-chairs <[email-masked]><mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]> <[email-masked]><mailto:[email-masked]>
Subject:  Semantic routing at CON interim

Hi chairs,

<mjm> As a research group with the goal of creating a community around I would say an organic view of the progress in the field of “in-network computing” the group is constantly evolving. We know that anything that is “standardization” or traditional routing is obviously out. But I agree that as the field is expanding we will have to be careful to not support too wide a scope.

<mjm> I love the world “clean-up” which means it’s currently and to a certain point purposely messy. We are open to ideas. I would call it a refinement more than a “clean-up” but I think I get what you mean.

<mjm> There has been a lot of discussion on this list and outside of it of what about Semantic Routing is related to COIN. We welcome a presentation but this is COIN so:

I think we might cover:

<mjm> fine but if this is a COIN presentation the use of programmable is important

<mjm> I think there were discussions about the "dumb mapping” on the list - but mapping is one aspect of match-action and modifying header fields based on that mapping is not just dumb -  I would not associate all “in network” processing of packet to dumb functionality - look at some of the use cases.

<mjm> I think you should do most of the above on the list - and we could agree on a presentation that focuses on the main aspects of your project.

<mjm> For the moment we are giving everyone 20 minutes hence the idea of using the list to start the discussion.

Best,
Adrian
<mjm> You should also know that as a research community we also favor conference or journal papers if you have any.

mjm

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 24 Jan 2022 11:48:58 -0000

Hi Marie-José,

Hi chairs, 

[AF] I think I agree with this. I hope that related standardisation efforts find space in the IETF. The challenge for us as a Research Group is to, as you say, not be too fixed, but evolve organically. At the same time, I think we have an overview scope of “compute in the network” and need to not (ridiculous example for the point of emphasis) develop a new experimental network configuration protocol “because it could be used in a network that supports compute in the network.”

[AF] One of the things that a group of us have been trying to put together is guidance to researchers on what aspects of the routing and forwarding system should be considered in research into changes to the routing and forwarding paradigms. Of course, our interest in this is mainly contained by discussion of semantic routing, but the principles apply across all routing research.

[AF] Well, I was specifically referring to the fact that the charter calls itself a “Proposed Charter:” and refers to the “PRG” (presumably “Proposed Research Group”). Almost three years (2019-3-13) since transitioning from a Proposed Research Group to an active Research Group, it might be time to fix up these nits.

[AF] Maybe the lack of milestones is indicative of something, too.

[AF] But these are all trivial items of “clean-up”, and the substance of our discussion needs to be much more about what the RG is working on. Particularly, is the word “compute” a cornerstone of everything the RG does?

[AF] Indeed. Although, I am not sure I am qualified to say what is related to COIN and what is not. I can tell you what Semantic Routing is. We all seem to be struggling to say what COIN is.

[AF] I *think* what you are saying is “show me that this isn’t just you, but that there is a community of people working in this area.” That way you’ll know that it is worth having work in the RG. I understand that desire although it is not consistent with “the goal of creating a community”. But it is easy enough to list some papers, mention some names, and point at recent conferences and workshop (SARNET-21 at IEEE HPSR-21, ICT-21, NIPAA-21). 

I think we might cover: 

[AF] That’s helpful, already. Thanks.

[AF] I believe that what you are saying is that those elements of Semantic Routing that do not use programmable network devices, is not in scope for COIN.

[AF] Yes, the use of “dumb” may have been a mistake. Sorry.

[AF] But, are you referring to use case of Semantic Routing, or use cases as described in draft-irtf-coinrg-use-cases? The difference here appears to be whether the forwarding device is “just” making a match from fields in the packet to specific forwarding actions, or whether the fields in the packet trigger more sophisticated processing. I tend to regard a look-up table as “dumb” even if that table is programmed from a sophisticated central controller, and even if the table is frequently updated by updates regarding network state. (After all, these are all components of a regular routing or TE system).

[AF] I’m happy to start some threads on these topics. I wouldn’t mind if they became conversations. To some extent I dislike talking to myself.

[AF] OK. Thanks. 20 minutes is better than 15 minutes 😊

[AF] Hopefully discussions on list will lead to the agenda slot being able to summarise some of the things that have been said.

Best, 
Adrian 

[AF] Sure

[AF] Many thanks

Adrian

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Mon, 24 Jan 2022 03:58:31 -0800

Thanks for this and yes we will edit the text (I thought I had done it).

mjm

From: Adrian Farrel <[email-masked]> <[email-masked]>
Reply: [email-masked] <[email-masked]> <[email-masked]>
Date: January 24, 2022 at 6:49:09 AM
To: Marie-Jose Montpetit <[email-masked]> <[email-masked]>,
coinrg-chairs <[email-masked]> <[email-masked]>
Cc: [email-masked] <[email-masked]> <[email-masked]>
Subject:  RE: Semantic routing at CON interim

Hi Marie-José,

Hi chairs,

[AF] I think I agree with this. I hope that related standardisation efforts
find space in the IETF. The challenge for us as a Research Group is to, as
you say, not be too fixed, but evolve organically. At the same time, I
think we have an overview scope of “compute in the network” and need to not
(ridiculous example for the point of emphasis) develop a new experimental
network configuration protocol “because it could be used in a network that
supports compute in the network.”

[AF] One of the things that a group of us have been trying to put together
is guidance to researchers on what aspects of the routing and forwarding
system should be considered in research into changes to the routing and
forwarding paradigms. Of course, our interest in this is mainly contained
by discussion of semantic routing, but the principles apply across all
routing research.

[AF] Well, I was specifically referring to the fact that the charter calls
itself a “Proposed Charter:” and refers to the “PRG” (presumably “Proposed
Research Group”). Almost three years (2019-3-13) since transitioning from a
Proposed Research Group to an active Research Group, it might be time to
fix up these nits.

[AF] But these are all trivial items of “clean-up”, and the substance of
our discussion needs to be much more about what the RG is working on.
Particularly, is the word “compute” a cornerstone of everything the RG does?

[AF] Indeed. Although, I am not sure I am qualified to say what is related
to COIN and what is not. I can tell you what Semantic Routing is. We all
seem to be struggling to say what COIN is.

[AF] I **think** what you are saying is “show me that this isn’t just you,
but that there is a community of people working in this area.” That way
you’ll know that it is worth having work in the RG. I understand that
desire although it is not consistent with “the goal of creating a
community”. But it is easy enough to list some papers, mention some names,
and point at recent conferences and workshop (SARNET-21 at IEEE HPSR-21,
ICT-21, NIPAA-21).

I think we might cover:

[AF] I believe that what you are saying is that those elements of Semantic
Routing that do not use programmable network devices, is not in scope for
COIN.

[AF] But, are you referring to use case of Semantic Routing, or use cases
as described in draft-irtf-coinrg-use-cases? The difference here appears to
be whether the forwarding device is “just” making a match from fields in
the packet to specific forwarding actions, or whether the fields in the
packet trigger more sophisticated processing. I tend to regard a look-up
table as “dumb” even if that table is programmed from a sophisticated
central controller, and even if the table is frequently updated by updates
regarding network state. (After all, these are all components of a regular
routing or TE system).

[AF] I’m happy to start some threads on these topics. I wouldn’t mind if
they became conversations. To some extent I dislike talking to myself.

[AF] Hopefully discussions on list will lead to the agenda slot being able
to summarise some of the things that have been said.

outing

Best,
Adrian

[AF] Sure

[AF] Many thanks

Adrian

---

From: Sharon Barkai <[email-masked]>
Date: Mon, 24 Jan 2022 14:10:38 +0200

Using couple themes brought up in this group as well as academic venues:

1. federated unified-sampling for anomaly learning-detection per application 
2. federated geolocation utilization-training per geospatial location and use

- App specific routing determines what gets processed where 
- This is achievable via the semantics of overlay addressing
- So programmability emerges by mapping and convention

Share-nothing federation of “addressable” problems allows the network to play such a role.
I believe (hope) the study of such constraints and implications are in the spirit of the charter.
The routing can mean the difference between solutions which are practical, or not economical.

Hope this makes sense.

> On Jan 24, 2022, at 13:58, Marie-Jose Montpetit <[email-masked]> wrote:
> 
> [email-masked] <mailto:[email-masked]>
> 
> 
> 
> From: Adrian Farrel <[email-masked]> <mailto:[email-masked]>
> Reply: [email-masked] <mailto:[email-masked]> <[email-masked]> <mailto:[email-masked]>
> To: Marie-Jose Montpetit <[email-masked]> <mailto:[email-masked]>, coinrg-chairs <[email-masked]> <mailto:[email-masked]>
> Cc: [email-masked] <mailto:[email-masked]> <[email-masked]> <mailto:[email-masked]>
>> http://datatracker.ietf.org/doc/draft-farrel-irtf-introduction-to-semantic-r <http://datatracker.ietf.org/doc/draft-farrel-irtf-introduction-to-semantic-r> 
>> outing 
>> https://datatracker.ietf.org/doc/draft-king-irtf-challenges-in-routing/ <https://datatracker.ietf.org/doc/draft-king-irtf-challenges-in-routing/> 
>> https://datatracker.ietf.org/doc/draft-king-irtf-semantic-routing-survey/ <https://datatracker.ietf.org/doc/draft-king-irtf-semantic-routing-survey/> 
> -- 
> Coin mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/coin

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 24 Jan 2022 12:49:29 -0000

Thanks, Sharon.

Do you have a pointer for more reading?

Your graphic here says “layering solves geolocation distribution” and your text says “this is achievable by the semantics of overlay addressing”. 

I am sympathetic to this solution because overlays are powerful (if not entirely a new concept ;-) and you can do a lot (as Scott Shenker points out in his Layer 3.5 Extensible Internet work {https://github.com/danielkinguk/sarah/tree/main/conferences/ietf-111}

But I just want to point out that this is a very limited subset of semantic routing. Yes, in your overlay network layer, you are placing information into the overlay addresses, and yes, you are routing in that layer based on those semantics. But semantic routing is much more interested in  adding semantics to IP packets and performing routing/forwarding of those packets in the IP layer based on those semantics.

However, I think your closing remark is very important: “the difference between solutions which are practical, or not economical.” This is a fundamental question in the development and deployment of semantic routing solutions. That is, while “fork-lift” network upgrades are possible and practical (and have happened), they rely on opportunity or, more likely, commercial imperatives. Overlays, on the other hand, are much easier to integrate into the living network.

Best,

Adrian

From: Sharon Barkai <[email-masked]> 
Sent: 24 January 2022 12:11
To: Marie-Jose Montpetit <[email-masked]>
Cc: [email-masked]; coinrg-chairs <[email-masked]>; [email-masked]
Subject: Re: [Coin] Semantic routing at CON interim

Hope this makes sense.

On Jan 24, 2022, at 13:58, Marie-Jose Montpetit <[email-masked] <mailto:[email-masked]> > wrote:

mjm

 

From: Adrian Farrel  <mailto:[email-masked]> <[email-masked]>
Reply: [email-masked] <mailto:[email-masked]>   <mailto:[email-masked]> <[email-masked]>
Date: January 24, 2022 at 6:49:09 AM
To: Marie-Jose Montpetit  <mailto:[email-masked]> <[email-masked]>, coinrg-chairs  <mailto:[email-masked]> <[email-masked]>
Cc: [email-masked] <mailto:[email-masked]>   <mailto:[email-masked]> <[email-masked]>
Subject:  RE: Semantic routing at CON interim 

Hi Marie-José,

Hi chairs, 

I think we might cover: 

Best, 
Adrian 

[AF] Sure

[AF] Many thanks

Adrian

-- 
Coin mailing list
[email-masked] <mailto:[email-masked]> 
https://www.irtf.org/mailman/listinfo/coin

---

From: Colin Perkins <[email-masked]>
Date: Mon, 24 Jan 2022 23:42:52 +0000

> On 24 Jan 2022, at 11:48, Adrian Farrel <[email-masked]> wrote:
> 
> Hi Marie-José,
>  
>> Hi chairs, 
>> 

That mostly indicates that the COINRG chairs sent me updated charter text in March 2020, which made it onto the website but not into the datatracker. I will fix that – I can only assume it got lost in amongst all the discussion of whether to cancel the in-person Vancouver IETF meeting that was happening at the same time.

> [AF] Maybe the lack of milestones is indicative of something, too.

There are milestones for COINRG listed in the datatracker. The IRTF website doesn’t list the milestones for any of the RGs; it’s not that well integrated with the datatracker.

That said, there's no requirement that RGs set milestones, and most of the current groups have not done so. Milestones make sense for IETF working groups, with focussed deliverables; they’re less useful for more open-ended research groups where the expected outcome is discussion and understanding.

Colin

---

From: Sharon Barkai <[email-masked]>
Date: Tue, 25 Jan 2022 08:34:33 +0200

Thanks Adrian,

I agree with your all your points bellow:

- overlays are as old as layering this is why i was surprised at the time when the open-flow team took the path of circuit switching for the control plane, rather than evolve session layer routing mechanisms. The notion of a “flow” though was key to both approaches to move forward 

- its always a challenge to strike a balance when conveying notions, especially in industry papers and RFCs, between simple to comprehend and real depth, especially when the basics are not yet common knowledge. The same chosen balance many times applies to different audiences for practical concerns as production effort continues 

- as an example will give one item concerning replication logic for application specific routing supporting hot standby and for implementing routing based map-reduce of mass amount of collected data, and publish-subscribe of changes, anomalies, and exceptions 

- i especially liked your comment regarding the “living network”, as all mechanisms to scale application specific programability of overlay routing, including mapping updates and lookups, as well as delegated steering logic, completely rely on fully functioning IP underlays

For further reading will point to:

https://datatracker.ietf.org/doc/html/draft-ietf-lisp-nexagon

--szb
Cell: +972.53.2470068
WhatsApp: +1.650.492.0794

> On Jan 24, 2022, at 14:49, Adrian Farrel <[email-masked]> wrote:
> 
> 
> Thanks, Sharon.
>  
> From: Adrian Farrel <[email-masked]>
> Reply: [email-masked] <[email-masked]>
> To: Marie-Jose Montpetit <[email-masked]>, coinrg-chairs <[email-masked]>
> Cc: [email-masked] <[email-masked]>