Subject: [Coin] Gap Analysis for Transport Protocol Issues Draft

From: Ike Kunze <[email-masked]>
Date: Mon, 17 Jan 2022 08:12:19 +0000

Hi all,

as discussed in our last meeting, we are actively looking for help in doing the gap analysis in the transport protocol issues draft.
In this context, Spencer had the suggestion to use GitHub issues to collect input and we have now set this up.

What are we looking for?
As outlined in Dirk’s presentation [1], we specifically look for help in doing the gap analysis.
For this, we have set up one issue for each of the technology areas and would like to collect thoughts on those aspects in the corresponding comments.
You can find the issues here: https://github.com/ike-kunze/transport-issues/issues?q=label%3AGapAnalysis+<https://github.com/ike-kunze/transport-issues/issues?q=label:GapAnalysis+>

If you have other comments or suggestions for the draft, e.g., regarding research questions, related concepts, ongoing efforts, etc. that we might have missed, please feel free to open new issues for those!
We are, of course, also happy to receive feedback via mail and will add that feedback to the issues ourselves.

You can find the latest draft version in the repository (.md/.txt, [2]) and in the datatracker (.txt/.html/.pdf, [3]).

Thanks in advance for your help!

Best,
Ike

[1] https://datatracker.ietf.org/meeting/112/materials/slides-112-coinrg-transport-protocol-issues-of-in-network-computing-systems-00.pdf
[2] https://github.com/ike-kunze/transport-issues/tree/main/version-05
[3] https://datatracker.ietf.org/doc/draft-kunze-coinrg-transport-issues/

---

From: Luigi Iannone <[email-masked]>
Date: Tue, 18 Jan 2022 09:29:45 +0100

Hi,

disclaimer: I did not read the draft but just had a look to dirk’s presentation!

Looking at the structure of the document I wonder whether it make sense to have « Privacy » as an additional Technology Areas, since privacy protection is mainly based on in-network operations that obfuscate your address (identity)?

Or may your plan is to cover this issue in section 3.1 Addressing?

Ciao

L.

> On 17 Jan 2022, at 09:12, Ike Kunze <[email-masked]> wrote:
> 
> Hi all,
> 
> You can find the issues here: https://github.com/ike-kunze/transport-issues/issues?q=label%3AGapAnalysis+ <https://github.com/ike-kunze/transport-issues/issues?q=label:GapAnalysis+>
> 
> [1] https://datatracker.ietf.org/meeting/112/materials/slides-112-coinrg-transport-protocol-issues-of-in-network-computing-systems-00.pdf <https://datatracker.ietf.org/meeting/112/materials/slides-112-coinrg-transport-protocol-issues-of-in-network-computing-systems-00.pdf>
> [2] https://github.com/ike-kunze/transport-issues/tree/main/version-05 <https://github.com/ike-kunze/transport-issues/tree/main/version-05>
> [3] https://datatracker.ietf.org/doc/draft-kunze-coinrg-transport-issues/ <https://datatracker.ietf.org/doc/draft-kunze-coinrg-transport-issues/>-- 
> Coin mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/coin

---

From: Dirk Trossen <[email-masked]>
Date: Tue, 18 Jan 2022 10:26:00 +0000

Hi Luigi,

Thanks for the pointer and a good point to be made, particularly when thinking how in-network computing could help here. 3.1 may be a place but I have the feeling that addressing this separately may be better and more suitable.

Would you have some particular thoughts to be included that you may be able to provide?

Best,

Dirk

From: Coin [mailto:[email-masked]] On Behalf Of Luigi Iannone
Sent: 18 January 2022 09:30
To: Ike Kunze <[email-masked]>
Cc: Dirk Trossen <[email-masked]>; [email-masked]
Subject: Re: [Coin] Gap Analysis for Transport Protocol Issues Draft

Hi,

Ciao

L.

On 17 Jan 2022, at 09:12, Ike Kunze <[email-masked]<mailto:[email-masked]>> wrote:

Hi all,

What are we looking for?

Best,
Ike

--
[email-masked]<mailto:[email-masked]>

---

From: Luigi Iannone <[email-masked]>
Date: Tue, 18 Jan 2022 12:06:03 +0100

Hi Dirk,

> On 18 Jan 2022, at 11:26, Dirk Trossen <[email-masked]> wrote:
> 
> Hi Luigi,
>  

Let me read the document to have a better idea of the type of content that you have in mind and I can certainly provide input on the privacy topic.

Ciao

L.

> On 17 Jan 2022, at 09:12, Ike Kunze <[email-masked] <mailto:[email-masked]>> wrote:
>  
> Hi all, 
>  
> [email-masked] <mailto:[email-masked]>
> https://www.irtf.org/mailman/listinfo/coin <https://www.irtf.org/mailman/listinfo/coin>