Subject: Re: [Coin] COIN interim February 10th 15:00 UTC

From: Dirk Trossen <[email-masked]>
Date: Tue, 1 Feb 2022 10:27:25 +0000

Dear chairs, all,

I want to come back to this email, which has not found much response – a bit to my surprise. Do I need to read from this that the (re-)charter of the RG is not on the radar of the RG at large and the chairs specifically?

On this, I was under the impression that the interim was arranged (largely?) for the purpose of a (re-)chartering discussion. For this, it would be good to receive some sort of draft for that renewed charter or at least some speaking points to discuss that may lead us to that (my email below meant to provide input from my side on this). Of course, I realize that those points should stem from the discussions we are having and the lack of those so far may be an issue on that. But I do feel that we have some points that need discussions beyond my own input.

More importantly, and coming back my point on why having the interim, I would like to understand if re-chartering indeed is a significant part of the interim’s agenda. For this, it would be good to share such agenda soon on the list.

Apologies for sounding impatient but having been an active member of this group so far, I’m highly interested where this group intends to go and I imagine so are others on this list.

Best,

Dirk

From: Coin [mailto:[email-masked]] On Behalf Of Dirk Trossen
Sent: 20 January 2022 09:01
To: Marie-Jose Montpetit <[email-masked]>; [email-masked]
Cc: coinrg-chairs <[email-masked]>; Colin Perkins <[email-masked]>
Subject: Re: [Coin] COIN interim February 10th 15:00 UTC

Hi Marie-Jose, all,

I hope you had a good start into 2022 and I wish you all the best moving into this new year!

Great to see the interim happening and thanks for kicking off the discussion on the charter. Let me try to outline a few thoughts defined through my current understanding of COIN, based on ongoing and past activities, with an intention to move forward.

Given the text below, specifically “general objective of this RG is to explore how the architecture can evolve to encompass a network that’s programmable enough to provide flexibility and extensibility for various use cases”, I can see three core parts of the charter:

A.     Formulate the vision and technologies for programmable networks (or ‘network is the computer’).

B.     Formulate distributed computing frameworks and languages to program the PN (or ‘network is the computer’) vision.

C.     Address the applicability of the former two to specific application areas

So far, activities around all three aspects have started (Dirk K’s draft, for instance, addressing items A and B) and some drafts on use cases, transport etc. When wanting to outline how to move forward, the following questions come to my mind:

1.      Do we agree that the first two items A and B are core to COIN albeit being a big story (in terms of activities) to tackle, particularly positioning this against how ‘in-network’ functions have been done so far (the dividing line MJM mentions below) and how it relates to, e.g., emerging edge computing?

2.      When addressing item C, i.e., wanting to tackle specific areas, should the approach be

a.      liaising with the many efforts in the IETF for doing so or

b.      pick a set of applicability areas?

If answering Q2.b positively, it poses additional questions on choice and scope, i.e., why picking specific applicability areas (over others) and if doing so, will we broaden the scope too much beyond working on the already challenging items A and B? Furthermore, do we have the constituency that we’d want to work on those selected applicability areas?

Best,

Dirk

From: Coin [mailto:[email-masked]] On Behalf Of Marie-Jose Montpetit
Sent: 16 January 2022 16:28
To: [email-masked]<mailto:[email-masked]>
Cc: coinrg-chairs <[email-masked]<mailto:[email-masked]>>; Colin Perkins <[email-masked]<mailto:[email-masked]>>
Subject: [Coin] COIN interim February 10th 15:00 UTC

Hello list and welcome to 2022!

There is a lot of activities in the realm of computing in the network as more an more previously closed network devices are becoming more programmable. We feel we need to dedicate an interim to how the charter of the group covers impacts of programmability: forwarding, routing, caching, in-network computation and packet processing.

We will send the Webex details but please note that the Interim is planned for February 10th at 15:00 UTC.

The chairs with the support of Colin did some preliminary brainstorming and agreed that one general objective of this RG is to explore how the architecture can evolve to encompass a network that’s programmable enough to provide flexibility and extensibility for various use cases - that seems to become more numerous each day.

The computation that leverage the programmable network devices, as well as in-flight computation that consumes data beyond the packet header are both topics that naturally fall within the group charter. A topic for debate is where is the dividing line between traditional packet header processing and COIN fall and what is the most important research towards systems and protocols. We feel that recent discussions on extensible Internet and semantic routing are just 2 aspects of this evolution towards the programmable network.

So mark the date and please suggest ideas for presentation highlighting the interesting research in the field.

mjm

Marie-José Montpetit, Ph.D.
[email-masked]<mailto:[email-masked]>

---

From: Colin Perkins <[email-masked]>
Date: Tue, 1 Feb 2022 10:46:46 +0000

Dirk,

Rechartering COINRG is not on the agenda.

The aim of the meeting, as I understand it, is partly to make progress with the research goals of the group, and partly to explore how, and to what extent, various topics that have been raised fit within the current charter.

Colin

> On 1 Feb 2022, at 10:27, Dirk Trossen <[email-masked]> wrote:
> 
> Dear chairs, all,
>  
> From: Coin [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Marie-Jose Montpetit
> To: [email-masked] <mailto:[email-masked]>
> Cc: coinrg-chairs <[email-masked] <mailto:[email-masked]>>; Colin Perkins <[email-masked] <mailto:[email-masked]>>
> [email-masked] <mailto:[email-masked]>

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Tue, 1 Feb 2022 06:41:15 -0500

Thanks Colin. Indeed re-chartering is not on the agenda (that we are
putting together) but yes to see how new ideas fit (or not).

mjm

[email-masked]

From: Colin Perkins <[email-masked]> <[email-masked]>
Reply: Colin Perkins <[email-masked]> <[email-masked]>
Date: February 1, 2022 at 5:47:08 AM
To: Dirk Trossen <[email-masked]> <[email-masked]>
Cc: Dirk Trossen <dirk.trossen=[email-masked]>
<dirk.trossen=[email-masked]>, Marie-Jose Montpetit
<[email-masked]> <[email-masked]>, [email-masked]
<[email-masked]> <[email-masked]>, coinrg-chairs <[email-masked]>
<[email-masked]>
Subject:  Re: [Coin] COIN interim February 10th 15:00 UTC

Dirk,

The aim of the meeting, as I understand it, is partly to make progress with
the research goals of the group, and partly to explore how, and to what
extent, various topics that have been raised fit within the current charter.

Colin

Dear chairs, all,

I want to come back to this email, which has not found much response – a
bit to my surprise. Do I need to read from this that the (re-)charter of
the RG is not on the radar of the RG at large and the chairs specifically?

On this, I was under the impression that the interim was arranged
(largely?) for the purpose of a (re-)chartering discussion. For this, it
would be good to receive some sort of draft for that renewed charter or at
least some speaking points to discuss that may lead us to that (my email
below meant to provide input from my side on this). Of course, I realize
that those points should stem from the discussions we are having and the
lack of those so far may be an issue on that. But I do feel that we have
some points that need discussions beyond my own input.

More importantly, and coming back my point on why having the interim, I
would like to understand if re-chartering indeed is a significant part of
the interim’s agenda. For this, it would be good to share such agenda soon
on the list.

Apologies for sounding impatient but having been an active member of this
group so far, I’m highly interested where this group intends to go and I
imagine so are others on this list.

Best,

Dirk

*From:* Coin [mailto:[email-masked] <[email-masked]>] *On
Behalf Of *Dirk Trossen
*Sent:* 20 January 2022 09:01
*To:* Marie-Jose Montpetit <[email-masked]>; [email-masked]
*Cc:* coinrg-chairs <[email-masked]>; Colin Perkins <
[email-masked]>
*Subject:* Re: [Coin] COIN interim February 10th 15:00 UTC

Hi Marie-Jose, all,

I hope you had a good start into 2022 and I wish you all the best moving
into this new year!

Great to see the interim happening and thanks for kicking off the
discussion on the charter. Let me try to outline a few thoughts defined
through my current understanding of COIN, based on ongoing and past
activities, with an intention to move forward.

Given the text below, specifically “general objective of this RG is to
explore how the architecture can evolve to encompass a network that’s
programmable enough to provide flexibility and extensibility for various
use cases”, I can see three core parts of the charter:
A.     Formulate the vision and technologies for programmable networks (or
‘network is the computer’).
B.     Formulate distributed computing frameworks and languages to program
the PN (or ‘network is the computer’) vision.
C.     Address the applicability of the former two to specific application
areas

So far, activities around all three aspects have started (Dirk K’s draft,
for instance, addressing items A and B) and some drafts on use cases,
transport etc. When wanting to outline how to move forward, the following
questions come to my mind:
1.      Do we agree that the first two items A and B are core to COIN
albeit being a big story (in terms of activities) to tackle, particularly
positioning this against how ‘in-network’ functions have been done so far
(the dividing line MJM mentions below) and how it relates to, e.g.,
emerging edge computing?
2.      When addressing item C, i.e., wanting to tackle specific areas,
should the approach be
a.      liaising with the many efforts in the IETF for doing so or
b.      pick a set of applicability areas?

If answering Q2.b positively, it poses additional questions on choice and
scope, i.e., why picking specific applicability areas (over others) and if
doing so, will we broaden the scope too much beyond working on the already
challenging items A and B? Furthermore, do we have the constituency that
we’d want to work on those selected applicability areas?

Best,

Dirk

*From:* Coin [mailto:[email-masked] <[email-masked]>] *On
Behalf Of *Marie-Jose Montpetit
*Sent:* 16 January 2022 16:28
*To:* [email-masked]
*Cc:* coinrg-chairs <[email-masked]>; Colin Perkins <
[email-masked]>
*Subject:* [Coin] COIN interim February 10th 15:00 UTC

There is a lot of activities in the realm of computing in the network as
more an more previously closed network devices are becoming more
programmable. We feel we need to dedicate an interim to how the charter of
the group covers impacts of programmability: forwarding, routing, caching,
in-network computation and packet processing.

We will send the Webex details but please note that the Interim is planned
for February 10th at 15:00 UTC.

The chairs with the support of Colin did some preliminary brainstorming and
agreed that one general objective of this RG is to explore how the
architecture can evolve to encompass a network that’s programmable enough
to provide flexibility and extensibility for various use cases - that seems
to become more numerous each day.

The computation that leverage the programmable network devices, as well as
in-flight computation that consumes data beyond the packet header are both
topics that naturally fall within the group charter. A topic for debate is
where is the dividing line between traditional packet header processing and
COIN fall and what is the most important research towards systems and
protocols. We feel that recent discussions on extensible Internet and
semantic routing are just 2 aspects of this evolution towards the
programmable network.

So mark the date and please suggest ideas for presentation highlighting the
interesting research in the field.

mjm

[email-masked]

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Tue, 1 Feb 2022 06:45:17 -0500

I saw Colin’s email before yours.

We are putting the agenda together with the goal of having some discussion
on various topics that may or may not fit the charter (Adrian’s work,
extensible Internet etc.) but not a re-charter or at least not yet. I
actually was expecting that you would make a presentation on your ideas
(independently of the on going draft) in order to follow-up on your on-list
discussions.

Let me know if that would be something you wish?

mjm

From: Dirk Trossen <[email-masked]> <[email-masked]>
Reply: Dirk Trossen <[email-masked]> <[email-masked]>
Date: February 1, 2022 at 5:27:27 AM
To: Dirk Trossen <dirk.trossen=[email-masked]>
<dirk.trossen=[email-masked]>, Marie-Jose Montpetit
<[email-masked]> <[email-masked]>, [email-masked]
<[email-masked]> <[email-masked]>
Cc: coinrg-chairs <[email-masked]> <[email-masked]>, Colin
Perkins <[email-masked]> <[email-masked]>
Subject:  RE: [Coin] COIN interim February 10th 15:00 UTC

Dear chairs, all,

Best,

Dirk

*From:* Coin [mailto:[email-masked]] *On Behalf Of *Dirk Trossen

Hi Marie-Jose, all,

Best,

Dirk

mjm

[email-masked]

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 1 Feb 2022 11:47:09 -0000

Hi Colin,

> Rechartering COINRG is not on the agenda.

I think you have the prerogative to tell the chairs that.

But we wait to see the agenda to see what is on it besides the three 20 minute slots we have heard about on the list.

At IETF-112 there was an agenda item (that fell off the bottom) marked “Interim to revisit the RG goals”. The chairs’ slides didn’t say much more than this, but obviously there was some confusion about the word “revisit” in this context. The confusion was not reduced by a thread on the COIN list in November that discussed the possible results of re-chartering (yes, I started that thread, but no one refuted it).

It would be also good if you could find some time to post the updated charter that you do have in hand. It’s not completely clear to the newer participants whether the changes are trivial editorials or points of substance, and without the most recent text in front of us it will be hard to address the questions of scope.

> The aim of the meeting, as I understand it, is partly to make progress

> with the research goals of the group, and partly to explore how, and

> to what extent, various topics that have been raised fit within the

> current charter.

If I understand you correctly, you are saying that you are happy with the wording of the charter that you have in hand, and that if interpretation of the wording of the charter shows something is out of scope, you prefer to rule out discussion of the topic at future meetings rather than modifying the charter to make it clear that it is in scope.

So, I think you are saying that the topics introduced at the meeting will be looked at to determine whether they fit within the current charter. If they do, the outcome is easy. If they don’t I presume the researchers involved must find other homes for their work.

Thanks,

Adrian

On 1 Feb 2022, at 10:27, Dirk Trossen <[email-masked] <mailto:[email-masked]> > wrote:

Dear chairs, all,

Best,

Dirk

From: Coin [mailto:[email-masked]] On Behalf Of Dirk Trossen
Sent: 20 January 2022 09:01
To: Marie-Jose Montpetit <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]> 
Cc: coinrg-chairs <[email-masked] <mailto:[email-masked]> >; Colin Perkins <[email-masked] <mailto:[email-masked]> >
Subject: Re: [Coin] COIN interim February 10th 15:00 UTC

Hi Marie-Jose, all,

Best,

Dirk

From: Coin [ <mailto:[email-masked]> mailto:[email-masked]] On Behalf Of Marie-Jose Montpetit
Sent: 16 January 2022 16:28
To:  <mailto:[email-masked]> [email-masked]
Cc: coinrg-chairs < <mailto:[email-masked]> [email-masked]>; Colin Perkins < <mailto:[email-masked]> [email-masked]>
Subject: [Coin] COIN interim February 10th 15:00 UTC

mjm

 <mailto:[email-masked]> [email-masked]

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Tue, 1 Feb 2022 06:54:33 -0500

Hi Adrian:

Re-chartering is not on the agenda because we don’t know if we need to. I
understand you and others feel that semantic routing needs either it’s own
RG or a major re-chartering of COIN but we (the chairs) have not concluded
that yet. So we have not asked Colin for a re-chartering (yet). Interims
are good for that: new work, new ideas :)

Let me quote you:

 If they do, the outcome is easy. If they don’t I presume the researchers
involved must find other homes for their work.

If they don’t:

1. we can discuss what is needed to maybe make them fit

2. see if there is a re-chartering that could accommodate the work.

3. You do find “homes” but I would not put that as a wished-for outcome

mjm

From: Adrian Farrel <[email-masked]> <[email-masked]>
Reply: [email-masked] <[email-masked]> <[email-masked]>
Date: February 1, 2022 at 6:47:37 AM
To: Colin Perkins <[email-masked]> <[email-masked]>, Dirk Trossen
<[email-masked]> <[email-masked]>
Cc: Marie-Jose Montpetit <[email-masked]> <[email-masked]>,
coinrg-chairs <[email-masked]> <[email-masked]>, Dirk
Trossen <dirk.trossen=[email-masked]>
<dirk.trossen=[email-masked]>, [email-masked] <[email-masked]>
<[email-masked]>
Subject:  RE: [Coin] COIN interim February 10th 15:00 UTC

Hi Colin,

At the risk of being seen as pedantic (although that should be a compliment

But we wait to see the agenda to see what is on it besides the three 20
minute slots we have heard about on the list.

At IETF-112 there was an agenda item (that fell off the bottom) marked
“Interim to revisit the RG goals”. The chairs’ slides didn’t say much
more than this, but obviously there was some confusion about the word
“revisit” in this context. The confusion was not reduced by a thread
on the COIN list in November that discussed the possible results of
re-chartering (yes, I started that thread, but no one refuted it).

It would be also good if you could find some time to post the updated
charter that you do have in hand. It’s not completely clear to the newer
participants whether the changes are trivial editorials or points of
substance, and without the most recent text in front of us it will be hard
to address the questions of scope.

> current charter.

If I understand you correctly, you are saying that you are happy with the
wording of the charter that you have in hand, and that if interpretation of
the wording of the charter shows something is out of scope, you prefer to
rule out discussion of the topic at future meetings rather than modifying
the charter to make it clear that it is in scope.

So, I think you are saying that the topics introduced at the meeting will
be looked at to determine whether they fit within the current charter. If
they do, the outcome is easy. If they don’t I presume the researchers
involved must find other homes for their work.

Thanks,

Adrian

Dear chairs, all,

Best,

Dirk

Hi Marie-Jose, all,

Best,

Dirk

mjm

[email-masked]

---

From: Colin Perkins <[email-masked]>
Date: Tue, 1 Feb 2022 12:06:23 +0000

> On 1 Feb 2022, at 11:47, Adrian Farrel <[email-masked]> wrote:
> 
> Hi Colin,
>  

The version of the charter on the IRTF website is up-to-date. That’s not yet reflected in the datatracker, but as you’ll see the differences are very minor.

> So, I think you are saying that the topics introduced at the meeting will be looked at to determine whether they fit within the current charter. If they do, the outcome is easy. If they don’t I pre…

As is usual, if the work is ruled out of scope for one of the existing research groups, then a conversation must be had to decide whether to change the scope of an existing group, to charter a new group, or to decide that the IRTF isn’t an appropriate home for the work.

Colin

---

From: Dirk Trossen <[email-masked]>
Date: Tue, 1 Feb 2022 12:27:05 +0000

Colin, all,

Thanks for the clarification and apologies for having misunderstood MJ’s original announcement to the interim as discussing the charter itself.

Nonetheless, I read your email below (hopefully correctly) that there is an intention to better understand on how to look at the various topics and how they relate to what COIN set out to do (as outlined in its charter), beyond making progress on various topics themselves.

If that is the case, please do see my original response to MJ’s announcement as my input into how to look at topics and work that is being brought to COIN. Particularly the relation between COIN and possible applicability areas is something I am very eager to better understand. This has an impact, for instance, on ongoing work like the ‘transport issues’ draft (something we as authors have been discussing in terms of progressing the work).

Hence, a discussion on how we bring the impact of the COIN vision to those areas possibly impacted by it is a crucial point of discussion I would like to see. Semantic routing here is only one other example but it is not alone here (e.g., the use case draft mentions a number of aspects, so does the already mentioned transport draft).

Best,

Dirk

From: Colin Perkins [mailto:[email-masked]]
Sent: 01 February 2022 11:47
To: Dirk Trossen <[email-masked]>
Cc: Dirk Trossen <dirk.trossen=[email-masked]>; Marie-Jose Montpetit <[email-masked]>; [email-masked]; coinrg-chairs <[email-masked]>
Subject: Re: [Coin] COIN interim February 10th 15:00 UTC

Dirk,

Colin

On 1 Feb 2022, at 10:27, Dirk Trossen <[email-masked]<mailto:[email-masked]>> wrote:

Dear chairs, all,

Best,

Dirk

To: Marie-Jose Montpetit <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>

Hi Marie-Jose, all,

Best,

Dirk

mjm

---

From: Dirk Trossen <[email-masked]>
Date: Tue, 1 Feb 2022 12:30:55 +0000

Hi Marie-Jose,

Lots of cross-traffic ;-)

When you say “I actually was expecting that you would make a presentation on your ideas (independently of the on going draft) in order to follow-up on your on-list discussions.”, I had originally hoped to have a list discussion around the original email.

But I’m happy to put those ideas into some material to discuss more at the interim itself, if you would find this useful.

Best,

Dirk

From: Marie-Jose Montpetit [mailto:[email-masked]]
Sent: 01 February 2022 12:45
To: Dirk Trossen <dirk.trossen=[email-masked]>; [email-masked]; Dirk Trossen <[email-masked]>
Cc: Colin Perkins <[email-masked]>; coinrg-chairs <[email-masked]>
Subject: RE: [Coin] COIN interim February 10th 15:00 UTC

We are putting the agenda together with the goal of having some discussion on various topics that may or may not fit the charter (Adrian’s work, extensible Internet etc.) but not a re-charter or at least not yet. I actually was expecting that you would make a presentation on your ideas (independently of the on going draft) in order to follow-up on your on-list discussions.

mjm

From: Dirk Trossen <[email-masked]><mailto:[email-masked]>
Reply: Dirk Trossen <[email-masked]><mailto:[email-masked]>
Date: February 1, 2022 at 5:27:27 AM
To: Dirk Trossen <dirk.trossen=[email-masked]><mailto:dirk.trossen=[email-masked]>, Marie-Jose Montpetit <[email-masked]><mailto:[email-masked]>, [email-masked]<mailto:[email-masked]> <[email-masked]><mailto:[email-masked]>
Cc: coinrg-chairs <[email-masked]><mailto:[email-masked]>, Colin Perkins <[email-masked]><mailto:[email-masked]>
Subject:  RE: [Coin] COIN interim February 10th 15:00 UTC

Dear chairs, all,

Best,

Dirk

From: Coin [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Dirk Trossen

Hi Marie-Jose, all,

Best,

Dirk

mjm

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Tue, 1 Feb 2022 07:42:16 -0500

I figured out a presentation would force more people to chime in :)

Thanks!

From: Dirk Trossen <[email-masked]> <[email-masked]>
Reply: Dirk Trossen <[email-masked]> <[email-masked]>
Date: February 1, 2022 at 7:30:57 AM
To: Marie-Jose Montpetit <[email-masked]> <[email-masked]>, Dirk
Trossen <dirk.trossen=[email-masked]>
<dirk.trossen=[email-masked]>, [email-masked] <[email-masked]>
<[email-masked]>
Cc: Colin Perkins <[email-masked]> <[email-masked]>, coinrg-chairs
<[email-masked]> <[email-masked]>
Subject:  RE: [Coin] COIN interim February 10th 15:00 UTC

Hi Marie-Jose,

When you say “I actually was expecting that you would make a presentation
on your ideas (independently of the on going draft) in order to follow-up
on your on-list discussions.”, I had originally hoped to have a list
discussion around the original email.

But I’m happy to put those ideas into some material to discuss more at the
interim itself, if you would find this useful.

Best,

Dirk

*From:* Marie-Jose Montpetit [mailto:[email-masked]]
*Sent:* 01 February 2022 12:45
*To:* Dirk Trossen <dirk.trossen=[email-masked]>; [email-masked];
Dirk Trossen <[email-masked]>
*Cc:* Colin Perkins <[email-masked]>; coinrg-chairs <
[email-masked]>
*Subject:* RE: [Coin] COIN interim February 10th 15:00 UTC

mjm

[email-masked]

Dear chairs, all,

Best,

Dirk

Hi Marie-Jose, all,

Best,

Dirk

mjm

[email-masked]

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Tue, 1 Feb 2022 07:44:23 -0500

Thanks for all the clarifications. Yes there are a lot of COIN aspects in
play...

BTW we intend to invite a presentation on transport to trigger discussion
on a yet to be fully addressed topic of the charter.

From: Dirk Trossen <[email-masked]> <[email-masked]>
Reply: Dirk Trossen <[email-masked]> <[email-masked]>
Date: February 1, 2022 at 7:27:07 AM
To: Colin Perkins <[email-masked]> <[email-masked]>
Cc: Dirk Trossen <dirk.trossen=[email-masked]>
<dirk.trossen=[email-masked]>, Marie-Jose Montpetit
<[email-masked]> <[email-masked]>, [email-masked]
<[email-masked]> <[email-masked]>, coinrg-chairs <[email-masked]>
<[email-masked]>
Subject:  RE: [Coin] COIN interim February 10th 15:00 UTC

Colin, all,

Thanks for the clarification and apologies for having misunderstood MJ’s
original announcement to the interim as discussing the charter itself.

Nonetheless, I read your email below (hopefully correctly) that there is an
intention to better understand on how to look at the various topics and how
they relate to what COIN set out to do (as outlined in its charter), beyond
making progress on various topics themselves.

If that is the case, please do see my original response to MJ’s
announcement as my input into how to look at topics and work that is being
brought to COIN. Particularly the relation between COIN and possible
applicability areas is something I am very eager to better understand. This
has an impact, for instance, on ongoing work like the ‘transport issues’
draft (something we as authors have been discussing in terms of progressing
the work).

Hence, a discussion on how we bring the impact of the COIN vision to those
areas possibly impacted by it is a crucial point of discussion I would like
to see. Semantic routing here is only one other example but it is not alone
here (e.g., the use case draft mentions a number of aspects, so does the
already mentioned transport draft).

Best,

Dirk

*From:* Colin Perkins [mailto:[email-masked]]
*Sent:* 01 February 2022 11:47
*To:* Dirk Trossen <[email-masked]>
*Cc:* Dirk Trossen <dirk.trossen=[email-masked]>; Marie-Jose
Montpetit <[email-masked]>; [email-masked]; coinrg-chairs <
[email-masked]>
*Subject:* Re: [Coin] COIN interim February 10th 15:00 UTC

Dirk,

Colin

Dear chairs, all,

Best,

Dirk

Hi Marie-Jose, all,

Best,

Dirk

mjm

[email-masked]

---

From: Dirk Trossen <[email-masked]>
Date: Tue, 1 Feb 2022 12:45:22 +0000

A discussion would be useful indeed. I’ll leave it to you where/when in the shaping-up agenda this may fit but happy to provide some strawman points for the sake of the wider discussion.

Dirk

Sent: 01 February 2022 13:42

Thanks!

From: Dirk Trossen <[email-masked]><mailto:[email-masked]>
Reply: Dirk Trossen <[email-masked]><mailto:[email-masked]>
Date: February 1, 2022 at 7:30:57 AM
To: Marie-Jose Montpetit <[email-masked]><mailto:[email-masked]>, Dirk Trossen <dirk.trossen=[email-masked]><mailto:dirk.trossen=[email-masked]>, [email-masked]<mailto:[email-masked]> <[email-masked]><mailto:[email-masked]>
Cc: Colin Perkins <[email-masked]><mailto:[email-masked]>, coinrg-chairs <[email-masked]><mailto:[email-masked]>
Subject:  RE: [Coin] COIN interim February 10th 15:00 UTC

Hi Marie-Jose,

Best,

Dirk

From: Marie-Jose Montpetit [mailto:[email-masked]<mailto:[email-masked]>]
Sent: 01 February 2022 12:45
To: Dirk Trossen <dirk.trossen=[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Dirk Trossen <[email-masked]<mailto:[email-masked]>>
Cc: Colin Perkins <[email-masked]<mailto:[email-masked]>>; coinrg-chairs <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Coin] COIN interim February 10th 15:00 UTC

mjm

Dear chairs, all,

Best,

Dirk

Hi Marie-Jose, all,

Best,

Dirk

mjm

---

From: Dirk Trossen <[email-masked]>
Date: Tue, 1 Feb 2022 12:49:49 +0000

Responded on the other part.

As for transport: the authors of the draft (Ike, Klaus and myself) would certainly like to see some discussion on how to progress. Not saying to do a presentation per se (we provided an update on the draft at the last IETF) but highlight that there’s an ongoing draft which looked at various aspects related to transport and COIN, and this work is certainly looking for contributors.

Not sure what you do have in mind on the presentation but there was a late request for presentation for IETF112 from one of the HotNets 2021 MTP paper co-authors; are you thinking of that? If so, would be very supportive of seeing this and we can maybe piggyback a slide at the end in reference to the transport draft (as mentioned before)!

Dirk

From: Marie-Jose Montpetit [mailto:[email-masked]]
Sent: 01 February 2022 13:44
To: Colin Perkins <[email-masked]>; Dirk Trossen <[email-masked]>
Cc: coinrg-chairs <[email-masked]>; [email-masked]; Dirk Trossen <dirk.trossen=[email-masked]>
Subject: RE: [Coin] COIN interim February 10th 15:00 UTC

Thanks for all the clarifications. Yes there are a lot of COIN aspects in play...

BTW we intend to invite a presentation on transport to trigger discussion on a yet to be fully addressed topic of the charter.

From: Dirk Trossen <[email-masked]><mailto:[email-masked]>
Reply: Dirk Trossen <[email-masked]><mailto:[email-masked]>
Date: February 1, 2022 at 7:27:07 AM
To: Colin Perkins <[email-masked]><mailto:[email-masked]>
Cc: Dirk Trossen <dirk.trossen=[email-masked]><mailto:dirk.trossen=[email-masked]>, Marie-Jose Montpetit <[email-masked]><mailto:[email-masked]>, [email-masked]<mailto:[email-masked]> <[email-masked]><mailto:[email-masked]>, coinrg-chairs <[email-masked]><mailto:[email-masked]>
Subject:  RE: [Coin] COIN interim February 10th 15:00 UTC

Colin, all,

Best,

Dirk

From: Colin Perkins [mailto:[email-masked]<mailto:[email-masked]>]
Sent: 01 February 2022 11:47
To: Dirk Trossen <[email-masked]<mailto:[email-masked]>>
Cc: Dirk Trossen <dirk.trossen=[email-masked]<mailto:[email-masked]>>; Marie-Jose Montpetit <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; coinrg-chairs <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Coin] COIN interim February 10th 15:00 UTC

Dirk,

Colin

Dear chairs, all,

Best,

Dirk

Hi Marie-Jose, all,

Best,

Dirk

mjm

---

From: Colin Perkins <[email-masked]>
Date: Tue, 1 Feb 2022 13:07:22 +0000

Dirk,

I would suggest that you should be approaching COINRG as a venue to discuss research ideas, rather than a place to progress drafts. IRTF research groups can publish RFCs, but working on drafts and publishing RFCs is not their main focus. 

Colin

> On 1 Feb 2022, at 12:27, Dirk Trossen <dirk.trossen=[email-masked]> wrote:
> 
> Colin, all,
>  
> On 1 Feb 2022, at 10:27, Dirk Trossen <[email-masked] <mailto:[email-masked]>> wrote:
>  
> Dear chairs, all,
>  
> From: Coin [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Dirk Trossen
> To: Marie-Jose Montpetit <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>
> -- 
> Coin mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/coin

-- 
Colin Perkins
https://csperkins.org/

---

From: Dirk Trossen <[email-masked]>
Date: Tue, 1 Feb 2022 13:11:27 +0000

Colin,

I understand that but documents like the use cases or transport issues are not aiming at RFCs in the sense of experimental specifications or similar but instead provide insights by looking at, e.g., requirements, challenges, impact of COIN on specific areas, etc.

It’s a ‘sense making’ and insights exercise that supports research as well as the impact of presented research on ongoing IETF activities; is this not within scope of the IRTF?

Best,

Dirk

From: Colin Perkins [mailto:[email-masked]]
Sent: 01 February 2022 14:07
To: Dirk Trossen <[email-masked]>
Cc: Marie-Jose Montpetit <[email-masked]>; coinrg-chairs <[email-masked]>; [email-masked]
Subject: Re: [Coin] COIN interim February 10th 15:00 UTC

Dirk,

Colin

On 1 Feb 2022, at 12:27, Dirk Trossen <dirk.trossen=[email-masked]<mailto:dirk.trossen=[email-masked]>> wrote:

Colin, all,

Best,

Dirk

Cc: Dirk Trossen <dirk.trossen=[email-masked]<mailto:dirk.trossen=[email-masked]>>; Marie-Jose Montpetit <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; coinrg-chairs <[email-masked]<mailto:[email-masked]>>

Dirk,

Colin

Dear chairs, all,

Best,

Dirk

Hi Marie-Jose, all,

Best,

Dirk

mjm

--
Coin mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/coin

--
Colin Perkins
https://csperkins.org/

---

From: Dirk Trossen <[email-masked]>
Date: Tue, 1 Feb 2022 13:13:42 +0000

…specifically I see charter item 4 supporting this work, i.e. “Research on potential new transport protocol, new privacy and security mechanisms required or enabled by in-network compute”

Or are you saying that purely the mechanisms themselves are desired here, not the identification of and need for them, stemming from insights on in-network computing?

Dirk

From: Dirk Trossen
Sent: 01 February 2022 14:11
To: 'Colin Perkins' <[email-masked]>
Cc: Marie-Jose Montpetit <[email-masked]>; coinrg-chairs <[email-masked]>; [email-masked]
Subject: RE: [Coin] COIN interim February 10th 15:00 UTC

Colin,

Best,

Dirk

Cc: Marie-Jose Montpetit <[email-masked]<mailto:[email-masked]>>; coinrg-chairs <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>

Dirk,

Colin

Colin, all,

Best,

Dirk

Dirk,

Colin

Dear chairs, all,

Best,

Dirk

Hi Marie-Jose, all,

Best,

Dirk

mjm

--
Colin Perkins
https://csperkins.org/

---

From: Colin Perkins <[email-masked]>
Date: Tue, 1 Feb 2022 14:00:05 +0000

My point was that COINRG is a research group, so the emphasis should be on discussion and fostering research collaborations, leading to results that can be published as research papers, rather than on progressing drafts.

Colin

> On 1 Feb 2022, at 13:13, Dirk Trossen <[email-masked]> wrote:
> 
> To: 'Colin Perkins' <[email-masked] <mailto:[email-masked]>>
> Cc: Marie-Jose Montpetit <[email-masked] <mailto:[email-masked]>>; coinrg-chairs <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>
> From: Colin Perkins [mailto:[email-masked] <mailto:[email-masked]>] 
> To: Dirk Trossen <[email-masked] <mailto:[email-masked]>>
> Cc: Marie-Jose Montpetit <[email-masked] <mailto:[email-masked]>>; coinrg-chairs <[email-masked] <mailto:[email-masked]>>;[email-masked] <mailto:[email-masked]>
> On 1 Feb 2022, at 12:27, Dirk Trossen <dirk.trossen=[email-masked] <mailto:dirk.trossen=[email-masked]>> wrote:
>  
> Colin, all,
>  
> From: Colin Perkins [mailto:[email-masked] <mailto:[email-masked]>] 
> To: Dirk Trossen <[email-masked] <mailto:[email-masked]>>
> Cc: Dirk Trossen <dirk.trossen=[email-masked] <mailto:dirk.trossen=[email-masked]>>; Marie-Jose Montpetit <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>; coinrg-chairs <[email-masked] <mailto:[email-masked]>>
> [email-masked] <mailto:[email-masked]>
> https://www.irtf.org/mailman/listinfo/coin <https://www.irtf.org/mailman/listinfo/coin>
>  
> 
> 
> -- 
> Colin Perkins
> https://csperkins.org/ <https://csperkins.org/>

-- 
Colin Perkins
https://csperkins.org/

---

From: Dirk Trossen <[email-masked]>
Date: Tue, 1 Feb 2022 14:45:34 +0000

Colin,

COIN is asking for that analysis (also looking at scope item 2 here), which is all about discussing and fostering research collaborations; I would argue that at least from my side, it’s a main driver doing the two exercises in the RG on use cases and transport.

Moreover, the use case analysis has gathered views and input from, right now, seven contributors and is therefore likely a significant collaborative effort in the COIN domain, one could argue. The fact that it’s using a notion of ‘draft’ to gather that input is merely one of vehicle of dissemination (and even that is temporary since we may decide to stick it into a paper in the end). So let’s not get stuck on what has a label of ‘draft’ attached and what is being presented in the form of a ‘paper’ but look at the analysis/input/result itself. It’s the latter that my email was originally.

Nonetheless, I’m just a bit puzzled that the notion of drafts is entirely removed from your view of an RG since it does not match with my experience in other RGs. If your guidance is to refrain from doing drafts and sticking, e.g., the use case analysis into a paper instead, then we can of course follow that. But I must say that I’m lacking a bit consistency here since I do see draft activity in other RGs, including pushing all the way to RFCs.

But regardless of outcome, I maintain that the activity and analysis here is still what is key and my statement below still applies even without being formulated with drafts in mind and text. I would argue that my entire email can be easily understood without any notion of draft or papers as specific ‘vehicles’ of dissemination in mind. So maybe we can focus on that part then and debate the vehicle to be used separately.

Best,

Dirk

Sent: 01 February 2022 15:00

Colin

On 1 Feb 2022, at 13:13, Dirk Trossen <[email-masked]<mailto:[email-masked]>> wrote:

Dirk

From: Dirk Trossen
Sent: 01 February 2022 14:11
To: 'Colin Perkins' <[email-masked]<mailto:[email-masked]>>
Cc: Marie-Jose Montpetit <[email-masked]<mailto:[email-masked]>>; coinrg-chairs <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Coin] COIN interim February 10th 15:00 UTC

Colin,

Best,

Dirk

Cc: Marie-Jose Montpetit <[email-masked]<mailto:[email-masked]>>; coinrg-chairs <[email-masked]<mailto:[email-masked]>>;[email-masked]<mailto:[email-masked]>

Dirk,

Colin

Colin, all,

Best,

Dirk

Dirk,

Colin

Dear chairs, all,

Best,

Dirk

Hi Marie-Jose, all,

Best,

Dirk

mjm

--
Colin Perkins
https://csperkins.org/

--
Colin Perkins
https://csperkins.org/

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Tue, 1 Feb 2022 09:49:33 -0500

I think we need to balance papers/drafts and I think we are aiming for that.

Actually I would claim that an Informational RFC is like a really good
publication since it will have been “peer reviewed” so we can’t no have any.

But to favor growth of the community we need to also foster research.

So it’s both in my POV.

mjm

From: Dirk Trossen <[email-masked]> <[email-masked]>
Reply: Dirk Trossen <[email-masked]> <[email-masked]>
Date: February 1, 2022 at 9:45:37 AM
To: Colin Perkins <[email-masked]> <[email-masked]>
Cc: Marie-Jose Montpetit <[email-masked]> <[email-masked]>,
coinrg-chairs <[email-masked]> <[email-masked]>,
[email-masked] <[email-masked]> <[email-masked]>
Subject:  RE: [Coin] COIN interim February 10th 15:00 UTC

Colin,

COIN is asking for that analysis (also looking at scope item 2 here), which
is all about discussing and fostering research collaborations; I would
argue that at least from my side, it’s a main driver doing the two
exercises in the RG on use cases and transport.

Moreover, the use case analysis has gathered views and input from, right
now, seven contributors and is therefore likely a significant collaborative
effort in the COIN domain, one could argue. The fact that it’s using a
notion of ‘draft’ to gather that input is merely one of vehicle of
dissemination (and even that is temporary since we may decide to stick it
into a paper in the end). So let’s not get stuck on what has a label of
‘draft’ attached and what is being presented in the form of a ‘paper’ but
look at the analysis/input/result itself. It’s the latter that my email was
originally.

Nonetheless, I’m just a bit puzzled that the notion of drafts is entirely
removed from your view of an RG since it does not match with my experience
in other RGs. If your guidance is to refrain from doing drafts and
sticking, e.g., the use case analysis into a paper instead, then we can of
course follow that. But I must say that I’m lacking a bit consistency here
since I do see draft activity in other RGs, including pushing all the way
to RFCs.

But regardless of outcome, I maintain that the activity and analysis here
is still what is key and my statement below still applies even without
being formulated with drafts in mind and text. I would argue that my entire
email can be easily understood without any notion of draft or papers as
specific ‘vehicles’ of dissemination in mind. So maybe we can focus on that
part then and debate the vehicle to be used separately.

Best,

Dirk

*From:* Colin Perkins [mailto:[email-masked]]
*Sent:* 01 February 2022 15:00
*To:* Dirk Trossen <[email-masked]>
*Cc:* Marie-Jose Montpetit <[email-masked]>; coinrg-chairs <
[email-masked]>; [email-masked]
*Subject:* Re: [Coin] COIN interim February 10th 15:00 UTC

My point was that COINRG is a research group, so the emphasis should be on
discussion and fostering research collaborations, leading to results that
can be published as research papers, rather than on progressing drafts.

Colin

…specifically I see charter item 4 supporting this work, i.e. “Research on
potential new transport protocol, new privacy and security mechanisms
required or enabled by in-network compute”

Or are you saying that purely the mechanisms themselves are desired here,
not the identification of and need for them, stemming from insights on
in-network computing?

Dirk

*From:* Dirk Trossen
*Sent:* 01 February 2022 14:11
*To:* 'Colin Perkins' <[email-masked]>
*Cc:* Marie-Jose Montpetit <[email-masked]>; coinrg-chairs <
[email-masked]>; [email-masked]
*Subject:* RE: [Coin] COIN interim February 10th 15:00 UTC

Colin,

I understand that but documents like the use cases or transport issues are
not aiming at RFCs in the sense of experimental specifications or similar
but instead provide insights by looking at, e.g., requirements, challenges,
impact of COIN on specific areas, etc.

It’s a ‘sense making’ and insights exercise that supports research as well
as the impact of presented research on ongoing IETF activities; is this not
within scope of the IRTF?

Best,

Dirk

*From:* Colin Perkins [mailto:[email-masked] <[email-masked]>]
*Sent:* 01 February 2022 14:07
*To:* Dirk Trossen <[email-masked]>
*Cc:* Marie-Jose Montpetit <[email-masked]>; coinrg-chairs <
[email-masked]>;[email-masked]
*Subject:* Re: [Coin] COIN interim February 10th 15:00 UTC

Dirk,

I would suggest that you should be approaching COINRG as a venue to discuss
research ideas, rather than a place to progress drafts. IRTF research
groups can publish RFCs, but working on drafts and publishing RFCs is not
their main focus.

Colin

On 1 Feb 2022, at 12:27, Dirk Trossen <
dirk.trossen=[email-masked]> wrote:

Colin, all,

Best,

Dirk

*From:* Colin Perkins [mailto:[email-masked] <[email-masked]>]

Dirk,

Colin

Dear chairs, all,

Best,

Dirk

Hi Marie-Jose, all,

Best,

Dirk

mjm

[email-masked]

-- 
Colin Perkins
https://csperkins.org/

-- 
Colin Perkins
https://csperkins.org/

---

From: Dirk Trossen <[email-masked]>
Date: Tue, 1 Feb 2022 14:55:52 +0000

Marie-Jose, all,

As I tried to point out, the vehicle of dissemination is secondary. I believe that you can read my points without having the notion of a ‘draft’ in mind (and I’m happy to withhold any notion of draft in future emails if mentioning them confuses the reader).

Right now, those ‘drafts’ are write-ups, similar to paper drafts, just using IETF templates. Stick it into an IEEE one and it becomes more acceptable? That really can’t be. What I tried to formulate was a way forward to bring research onto the stage but also foster analysis and linkage to other activities, all falling in line with the idea of increasing collaboration (not in research but also maybe exposing research to operational insights, one of the strong points I see in doing this in conjunction with the IETF). What label of dissemination we stick on it later is really secondary although it may be important to consider once you get to the stage (e.g., an informational RFC may be a good vehicle if you want to address a community like the IETF with insights).

So maybe we can agree to talk the things here as topics and leave the vehicle of dissemination for the stage when it comes close to readiness.

Best,

Dirk

From: Marie-Jose Montpetit [mailto:[email-masked]]
Sent: 01 February 2022 15:50
To: Colin Perkins <[email-masked]>; Dirk Trossen <[email-masked]>
Cc: [email-masked]; coinrg-chairs <[email-masked]>
Subject: RE: [Coin] COIN interim February 10th 15:00 UTC

Actually I would claim that an Informational RFC is like a really good publication since it will have been “peer reviewed” so we can’t no have any.

So it’s both in my POV.

mjm

Cc: Marie-Jose Montpetit <[email-masked]><mailto:[email-masked]>, coinrg-chairs <[email-masked]><mailto:[email-masked]>, [email-masked]<mailto:[email-masked]> <[email-masked]><mailto:[email-masked]>

Colin,

Best,

Dirk

Colin

Dirk

From: Dirk Trossen

Colin,

Best,

Dirk

Dirk,

Colin

Colin, all,

Best,

Dirk

Dirk,

Colin

Dear chairs, all,

Best,

Dirk

Hi Marie-Jose, all,

Best,

Dirk

mjm

--
Colin Perkins
https://csperkins.org/

--
Colin Perkins
https://csperkins.org/

---

From: Colin Perkins <[email-masked]>
Date: Tue, 1 Feb 2022 15:59:28 +0000

Dirk,

Research is about a journey, engineering is about a destination. You appear to be approaching the chartering discussion as-if this was an engineering group. I’m reminding you that it is not. 

Colin

> On 1 Feb 2022, at 14:45, Dirk Trossen <[email-masked]> wrote:
> 
> Colin,
>  
> On 1 Feb 2022, at 13:13, Dirk Trossen <[email-masked] <mailto:[email-masked]>> wrote:
>

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Tue, 1 Feb 2022 11:28:37 -0500

And since I have always done engineering research I am on a journey to a destination (and sometimes not the one originally planned).

Keep the discussion going (keep walking).

mjm

Marie-José Montpetit, Ing. Ph.D.

> On Feb 1, 2022, at 10:59 AM, Colin Perkins <[email-masked]> wrote:
> 
> Dirk,
> 
>> Cc: Marie-Jose Montpetit <[email-masked]>; coinrg-chairs <[email-masked]>;[email-masked]
>> To: [email-masked]

---

From: Dirk Trossen <[email-masked]>
Date: Tue, 1 Feb 2022 16:29:28 +0000

Colin,

I’m a bit puzzled here. What in my mail makes you characterize my approach as engineering? Performance of a use case analysis (if so, that analysis is part of the charter of COIN)? The fact that some of us are trying to outline issues in transport that COIN may bring (and/or address) – another part of the charter? The fact that I’m trying to rationalize those things that may be in scope of somewhat outside (or merely linked)? I don’t see the engineering (vs, I assume, the research) approach.

I would appreciate if you linked your statements back to what I said, even for the mere benefit in helping me out here. Generally, I find the reminder that COIN is a research group not particularly useful, to say the least.

Best,

Dirk

Sent: 01 February 2022 16:59

Dirk,

Colin

On 1 Feb 2022, at 14:45, Dirk Trossen <[email-masked]<mailto:[email-masked]>> wrote:

Colin,

Best,

Dirk

Colin

Dirk

From: Dirk Trossen

Colin,

Best,

Dirk

Dirk,

Colin

Colin, all,

Best,

Dirk

Dirk,

Colin

Dear chairs, all,

Best,

Dirk

Hi Marie-Jose, all,

Best,

Dirk

mjm

---

From: "David R. Oran" <[email-masked]>
Date: Tue, 01 Feb 2022 11:37:40 -0500

…at the risk of prolonging a philosophical discussion that may not be 
helping to move things forward:

While I do agree mostly with the characterization around journey versus 
destination, a sufficiently abstract destination or one with no proven 
paths to success is also research (e.g. cure blood cancers with 
genetically engineered T cells).

A different formulation I tend to prefer (and used to good effect in my 
industrial research career) is:

“Research involves building artifacts in order to obtain knowledge; 
engineering involves gaining knowledge in order to build artifacts.”

So, I think the main thrust of COINRG should be advancing knowledge; not 
making specifications for particular artifacts (or classes of artifact).

Cheers, DaveO.

On 1 Feb 2022, at 11:28, Marie-Jose Montpetit wrote:

> And since I have always done engineering research I am on a journey to 
> a destination (and sometimes not the one originally planned).
>
>> Research is about a journey, engineering is about a destination. You 
>> appear to be approaching the chartering discussion as-if this was an 
>> engineering group. I’m reminding you that it is not.
>>
>> Colin
>>
>>
>>
>>
>>> COIN is asking for that analysis (also looking at scope item 2 
>>> here), which is all about discussing and fostering research 
>>> collaborations; I would argue that at least from my side, it’s a 
>>> main driver doing the two exercises in the RG on use cases and 
>>> transport.
>>>
>>> Moreover, the use case analysis has gathered views and input from, 
>>> right now, seven contributors and is therefore likely a significant 
>>> collaborative effort in the COIN domain, one could argue. The fact 
>>> that it’s using a notion of ‘draft’ to gather that input is 
>>> merely one of vehicle of dissemination (and even that is temporary 
>>> since we may decide to stick it into a paper in the end). So let’s 
>>> not get stuck on what has a label of ‘draft’ attached and what 
>>> is being presented in the form of a ‘paper’ but look at the 
>>> analysis/input/result itself. It’s the latter that my email was 
>>> originally.
>>>
>>> Nonetheless, I’m just a bit puzzled that the notion of drafts is 
>>> entirely removed from your view of an RG since it does not match 
>>> with my experience in other RGs. If your guidance is to refrain from 
>>> doing drafts and sticking, e.g., the use case analysis into a paper 
>>> instead, then we can of course follow that. But I must say that 
>>> I’m lacking a bit consistency here since I do see draft activity 
>>> in other RGs, including pushing all the way to RFCs.
>>>
>>> But regardless of outcome, I maintain that the activity and analysis 
>>> here is still what is key and my statement below still applies even 
>>> without being formulated with drafts in mind and text. I would argue 
>>> that my entire email can be easily understood without any notion of 
>>> draft or papers as specific ‘vehicles’ of dissemination in mind. 
>>> So maybe we can focus on that part then and debate the vehicle to be 
>>> used separately.
>>>
>>> Best,
>>>
>>> Dirk
>>>
>>> My point was that COINRG is a research group, so the emphasis should 
>>> be on discussion and fostering research collaborations, leading to 
>>> results that can be published as research papers, rather than on 
>>> progressing drafts.
>>>
>>> Colin
>>>
>>>
>>>
>>> …specifically I see charter item 4 supporting this work, i.e. 
>>> “Research on potential new transport protocol, new privacy and 
>>> security mechanisms required or enabled by in-network compute”
>>>
>>> Or are you saying that purely the mechanisms themselves are desired 
>>> here, not the identification of and need for them, stemming from 
>>> insights on in-network computing?
>>>
>>> Dirk
>>>
>>> From: Dirk Trossen
>>> I understand that but documents like the use cases or transport 
>>> issues are not aiming at RFCs in the sense of experimental 
>>> specifications or similar but instead provide insights by looking 
>>> at, e.g., requirements, challenges, impact of COIN on specific 
>>> areas, etc.
>>>
>>> It’s a ‘sense making’ and insights exercise that supports 
>>> research as well as the impact of presented research on ongoing IETF 
>>> activities; is this not within scope of the IRTF?
>>>
>>> Best,
>>>
>>> Dirk
>>>
>>> I would suggest that you should be approaching COINRG as a venue to 
>>> discuss research ideas, rather than a place to progress drafts. IRTF 
>>> research groups can publish RFCs, but working on drafts and 
>>> publishing RFCs is not their main focus.
>>>
>>> Colin
>>>
>>>
>>>
>>>
>>>
>>> On 1 Feb 2022, at 12:27, Dirk Trossen 
>>> <dirk.trossen=[email-masked]> wrote:
>>>
>>> Colin, all,
>>>
>>> Thanks for the clarification and apologies for having misunderstood 
>>> MJ’s original announcement to the interim as discussing the 
>>> charter itself.
>>>
>>> Nonetheless, I read your email below (hopefully correctly) that 
>>> there is an intention to better understand on how to look at the 
>>> various topics and how they relate to what COIN set out to do (as 
>>> outlined in its charter), beyond making progress on various topics 
>>> themselves.
>>>
>>> announcement as my input into how to look at topics and work that is 
>>> being brought to COIN. Particularly the relation between COIN and 
>>> possible applicability areas is something I am very eager to better 
>>> understand. This has an impact, for instance, on ongoing work like 
>>> the ‘transport issues’ draft (something we as authors have been 
>>> discussing in terms of progressing the work).
>>>
>>> Hence, a discussion on how we bring the impact of the COIN vision to 
>>> those areas possibly impacted by it is a crucial point of discussion 
>>> I would like to see. Semantic routing here is only one other example 
>>> but it is not alone here (e.g., the use case draft mentions a number 
>>> of aspects, so does the already mentioned transport draft).
>>>
>>> Best,
>>>
>>> Dirk
>>>
>>> Cc: Dirk Trossen <dirk.trossen=[email-masked]>; 
>>> Marie-Jose Montpetit <[email-masked]>; [email-masked]; 
>>> coinrg-chairs <[email-masked]>
>>> The aim of the meeting, as I understand it, is partly to make 
>>> progress with the research goals of the group, and partly to explore 
>>> how, and to what extent, various topics that have been raised fit 
>>> within the current charter.
>>>
>>> Colin
>>>
>>>
>>>
>>>
>>>
>>>
>>> I want to come back to this email, which has not found much response 
>>> – a bit to my surprise. Do I need to read from this that the 
>>> (re-)charter of the RG is not on the radar of the RG at large and 
>>> the chairs specifically?
>>>
>>> (largely?) for the purpose of a (re-)chartering discussion. For 
>>> this, it would be good to receive some sort of draft for that 
>>> renewed charter or at least some speaking points to discuss that may 
>>> lead us to that (my email below meant to provide input from my side 
>>> on this). Of course, I realize that those points should stem from 
>>> the discussions we are having and the lack of those so far may be an 
>>> issue on that. But I do feel that we have some points that need 
>>> discussions beyond my own input.
>>>
>>> More importantly, and coming back my point on why having the 
>>> interim, I would like to understand if re-chartering indeed is a 
>>> significant part of the interim’s agenda. For this, it would be 
>>> good to share such agenda soon on the list.
>>>
>>> Apologies for sounding impatient but having been an active member of 
>>> this group so far, I’m highly interested where this group intends 
>>> to go and I imagine so are others on this list.
>>>
>>> Best,
>>>
>>> Dirk
>>>
>>> discussion on the charter. Let me try to outline a few thoughts 
>>> defined through my current understanding of COIN, based on ongoing 
>>> and past activities, with an intention to move forward.
>>>
>>> Given the text below, specifically “general objective of this RG 
>>> is to explore how the architecture can evolve to encompass a network 
>>> that’s programmable enough to provide flexibility and 
>>> extensibility for various use cases”, I can see three core parts 
>>> of the charter:
>>> B.     Formulate distributed computing frameworks and languages to 
>>> program the PN (or ‘network is the computer’) vision.
>>> So far, activities around all three aspects have started (Dirk K’s 
>>> draft, for instance, addressing items A and B) and some drafts on 
>>> use cases, transport etc. When wanting to outline how to move 
>>> forward, the following questions come to my mind:
>>> 1.      Do we agree that the first two items A and B are core to 
>>> COIN albeit being a big story (in terms of activities) to tackle, 
>>> particularly positioning this against how ‘in-network’ functions 
>>> have been done so far (the dividing line MJM mentions below) and how 
>>> it relates to, e.g., emerging edge computing?
>>> If answering Q2.b positively, it poses additional questions on 
>>> choice and scope, i.e., why picking specific applicability areas 
>>> (over others) and if doing so, will we broaden the scope too much 
>>> beyond working on the already challenging items A and B? 
>>> Furthermore, do we have the constituency that we’d want to work on 
>>> those selected applicability areas?
>>>
>>> Best,
>>>
>>> Dirk
>>>
>>> There is a lot of activities in the realm of computing in the 
>>> network as more an more previously closed network devices are 
>>> becoming more programmable. We feel we need to dedicate an interim 
>>> to how the charter of the group covers impacts of programmability: 
>>> forwarding, routing, caching, in-network computation and packet 
>>> processing.
>>>
>>> The chairs with the support of Colin did some preliminary 
>>> brainstorming and agreed that one general objective of this RG is to 
>>> explore how the architecture can evolve to encompass a network 
>>> that’s programmable enough to provide flexibility and 
>>> extensibility for various use cases - that seems to become more 
>>> numerous each day.
>>>
>>> The computation that leverage the programmable network devices, as 
>>> well as in-flight computation that consumes data beyond the packet 
>>> header are both topics that naturally fall within the group charter. 
>>> A topic for debate is where is the dividing line between traditional 
>>> packet header processing and COIN fall and what is the most 
>>> important research towards systems and protocols. We feel that 
>>> recent discussions on extensible Internet and semantic routing are 
>>> just 2 aspects of this evolution towards the programmable network.
>>>
>>> So mark the date and please suggest ideas for presentation 
>>> highlighting the interesting research in the field.
>>>
>>> mjm
>>>

---

From: "David R. Oran" <[email-masked]>
Date: Tue, 01 Feb 2022 11:43:51 -0500

> I’m a bit puzzled here. What in my mail makes you characterize my approach as engineering? Performance of a use case analysis (if so, that analysis is part of the charter of COIN)? The fact that so…
Use cases can be part of either a research or engineering endeavor. From an engineering perspective, they are (mostly) used to decide which features to include or not include in a given artifact/product so that the artifact successfully addresses a particular market. In research, use cases are valuable in order to identify which measures of success could/should be used to evaluate the the (relative) success of a given approach.

So, for me it isn’t so much whether we do work on use cases in COINRG, but rather what exactly “conclusions” are proposed by looking at a use case, and whether useful measures/metrics emerge that can be applied to the evaluations of technical approaches in future research.

> Cc: Marie-Jose Montpetit <[email-masked]<mailto:[email-masked]>> ; coinrg-chairs <[email-masked]<mailto:[email-masked]>> ; [email-masked]<mailto:[email-masked]>
> Cc: Marie-Jose Montpetit <[email-masked]<mailto:[email-masked]>> ; coinrg-chairs <[email-masked]<mailto:[email-masked]>> ; [email-masked]<mailto:[email-masked]>
> Cc: Marie-Jose Montpetit <[email-masked]<mailto:[email-masked]>> ; coinrg-chairs <[email-masked]<mailto:[email-masked]>> ;[email-masked]<mailto:[email-masked]>
> Cc: Dirk Trossen <dirk.trossen=[email-masked]<mailto:dirk.trossen=[email-masked]>> ; Marie-Jose Montpetit <[email-masked]<mailto:[email-masked]>> ; [email-masked]<mailto:[email-masked]> ; coinrg-chairs <[email-masked]<mailto:[email-masked]>>
> To: Marie-Jose Montpetit <[email-masked]<mailto:[email-masked]>> ; [email-masked]<mailto:[email-masked]>
> Cc: coinrg-chairs <[email-masked]<mailto:[email-masked]>> ; Colin Perkins <[email-masked]<mailto:[email-masked]>>
> Cc: coinrg-chairs <[email-masked]<mailto:[email-masked]>> ; Colin Perkins <[email-masked]<mailto:[email-masked]>>

DaveO

---

From: Dirk Trossen <[email-masked]>
Date: Tue, 1 Feb 2022 16:47:57 +0000

-----Original Message-----
From: David R. Oran [mailto:[email-masked]] 
Sent: 01 February 2022 17:44
To: Dirk Trossen <[email-masked]>
Cc: Colin Perkins <[email-masked]>; Marie-Jose Montpetit <[email-masked]>; coinrg-chairs <[email-masked]>; [email-masked]
Subject: Re: [Coin] COIN interim February 10th 15:00 UTC

[DOT] Which aspect do you think the current use cases document covers? 

[DOT] that is the analysis part of the use case work that is exactly at the heart of progressing the relevant document (call it draft due to the template used for it). I would like to see the same for the transport draft although right now, I would want to see more contributors to the work.

DaveO

---

From: Jon Crowcroft <[email-masked]>
Date: Tue, 1 Feb 2022 17:05:44 +0000

what is in the realm of coin....?

to be honest, an RFC is of no use to many researchers in some
countries as a research output as it isn't recognized (typically same
countries that don't appoint or promote academics without lots of
journal papers as conferences (like nsdi/sigcom/mobicom/sosp) don't
count....

meanwhile, can't see why stuff isnt already covered by "Research on
novel architectures, data-plane abstractions and new network protocol
designs to efficiently federate decentralized computing resources,
across the infrastructure regardless of where in the network the
compute is placed (the DC, the core, the edge, and even in the
end-user devices)." in current charter, which is pretty broad.

---

From: Dirk Trossen <[email-masked]>
Date: Tue, 1 Feb 2022 16:48:52 +0000

Dave,

Thanks, appreciate that intervention but makes me even less understand Colin’s interpretation of my approach to the discussion.

But your characterization below links to a key part of my original email: how shall we link our advanced knowledge with those who aim to apply that knowledge (i.e. the communities working on areas like transport, routing, and others), i.e. the third point my list of my email? What I’m still failing to see is the engineering approach that Colin seems to have seen.

Best,

Dirk

From: David R. Oran [mailto:[email-masked]]
Sent: 01 February 2022 17:38
To: Marie-Jose Montpetit <[email-masked]>
Cc: Colin Perkins <[email-masked]>; Dirk Trossen <[email-masked]>; [email-masked]
Subject: Re: [Coin] COIN interim February 10th 15:00 UTC

…at the risk of prolonging a philosophical discussion that may not be helping to move things forward:

While I do agree mostly with the characterization around journey versus destination, a sufficiently abstract destination or one with no proven paths to success is also research (e.g. cure blood cancers with genetically engineered T cells).

A different formulation I tend to prefer (and used to good effect in my industrial research career) is:

“Research involves building artifacts in order to obtain knowledge; engineering involves gaining knowledge in order to build artifacts.”

So, I think the main thrust of COINRG should be advancing knowledge; not making specifications for particular artifacts (or classes of artifact).

Cheers, DaveO.

mjm

On Feb 1, 2022, at 10:59 AM, Colin Perkins <[email-masked]<mailto:[email-masked]>> wrote:
 Dirk,

Colin

Colin,

Best,

Dirk

Colin

Dirk

From: Dirk Trossen

Colin,

Best,

Dirk

Dirk,

Colin

Colin, all,

Best,

Dirk

Dirk,

Colin

Dear chairs, all,

Best,

Dirk

Hi Marie-Jose, all,

Best,

Dirk

mjm

---

From: Colin Perkins <[email-masked]>
Date: Tue, 1 Feb 2022 20:28:48 +0000

Dirk,

Your initial email, on which you solicited feedback, focussed on narrowing the scope of the charter, picking activities to tackle, identifying applicability areas, liaising with relevant IETF groups, and so on. You’ve also repeatedly spoken about progressing drafts. These sound like appropriate actions to consider when discussing how an IETF working group can make progress, where the goal is to narrow the scope enough to develop a concrete solution, and to push forward the work to solve a problem. 

Research groups should be broader and more exploratory. The charter is a sketch of some representative topics of interest to the group, not a concrete work plan. My comment about engineering vs research was to suggest you focus less on the details of the charter, and more on doing the research. The group doesn’t need to focus its charter to move forward. It’s already broad enough to cover the areas of interest.

Colin

> On 1 Feb 2022, at 16:29, Dirk Trossen <[email-masked]> wrote:
> 
> Colin,
>  
> On 1 Feb 2022, at 14:45, Dirk Trossen <[email-masked] <mailto:[email-masked]>> wrote:
>  
> Colin,
>

---

From: Ike Kunze <[email-masked]>
Date: Wed, 2 Feb 2022 07:09:03 +0000

Hi all,

not trying to reignite the discussion here, but just offering my perspective as a co-author of the 'use cases' and ‘transport' drafts:

To me, the main motivation for those two drafts is to create the basis for further research in those topics.
In case of the 'use cases’, our goal is to collect and analyze use cases that might (or might not) require COIN for becoming reality.
While we certainly also consider requirements for potential solutions, something that might (or might not) rather go into the ‘engineering’ direction,
we specifically also discuss research questions and plan to identify questions that are relevant for some/many/most/all of the use cases.
Future research could then pick out those questions that are most interesting and pursue them in detail.

In the ’transport’ draft, we try to identify potential challenges that arise when plainly combining COIN with (today’s) transport protocols.
Until now, we have mainly collected such challenges and would like to analyze how critical they are for existing transport protocols as a next step.
As we have seen at the example of the MTP paper at HotNets, some of the issues have already been worked on in other contexts and
we thus believe that broadening the input from our current list of authors is crucial.
Again, future research could then pick out specific challenges and address them.

In both cases, we purse these endeavours as ‘drafts’ to create an ‘open' basis for research that is also directly linked to the IRTF
in order to bridge research and engineering and ideally get input from both communities.
In contrast to just writing a paper behind closed doors, I believe that this makes it easier for other individuals to chime in and contribute feedback
as we have already seen at the example of the 'use cases' draft.

Thus, whenever we call for 'progressing the drafts’, we only want to get feedback on those topics and advance the fundamental idea that we purse with them, i.e., creating a common basis for research.
Our frequent links to the COIN charter are mainly there to show that COIN is indeed the right place for this research work (if that’s clear to everyone, we can just leave that out in the future :)).
Similarly, the ‘draft’ form is just a ‘vehicle’, as Dirk has called it before, for this work and our fundamental idea does not revolve around getting this published as an RFC.
We just would like to have a document with input from the whole community (or at least any member of the community who wanted to contribute).
As Jon has rightly pointed out, it might then also make sense to bring our findings to the ‘real’ research world by writing a paper about it.
If you have specific ideas for other forms of soliciting community feedback that could, e.g., increase the range of input, I would be very interested in hearing them!

With that being said, I hope that we can, among other things to be discussed in the interim,
progress our drafts journey towards finding overarching and interesting research questions based on the 'use cases' draft
and identifying interesting challenges to be solved when combining COIN with transport based on the ’transport’ draft! :)

Cheers
Ike

On 1. Feb 2022, at 21:28, Colin Perkins <[email-masked]<mailto:[email-masked]>> wrote:

Dirk,

Colin

On 1 Feb 2022, at 16:29, Dirk Trossen <[email-masked]<mailto:[email-masked]>> wrote:

Colin,

Best,

Dirk

Dirk,

Colin

Colin,

Best,

Dirk

Colin

Dirk

From: Dirk Trossen

Colin,

Best,

Dirk

Dirk,

Colin

Colin, all,

Best,

Dirk

Dirk,

Colin

Dear chairs, all,

Best,

Dirk

Hi Marie-Jose, all,

Best,

Dirk

mjm

---

From: Dirk Trossen <[email-masked]>
Date: Wed, 2 Feb 2022 08:11:00 +0000

Colin,

Please see inline.

Sent: 01 February 2022 21:29

Dirk,

Your initial email, on which you solicited feedback, focussed on narrowing the scope of the charter, picking activities to tackle, identifying applicability areas, liaising with relevant IETF groups, and so on.
[DOT] I asked for a discussion on the charter, as the impression from previous communication, including a topic item on the IETF112 agenda, was that this may be one of the drivers for the interim. I merely wanted to provide input into that, noting that I meant to provide “…few thoughts defined through my current understanding of COIN, based on ongoing and past activities, with an intention to move forward”. In other words, I picked apart my understanding of the current charter, including the tackling of what I named ‘applicability areas’ (the current draft already mentions transport, while routing could be another). I did not see my input as an attempt to narrow the scope of the charter, not even to re-charter per se, but to understand the charter better and its scope in terms of interests; is that a wrong thing to do? As liaison with IETF groups, is that a question that points to a pure engineering approach? As a researcher coming to the IRTF, I may be quite interested in linking my research into the IETF, too – I heard this desire from many.

[DOT] So again, if my email was understood wanting to narrow scope, I would want to correct that. It is not my intention to preclude any discussion on the understanding of the charter’s scope but merely understand the latter better. Statements like ‘the charter is broad and that is good’ is not helping me as a researcher and I would want to see if others share that concern. If it’s not a concern, let’s move on.

You’ve also repeatedly spoken about progressing drafts. These sound like appropriate actions to consider when discussing how an IETF working group can make progress, where the goal is to narrow the scope enough to develop a concrete solution, and to push forward the work to solve a problem.
[DOT] I want to progress work, capturing in documents that are currently presented as drafts. I didn’t even initiate those drafts but joined them with my own research output as a contributor. Drafts may be interpreted as way to a solution but you know that this is not generally true and I don’t think the current drafts are pursuing this direction either. Again, Ike and myself, as the co-authors having solicited input, want to progress work, not drafts towards a solution. If drafts are an inappropriate vehicle, let’s stick the work into another format, that is fine by me. It won’t change the intention of the solicitation – we are looking for contributors to this research-driven activity. I would think that this was clear but did not expect that the use of the word ‘draft’ would blind that intention so much.

Research groups should be broader and more exploratory. The charter is a sketch of some representative topics of interest to the group, not a concrete work plan. My comment about engineering vs research was to suggest you focus less on the details of the charter, and more on doing the research. The group doesn’t need to focus its charter to move forward. It’s already broad enough to cover the areas of interest.
[DOT] And I want to understand that interest. The charter is meant to provide guidance and I wanted to understand the guidance to gauge the interests. Whether we capture any better understanding is a revised charter is secondary, even mainly irrelevant to me. I wanted a discussion to see what interests we can see and how we can pursue those interests. I have gone about research in similar manner in the past.

Colin

Colin,

Best,

Dirk

Dirk,

Colin

Colin,

Best,

Dirk

Colin

Dirk

From: Dirk Trossen

Colin,

Best,

Dirk

Dirk,

Colin

Colin, all,

Best,

Dirk

Dirk,

Colin

Dear chairs, all,

Best,

Dirk

Hi Marie-Jose, all,

Best,

Dirk

mjm

---

From: Colin Perkins <[email-masked]>
Date: Wed, 2 Feb 2022 09:35:11 +0000

Ike,

I intentionally made no comment on any specific drafts.

Collaborative research is clearly good. IRTF research groups provide a venue for such collaboration that is close to the IETF, and encourages input from a particular group of people that can offer a useful perspective. Internet drafts provide one way of capturing such discussions and organising material. They were arguably a more useful way of doing that in the past, before collaboration tools like Google docs, Overleaf, and GitHub were developed, but they certainly have a place.

What I want to push back on, though, is the idea that IRTF groups operate like IETF working groups, with a detailed charter and set of milestones to organise and guide the work, and with drafts being progressed to meet various deliverables and targets. That works for standards where there’s a known product to build, but it’s not effective for research where the destination is less clear.

Colin

> On 2 Feb 2022, at 07:09, Ike Kunze <[email-masked]> wrote:
> 
> Hi all,
> 
>> On 1. Feb 2022, at 21:28, Colin Perkins <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Dirk,
>> 
>>> On 1 Feb 2022, at 16:29, Dirk Trossen <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> Colin,
>>>  

-- 
Colin Perkins
https://csperkins.org/