Subject: [Coin] FW: New Version Notification for draft-trossen-rtgwg-routing-beyond-reachability-00.txt

From: Luigi Iannone <[email-masked]>
Date: Wed, 9 Feb 2022 11:56:55 +0100

Hi,

In light of recent discussion on this mailing list the document below announced on the RTGWG mailing list may be of some interest here as well (IMO).

Ciao

L.

Dirk Trossen <[email-masked]> Tue, 08 February 2022 13:20 UTCShow header
Dear all,

We have posted the draft below to seed a wider RTG WG discussion on routing evolution, based on various ongoing interactions and discussions within the IETF and IRTF on this topic. 

This draft recognizes the ongoing evolution of Internet routing based on the many extensions to the original reachability-focused purpose of IP routing, identifies issues with the approach of developing those extensions, and proposes a way forward in direct relation to the RTG WG charter. 

We are seeking feedback and comments from the WG on the topic of routing evolution, particularly on the suggested actions as well as issues identified in the draft. 

Best,

Dirk (on behalf of the authors)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: 08 February 2022 14:10
To: Zhe Lou <[email-masked]>om>; Dirk Trossen <[email-masked]>om>; Sheng Jiang <[email-masked]>om>; Zhe Lou <[email-masked]>
Subject: New Version Notification for draft-trossen-rtgwg-routing-beyond-reachability-00.txt

A new version of I-D, draft-trossen-rtgwg-routing-beyond-reachability-00.txt
has been successfully submitted by Dirk Trossen and posted to the IETF repository.

Name:		draft-trossen-rtgwg-routing-beyond-reachability
Revision:	00
Title:		Continuing to Evolve Internet Routing Beyond 'Mere' Reachability
Document date:	2022-02-08
Group:		Individual Submission
Pages:		25
URL:            https://www.ietf.org/archive/id/draft-trossen-rtgwg-routing-beyond-reachability-00.txt
Status:         https://datatracker.ietf.org/doc/draft-trossen-rtgwg-routing-beyond-reachability/
Htmlized:       https://datatracker.ietf.org/doc/html/draft-trossen-rtgwg-routing-beyond-reachability

Abstract:
   This document discusses the evolution of the Internet routing system
   beyond mere reachability.  We observe, through examples of past
   development, that such evolution has been taking place to improve on
   capabilities of the Internet, deal with more complicated network
   deployments and cater to changing requirements by end users as well
   as novel and emerging applications.

   For achieving a routing system that serves more than a singular
   reachability purpose, more information is taken into account when
   performing the purpose-specific functions.  Such extra information
   can be obtained by extending current routing protocols to exchange
   more information or by carrying that information within packets.

   This document is intended to seed discussions of how the observed
   evolution of the Internet's routing system can continue, what issues
   may occur when simply continuing the current approach for achieving
   routing beyond 'mere' reachability and what may be needed to address
   those issues.  Ultimately, however, this document recognizes the
   positive impact that moving beyond reachability has brought to the
   Internet and will continue to do so.

The IETF Secretariat

---

From: Sharon Barkai <[email-masked]>
Date: Wed, 9 Feb 2022 13:22:16 +0200

Great and much needed initiative.
Can really help structure the wild west of edge computing. 

--szb
Cell: +972.53.2470068
WhatsApp: +1.650.492.0794

> On Feb 9, 2022, at 12:58, Luigi Iannone <[email-masked]> wrote:
> 
> Hi,
> 
> -- 
> Coin mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/coin

---

From: Jon Crowcroft <[email-masked]>
Date: Fri, 11 Feb 2022 09:23:31 +0000

so the checklist for any new routing approach is the three M's

-Mobility
-Multihoming
-Multicast

extra marks  are avaialble for:

security:
+typically integrity of routes
+mitigate or don't make worse DoS
+retain as much (optinal) anonimity as people want

policy:
by which i mean anything that isn't just optimisation against some performance metric.

so my fave work out of all the future internet work 20 years back was I3
http://i3.cs.berkeley.edu/publications/papers/i3-sigcomm.pdf
as it asically spoke to the three Ms directly, by putting
rendezvous points in the net as a first class piece of the architecture
(obviously RPs had shown up in multicast as cores or in PIM already
but this generalised that) - then it falls to the designer to addres the extra mark
challenges, once you put a 3rd party in the net, you create a lovely pivot for all sorts of
attacks - hence it behoves us in groups like coin, to think about how you secure this
and it is now a three body problem, which we all know to be very much harder than two.

and that really is in-net compute in a nutshell...

> 
> In light of recent discussion on this mailing list the document below 
> announced on the RTGWG mailing list may be of some interest here as well 
> (IMO).
> 
> Ciao
> 
> L.
> 
> We have posted the draft below to seed a wider RTG WG discussion on 
> routing evolution, based on various ongoing interactions and discussions 
> within the IETF and IRTF on this topic.
> 
> This draft recognizes the ongoing evolution of Internet routing based on 
> the many extensions to the original reachability-focused purpose of IP 
> routing, identifies issues with the approach of developing those 
> extensions, and proposes a way forward in direct relation to the RTG WG 
> charter.
> 
> We are seeking feedback and comments from the WG on the topic of routing 
> evolution, particularly on the suggested actions as well as issues 
> identified in the draft.
> 
> Best,
> 
> 
> To: Zhe Lou <[email-masked]>om>; Dirk Trossen 
> <[email-masked]>om>; Sheng Jiang <[email-masked]>om>; Zhe 
> Lou <[email-masked]>
> Subject: New Version Notification for 
> draft-trossen-rtgwg-routing-beyond-reachability-00.txt
> 
> 
> A new version of I-D, 
> draft-trossen-rtgwg-routing-beyond-reachability-00.txt
> URL:            
> https://www.ietf.org/archive/id/draft-trossen-rtgwg-routing-beyond-reachability-00.txt
> Status:         
> https://datatracker.ietf.org/doc/draft-trossen-rtgwg-routing-beyond-reachability/
> Htmlized:       
> https://datatracker.ietf.org/doc/html/draft-trossen-rtgwg-routing-beyond-reachability
> 
> 
> Abstract:

---

From: Dirk Trossen <[email-masked]>
Date: Fri, 11 Feb 2022 09:52:04 +0000

-----Original Message-----
From: Coin [mailto:[email-masked]] On Behalf Of Jon Crowcroft
Sent: 11 February 2022 10:24
To: Luigi Iannone <[email-masked]>
Cc: Jon Crowcroft <[email-masked]>; [email-masked]
Subject: Re: [Coin] FW: New Version Notification for draft-trossen-rtgwg-routing-beyond-reachability-00.txt

-Mobility
-Multihoming
-Multicast

security:

[DOT] A good list. I want to point out though that the draft in question (see below) is not proposing a new routing approach but the creation of efforts to look at routing extensions in a more architectural manner

policy:
[DOT] Agree on that. 

so my fave work out of all the future internet work 20 years back was I3 http://i3.cs.berkeley.edu/publications/papers/i3-sigcomm.pdf
as it asically spoke to the three Ms directly, by putting rendezvous points in the net as a first class piece of the architecture (obviously RPs had shown up in multicast as cores or in PIM already but this generalised that) - then it falls to the designer to addres the extra mark challenges, once you put a 3rd party in the net, you create a lovely pivot for all sorts of attacks - hence it behoves us in groups like coin, to think about how you secure this and it is now a three body problem, which we all know to be very much harder than two.
[DOT] as you know, some of the ICN work inherited that approach, i.e. using explicit rendezvous to establish pub/sub relations. Indeed, it comes with a bag of issues, not only of technical nature.

and that really is in-net compute in a nutshell...
[DOT] of course it is but all communication is in-network compute (since computational capabilities are used for the purpose of communication) -> we may end up in COIN simply being about networking, right? The question more is where is the delineation? 

[DOT] Take your example of I3 - why is this in-net compute? The role of its rendezvous points, similar to approaches in ICN, is that of the DNS with similar multi-party interactions (at protocol and economic level). So with that, is DNS+IP in-network compute and with it work on evolving the DNS (doing some work with UCL on this, so maybe they could come to COIN to present)? 

> announced on the RTGWG mailing list may be of some interest here as 
> well (IMO).
> 
> Ciao
> 
> L.
> 
> Dirk Trossen <[email-masked]> Tue, 08 February 2022 13:20 
> UTCShow header Dear all,
> 
> routing evolution, based on various ongoing interactions and 
> discussions within the IETF and IRTF on this topic.
> 
> This draft recognizes the ongoing evolution of Internet routing based 
> on the many extensions to the original reachability-focused purpose of 
> IP routing, identifies issues with the approach of developing those 
> extensions, and proposes a way forward in direct relation to the RTG 
> WG charter.
> 
> We are seeking feedback and comments from the WG on the topic of 
> routing evolution, particularly on the suggested actions as well as 
> issues identified in the draft.
> 
> Best,
> 
> 
> <[email-masked]>om>; Sheng Jiang <[email-masked]>om>; 
> Zhe Lou <[email-masked]>