Subject: [Coin] I-D Action: draft-irtf-coinrg-use-cases-02.txt

From: [email-masked]
Date: Mon, 07 Mar 2022 02:53:53 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Computing in the Network Research Group RG of the IRTF.

        Title           : Use Cases for In-Network Computing
        Authors         : Ike Kunze
                          Klaus Wehrle
                          Dirk Trossen
                          Marie-Jose Montpetit
                          Xavier de Foy
                          David Griffin
                          Miguel Rio
	Filename        : draft-irtf-coinrg-use-cases-02.txt
	Pages           : 54
	Date            : 2022-03-07

Abstract:
   Computing in the Network (COIN) comes with the prospect of deploying
   processing functionality on networking devices, such as switches and
   network interface cards.  While such functionality can be beneficial
   in several contexts, it has to be carefully placed into the context
   of the general Internet communication.

   This document discusses some use cases to demonstrate how real
   applications can benefit from COIN and to showcase essential
   requirements that have to be fulfilled by COIN applications.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-irtf-coinrg-use-cases/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-irtf-coinrg-use-cases-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-irtf-coinrg-use-cases-02

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

---

From: Ike Kunze <[email-masked]>
Date: Mon, 7 Mar 2022 10:58:16 +0000

Hi all,

as already announced last week, we have updated the use case draft with a first analysis of the collected research questions (Section 7.2).

Our main goal was not to directly come up with a “final”, polished analysis, but to start things off with a first categorization of the research questions.
This is also the reason why parts of the text are still a bit “raw”.
We roughly grouped the research questions into four main categories:

   *  VISION(S) for COIN: Questions that aim at defining and shaping the exact scope of COIN.

   *  ENABLING TECHNOLOGIES for COIN: Questions that target the capabilities of the technologies and devices that are intended to be used in COIN.

   *  Distributed Computing FRAMEWORKS and LANGUAGES to COIN: Questions that aim at concretizing how a framework or languages for deploying and operating COIN systems might look like.

   *  Applicability areas: Questions that are use-case near and heavily influenced by the specific constraints and goals of the use cases.

Within these larger categories, we have tried to come up with subgroups to identify particular aspects that might be important for the different categories.

Now, we would love to hear your opinion on our preliminary analysis. Let me phrase a couple of questions to inspire your thinking:
- Does the overall categorization make sense? If not, do you have concrete other ideas/proposals?
- Does the subgrouping make sense?
- Are there aspects and/or research questions that are miscategorized?
- Are there interesting aspects of the different categories/subcategories that are not yet captured by the current research questions? (Remember: our RQs are all directly derived from specific use cases, so it might very well be that they are not comprehensive).

We are really looking for honest feedback.
If you have any thoughts on those or other questions, please reach out to us, either by responding to this mail thread or by contacting us directly.

Thanks!

Best,
Ike

> On 7. Mar 2022, at 11:53, [email-masked] wrote:
> 
> 
> -- 
> Coin mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/coin