Subject: Re: [Coin] I-D Action: draft-irtf-coinrg-use-cases-02.txt

From: "jefhe"<[email-masked]>
Date: Tue, 8 Mar 2022 18:41:12 +0800

Hi Ike,
Thank you and other authors for such a detailed draft. I think identifying the research questions are important for a research group like COIN to do use case analysis, so I really appreciate your efforts. Below are some comments and suggestions with my chair hat off.
(1) In what degree, should we describe our research questions? 
In current draft, there are many one-sentence research questions, for example, "RQ 4.3.3: How to dynamically change COIN programs?”. I would say, it would be helpful for readers like me if the authors can share their insight why this is a research question in that context, e.g. in which part of knowledge, we lack enough understanding to find an optimal solution for that problem. Maybe one or two sentences can be very helpful.

(2) Four main categories. It looks reasonable to have a section to research questions across use cases, although it is ambitious in my view :)
I feel the questions in "VISION(S) for COIN” may be less interesting than research questions on alternatives in COIN architectures. For example, in 7.2.2.1.1. 
"an arising question is whether such computations are still to be considered as "in-network processing" and where the exact line is between "in-network processing" and "routing to end systems" (3.3.7)”. More interesting question than this line is , in the same context, what results does these two methods imply to? In which condition, one method is more favourable than the other? 
“Applicability areas”: it seems challenging to define mutually exclusive subareas here.

(3) Distributed Computing FRAMEWORKS and LANGUAGES to COIN. Actually I have one curious question (below) recently in this category.
"Network Programming Language+Network Compiler" vs "Middleware/Library” approach
This is a question coming to me when I was reading a textbook about compiler. My initial question asking myself was what is the condition that requires us to develop a new language (with a new complier). The answer in the compute community seems: when there are new instruction sets in new hardwards or a computing paradigm. A new language can provide an abstraction releasing the sofware developer from the complexity in using these hardware resources. So the question in the context of COIN to me is why we rely on middleware like Saphhire[1] or library like MPI in HPC in distributed computing across nodes. Why don't we develop a language for networked computing with a compiler to help the developer to make full use of the distributed compute resources including the compute inside the network? There was a workshop in sigcomm 2016 named network programming language [2], but it seems most of the research are how to progrom the “network devices” like P4 instead of "networked computing”. I feel the answer may be related to complier time vs running time or software vs hardware processing, but I am not sure.
[1] https://www.usenix.org/conference/osdi16/technical-sessions/presentation/zhang-irene
[2] https://conferences.sigcomm.org/sigcomm/2016/netpl.php
hope these comments helpful,
Jeffrey

On Mar 7, 2022 18:58，Ike Kunze<[email-masked]> wrote：

Hi all, as already announced last week, we have updated the use case draft with a first analysis of the collected research questions (Section 7.2). Our main goal was not to directly come up with a “final”, polished analysis, but to start things off with a first categorization of the research questions. This is also the reason why parts of the text are still a bit “raw”. We roughly grouped the research questions into four main categories: * VISION(S) for COIN: Questions that aim at defining and shaping the exact scope of COIN. * ENABLING TECHNOLOGIES for COIN: Questions that target the capabilities of the technologies and devices that are intended to be used in COIN. * Distributed Computing FRAMEWORKS and LANGUAGES to COIN: Questions that aim at concretizing how a framework or languages for deploying and operating COIN systems might look like. * Applicability areas: Questions that are use-case near and heavily influenced by the specific constraints and goals of the use cases. Within these larger categories, we have tried to come up with subgroups to identify particular aspects that might be important for the different categories. Now, we would love to hear your opinion on our preliminary analysis. Let me phrase a couple of questions to inspire your thinking: - Does the overall categorization make sense? If not, do you have concrete other ideas/proposals? - Does the subgrouping make sense? - Are there aspects and/or research questions that are miscategorized? - Are there interesting aspects of the different categories/subcategories that are not yet captured by the current research questions? (Remember: our RQs are all directly derived from specific use cases, so it might very well be that they are not comprehensive). We are really looking for honest feedback. If you have any thoughts on those or other questions, please reach out to us, either by responding to this mail thread or by contacting us directly. Thanks! Best, Ike > On 7. Mar 2022, at 11:53, [email-masked] wrote: > > > A New Internet-Draft is available from the on-line Internet-Drafts directories. > This draft is a work item of the Computing in the Network Research Group RG of the IRTF. > > Title : Use Cases for In-Network Computing > Authors : Ike Kunze > Klaus Wehrle > Dirk Trossen > Marie-Jose Montpetit > Xavier de Foy > David Griffin > Miguel Rio > Filename : draft-irtf-coinrg-use-cases-02.txt > Pages : 54 > Date : 2022-03-07 > > Abstract: > Computing in the Network (COIN) comes with the prospect of deploying > processing functionality on networking devices, such as switches and > network interface cards. While such functionality can be beneficial > in several contexts, it has to be carefully placed into the context > of the general Internet communication. > > This document discusses some use cases to demonstrate how real > applications can benefit from COIN and to showcase essential > requirements that have to be fulfilled by COIN applications. > > > The IETF datatracker status page for this draft is: > https://datatracker.ietf.org/doc/draft-irtf-coinrg-use-cases/ > > There is also an htmlized version available at: > https://datatracker.ietf.org/doc/html/draft-irtf-coinrg-use-cases-02 > > A diff from the previous version is available at: > https://www.ietf.org/rfcdiff?url2=draft-irtf-coinrg-use-cases-02 > > > Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts > > > -- > Coin mailing list > [email-masked] > https://www.irtf.org/mailman/listinfo/coin -- Coin mailing list [email-masked] https://www.irtf.org/mailman/listinfo/coin

---

From: Dirk Trossen <[email-masked]>
Date: Tue, 8 Mar 2022 11:23:54 +0000

Hi Jeffrey,

Thanks for those questions. Yes, we need more than a single tag line for each RQ, that’s something already identified.

As for the aspects in your point (2), we can directly incorporate them into the next revision as possible directions – it’s feedback like this we would want to widen the RQs beyond what we directly identified. If, together with item (1), we can nicely link this into the use cases where we identified those RQs, the better it is IMO.

Best,

Dirk

From: Coin [mailto:[email-masked]] On Behalf Of jefhe
Sent: 08 March 2022 11:41
To: [email-masked]; Ike Kunze <[email-masked]>
Subject: Re: [Coin] I-D Action: draft-irtf-coinrg-use-cases-02.txt

Hi Ike,

I feel the questions in "VISION(S) for COIN” may be less interesting than research questions on alternatives in COIN architectures. For example, in 7.2.2.1.1<https://datatracker.ietf.org/doc/html/draft-irtf-coinrg-use-cases-02#section-7.2.2.1.1>.

Jeffrey

On Mar 7, 2022 18:58，Ike Kunze<[email-masked]<mailto:[email-masked]>> wrote：

Hi all,

as already announced last week, we have updated the use case draft with a first analysis of the collected research questions (Section 7.2).

Our main goal was not to directly come up with a “final”, polished analysis, but to start things off with a first categorization of the research questions.

This is also the reason why parts of the text are still a bit “raw”.

We roughly grouped the research questions into four main categories:

   *  VISION(S) for COIN: Questions that aim at defining and shaping the exact scope of COIN.

   *  ENABLING TECHNOLOGIES for COIN: Questions that target the capabilities of the technologies and devices that are intended to be used in COIN.

   *  Distributed Computing FRAMEWORKS and LANGUAGES to COIN: Questions that aim at concretizing how a framework or languages for deploying and operating COIN systems might look like.

   *  Applicability areas: Questions that are use-case near and heavily influenced by the specific constraints and goals of the use cases.

Within these larger categories, we have tried to come up with subgroups to identify particular aspects that might be important for the different categories.

Now, we would love to hear your opinion on our preliminary analysis. Let me phrase a couple of questions to inspire your thinking:

- Does the overall categorization make sense? If not, do you have concrete other ideas/proposals?

- Does the subgrouping make sense?

- Are there aspects and/or research questions that are miscategorized?

- Are there interesting aspects of the different categories/subcategories that are not yet captured by the current research questions? (Remember: our RQs are all directly derived from specific use cases, so it might very well be that they are not comprehensive).

We are really looking for honest feedback.

If you have any thoughts on those or other questions, please reach out to us, either by responding to this mail thread or by contacting us directly.

Thanks!

Best,

Ike

> On 7. Mar 2022, at 11:53, [email-masked]<mailto:[email-masked]> wrote:

> A New Internet-Draft is available from the on-line Internet-Drafts directories.

> This draft is a work item of the Computing in the Network Research Group RG of the IRTF.

>        Title           : Use Cases for In-Network Computing

>        Authors         : Ike Kunze

>                          Klaus Wehrle

>                          Dirk Trossen

>                          Marie-Jose Montpetit

>                          Xavier de Foy

>                          David Griffin

>                          Miguel Rio

>     Filename        : draft-irtf-coinrg-use-cases-02.txt

>     Pages           : 54

>     Date            : 2022-03-07

> Abstract:

>   Computing in the Network (COIN) comes with the prospect of deploying

>   processing functionality on networking devices, such as switches and

>   network interface cards.  While such functionality can be beneficial

>   in several contexts, it has to be carefully placed into the context

>   of the general Internet communication.

>   This document discusses some use cases to demonstrate how real

>   applications can benefit from COIN and to showcase essential

>   requirements that have to be fulfilled by COIN applications.

> The IETF datatracker status page for this draft is:

> https://datatracker.ietf.org/doc/draft-irtf-coinrg-use-cases/

> There is also an htmlized version available at:

> https://datatracker.ietf.org/doc/html/draft-irtf-coinrg-use-cases-02

> A diff from the previous version is available at:

> https://www.ietf.org/rfcdiff?url2=draft-irtf-coinrg-use-cases-02

> Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

> --

> Coin mailing list

> [email-masked]<mailto:[email-masked]>

> https://www.irtf.org/mailman/listinfo/coin

--

Coin mailing list

[email-masked]<mailto:[email-masked]>

https://www.irtf.org/mailman/listinfo/coin

---

From: Ike Kunze <[email-masked]>
Date: Wed, 9 Mar 2022 06:34:08 +0000

Hi Jeffrey, Dirk,

thank you Jeffrey for the pointers, it’s very helpful getting an opinion from a different angle :)

Only adding to Dirk’s remarks:

(1) As Dirk said, this is something we already identified. Our current plan is to first get a better understanding of what the overall landscape of research questions is (i.e., better understand the content/structure of Sec. 7.2 and how questions of different use cases might overlap) and then afterwards come back to the research questions in the “use case sections” and update them.

(2) Re “research questions on alternatives”: That’s an interesting aspect. At the moment, we have only taken the RQs from the use cases sections and sorted them into the different categories, i.e., we have not yet added “new” RQs based on our categorization. However, as Dirk said, pointers like yours are exactly what we need to get started with that, so thanks!

Re “applicability areas”: I agree. In fact, there is even some overlap between the other categories. However, we think that this is not necessarily a problem as, e.g., different “applicability areas” will/might bring out different nuances of the RQs.
Maybe we can describe this in advance so that there is no confusion as to why some RQs are in multiple categories or why the categories are not mutually exclusive.

(3) That’s again an interesting view on the topic and should complement well with what we currently have on frameworks and languages.

Thanks again, Jeffrey!

Best,
Ike

On 8. Mar 2022, at 12:23, Dirk Trossen <[email-masked]<mailto:[email-masked]>> wrote:

Hi Jeffrey,

Best,

Dirk

From: Coin [mailto:[email-masked]] On Behalf Of jefhe
Sent: 08 March 2022 11:41
To: [email-masked]<mailto:[email-masked]>; Ike Kunze <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Coin] I-D Action: draft-irtf-coinrg-use-cases-02.txt

Hi Ike,

Hi all,

Thanks!

Best,

Ike

> Internet-Drafts are also available by rsync at rsync.ietf.org<http://rsync.ietf.org>::internet-drafts

--

Coin mailing list