Subject: Re: Capability terminology

From: Graham Klyne <[email-masked]>
Date: Mon, 16 Nov 1998 13:55:21 +0000

At 15:16 13/11/98 -0500, James  Rafferty wrote:

[...]
>I think the definitions are useful, but overlap considerably with terms
>already used in the Internet Fax Goals and Terminology document.   I
>believe terms for IETF Internet fax use are best defined in -goals and then
>used in other documents.  Where the terms are more general with respect to
>capabilities, CONNEG documents may be the best place for the definitions;
>see my comments below.  

I agree with all these points.

>You have proposed:  
>
>>"capability exchange" describes any transfer of 
>>  information between communicating systems that is used to 
>>  indicate system capabilities and hence determine the form 
>>  of data transferred.
>>
>A similar definition is in "Goals" already:   
>
># The exchange of capabilities in Internet Fax should {2} be robust. To
>
># accomplish this, recipients should {2} be encouraged to provide
># capabilities, even while senders must {1} have a way to send messages
># to recipients whose capabilities are unknown.

Hmmm... I would not read the "goals" paragraph you cite as a definition of
"capability exchange".

>>  "capability identification" is a particular form of 
>>  capability exchange in which a receiving system provides 
>>  capability information to a sending system.
>>
>Goals uses the term Capabilities "indication" for this as shown below:
>
># Even minimum-capability recipients of messages should {2} be required
># to provide a capability indication in some reliable way. This might be
># accomplished by providing an entry in a directory service, by offering
># automatic or semi-automatic replies, or by sending some indication of
># in a reply to a message with multiple renditions, or as an addition to
># a negative acknowledgement requiring retransmission.
> 
>I personally think identification is the better term here than indication.
> I could 
>support changing the word "indication" in Goals to "identification".    In
>practice, this is what takes place in extended Internet fax as defined in
>-eifax.   

Again, I would not normally read this is a terminology definition.

>>  "capability description" is a collection of data 
>>  presented in some specific format that describes the 
>>  capabilities of some commincating entity.  It may exist 
>>  separately from any specific capability exchange 
>>  mechanism.
>
>Goals has done a reasonable job of making the same point (expression or
>description being indepedent of mechanism), using the term
>capabilities expression, which to me seems equally valid.  I don't see a
>need to change this part of -Goals.   

I could live with that.  I plumped for "description" because the 'conneg'
documents talk about "description of capabilities", and tend to use the
term "expression" in the more specific context of feature predicate
expressions.

>Maybe the place to define this term (capabilities description) is in one of
>the Conneg documents, such as in the -reg or the -requirements document.  I
>checked the registration document and it already makes the distinction
between
>expression and mechanism, but does not use the term "capabilties
>description". 

I would tend to agree thet conneg-requirements is probably the natural home
for these definitions, but I am not sure if that will be progressed in line
with the others (and am fairly sure it is not intended to progress as
standards track).

#g

------------
Graham Klyne
([email-masked])

---

From: Al Gilman <[email-masked]>
Date: Mon, 16 Nov 1998 10:09:56 -0500 (EST)

For what it's worth, here is how I would compare/contrast some
of the candidate terms:

Capability indication:
	A data item occuring in a message (which is a data structure
  	  transferred in a communication transaction or protocol step.)
	A specific utterance, probably in a formal system.
	is_a capability expression
	is_a capability description

Capability expression:
	A looser category containing both specific capability
	indications and patterns or forms of indication.
	is_a capability description or category of capability descriptions

Capability description:
	Any utterance or form of utterance used to communicate
	information about a capability.  Natural and formal
	forms of expression are included.  The emphasis in
	this term is more on capability coverage and discrimination
	and less on the specific details of how the concepts
	are communicated than in the previous two terms.
	Especially in the use "capability description capability"
	the information model is paramount and the lexical
	and syntactic particulars are de-emphasized.

Al

to follow up on what Graham Klyne said:
> From [email-masked]  Mon Nov 16 09:08:17 1998
> Message-Id: <[email-masked]>
> X-Sender: [email-masked]
> X-Mailer: Windows Eudora Pro Version 3.0 (32)
> Date: Mon, 16 Nov 1998 13:55:21 +0000
> To: James  Rafferty <[email-masked]>
> From: Graham Klyne <[email-masked]>
> Subject: Re: Capability terminology
> Cc: conneg WG <[email-masked]>, [email-masked]
> Sender: [email-masked]
> Precedence: bulk