Subject: Feature registration, IANA considerations

From: Graham Klyne <[email-masked]>
Date: Tue, 17 Nov 1998 16:46:28 +0000

The feature registration template provides for IANA asignment of ASN.1
object identifiers.

Where a feature is token-values, I think it may be neccessary to
distinguish between ASN.1 allocation for the feature tag and feature tag
token values.

Also, in situations where a tag is derived from some MIB definition, it
would probably be appropriate to use the MIB values rather than assign new
values.

#g

------------
Graham Klyne
([email-masked])

---

From: Ted Hardie <[email-masked]>
Date: Tue, 17 Nov 1998 12:10:05 -0800 (PST)

Graham,
	Do you mean that you would like IANA to assign
ASN.1 oids to the token values themselves?  If we want
that, I suspect we need to indicate the mapping in
the registration from the assigned oid (something like 
token1=IANA-ASSIGNED-OID.1).  I suspect, though, that
anyone wanting that level of suport for ASN.1 will want
their own ASN.1 namespace. 
			regards,
				Ted Hardie
				[email-masked]