Subject: [COSE] [cose-issues] Change “SHOULD” to “MUST” in statement about parsers rejecting duplicate labels (#20)

From: Mike Jones <[email-masked]>
Date: Sun, 1 Nov 2015 10:52:09 +0000

Please change the “SHOULD” to “MUST” in this sentence in Section 14 (CBOR Encoder Restrictions): “All parsers used SHOULD fail on both parsing and generation if the same label is used twice as a key for the same map.” Allowing duplicate keys would result in interop and security problems.

View it on GitHub at https://github.com/cose-wg/cose-issues/issues/20

---

From: Justin Richer <[email-masked]>
Date: Mon, 30 Nov 2015 07:31:11 -0800

Closed #20.

---
Reply to this email directly or view it on GitHub:
https://github.com/cose-wg/cose-issues/issues/20#event-477834218