Subject: [COSE] Consensus Call: RSA 1.5

From: Justin Richer <[email-masked]>
Date: Sat, 7 Nov 2015 17:01:58 +0900

At the Yokohama meeting, the chairs agreed to do a consensus call regarding the definition of RSA 1.5 algorithms within the messages draft or an auxiliary draft. This functionality is analogous to the RS* series of signature methods in JWS and the RSA1_5 encryption method in JWE. The five positions we are asking the working group to consider and voice their support for are:

A) Drop all support for RSA 1.5 signatures and encryption.
B) Define RSA 1.5 support in an auxiliary draft.
C) Define RSA 1.5 support in the main draft (note that this option was previously discussed on the list and did not find favor at the time, so if you want it back you’ll need to make a strong case).
D) You need more information to decide.
E) You don’t give a flying rat about RSA 1.5.*

Note that this is distinct from RSA PSS support which is being discussed in a separate thread.

The consensus call will remain open for two weeks from today, closing on November 21, 2015; at which time, hopefully we will have a clear answer and direction for our editor.

Thank you,
 — Justin & Kepeng, your COSE chairs

* I promised those in the room at Yokohama to offer a flying rat option, for which I am deeply sorry.

---

From: "Jim Schaad" <[email-masked]>
Date: Sat, 7 Nov 2015 10:48:16 -0800

A

It is historic and should be killed.

> -----Original Message-----
> From: COSE [mailto:[email-masked]] On Behalf Of Justin Richer
> Sent: Saturday, November 07, 2015 12:02 AM
> To: [email-masked]
> Subject: [COSE] Consensus Call: RSA 1.5
> 
> At the Yokohama meeting, the chairs agreed to do a consensus call regarding
> the definition of RSA 1.5 algorithms within the messages draft or an auxiliary
> draft. This functionality is analogous to the RS* series of signature methods in
> JWS and the RSA1_5 encryption method in JWE. The five positions we are asking
> the working group to consider and voice their support for are:
> 
> C) Define RSA 1.5 support in the main draft (note that this option was previously
> discussed on the list and did not find favor at the time, so if you want it back
> you’ll need to make a strong case).
> The consensus call will remain open for two weeks from today, closing on
> November 21, 2015; at which time, hopefully we will have a clear answer and
> direction for our editor.
> 
> Thank you,
> _______________________________________________
> COSE mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cose

---

From: Ludwig Seitz <[email-masked]>
Date: Mon, 9 Nov 2015 10:28:52 +0100

On 2015-11-07 09:01, Justin Richer wrote:
> At the Yokohama meeting, the chairs agreed to do a consensus call
> regarding the definition of RSA 1.5 algorithms within the messages
> draft or an auxiliary draft. This functionality is analogous to the
> RS* series of signature methods in JWS and the RSA1_5 encryption
> method in JWE. The five positions we are asking the working group to
> consider and voice their support for are:

> C) Define RSA 1.5 support in the main draft (note that this option
> waspreviously discussed on the list and did not find favor at the time, so
> if you want it back you’ll need to make a strong case).

A.)

/Ludwig

-- 
Ludwig Seitz, PhD
SICS Swedish ICT AB
Ideon Science Park
Building Beta 2
Scheelevägen 17
SE-223 70 Lund

Phone +46(0)70-349 92 51
http://www.sics.se

---

From: Brian Campbell <[email-masked]>
Date: Tue, 10 Nov 2015 12:10:57 -0700

B or C (for RSA 1.5 signatures only - don't think signatures and encryption
should be lumped together here).

As I tried to say in the previous thread [COSE] RSA Algorithm Decisions
<https://mailarchive.ietf.org/arch/search/?email_list=cose&gbt=1&index=QDYaW9SQ8HZZ9AKAYrZSoS0VvjQ>,
to the extent that COSE supports RSA, then RSASSA-PKCS1-v1_5 should be
included due to being significantly more widely available than RSASSA-PSS
and a lack of momentum towards PSS.

---

From: "Matt Miller (mamille2)" <[email-masked]>
Date: Tue, 10 Nov 2015 21:30:17 +0000

encryption:  A)
signatures:  B) or C)

--
- m&m

Matt Miller <[email-masked]>
Cisco Systems, Inc.

> On Nov 7, 2015, at 01:01, Justin Richer <[email-masked]> wrote:
>

---

From: Chuck Mortimore <[email-masked]>
Date: Tue, 10 Nov 2015 13:47:17 -0800

+1 on signatures B) or C)

On Tue, Nov 10, 2015 at 1:30 PM, Matt Miller (mamille2) <[email-masked]>
wrote:

> regarding the definition of RSA 1.5 algorithms within the messages draft or
> an auxiliary draft. This functionality is analogous to the RS* series of
> signature methods in JWS and the RSA1_5 encryption method in JWE. The five
> positions we are asking the working group to consider and voice their
> support for are:
> >
> > C) Define RSA 1.5 support in the main draft (note that this option was
> previously discussed on the list and did not find favor at the time, so if
> you want it back you’ll need to make a strong case).

---

From: Nat Sakimura <[email-masked]>
Date: Wed, 11 Nov 2015 08:00:52 +0900

A)

=nat via iPhone

2015/11/07 17:01、Justin Richer <[email-masked]> のメッセージ:

> ― Justin & Kepeng, your COSE chairs
>

---

From: Mike Jones <[email-masked]>
Date: Fri, 13 Nov 2015 03:56:58 +0000

I agree with Matt:

encryption:  A)
signatures:  B) or C)

-----Original Message-----
From: COSE [mailto:[email-masked]] On Behalf Of Matt Miller (mamille2)
Sent: Tuesday, November 10, 2015 1:30 PM
To: Justin Richer
Cc: [email-masked]
Subject: Re: [COSE] Consensus Call: RSA 1.5

encryption:  A)
signatures:  B) or C)

--
- m&m

---

From: Justin Richer <[email-masked]>
Date: Sat, 21 Nov 2015 12:42:34 -0500

There’s consensus for dropping RSA 1.5 encryption support entirely, so that will be done.

There’s also enough support for supporting RSA 1.5 signatures that putting them into an auxiliary draft sounds like the best approach. The chairs would like to ask for volunteers to edit such an auxiliary draft.

 — Justin, your COSE chair

> On Nov 7, 2015, at 3:01 AM, Justin Richer <[email-masked]> wrote:
>