Subject: Re: [COSE] [cose-issues] Are there enough use cases for external_aad to warrant its inclusion? (#16)

From: Ludwig Seitz <[email-masked]>
Date: Mon, 2 Nov 2015 13:18:07 +0100

On 2015-11-01 07:19, Mike Jones wrote:
> The “external_aad” field appears in the Sig_structure, Enc_structure,
> and MAC_structure. Many other cryptographic specs have gotten along fine
> without this, and are simpler as a result. Is its inclusion warranted by
> common use cases, or is this an edge case not satisfying the 80/20 rule
> for inclusion? The simpler way of achieving this is to include these
> values as part of the payload.
>
> Note also that some places in the spec prohibit supplying this value.
> For instance, 5.4 (Encryption algorithm for AE algorithms) includes the
> instruction “Verify that there was no external additional authenticated
> data supplied for this operation.” That makes me think that having
> external_aad at all is a likely source of implementation and usage
> errors and interoperability problems.
>

Actually external AAD is a very useful feature to keep message size 
small, for example if you have parameters that are part of the 
application layer protocol (like the URI-* options or the RESTful method 
header in a CoAP message) that you want to integrity protect, without 
having to duplicate them in the COSE message.

/Ludwig

-- 
Ludwig Seitz, PhD
SICS Swedish ICT AB
Ideon Science Park
Building Beta 2
Scheelevägen 17
SE-223 70 Lund

Phone +46(0)70-349 92 51
http://www.sics.se

---

From: Malisa Vucinic <[email-masked]>
Date: Mon, 2 Nov 2015 15:06:19 +0100

+1. This is an important feature for any environment with limited MTU sizes. Said that, the argument that COSE should deal only with UDP payload size is not very helpful in energy-constrained environments where packet loss is significant, as we try to avoid fragmentation at all costs.  

Mališa

> On 02 Nov 2015, at 13:18, Ludwig Seitz <[email-masked]> wrote:
> 
> Actually external AAD is a very useful feature to keep message size small, for example if you have parameters that are part of the application layer protocol (like the URI-* options or the RESTful method header in a CoAP message) that you want to integrity protect, without having to duplicate them in the COSE message.

---

From: Jim Schaad <[email-masked]>
Date: Tue, 03 Nov 2015 04:19:46 -0800

Per discussion at the f2f meeting:  This is a required feature for the CoAP world so that headers in the message can be integrity protected without having to duplicate them

---
Reply to this email directly or view it on GitHub:
https://github.com/cose-wg/cose-issues/issues/16#issuecomment-153336418

---

From: Justin Richer <[email-masked]>
Date: Mon, 30 Nov 2015 07:31:11 -0800

Closed #16.

---
Reply to this email directly or view it on GitHub:
https://github.com/cose-wg/cose-issues/issues/16#event-477834216