Subject: [COSE] [cose-issues] Separate the nonce and IV header parameters (#27)

From: Mike Jones <[email-masked]>
Date: Sun, 01 Nov 2015 02:26:59 -0800

The description of the “nonce” header parameter in Section 3.1 says that “This parameter holds either a nonce or Initialization Vector value.”  Is there a well-understood reason why both a nonce and an initialization vector will never both be needed in the same set of header parameters.  Unless such a reason can be documented, please create separate header parameters for “nonce” and “IV”.

---
Reply to this email directly or view it on GitHub:
https://github.com/cose-wg/cose-issues/issues/27

---

From: Jim Schaad <[email-masked]>
Date: Wed, 04 Nov 2015 20:12:04 -0800

It is not clear that this makes sense.  In many cases the IV is described as a nonce value not an IV.  An example of this is GCM.  It depends on what one things a nonce is as oppose to an IV.   How would you characterize a nonce that is not trans-actional, and thus by your criteria it should be place in the content not the wrapper

---
Reply to this email directly or view it on GitHub:
https://github.com/cose-wg/cose-issues/issues/27#issuecomment-153950534

---

From: Jim Schaad <[email-masked]>
Date: Sun, 08 Nov 2015 21:39:53 -0800

Part of pull request cose-wg/cose-spec#98

---
Reply to this email directly or view it on GitHub:
https://github.com/cose-wg/cose-issues/issues/27#issuecomment-154938149