Subject: [COSE] Consensus Call: RSA PSS

From: Justin Richer <[email-masked]>
Date: Sat, 7 Nov 2015 17:02:04 +0900

At the Yokohama meeting, the chairs agreed to do a consensus call regarding the definition of RSA PSS algorithms within the messages draft or an auxiliary draft. This functionality is analogous to the PS* series of signature methods in JWS. The five positions we are asking the working group to consider and voice their support for are:

A) Drop all support for RSA PSS signatures and encryption.
B) Define RSA PSS support in an auxiliary draft.
C) Define RSA PSS support in the main draft.
D) You need more information to decide.
E) You don’t give a flying rat about RSA PSS.*

Note that this is separate from RSA 1.5 support, which is being discussed on a separate thread.

The consensus call will remain open for two weeks from today, closing on November 21, 2015; at which time, hopefully we will have a clear answer and direction for our editor.

Thank you,
 — Justin & Kepeng, your COSE chairs

* I promised those in the room at Yokohama to offer a flying rat option, for which I am deeply sorry.

---

From: "Jim Schaad" <[email-masked]>
Date: Sat, 7 Nov 2015 10:48:42 -0800

B - It is not a primary algorithm for the current known usages of COSE

> -----Original Message-----
> From: COSE [mailto:[email-masked]] On Behalf Of Justin Richer
> Sent: Saturday, November 07, 2015 12:02 AM
> To: [email-masked]
> Subject: [COSE] Consensus Call: RSA PSS
> 
> At the Yokohama meeting, the chairs agreed to do a consensus call regarding
> the definition of RSA PSS algorithms within the messages draft or an auxiliary
> draft. This functionality is analogous to the PS* series of signature methods in
> JWS. The five positions we are asking the working group to consider and voice
> their support for are:
> 
> The consensus call will remain open for two weeks from today, closing on
> November 21, 2015; at which time, hopefully we will have a clear answer and
> direction for our editor.
> 
> Thank you,
> _______________________________________________
> COSE mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cose

---

From: Ludwig Seitz <[email-masked]>
Date: Mon, 9 Nov 2015 10:31:49 +0100

> * I promised those in the room at Yokohama to offer a flying rat option, for which I am deeply sorry.

E) in the CoRE context, if someone else cares strongly B).

(don't be sorry Justin, I knew E would come handy)
/Ludwig

-- 
Ludwig Seitz, PhD
SICS Swedish ICT AB
Ideon Science Park
Building Beta 2
Scheelevägen 17
SE-223 70 Lund

Phone +46(0)70-349 92 51
http://www.sics.se

---

From: Brian Campbell <[email-masked]>
Date: Tue, 10 Nov 2015 12:21:19 -0700

B or E

On Mon, Nov 9, 2015 at 2:31 AM, Ludwig Seitz <[email-masked]> wrote:

>> At the Yokohama meeting, the chairs agreed to do a consensus call
>> regarding the definition of RSA PSS algorithms within the messages draft or
>> an auxiliary draft. This functionality is analogous to the PS* series of
>> signature methods in JWS. The five positions we are asking the working
>> group to consider and voice their support for are:
>>

---

From: "Matt Miller (mamille2)" <[email-masked]>
Date: Tue, 10 Nov 2015 21:18:46 +0000

B) or C).

--
- m&m

Matt Miller <[email-masked]>
Cisco Systems, Inc.

> On Nov 7, 2015, at 01:02, Justin Richer <[email-masked]> wrote:
>

---

From: Mike Jones <[email-masked]>
Date: Fri, 13 Nov 2015 03:58:08 +0000

I agree with Matt again:

B or C.

-----Original Message-----
From: COSE [mailto:[email-masked]] On Behalf Of Matt Miller (mamille2)
Sent: Tuesday, November 10, 2015 1:19 PM
To: Justin Richer
Cc: [email-masked]
Subject: Re: [COSE] Consensus Call: RSA PSS

B) or C).

--
- m&m

---

From: Justin Richer <[email-masked]>
Date: Sat, 21 Nov 2015 12:43:28 -0500

There’s a reasonably strong consensus to define RSA PSS support in an auxiliary draft. The chairs would like to ask for volunteers to edit such an auxiliary draft.

 — Justin, your COSE chair

> On Nov 7, 2015, at 3:02 AM, Justin Richer <[email-masked]> wrote:
>