Subject: Re: [COSE] [cose-issues] Remove “counter signature” header parameter (#12)

From: obgm <[email-masked]>
Date: Sun, 01 Nov 2015 10:33:56 -0800

Concur. I presume that the counter signature was introduced to handle the case of intermediaries that (legally) change options of CoAP messages when forwarding them (e.g. forwarding proxy that creates a Uri-* options from a Proxy-Uri options).
The solution to deal with changeable CoAP options such as Max-Age, Observe, etc. will most likely require encapsulating the original CoAP message into a COSE object and transfer this as a payload in one of the proposed CoAP-over-COSE messaging mechanisms anyway. 

---
Reply to this email directly or view it on GitHub:
https://github.com/cose-wg/cose-issues/issues/12#issuecomment-152850855

---

From: Ludwig Seitz <[email-masked]>
Date: Mon, 2 Nov 2015 13:23:26 +0100

On 2015-11-01 19:33, obgm wrote:
> Concur. I presume that the counter signature was introduced to handle
> the case of intermediaries that (legally) change options of CoAP
> messages when forwarding them (e.g. forwarding proxy that creates a
> Uri-* options from a Proxy-Uri options).
> The solution to deal with changeable CoAP options such as Max-Age,
> Observe, etc. will most likely require encapsulating the original CoAP
> message into a COSE object and transfer this as a payload in one of the
> proposed CoAP-over-COSE messaging mechanisms anyway.
>

Encapsulating CoAP messages in COSE objects and sending them as the 
payload of a new CoAP message seems like a very bad idea if your main 
goal is to reduce the over-the-wire message sizes.

Also counter signatures could be used in a publish-subscribe scenario 
with a message broker (as described in draft-koster-core-coap-pubsub) 
where the message broker provides the counter signature.

/Ludwig

-- 
Ludwig Seitz, PhD
SICS Swedish ICT AB
Ideon Science Park
Building Beta 2
Scheelevägen 17
SE-223 70 Lund

Phone +46(0)70-349 92 51
http://www.sics.se

---

From: Jim Schaad <[email-masked]>
Date: Wed, 04 Nov 2015 17:02:18 -0800

Counter signature was actually introduced to deal with the subscription model of CoAP.  There is a potential need for the server providing the data store the ability to 1) validate that the Resource server provided the data, without being able to decrypt the data  2) to provide to the observers a statement that the data was received by the data store.  The goal was to not require a full two layer mapping of the message and this was done to try and avoid that.  It may also find some usage in terms of proxies doing counter signatures to say that it did come from a specific sub-network and give a greater amount of origination attestation.

---
Reply to this email directly or view it on GitHub:
https://github.com/cose-wg/cose-issues/issues/12#issuecomment-153919924

---

From: Mike Jones <[email-masked]>
Date: Wed, 04 Nov 2015 21:31:15 -0800

I'm certainly not against CoAP or other applications defining additional header parameters beyond those defined by the base COSE specification that they want to use via the IANA "COSE Header Parameters" registry.  But that's the mechanism that should be used for defining such application-specific parameters - not speculatively adding them to the base specification.

Even if possibly useful to multiple applications, that's still not sufficient justification to add it to the base spec.  Parameters registered in the IANA registry *are* available for use by multiple applications - which part of the point of registering them.  But let's remove "counter signature" from the base spec now.

---
Reply to this email directly or view it on GitHub:
https://github.com/cose-wg/cose-issues/issues/12#issuecomment-153961577