Subject: Re: [COSE] [cose-issues] Move “sequence number” value to the payload (#14)

From: Ludwig Seitz <[email-masked]>
Date: Mon, 2 Nov 2015 13:13:34 +0100

On 2015-11-01 07:17, Mike Jones wrote:
> Like “creation time”, the “sequence number” header parameter defined in
> Section 3.1 is a non-cryptographic application-defined attribute, and so
> should be defined in a companion CBOR payload definitions specification,
> if at all. Only cryptographic-relevant header parameters should be
> defined by COSE. The text “The use of this parameter is application
> specific” is the giveaway that this doesn’t belong here.
>
> —
> Reply to this email directly or view it on GitHub
> <https://github.com/cose-wg/cose-issues/issues/14>.
>
>

What if I use the sequence number to construct my IV for the AEAD algorithm?

/Ludwig

-- 
Ludwig Seitz, PhD
SICS Swedish ICT AB
Ideon Science Park
Building Beta 2
Scheelevägen 17
SE-223 70 Lund

Phone +46(0)70-349 92 51
http://www.sics.se

---

From: Justin Richer <[email-masked]>
Date: Mon, 30 Nov 2015 07:31:10 -0800

Closed #14.

---
Reply to this email directly or view it on GitHub:
https://github.com/cose-wg/cose-issues/issues/14#event-477834214