Subject: [COSE] [cose-issues] Require publicly visible stable specifications for IANA registrations (#39)

From: Mike Jones <[email-masked]>
Date: Sun, 01 Nov 2015 02:31:57 -0800

The COSE Header Parameter Registry in Section 15.2 describes the “specification” registration parameter as “This contains a pointer to the specification defining the header field (where public).”  It’s not reasonable for people to be able reserve values in our registries without providing a publicly visible stable specification defining the meaning of the value.  Please delete the “(where public)” and similar phrases such as “(if publicly available)” and “if one exists” from all the registries.

---
Reply to this email directly or view it on GitHub:
https://github.com/cose-wg/cose-issues/issues/39

---

From: Jim Schaad <[email-masked]>
Date: Tue, 03 Nov 2015 04:50:09 -0800

The range for first come, first serve, which is where I would expect this to be generally done, starts with the > 65536 range.  The private range works for testing, but not for deployment except for closed systems.  Numbers in the lower positive range could be issued on a early basis in which case the specification might not be immediately required.  Again a case where the spec is not registered. There is no real shortage of points to register in and there would be more careful monitoring of the smaller number range.

---
Reply to this email directly or view it on GitHub:
https://github.com/cose-wg/cose-issues/issues/39#issuecomment-153341875