Subject: Re: [COSE] [cose-issues] Restore compression header parameter (#22)

From: LudwigSeitz <[email-masked]>
Date: Tue, 03 Nov 2015 16:44:34 -0800

I am not in favour of having this parameter in the COSE spec. The reason is that I suspect it will not be used very much in the constrained space, and if this parameter can be part  of a message, I have to implement code on my constrained device to handle it.
Keep in mind that we are dealing with devices that can have as little as 100 KB of flash memory for code libraries and other persistent data (See Class 1, Section 3 RFC 7228).

---
Reply to this email directly or view it on GitHub:
https://github.com/cose-wg/cose-issues/issues/22#issuecomment-153535305

---

From: cabo <[email-masked]>
Date: Tue, 03 Nov 2015 20:54:42 -0800

I'm sympathetic with Ludwig's point, however, it should be the prerogative of the enclosing media type to define whether decompression capability is expected or not.
(Also, we have to be careful about equating compression with deflate.  There are other schemes that are more appropriate for decompression on constrained devices.)

---
Reply to this email directly or view it on GitHub:
https://github.com/cose-wg/cose-issues/issues/22#issuecomment-153572455

---

From: Mike Jones <[email-masked]>
Date: Wed, 04 Nov 2015 21:22:16 -0800

The CRIME argument is persuasive.  I'm willing to drop this request on that basis.  Thanks to all who discussed the possibility.

---
Reply to this email directly or view it on GitHub:
https://github.com/cose-wg/cose-issues/issues/22#issuecomment-153960558

---

From: Justin Richer <[email-masked]>
Date: Mon, 30 Nov 2015 07:31:11 -0800

Closed #22.

---
Reply to this email directly or view it on GitHub:
https://github.com/cose-wg/cose-issues/issues/22#event-477834219