Subject: [COSE] Consensus Call: Placement of CDDL

From: Justin Richer <[email-masked]>
Date: Sat, 7 Nov 2015 17:02:07 +0900

At the Yokohama meeting, the chairs agreed to do a consensus call regarding the placement of the CDDL formatted text within the messages draft. The four positions we are asking the working group to consider and voice their support for are:

A) Place the CDDL at the end of the document in an appendix. Other examples will remain inline.
B) Place the CDDL inline with the normative text alongside other examples.
C) You need more information to decide.
D) You don’t give a flying rat about CDDL.*

Note that this proposal does NOT consider removal of CDDL or declaration of normative dependence on CDDL. The English text will remain the normative form and the CDDL will remain a non-normative example. The (unfinished, unhomed) CDDL draft will remain an informative reference.

The consensus call will remain open for two weeks from today, closing on November 21, 2015; at which time, hopefully we will have a clear answer and direction for our editor.

Thank you,
 — Justin & Kepeng, your COSE chairs

* I promised those in the room at Yokohama to offer a flying rat option, for which I am deeply sorry.

---

From: Brian Campbell <[email-masked]>
Date: Mon, 9 Nov 2015 08:38:28 -0700

B)

On Sat, Nov 7, 2015 at 1:02 AM, Justin Richer <[email-masked]> wrote:

> At the Yokohama meeting, the chairs agreed to do a consensus call
> regarding the placement of the CDDL formatted text within the messages
> draft. The four positions we are asking the working group to consider and
> voice their support for are:
>
> Note that this proposal does NOT consider removal of CDDL or declaration
> of normative dependence on CDDL. The English text will remain the normative
> form and the CDDL will remain a non-normative example. The (unfinished,
> unhomed) CDDL draft will remain an informative reference.
>
> The consensus call will remain open for two weeks from today, closing on
> November 21, 2015; at which time, hopefully we will have a clear answer and
> direction for our editor.
>
> Thank you,
> _______________________________________________
> COSE mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cose
>

---

From: "Matt Miller (mamille2)" <[email-masked]>
Date: Tue, 10 Nov 2015 21:29:15 +0000

B)

--
- m&m

Matt Miller <[email-masked]>
Cisco Systems, Inc.

> On Nov 7, 2015, at 01:02, Justin Richer <[email-masked]> wrote:
>

---

From: Nat Sakimura <[email-masked]>
Date: Wed, 11 Nov 2015 08:00:27 +0900

b)

=nat via iPhone

2015/11/07 17:02、Justin Richer <[email-masked]> のメッセージ:

> ― Justin & Kepeng, your COSE chairs
>

---

From: Mike Jones <[email-masked]>
Date: Fri, 13 Nov 2015 03:59:00 +0000

Third time's a charm:

B

-----Original Message-----
From: COSE [mailto:[email-masked]] On Behalf Of Matt Miller (mamille2)
Sent: Tuesday, November 10, 2015 1:29 PM
To: Justin Richer
Cc: [email-masked]
Subject: Re: [COSE] Consensus Call: Placement of CDDL

B)

--
- m&m

---

From: Derek Atkins <[email-masked]>
Date: Tue, 17 Nov 2015 12:01:59 -0500

I feel the CDDL should be inline with the normative text alongside other
examples (B).

-derek

Justin Richer <[email-masked]> writes:

> draft. The four positions we are asking the working group to consider
> and voice their support for are:
>
> Note that this proposal does NOT consider removal of CDDL or
> declaration of normative dependence on CDDL. The English text will
> remain the normative form and the CDDL will remain a non-normative
> example. The (unfinished, unhomed) CDDL draft will remain an
> informative reference.
>
> The consensus call will remain open for two weeks from today, closing
> on November 21, 2015; at which time, hopefully we will have a clear
> answer and direction for our editor.
>
> Thank you,

-- 
       Derek Atkins                 617-623-3745
       [email-masked]             www.ihtfp.com
       Computer and Internet Security Consultant

---

From: Justin Richer <[email-masked]>
Date: Sat, 21 Nov 2015 12:39:43 -0500

There’s a very clear consensus that the CDDL will be inline with the text and marked as non-normative examples. The drafts will reflect that.

 — Justin

> On Nov 7, 2015, at 3:02 AM, Justin Richer <[email-masked]> wrote:
>