Subject: Re: [COSE] Agenda proposal

From: Justin Richer <[email-masked]>
Date: Sun, 27 Mar 2016 17:25:25 -0400

Thanks for your feedback on the agenda. 

The working group document is the last item on the agenda to ensure it has enough time given to it and open issues, just like we've successfully done twice now in this group. 

The other documents were requested presentations that we considered reasonable for small slots. Note that these times include questions and discussion, and we trust that Sean will help keep things moving. Thus we encourage the group to read the drafts ahead of time. 

--Justin

 Sent from my phone
Thanks for your feedback on the agenda. 
The working group document is the last item on the agenda to ensure it has enough time given to it and open issues, just like we've successfully done twice now in this group. 
The other documents were requested presentations that we considered reasonable for small slots. Note that these times include questions and discussion, and we trust that Sean will help keep things moving. Thus we encourage the group to read the drafts ahead of time. 
--Justin
 Sent from my phone
-------- Original message --------
From: Hannes Tschofenig <[email-masked]>
Date: 3/27/16 3:34 PM (GMT-05:00)
To: Kepeng Li <[email-masked]>, [email-masked]
Cc: Justin Richer <[email-masked]>, Sean Turner <[email-masked]>
Subject: Re: [COSE] Agenda proposal

Hi Kepeng,

the working group document needs to be the first item on the agenda.

I don't think that the ACE Object Security belong to this group and I
hate to hear the same presentation given in multiple groups. We had
discussions in the ACE working group about the best working group where
this work should be done and the decision was to do it in CORE. Hence,
we should not have presentations about it in other groups and I was
actually hoping that Goeran would re-submit the draft with the correct
file name so that the working group can be identified correctly.

Ciao
Hannes

On 03/27/2016 05:35 PM, Kepeng Li wrote:
> Hi all,
> 
> Here is a proposal for the agenda of the upcoming meeting:
> 
> * Opening & Welcome - 5 min (Sean)
> 
> * ACE Object Security - 10 min (Goran)
>  - https://tools.ietf.org/html/draft-selander-ace-object-security-04
> 
> * Ephemeral Diffie-Hellman Over COSE – 10 min (Goran)
>  — https://datatracker.ietf.org/doc/draft-selander-ace-cose-ecdhe/
> 
> * COSE Additional Algorithms - 20 min (Jim)
>  — https://datatracker.ietf.org/doc/draft-schaad-cose-alg/
> 
> * CBOR Encoded Message Syntax - 40 min (Jim)
>  — https://datatracker.ietf.org/doc/draft-ietf-cose-msg/
> 
> * Wrap-up - 5 min (Sean)
> 
> Note that we arrange our WG draft as the last one, which means editor
> can get all the remaining time to go through the open issues.
> 
> Also note that Sean Turner will be the acting chair during the meeting.
> Justin and I will dial in remotely.
> 
> The latest version can be found at:
> https://www.ietf.org/proceedings/95/agenda/agenda-95-cose
> 
> Kind Regards
> Kepeng & Justin, your COSE chairs
> 
> 
> 
> 
> 
> 
> _______________________________________________
> COSE mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cose
> 

-------- Original message --------From: Hannes Tschofenig <[email-masked]> Date: 3/27/16  3:34 PM  (GMT-05:00) To: Kepeng Li <[email-masked]>, [email-masked] Cc: Justin Richer <[email-masked]>, Sean Turner <[email-masked]> Subject: Re: [COSE] Agenda proposal 
Hi Kepeng,

the working group document needs to be the first item on the agenda.

I don't think that the ACE Object Security belong to this group and I
hate to hear the same presentation given in multiple groups. We had
discussions in the ACE working group about the best working group where
this work should be done and the decision was to do it in CORE. Hence,
we should not have presentations about it in other groups and I was
actually hoping that Goeran would re-submit the draft with the correct
file name so that the working group can be identified correctly.

Ciao
Hannes

On 03/27/2016 05:35 PM, Kepeng Li wrote:
> Hi all,
> 
> Here is a proposal for the agenda of the upcoming meeting:
> 
> * Opening & Welcome - 5 min (Sean)
> 
> * ACE Object Security - 10 min (Goran)
>   - https://tools.ietf.org/html/draft-selander-ace-object-security-04
> 
> * Ephemeral Diffie-Hellman Over COSE – 10 min (Goran)
>   — https://datatracker.ietf.org/doc/draft-selander-ace-cose-ecdhe/
> 
> * COSE Additional Algorithms - 20 min (Jim)
>   — https://datatracker.ietf.org/doc/draft-schaad-cose-alg/
> 
> * CBOR Encoded Message Syntax - 40 min (Jim)
>   — https://datatracker.ietf.org/doc/draft-ietf-cose-msg/
> 
> * Wrap-up - 5 min (Sean)
> 
> Note that we arrange our WG draft as the last one, which means editor
> can get all the remaining time to go through the open issues.
> 
> Also note that Sean Turner will be the acting chair during the meeting.
> Justin and I will dial in remotely.
> 
> The latest version can be found at:
> https://www.ietf.org/proceedings/95/agenda/agenda-95-cose
> 
> Kind Regards
> Kepeng & Justin, your COSE chairs
> 
> 
> 
> 
> 
> 
> _______________________________________________
> COSE mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cose
>

---

From: "Jim Schaad" <[email-masked]>
Date: Sun, 27 Mar 2016 18:59:35 -0700

I would prefer having the additional algorithms presented at the end of the meeting on an if time is available basis.

Jim

From: COSE [mailto:[email-masked]] On Behalf Of Justin Richer
Sent: Sunday, March 27, 2016 2:25 PM
To: Hannes Tschofenig <[email-masked]>; Kepeng Li <[email-masked]>; [email-masked]
Cc: Sean Turner <[email-masked]>
Subject: Re: [COSE] Agenda proposal

--Justin

 Sent from my phone

-------- Original message --------

From: Hannes Tschofenig <[email-masked] <mailto:[email-masked]> > 

To: Kepeng Li <[email-masked] <mailto:[email-masked]> >, [email-masked] <mailto:[email-masked]>  

Cc: Justin Richer <[email-masked] <mailto:[email-masked]> >, Sean Turner <[email-masked] <mailto:[email-masked]> > 

Hi Kepeng,

Ciao
Hannes

On 03/27/2016 05:35 PM, Kepeng Li wrote:
> [email-masked] <mailto:[email-masked]> 

-------- Original message --------From: Hannes Tschofenig <[email-masked] <mailto:[email-masked]> > Date: 3/27/16  3:34 PM  (GMT-05:00) To: Kepeng Li <[email-masked] <mailto:[email-masked]> >, [email-masked] <mailto:[email-masked]>  Cc: Justin Richer <[email-masked] <mailto:[email-masked]> >, Sean Turner <[email-masked] <mailto:[email-masked]> > Subject: Re: [COSE] Agenda proposal 
Hi Kepeng,

Ciao
Hannes

Hi all,

* Wrap-up - 5 min (Sean)

Kind Regards

_______________________________________________
COSE mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/cose

---

From: "Kepeng Li" <[email-masked]>
Date: Tue, 29 Mar 2016 10:36:48 +0800

I swap the order according to the received feedback.
https://www.ietf.org/proceedings/95/agenda/agenda-95-cose
* Opening & Welcome - 5 min (Sean)

* Wrap-up - 5 min (Sean)
Kind Regards
Kepeng

发件人:  Jim Schaad <[email-masked]>
日期:  Monday, 28 March, 2016 9:59 am
至:  'Justin Richer' <[email-masked]>, 'Hannes Tschofenig'
<[email-masked]>, Li Kepeng <[email-masked]>,
<[email-masked]>
抄送:  'Sean Turner' <[email-masked]>
主题:  Re: [COSE] Agenda proposal

I would prefer having the additional algorithms presented at the end of the
meeting on an if time is available basis.
 
Jim

From: COSE [mailto:[email-masked]] On Behalf Of Justin Richer
Sent: Sunday, March 27, 2016 2:25 PM
To: Hannes Tschofenig <[email-masked]>; Kepeng Li
<[email-masked]>; [email-masked]
Cc: Sean Turner <[email-masked]>
Subject: Re: [COSE] Agenda proposal

The working group document is the last item on the agenda to ensure it has
enough time given to it and open issues, just like we've successfully done
twice now in this group.

The other documents were requested presentations that we considered
reasonable for small slots. Note that these times include questions and
discussion, and we trust that Sean will help keep things moving. Thus we
encourage the group to read the drafts ahead of time.

--Justin

 Sent from my phone
Thanks for your feedback on the agenda.
The working group document is the last item on the agenda to ensure it has
enough time given to it and open issues, just like we've successfully done
twice now in this group.
The other documents were requested presentations that we considered
reasonable for small slots. Note that these times include questions and
discussion, and we trust that Sean will help keep things moving. Thus we
encourage the group to read the drafts ahead of time.
--Justin
 Sent from my phone

-------- Original message --------

Hi Kepeng,

Ciao
Hannes

> Kepeng & Justin, your COSE chairs

-------- Original message --------From: Hannes Tschofenig
<[email-masked]> Date: 3/27/16  3:34 PM  (GMT-05:00) To: Kepeng
Li <[email-masked]>, [email-masked] Cc: Justin Richer
<[email-masked]>, Sean Turner <[email-masked]> Subject: Re: [COSE] Agenda
proposal 
Hi Kepeng,

Ciao
Hannes

> Kepeng & Justin, your COSE chairs
 
_______________________________________________ COSE mailing list
[email-masked] https://www.ietf.org/mailman/listinfo/cose

---

From: Justin Richer <[email-masked]>
Date: Tue, 29 Mar 2016 08:52:30 -0400

Hi everybody,

There was a little bit of confusion regarding the agenda, it’s now revised to this:

https://www.ietf.org/proceedings/95/agenda/agenda-95-cose <https://www.ietf.org/proceedings/95/agenda/agenda-95-cose>
* Opening & Welcome - 5 min (Sean)

* Ephemeral Diffie-Hellman Over COSE – 10 min (Goran)
 — https://datatracker.ietf.org/doc/draft-selander-ace-cose-ecdhe/ <https://datatracker.ietf.org/doc/draft-selander-ace-cose-ecdhe/>

* ACE Object Security - 10 min (Goran)
 - https://tools.ietf.org/html/draft-selander-ace-object-security-04 <https://tools.ietf.org/html/draft-selander-ace-object-security-04>

* CBOR Encoded Message Syntax - 40 min (including open issues) (Jim)
 — https://datatracker.ietf.org/doc/draft-ietf-cose-msg/ <https://datatracker.ietf.org/doc/draft-ietf-cose-msg/>

* COSE Additional Algorithms - 20 min (if time allows) (Jim)
 — https://datatracker.ietf.org/doc/draft-schaad-cose-alg/ <https://datatracker.ietf.org/doc/draft-schaad-cose-alg/>

* Wrap-up - 5 min (Sean)

Note that the algorithms draft slot is optional and only if time permits. If the issues with the Messages draft are taking too long, they’ll fill up the remaining time as needed. 

 — Justin

> On Mar 28, 2016, at 10:36 PM, Kepeng Li <[email-masked]> wrote:
> 
> https://www.ietf.org/proceedings/95/agenda/agenda-95-cose <https://www.ietf.org/proceedings/95/agenda/agenda-95-cose>
>  — https://datatracker.ietf.org/doc/draft-ietf-cose-msg/ <https://datatracker.ietf.org/doc/draft-ietf-cose-msg/>
> 
>  — https://datatracker.ietf.org/doc/draft-schaad-cose-alg/ <https://datatracker.ietf.org/doc/draft-schaad-cose-alg/>
> 
>  — https://datatracker.ietf.org/doc/draft-selander-ace-cose-ecdhe/ <https://datatracker.ietf.org/doc/draft-selander-ace-cose-ecdhe/>
> 
>  - https://tools.ietf.org/html/draft-selander-ace-object-security-04 <https://tools.ietf.org/html/draft-selander-ace-object-security-04>
> 
> * Wrap-up - 5 min (Sean)
> Kind Regards
> Kepeng
> 
> 发件人: Jim Schaad <[email-masked] <mailto:[email-masked]>>
> 至: 'Justin Richer' <[email-masked] <mailto:[email-masked]>>, 'Hannes Tschofenig' <[email-masked] <mailto:[email-masked]>>, Li Kepeng <[email-masked] <mailto:[email-masked]>>, <[email-masked] <mailto:[email-masked]>>
> 抄送: 'Sean Turner' <[email-masked] <mailto:[email-masked]>>
> From: COSE [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Justin Richer
> To: Hannes Tschofenig <[email-masked] <mailto:[email-masked]>>; Kepeng Li <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>
> Cc: Sean Turner <[email-masked] <mailto:[email-masked]>>
> From: Hannes Tschofenig <[email-masked] <mailto:[email-masked]>> 
> To: Kepeng Li <[email-masked] <mailto:[email-masked]>>, [email-masked] <mailto:[email-masked]>
> Cc: Justin Richer <[email-masked] <mailto:[email-masked]>>, Sean Turner <[email-masked] <mailto:[email-masked]>> 
> >  - https://tools.ietf.org/html/draft-selander-ace-object-security-04 <https://tools.ietf.org/html/draft-selander-ace-object-security-04>
> > 
> >  — https://datatracker.ietf.org/doc/draft-selander-ace-cose-ecdhe/ <https://datatracker.ietf.org/doc/draft-selander-ace-cose-ecdhe/>
> > 
> >  — https://datatracker.ietf.org/doc/draft-schaad-cose-alg/ <https://datatracker.ietf.org/doc/draft-schaad-cose-alg/>
> > 
> >  — https://datatracker.ietf.org/doc/draft-ietf-cose-msg/ <https://datatracker.ietf.org/doc/draft-ietf-cose-msg/>
> > 
> > * Wrap-up - 5 min (Sean)
> > 
> > https://www.ietf.org/proceedings/95/agenda/agenda-95-cose <https://www.ietf.org/proceedings/95/agenda/agenda-95-cose>
> > 
> > Kind Regards
> > https://www.ietf.org/mailman/listinfo/cose <https://www.ietf.org/mailman/listinfo/cose>
> > 
> 
> -------- Original message --------From: Hannes Tschofenig <[email-masked] <mailto:[email-masked]>> Date: 3/27/16  3:34 PM  (GMT-05:00) To: Kepeng Li <[email-masked] <mailto:[email-masked]>>, [email-masked] <mailto:[email-masked]> Cc: Justin Richer <[email-masked] <mailto:[email-masked]>>, Sean Turner <[email-masked] <mailto:[email-masked]>> Subject: Re: [COSE] Agenda proposal 
> Hi Kepeng,
> 
>>   - https://tools.ietf.org/html/draft-selander-ace-object-security-04 <https://tools.ietf.org/html/draft-selander-ace-object-security-04>
>> 
>>   — https://datatracker.ietf.org/doc/draft-selander-ace-cose-ecdhe/ <https://datatracker.ietf.org/doc/draft-selander-ace-cose-ecdhe/>
>> 
>>   — https://datatracker.ietf.org/doc/draft-schaad-cose-alg/ <https://datatracker.ietf.org/doc/draft-schaad-cose-alg/>
>> 
>>   — https://datatracker.ietf.org/doc/draft-ietf-cose-msg/ <https://datatracker.ietf.org/doc/draft-ietf-cose-msg/>
>> 
>> * Wrap-up - 5 min (Sean)
>> 
>> https://www.ietf.org/proceedings/95/agenda/agenda-95-cose <https://www.ietf.org/proceedings/95/agenda/agenda-95-cose>
>> 
>> Kind Regards
>> https://www.ietf.org/mailman/listinfo/cose <https://www.ietf.org/mailman/listinfo/cose> 
> _______________________________________________ COSE mailing list [email-masked] <mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/cose <https://www.ietf.org/mailman/listinfo/cose>

---

From: Francesca Palombini <[email-masked]>
Date: Thu, 31 Mar 2016 09:34:32 +0000

Hi,

The last version of the draft and some offline discussion answered all the issues we (OSCOAP) had raised in the last meeting and on the mailing list, so we don’t need the 10 minutes to talk about draft-selander-ace-object-security-04 (ACE Object Security).

Thanks,
Francesca

From: COSE [mailto:[email-masked]] On Behalf Of Justin Richer
Sent: den 29 mars 2016 14:53
To: [email-masked]
Cc: Jim Schaad; Hannes Tschofenig; Sean Turner; Kepeng Li
Subject: Re: [COSE] Agenda proposal

Hi everybody,

* Wrap-up - 5 min (Sean)

 — Justin

On Mar 28, 2016, at 10:36 PM, Kepeng Li <[email-masked]<mailto:[email-masked]>> wrote:

* Wrap-up - 5 min (Sean)
Kind Regards
Kepeng

发件人: Jim Schaad <[email-masked]<mailto:[email-masked]>>
日期: Monday, 28 March, 2016 9:59 am
至: 'Justin Richer' <[email-masked]<mailto:[email-masked]>>, 'Hannes Tschofenig' <[email-masked]<mailto:[email-masked]>>, Li Kepeng <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>
抄送: 'Sean Turner' <[email-masked]<mailto:[email-masked]>>
主题: Re: [COSE] Agenda proposal

Jim

From: COSE [mailto:[email-masked]] On Behalf Of Justin Richer
Sent: Sunday, March 27, 2016 2:25 PM
To: Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>; Kepeng Li <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: Sean Turner <[email-masked]<mailto:[email-masked]>>
Subject: Re: [COSE] Agenda proposal

--Justin

 Sent from my phone
-------- Original message --------
From: Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>
Date: 3/27/16 3:34 PM (GMT-05:00)
To: Kepeng Li <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]>
Cc: Justin Richer <[email-masked]<mailto:[email-masked]>>, Sean Turner <[email-masked]<mailto:[email-masked]>>
Subject: Re: [COSE] Agenda proposal

Hi Kepeng,

Ciao
Hannes

On 03/27/2016 05:35 PM, Kepeng Li wrote:
> [email-masked]<mailto:[email-masked]>

-------- Original message --------From: Hannes Tschofenig <[email-masked]<mailto:[email-masked]>> Date: 3/27/16  3:34 PM  (GMT-05:00) To: Kepeng Li <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> Cc: Justin Richer <[email-masked]<mailto:[email-masked]>>, Sean Turner <[email-masked]<mailto:[email-masked]>> Subject: Re: [COSE] Agenda proposal
Hi Kepeng,

Ciao
Hannes

Hi all,

* Wrap-up - 5 min (Sean)

Kind Regards

_______________________________________________
COSE mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/cose

_______________________________________________ COSE mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/cose