Subject: [COSE] [Editorial Errata Reported] RFC8152 (5533)

From: RFC Errata System <[email-masked]>
Date: Thu, 18 Oct 2018 03:23:04 -0700 (PDT)

The following errata report has been submitted for RFC8152,
"CBOR Object Signing and Encryption (COSE)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5533

--------------------------------------
Type: Editorial
Reported by: Jian Huang <[email-masked]>

Section: 3.1

Original Text
-------------
alg:  This parameter is used to indicate the algorithm used for the
      security processing.  This parameter MUST be authenticated where
      the ability to do so exists.  This support is provided by AEAD
      algorithms or construction (COSE_Sign, COSE_Sign0, COSE_Mac, and
      COSE_Mac0).

Corrected Text
--------------
alg:  This parameter is used to indicate the algorithm used for the
      security processing.  This parameter MUST be authenticated where
      the ability to do so exists.  This support is provided by AEAD
      algorithms or construction (COSE_Sign, COSE_Sign1, COSE_Mac, and
      COSE_Mac0).

Notes
-----
COSE_Sign0 is only mentioned once. I think it should have been COSE_Sign1

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8152 (draft-ietf-cose-msg-24)
--------------------------------------
Title               : CBOR Object Signing and Encryption (COSE)
Publication Date    : July 2017
Author(s)           : J. Schaad
Category            : PROPOSED STANDARD
Source              : CBOR Object Signing and Encryption
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Jim Schaad <[email-masked]>
Date: Thu, 18 Oct 2018 07:41:19 -0700

This should be approved - it is incorrect.

> -----Original Message-----
> From: RFC Errata System <[email-masked]>
> Sent: Thursday, October 18, 2018 3:23 AM
> To: [email-masked]; [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: [Editorial Errata Reported] RFC8152 (5533)
> 
> The following errata report has been submitted for RFC8152, "CBOR Object
> Signing and Encryption (COSE)".
> 
> This erratum is currently posted as "Reported". If necessary, please use "Reply
> All" to discuss whether it should be verified or rejected. When a decision is
> reached, the verifying party can log in to change the status and edit the report,
> if necessary.
>