Subject: [COSE] Review of draft-ietf-cose-rc8152bis-algs-03

From: Ludwig Seitz <[email-masked]>
Date: Mon, 19 Aug 2019 13:03:55 +0200

Hello group, Jim

here is my review of draft-ietf-cose-rfc8152bis-algs-03, omitting the 
parts that Jim fixed in response to my review of the other draft.

I did only find two nits in that document.

/Ludwig

==

Nit: Section 3.

"Section 10 of [I-D.ietf-cose-rfc8152bis-struct]
    [I-D.ietf-cose-rfc8152bis-struct] contains a generic description of
    MAC algorithms."

The reference seems to be duplicated here.

==

Nit: 3.1

"For use in constrained environments, we define one HMAC algorithms that 
is truncated."

should be "algorithm" since it is only one.

-- 
Ludwig Seitz, PhD
Security Lab, RISE
Phone +46(0)70-349 92 51

---

From: Jim Schaad <[email-masked]>
Date: Mon, 19 Aug 2019 10:13:13 -0700

-----Original Message-----
From: Ludwig Seitz <[email-masked]> 
Sent: Monday, August 19, 2019 4:04 AM
To: [email-masked]; Jim Schaad <[email-masked]>
Subject: Review of draft-ietf-cose-rc8152bis-algs-03

Hello group, Jim

/Ludwig

==

Nit: Section 3.

[JLS] I missed this when I tried to be cute about how the reference is done, I wanted to include both the section and the pointer and it got clobbered badly.  I have fixed this by using the new <relref> tag in the v3 vocabulary which does that right.

==

Nit: 3.1

[JLS] Fixed.

-- 
Ludwig Seitz, PhD
Security Lab, RISE
Phone +46(0)70-349 92 51