Subject: [COSE] [IANA #1148103] Early Code Point Assignments

From: "Sabrina Tanamal via RT" <[email-masked]>
Date: Tue, 13 Aug 2019 22:23:53 +0000

Hi Jim, 

We've made the early allocations for draft-ietf-cose-hash-algs, but we're still waiting to hear back from the experts regarding the assignments in draft-ietf-cose-x509. We'll let you know as soon as we hear from them. 

These early allocations are complete: 

SHAKE256 (TEMPORARY - registered 2019-08-13, expires 2020-08-13)	-45	256-bit SHAKE	[draft-ietf-cose-hash-algs]	Yes
SHA-512 (TEMPORARY - registered 2019-08-13, expires 2020-08-13)	-44	SHA-2 512-bit Hash	[draft-ietf-cose-hash-algs]	Yes
SHA-384 (TEMPORARY - registered 2019-08-13, expires 2020-08-13)	-43	SHA-2 384-bit Hash	[draft-ietf-cose-hash-algs]	Yes
SHAKE128 (TEMPORARY - registered 2019-08-13, expires 2020-08-13)	-18	128-bit SHAKE	[draft-ietf-cose-hash-algs]	Yes
SHA-512/256 (TEMPORARY - registered 2019-08-13, expires 2020-08-13)	-17	SHA-2 512-bit Hash truncated to 256-bits	[draft-ietf-cose-hash-algs]	Yes
SHA-256 (TEMPORARY - registered 2019-08-13, expires 2020-08-13)	-16	SHA-2 256-bit Hash	[draft-ietf-cose-hash-algs]	Yes
SHA-256/64 (TEMPORARY - registered 2019-08-13, expires 2020-08-13)	-15	SHA-2 256-bit Hash truncated to 64-bits	[draft-ietf-cose-hash-algs]	Filter Only
SHA-1 (TEMPORARY - registered 2019-08-13, expires 2020-08-13)	-14	SHA-1 Hash	[draft-ietf-cose-hash-algs]	Filter Only

If this document hasn't been approved for publication by July 2020, we'll contact you about approving a one-year renewal. Any further renewals would require IESG approval.

Best regards,

Sabrina Tanamal
Senior IANA Services Specialist

On Mon Jul 29 14:52:02 2019, [email-masked] wrote:
> Following the meeting in Montreal where I asked for the ability to do early
> point assignment for documents in the working group and got permission,
> these are the code points that I am assigning.   I am only assigning points
> that I know people are asking for now, some points will be setup later.
> 
> For draft-ietf-cose-x509 (https://tools.ietf.org/html/draft-ietf-cose-x509):
> 
> Table COSE Header Parameters
> https://www.iana.org/assignments/cose/cose.xhtml#header-parameters
> 
> Name		Value
> x5bag               	32
> x5chain		33
> x5t		34
> x5u		35
> 
> For draft-ietf-cose-hash-algs
> (https://tools.ietf.org/html/draft-ietf-cose-hash-algs):
> 
> Table  COSE Algorithms
> https://www.iana.org/assignments/cose/cose.xhtml#algorithms
> 
> Name		Value
> 
> SHA-1		-14
> SHA-256/64	-15
> SHA-256	-16
> SHA-384	-43
> SHA-512	-44
> SHA-512/256	-17
> SHAKE128	-18
> SHAKE256	-45
> 
> 
> Jim
> 
>

---

From: DESPERRIER Jean-Marc <[email-masked]>
Date: Tue, 20 Aug 2019 16:29:18 +0000

Hi,

I hope you can hear back from the expert about ietf-cose-x509 quickly. 
Meanwhile in ISO/IEC JTC 1/SC 17/WG 10, for the informal prototype test event of the current draft of ISO 18013-5 we organized this week-end, we used the value 33 for x5chain that Jim proposed. Let's hope we don't have to change it later, and can rapidly reference it in the newer draft.

Best regards,
Jean-Marc

-----Message d'origine-----
De : COSE <[email-masked]> De la part de Sabrina Tanamal via RT
Envoyé : mercredi 14 août 2019 00:24
À : [email-masked]
Cc : [email-masked]; [email-masked]
Objet : [COSE] [IANA #1148103] Early Code Point Assignments

Hi Jim, 

Best regards,

Sabrina Tanamal

On Mon Jul 29 14:52:02 2019, [email-masked] wrote:
> Following the meeting in Montreal where I asked for the ability to do 
> early point assignment for documents in the working group and got permission,
> For draft-ietf-cose-x509 (https://urldefense.com/v3/__https://tools.ietf.org/html/draft-ietf-cose-x509__;!U11cABxz5NU!l1Wgt4J1m7vpUmVAJc210eIq0w2nX3wx4mddkqAX-AXr5yijD3btkT8QN5cqdYkQdceWs-22$ ):
> 
> https://urldefense.com/v3/__https://www.iana.org/assignments/cose/cose
> .xhtml*header-parameters__;Iw!U11cABxz5NU!l1Wgt4J1m7vpUmVAJc210eIq0w2n
> X3wx4mddkqAX-AXr5yijD3btkT8QN5cqdYkQdWsgiY8C$
> 
> Name		Value
> x5bag               	32
> x5chain		33
> x5t		34
> x5u		35
> 
> (https://urldefense.com/v3/__https://tools.ietf.org/html/draft-ietf-cose-hash-algs__;!U11cABxz5NU!l1Wgt4J1m7vpUmVAJc210eIq0w2nX3wx4mddkqAX-AXr5yijD3btkT8QN5cqdYkQdTBumviG$ ):
> 
> Table  COSE Algorithms
> https://urldefense.com/v3/__https://www.iana.org/assignments/cose/cose
> .xhtml*algorithms__;Iw!U11cABxz5NU!l1Wgt4J1m7vpUmVAJc210eIq0w2nX3wx4md
> dkqAX-AXr5yijD3btkT8QN5cqdYkQdTHbtJY4$
> 
> Name		Value
> 
> SHA-1		-14
> SHA-256/64	-15
> SHA-256	-16
> SHA-384	-43
> SHA-512	-44
> SHA-512/256	-17
> SHAKE128	-18
> SHAKE256	-45
> 
> 
> Jim
> 
> 

_______________________________________________
COSE mailing list
[email-masked]
https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/cose__;!U11cABxz5NU!l1Wgt4J1m7vpUmVAJc210eIq0w2nX3wx4mddkqAX-AXr5yijD3btkT8QN5cqdYkQdfhP1OAe$

---

From: "Matthew A. Miller" <[email-masked]>
Date: Tue, 20 Aug 2019 10:48:50 -0600

Hello Jean-Marc,

Two reviewers have approved of the header parameters, so I believe the
value 33 should be safe.

I will follow up with IANA to see when that will be reflected in the
registry.

- m&m

Matthew A. Miller
one each of Expert Reviewers and COSE chairs
On 19/08/20 10:29, DESPERRIER Jean-Marc wrote:
> https://www.ietf.org/mailman/listinfo/cose
>

---

From: "Sabrina Tanamal via RT" <[email-masked]>
Date: Tue, 20 Aug 2019 22:52:07 +0000

Hi all, 

Thank you for your patience. We've made the early allocations for draft-ietf-cose-x509: 

x5bag (TEMPORARY - registered 2019-08-20, expires 2020-08-20)	32	COSE_X509		An unordered bag of X.509 certificates	[draft-ietf-cose-x509]
x5chain (TEMPORARY - registered 2019-08-20, expires 2020-08-20)	33	COSE_X509		An ordered chain of X.509 certificates	[draft-ietf-cose-x509]
x5t (TEMPORARY - registered 2019-08-20, expires 2020-08-20)	34	COSE_CertHash		Hash of an X.509 certificate	[draft-ietf-cose-x509]
x5u (TEMPORARY - registered 2019-08-20, expires 2020-08-20)	35	uri		URI pointing to an X.509 certificate	[draft-ietf-cose-x509]

Please see
https://www.iana.org/assignments/cose

If this document hasn't been approved for publication by August 2020, we'll contact you about approving a one-year renewal. Any further renewals would require IESG approval.

Best regards,

Sabrina Tanamal