Subject: [COSE] Three comments regarding certificate compression in the charter

From: John Mattsson <[email-masked]>
Date: Wed, 23 Sep 2020 16:33:45 +0000

Three suggestion regarding certificate compression in the charter.

OLD
"A CBOR encoding of the compressed certificate profile defined in RFC 7925."

NEW
"A CBOR encoding of the compressed certificate profile defined in RFC 7925. It is expected that the compression works with a large subset of RFC 7925 and takes into consideration any updates in draft-ietf-uta-tls13-iot-profile-00. The compression may also include other important IoT certificate profiles like IEEE 802.11AR."

OLD:
"This work will be based on draft-mattsson-cose-cbor-cert-compress and draft-raza-ace-cbor-certificates. It is expected these documents are to be combined into a single document."

NEW
"This work will be based on draft-mattsson-cose-cbor-cert-compress"

ADD
"The working group will collaborate and coordinate with other IETF WGs such as TLS, UTA, LAKE to understand and validate the
requirements and solution."

---

From: Michael Richardson <[email-masked]>
Date: Wed, 23 Sep 2020 12:55:12 -0400

> Three suggestion regarding certificate compression in the charter.

These changes look fine to me.

    > "This work will be based on draft-mattsson-cose-cbor-cert-compress"

Is this because you've already merged with the other document?

    > _______________________________________________
    > COSE mailing list
    > [email-masked]
    > https://www.ietf.org/mailman/listinfo/cose

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Matthew Miller <[email-masked]>
Date: Wed, 23 Sep 2020 11:23:32 -0600

[speaking for myself]

> On Sep 23, 2020, at 10:55 AM, Michael Richardson <[email-masked]> wrote:
> 
> 
>> OLD:

That is correct; -01 contains that merge[1].

- m&m
Matthew A. Miller

[1] <https://tools.ietf.org/html/draft-mattsson-cose-cbor-cert-compress-01 <https://tools.ietf.org/html/draft-mattsson-cose-cbor-cert-compress-01>>

---

From: John Mattsson <[email-masked]>
Date: Mon, 28 Sep 2020 09:51:15 +0000

Based on Jim's comment regarding support of GeneralizedTime, I seems like the CBOR encoding might support RFC 5280 features that are not in RFC 7925. The charter should be written so that it allows this. E.g. something like

"A CBOR encoding based of the certificate profile defined in RFC 7925. It is expected that the encoding works with a large subset of RFC 7925. The encoding might support additional RFC 5280 options like GeneralizedTime and shall take into consideration any updates in draft-ietf-uta-tls13-iot-profile. The compression may also include other important IoT certificate profiles like IEEE 802.11AR."