Subject: Re: [COSE] Roman Danyliw's Discuss on draft-ietf-cose-rfc8152bis-struct-10: (with DISCUSS and COMMENT)

From: Jim Schaad <[email-masked]>
Date: Mon, 7 Sep 2020 20:10:21 -0700

Roman,

I think you can close your discuss.  The latest version of the document has trimmed out everything to do with countersignatures except that there was one previously and it has been dropped from this document and put into a new document.

Jim

-----Original Message-----
From: Roman Danyliw via Datatracker <[email-masked]> 
Sent: Monday, June 8, 2020 7:08 PM
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; Matthew Miller <[email-masked]>; [email-masked]
Subject: Roman Danyliw's Discuss on draft-ietf-cose-rfc8152bis-struct-10: (with DISCUSS and COMMENT)

Roman Danyliw has entered the following ballot position for
draft-ietf-cose-rfc8152bis-struct-10: Discuss

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-cose-rfc8152bis-struct/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

Are the wrong data structures being referenced or did I misunderstand something?

** Section 5.  Per “Abbreviated counter signatures use the structure COSE_Countersign1”, this doesn’t seem consistent with the more detailed write-up in Section 5.2 which says that “The byte string representing the signature value is placed in the CounterSignature0 attribute”.  The document makes no other reference to COSE_Countersign1.

The shepherd write-up notes that ‘one item to note is the decision to keep the context string "COSE_Countersign1" for abbreviated countersignatures’. 
However, I found no such reference in Step 1 of Section 4.4 (page 22) which enumerated the possible strings.

** What is the intended name of the structure for the Counter Signature -- is it COSE_Countersignature or COSE_Countersign?

-- Table 1, Section 2, Section 4.4 and Section 5.1 (to include the CDDL) reference COSE_Countersignature

but
-- Section 5. Per “Full counter signatures use the structure COSE_Countersign …”

-- Section 5.1.  Per “A tagged COSE_Countersign structure …”

---

From: Roman Danyliw <[email-masked]>
Date: Tue, 8 Sep 2020 11:21:40 +0000

Hi Jim!

Thanks for this edit and all the discussions around counter signatures.  I've updated my ballot.

Regards,
Roman

> From: COSE <[email-masked]> On Behalf Of Jim Schaad
> Sent: Monday, September 7, 2020 11:10 PM
> To: Roman Danyliw <[email-masked]>; 'The IESG' <[email-masked]>
> Cc: [email-masked]; [email-masked]; 'Matthew
> Miller' <[email-masked]>; [email-masked]
> Subject: Re: [COSE] Roman Danyliw's Discuss on draft-ietf-cose-rfc8152bis-
> struct-10: (with DISCUSS and COMMENT)
> 
> Roman,
> 
> I think you can close your discuss.  The latest version of the document has
> trimmed out everything to do with countersignatures except that there was
> one previously and it has been dropped from this document and put into a new
> document.
> 
> Jim
> 
> 
> Cc: [email-masked]; [email-masked];
> [email-masked]; Matthew Miller <[email-masked]>;
> [email-masked]
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)
> 
> 
> ** Section 5.  Per “Abbreviated counter signatures use the structure
> COSE_Countersign1”, this doesn’t seem consistent with the more detailed
> write-up in Section 5.2 which says that “The byte string representing the
> signature value is placed in the CounterSignature0 attribute”.  The document
> makes no other reference to COSE_Countersign1.
> 
> The shepherd write-up notes that ‘one item to note is the decision to keep the
> context string "COSE_Countersign1" for abbreviated countersignatures’.
> ** What is the intended name of the structure for the Counter Signature -- is it
> COSE_Countersignature or COSE_Countersign?
> 
> _______________________________________________
> COSE mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cose