Subject: [COSE] Jim Schaad

From: Matthew Miller <[email-masked]>
Date: Tue, 6 Oct 2020 09:14:43 -0600

Jim Schaad passed away recently.  His loss is felt heavily, and will be felt for a very long time.  This working group and its products would likely not exist -- in either iterations -- without Jim's efforts.

The COSE WG still has a interim scheduled for tomorrow (10-07), and we are reserving as much time as the working group wishes to remember Jim.

Jim was responsible for all of the working group's remaining documents, and while no one can replace his work, the chairs and ADs have worked out some form of succession on those documents:

* draft-ietf-cose-countersign will be edited by Russ Housley.  An updated draft noting this and including a memorial will be uploaded sometime soon.
* draft-ietf-cose-rfc8152bis-struct will be continued by Matthew Miller (uncredited); this document is awaiting another IETF LC.
* draft-ietf-cose-x509 will be continued by Ivaylo Petrov (uncredited); this document is on the IESG telechat for 10-22, and needs some editorial changes.
* draft-ietf-cose-rfc8152bis-algs is in the RFC Editors' queue.  The WG will be asked to help address any issues that arise from the editing process, as needed.
* draft-ietf-cose-hash-algs is n the RFC Editors' queue.  The WG will be asked to help address any issues that arise from the editing process, as needed.

Thank you again, Russ, for volunteering to edit.

Sincerely,

- Ivaylo and Matthew
COSE WG Chairs

- m&m
Matthew A. Miller

---

From: Russ Housley <[email-masked]>
Date: Wed, 7 Oct 2020 16:22:33 -0400

I just posted draft-ietf-cose-countersign-01.

Russ

> On Oct 6, 2020, at 11:14 AM, Matthew Miller <[email-masked]> wrote:
>

---

From: Michael Richardson <[email-masked]>
Date: Wed, 07 Oct 2020 18:14:39 -0400

> I just posted draft-ietf-cose-countersign-01.

Thanks for taking on this editing Russ.
I had read -00 before the last virtual interim meeting.

I see you updated the github repo.

A gap that I think we need to talk about as a WG is the question of the examples.
Jim didn't just edit the documents, he wrote code to generate the examples.

1) can someone take over those examples?
   {I use some of them in some them via gitmodule in my RFC8366 library to
   validate my COSE code, but I don't have competence on the modes I don't use}

2) do we need/want new examples for the new countersignature modes?

I certainly didn't really understand the specification well enough to argue
until I wrote code.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Russ Housley <[email-masked]>
Date: Thu, 8 Oct 2020 10:35:57 -0400

> I had read -00 before the last virtual interim meeting.

I did not make any changes to the body of the document.

> Jim didn't just edit the documents, he wrote code to generate the examples.

Indeed.  I'm pleased to work with someone on examples.  I think that Jim's code is available.

If we do not have someone that cares to help produce a particular example, then we can move forward with an incomplete set.

> I certainly didn't really understand the specification well enough to argue

This is typical of Jim's approach.  I recall a document a few years ago, he was asked if a document was complete, and he said it had enough detail for him to write code that validated the test vectors.

Russ

---

From: Michael Richardson <[email-masked]>
Date: Sat, 10 Oct 2020 18:36:11 -0400

> If we do not have someone that cares to help produce a particular
    > example, then we can move forward with an incomplete set.

It takes two implementers to be sure, so getting Jim's code runnable
somewhere would be a good thing.... who has some fourth-year students? :-)

    > This is typical of Jim's approach.  I recall a document a few years
    > ago, he was asked if a document was complete, and he said it had enough
    > detail for him to write code that validated the test vectors.

:-)

We had some users of the old-style countersignature.
I think it was in ACE, but I can't recall.  If they have library code